]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- hack for crappy m4
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define snap    20061125
5 Summary:        Cinelerra - capturing, editing and production of audio/video material
6 Summary(pl):    Cinelerra - nagrywanie, obróbka i produkcja materia³u audio/video
7 Name:           cinelerra-cv
8 Version:        2.1
9 Release:        0.%{snap}.1
10 License:        GPL
11 Group:          X11/Applications
12 # svn://svn.skolelinux.org/cinelerra/trunk/hvirtual
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  89a039be86acab89ed392ce987dea2c8
15 Patch0:         %{name}-build.patch
16 URL:            http://cvs.cinelerra.org/
17 BuildRequires:  OpenEXR-devel >= 1.2.1
18 #BuildRequires: OpenGL-devel >= 2.0
19 BuildRequires:  alsa-lib-devel >= 1.0.8
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  esound-devel
23 BuildRequires:  freetype-devel >= 2.1.4
24 BuildRequires:  gettext-devel
25 #BuildRequires: lame-libs-devel >= 3.93.1
26 BuildRequires:  libavc1394-devel >= 0.5.1
27 BuildRequires:  libiec61883-devel >= 1.0.0
28 #BuildRequires: libmpeg3-devel >= 1.7
29 BuildRequires:  libraw1394-devel >= 1.2.0
30 BuildRequires:  libsndfile-devel >= 1.0.11
31 BuildRequires:  libstdc++-devel >= 5:3.2.2
32 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
33 BuildRequires:  libtiff-devel >= 3.5.7
34 BuildRequires:  libtool
35 BuildRequires:  libuuid-devel
36 %ifarch %{ix86}
37 BuildRequires:  nasm
38 %endif
39 #BuildRequires: quicktime4linux-devel >= 2.2
40 BuildRequires:  xorg-lib-libX11-devel
41 BuildRequires:  xorg-lib-libXext-devel
42 BuildRequires:  xorg-lib-libXv-devel
43 BuildRequires:  xorg-lib-libXxf86vm-devel
44 Requires:       OpenEXR-devel >= 1.2.1
45 Requires:       alsa-lib >= 1.0.8
46 Requires:       freetype >= 2.1.4
47 Requires:       libavc1394 >= 0.5.1
48 Requires:       libiec61883 >= 1.0.0
49 #Requires:      libmpeg3 >= 1.7
50 Requires:       libraw1394 >= 1.2.0
51 Requires:       libsndfile >= 1.0.11
52 Requires:       libtheora >= 1.0-0.alpha4
53 #Requires:      quicktime4linux >= 2.2
54 Obsoletes:      bcast
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _noautostrip    .*/microtheme.plugin
58
59 %description
60 There are two types of moviegoers: producers who create new content,
61 going back over their content at future points for further refinement,
62 and consumers who want to acquire the content and watch it. Cinelerra
63 is not intended for consumers. Cinelerra has many features for
64 uncompressed content, high resolution processing, and compositing,
65 with very few shortcuts. Producers need these features because of the
66 need to retouch many generations of footage with alterations to the
67 format, which makes Cinelerra very complex.
68
69 Cinelerra was meant to be a Broadcast 2000 replacement.
70
71 This is Community Version.
72
73 %description -l pl
74 S± dwa rodzaje u¿ytkowników zajmuj±cych siê filmami: producenci
75 tworz±cy nowe filmy, wracaj±cy do nich w przysz³o¶ci w celu dalszego
76 wyg³adzenia, oraz konsumenci, którzy chc± tylko zdobyæ film i go
77 obejrzeæ. Cinelerra nie jest dla konsumentów. Program ma wiele
78 mo¿liwo¶ci do edycji nieskompresowanej zawarto¶ci, obróbki w wysokiej
79 rozdzielczo¶ci oraz monta¿u, z bardzo ma³± liczb± skrótów. Producenci
80 potrzebuj± tych mo¿liwo¶ci ze wzglêdu na konieczno¶æ retuszowania oraz
81 modyfikacji formatu, co czyni program bardzo z³o¿onym.
82
83 Cinelerra by³a tworzona z my¶l± o zast±pieniu programu Broadcast 2000.
84
85 Wersja Spo³eczno¶ciowa.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %build
92 rm -f m4/*.m4 *.m4
93 touch config.rpath
94 %{__gettextize}
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoheader}
98 %{__automake}
99 %{__autoconf}
100
101 %configure \
102 %ifarch ppc
103         --enable-altivec \
104 %endif
105 %ifarch %{ix86} %{x8664}
106         --enable-mmx \
107         --enable-3dnow \
108 %endif
109         --enable-freetype2 \
110         --with-external-ffmpeg \
111         --with-alsa-prefix=%{_prefix} \
112         --with-fontsdir=%{_fontsdir} \
113         --with-plugindir=%{_libdir}/cinelerra
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %find_lang cinelerra
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f cinelerra.lang
132 %defattr(644,root,root,755)
133 %doc doc/* README* TODO
134 %attr(755,root,root) %{_bindir}/*
135 %dir %{_libdir}/cinelerra
136 %attr(755,root,root) %{_libdir}/cinelerra/*.so
137 %{_libdir}/cinelerra/*.la
138 %{_libdir}/cinelerra/shapewipe
139 %attr(755,root,root) %{_libdir}/lib*.so.*
140 %{_desktopdir}/*.desktop
141 %{_pixmapsdir}/*.*
This page took 0.064778 seconds and 3 git commands to generate.