- fix building qith ffmpeg2
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20121104
5 %define         rel     4
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.2
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  06b92b01fa6ba32ca4622922f2cbaa68
16 Patch0:         %{name}-build.patch
17 Patch1:         %{name}-desktop.patch
18 # http://bugs.cinelerra.org/raw-attachment/ticket/949/remove-support-v4l-buzz-k2-6-38.diff
19 Patch2:         remove-support-v4l-buzz-k2-6-38.diff
20 Patch3:         %{name}-ffmpeg.patch
21 Patch4:         %{name}-format-security.patch
22 Patch5:         %{name}-ffmpeg2.patch
23 URL:            http://cinelerra.org/
24 BuildRequires:  OpenEXR-devel >= 1.2.1
25 BuildRequires:  OpenGL-GLU-devel
26 BuildRequires:  OpenGL-devel
27 BuildRequires:  a52dec-libs-devel
28 BuildRequires:  alsa-lib-devel >= 1.0.8
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  ffmpeg-devel >= 0.7.1
32 BuildRequires:  fftw3-devel
33 BuildRequires:  freetype-devel >= 2.1.4
34 BuildRequires:  gettext-devel
35 BuildRequires:  lame-libs-devel >= 3.93.1
36 BuildRequires:  libavc1394-devel >= 0.5.1
37 BuildRequires:  libdv-devel
38 BuildRequires:  libiec61883-devel >= 1.0.0
39 #BuildRequires: libmpeg3-devel >= 1.7
40 BuildRequires:  libpng-devel >= 2:1.4.0
41 BuildRequires:  libraw1394-devel >= 1.2.0
42 BuildRequires:  libsndfile-devel >= 1.0.11
43 BuildRequires:  libstdc++-devel >= 5:3.2.2
44 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
45 BuildRequires:  libtiff-devel >= 3.5.7
46 BuildRequires:  libtool
47 BuildRequires:  libuuid-devel
48 BuildRequires:  mjpegtools-devel
49 BuildRequires:  pkgconfig
50 %ifarch %{ix86} %{x8664}
51 BuildRequires:  nasm
52 %endif
53 #BuildRequires: quicktime4linux-devel >= 2.2
54 BuildRequires:  sed >= 4.0
55 BuildRequires:  xorg-lib-libX11-devel
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXv-devel
58 BuildRequires:  xorg-lib-libXxf86vm-devel
59 Requires:       OpenEXR >= 1.2.1
60 Requires:       alsa-lib >= 1.0.8
61 Requires:       freetype >= 2.1.4
62 Requires:       libavc1394 >= 0.5.1
63 Requires:       libiec61883 >= 1.0.0
64 #Requires:      libmpeg3 >= 1.7
65 Requires:       libraw1394 >= 1.2.0
66 Requires:       libsndfile >= 1.0.11
67 Requires:       libtheora >= 1.0-0.alpha4
68 #Requires:      quicktime4linux >= 2.2
69 Obsoletes:      bcast
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _noautostrip    .*/microtheme.plugin
73
74 %description
75 There are two types of moviegoers: producers who create new content,
76 going back over their content at future points for further refinement,
77 and consumers who want to acquire the content and watch it. Cinelerra
78 is not intended for consumers. Cinelerra has many features for
79 uncompressed content, high resolution processing, and compositing,
80 with very few shortcuts. Producers need these features because of the
81 need to retouch many generations of footage with alterations to the
82 format, which makes Cinelerra very complex.
83
84 Cinelerra was meant to be a Broadcast 2000 replacement.
85
86 This is Community Version.
87
88 %description -l pl.UTF-8
89 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
90 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
91 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
92 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
93 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
94 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
95 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
96 modyfikacji formatu, co czyni program bardzo złożonym.
97
98 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
99
100 Wersja społecznościowa.
101
102 %prep
103 %setup -q -n %{name}
104 %patch0 -p1
105 %patch1 -p1
106 #%patch2 -p1
107 %patch3 -p1
108 %patch4 -p1
109 %patch5 -p0
110
111 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
112
113 %build
114 rm -f m4/*.m4 *.m4
115 touch config.rpath
116 %{__gettextize}
117 %{__libtoolize}
118 %{__aclocal} -I m4
119 %{__autoheader}
120 %{__automake}
121 %{__autoconf}
122
123 %configure \
124         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
125         CXXFLAGS="%{rpmcxxflags} -D__STDC_CONSTANT_MACROS=1" \
126 %ifarch ppc
127         --enable-altivec \
128 %endif
129 %ifarch %{ix86} %{x8664}
130         --enable-mmx \
131         --enable-3dnow \
132 %endif
133         --disable-esd \
134         --enable-freetype2 \
135         --with-external-ffmpeg \
136         --with-alsa-prefix=%{_prefix} \
137         --with-fontsdir=%{_fontsdir} \
138         --with-plugindir=%{_libdir}/cinelerra
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
149
150 %find_lang cinelerra
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files -f cinelerra.lang
159 %defattr(644,root,root,755)
160 %doc doc/* README* TODO
161 %attr(755,root,root) %{_bindir}/*
162 %dir %{_libdir}/cinelerra
163 %attr(755,root,root) %{_libdir}/cinelerra/*.so
164 %{_libdir}/cinelerra/*.la
165 %{_libdir}/cinelerra/shapewipe
166 %{_libdir}/cinelerra/fonts
167 %attr(755,root,root) %{_libdir}/lib*.so.*
168 %{_desktopdir}/*.desktop
169 %{_pixmapsdir}/*.*
This page took 0.111455 seconds and 3 git commands to generate.