]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- fix building with -Wformat-security
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20121104
5 %define         rel     2
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.2
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  06b92b01fa6ba32ca4622922f2cbaa68
16 Patch0:         %{name}-build.patch
17 Patch1:         %{name}-desktop.patch
18 # http://bugs.cinelerra.org/raw-attachment/ticket/949/remove-support-v4l-buzz-k2-6-38.diff
19 Patch2:         remove-support-v4l-buzz-k2-6-38.diff
20 Patch3:         %{name}-ffmpeg.patch
21 Patch4:         %{name}-format-security.patch
22 URL:            http://cinelerra.org/
23 BuildRequires:  OpenEXR-devel >= 1.2.1
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  a52dec-libs-devel
27 BuildRequires:  alsa-lib-devel >= 1.0.8
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  ffmpeg-devel >= 0.7.1
31 BuildRequires:  fftw3-devel
32 BuildRequires:  freetype-devel >= 2.1.4
33 BuildRequires:  gettext-devel
34 BuildRequires:  lame-libs-devel >= 3.93.1
35 BuildRequires:  libavc1394-devel >= 0.5.1
36 BuildRequires:  libdv-devel
37 BuildRequires:  libiec61883-devel >= 1.0.0
38 #BuildRequires: libmpeg3-devel >= 1.7
39 BuildRequires:  libpng-devel >= 2:1.4.0
40 BuildRequires:  libraw1394-devel >= 1.2.0
41 BuildRequires:  libsndfile-devel >= 1.0.11
42 BuildRequires:  libstdc++-devel >= 5:3.2.2
43 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
44 BuildRequires:  libtiff-devel >= 3.5.7
45 BuildRequires:  libtool
46 BuildRequires:  libuuid-devel
47 BuildRequires:  mjpegtools-devel
48 BuildRequires:  pkgconfig
49 %ifarch %{ix86} %{x8664}
50 BuildRequires:  nasm
51 %endif
52 #BuildRequires: quicktime4linux-devel >= 2.2
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  xorg-lib-libX11-devel
55 BuildRequires:  xorg-lib-libXext-devel
56 BuildRequires:  xorg-lib-libXv-devel
57 BuildRequires:  xorg-lib-libXxf86vm-devel
58 Requires:       OpenEXR >= 1.2.1
59 Requires:       alsa-lib >= 1.0.8
60 Requires:       freetype >= 2.1.4
61 Requires:       libavc1394 >= 0.5.1
62 Requires:       libiec61883 >= 1.0.0
63 #Requires:      libmpeg3 >= 1.7
64 Requires:       libraw1394 >= 1.2.0
65 Requires:       libsndfile >= 1.0.11
66 Requires:       libtheora >= 1.0-0.alpha4
67 #Requires:      quicktime4linux >= 2.2
68 Obsoletes:      bcast
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _noautostrip    .*/microtheme.plugin
72
73 %description
74 There are two types of moviegoers: producers who create new content,
75 going back over their content at future points for further refinement,
76 and consumers who want to acquire the content and watch it. Cinelerra
77 is not intended for consumers. Cinelerra has many features for
78 uncompressed content, high resolution processing, and compositing,
79 with very few shortcuts. Producers need these features because of the
80 need to retouch many generations of footage with alterations to the
81 format, which makes Cinelerra very complex.
82
83 Cinelerra was meant to be a Broadcast 2000 replacement.
84
85 This is Community Version.
86
87 %description -l pl.UTF-8
88 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
89 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
90 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
91 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
92 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
93 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
94 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
95 modyfikacji formatu, co czyni program bardzo złożonym.
96
97 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
98
99 Wersja społecznościowa.
100
101 %prep
102 %setup -q -n %{name}
103 %patch0 -p1
104 %patch1 -p1
105 #%patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108
109 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
110
111 %build
112 rm -f m4/*.m4 *.m4
113 touch config.rpath
114 %{__gettextize}
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoheader}
118 %{__automake}
119 %{__autoconf}
120
121 %configure \
122         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
123         CXXFLAGS="%{rpmcxxflags} -D__STDC_CONSTANT_MACROS=1" \
124 %ifarch ppc
125         --enable-altivec \
126 %endif
127 %ifarch %{ix86} %{x8664}
128         --enable-mmx \
129         --enable-3dnow \
130 %endif
131         --disable-esd \
132         --enable-freetype2 \
133         --with-external-ffmpeg \
134         --with-alsa-prefix=%{_prefix} \
135         --with-fontsdir=%{_fontsdir} \
136         --with-plugindir=%{_libdir}/cinelerra
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
147
148 %find_lang cinelerra
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files -f cinelerra.lang
157 %defattr(644,root,root,755)
158 %doc doc/* README* TODO
159 %attr(755,root,root) %{_bindir}/*
160 %dir %{_libdir}/cinelerra
161 %attr(755,root,root) %{_libdir}/cinelerra/*.so
162 %{_libdir}/cinelerra/*.la
163 %{_libdir}/cinelerra/shapewipe
164 %{_libdir}/cinelerra/fonts
165 %attr(755,root,root) %{_libdir}/lib*.so.*
166 %{_desktopdir}/*.desktop
167 %{_pixmapsdir}/*.*
This page took 0.042574 seconds and 3 git commands to generate.