]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- rel .5
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define snap    20061125
5 Summary:        Cinelerra - capturing, editing and production of audio/video material
6 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
7 Name:           cinelerra-cv
8 Version:        2.1
9 Release:        0.%{snap}.5
10 License:        GPL
11 Group:          X11/Applications
12 # svn://svn.skolelinux.org/cinelerra/trunk/hvirtual
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  89a039be86acab89ed392ce987dea2c8
15 Patch0:         %{name}-build.patch
16 URL:            http://cvs.cinelerra.org/
17 BuildRequires:  OpenEXR-devel >= 1.2.1
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  a52dec-libs-devel
20 BuildRequires:  alsa-lib-devel >= 1.0.8
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  esound-devel
24 BuildRequires:  ffmpeg-devel
25 BuildRequires:  fftw3-devel
26 BuildRequires:  freetype-devel >= 2.1.4
27 BuildRequires:  gettext-devel
28 BuildRequires:  lame-libs-devel >= 3.93.1
29 BuildRequires:  libavc1394-devel >= 0.5.1
30 BuildRequires:  libdv-devel
31 BuildRequires:  libiec61883-devel >= 1.0.0
32 #BuildRequires: libmpeg3-devel >= 1.7
33 BuildRequires:  libraw1394-devel >= 1.2.0
34 BuildRequires:  libsndfile-devel >= 1.0.11
35 BuildRequires:  libstdc++-devel >= 5:3.2.2
36 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
37 BuildRequires:  libtiff-devel >= 3.5.7
38 BuildRequires:  libtool
39 BuildRequires:  libuuid-devel
40 BuildRequires:  mjpegtools-devel
41 %ifarch %{ix86}
42 BuildRequires:  nasm
43 %endif
44 #BuildRequires: quicktime4linux-devel >= 2.2
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xorg-lib-libXext-devel
47 BuildRequires:  xorg-lib-libXv-devel
48 BuildRequires:  xorg-lib-libXxf86vm-devel
49 Requires:       OpenEXR-devel >= 1.2.1
50 Requires:       alsa-lib >= 1.0.8
51 Requires:       freetype >= 2.1.4
52 Requires:       libavc1394 >= 0.5.1
53 Requires:       libiec61883 >= 1.0.0
54 #Requires:      libmpeg3 >= 1.7
55 Requires:       libraw1394 >= 1.2.0
56 Requires:       libsndfile >= 1.0.11
57 Requires:       libtheora >= 1.0-0.alpha4
58 #Requires:      quicktime4linux >= 2.2
59 Obsoletes:      bcast
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _noautostrip    .*/microtheme.plugin
63
64 %description
65 There are two types of moviegoers: producers who create new content,
66 going back over their content at future points for further refinement,
67 and consumers who want to acquire the content and watch it. Cinelerra
68 is not intended for consumers. Cinelerra has many features for
69 uncompressed content, high resolution processing, and compositing,
70 with very few shortcuts. Producers need these features because of the
71 need to retouch many generations of footage with alterations to the
72 format, which makes Cinelerra very complex.
73
74 Cinelerra was meant to be a Broadcast 2000 replacement.
75
76 This is Community Version.
77
78 %description -l pl.UTF-8
79 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
80 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
81 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
82 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
83 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
84 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
85 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
86 modyfikacji formatu, co czyni program bardzo złożonym.
87
88 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
89
90 Wersja Społecznościowa.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 rm -f m4/*.m4 *.m4
98 touch config.rpath
99 %{__gettextize}
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoheader}
103 %{__automake}
104 %{__autoconf}
105
106 %configure \
107 %ifarch ppc
108         --enable-altivec \
109 %endif
110 %ifarch %{ix86} %{x8664}
111         --enable-mmx \
112         --enable-3dnow \
113 %endif
114         --enable-freetype2 \
115         --with-external-ffmpeg \
116         --with-alsa-prefix=%{_prefix} \
117         --with-fontsdir=%{_fontsdir} \
118         --with-plugindir=%{_libdir}/cinelerra
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
129
130 %find_lang cinelerra
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files -f cinelerra.lang
139 %defattr(644,root,root,755)
140 %doc doc/* README* TODO
141 %attr(755,root,root) %{_bindir}/*
142 %dir %{_libdir}/cinelerra
143 %attr(755,root,root) %{_libdir}/cinelerra/*.so
144 %{_libdir}/cinelerra/*.la
145 %{_libdir}/cinelerra/shapewipe
146 %{_libdir}/cinelerra/fonts
147 %attr(755,root,root) %{_libdir}/lib*.so.*
148 %{_desktopdir}/*.desktop
149 %{_pixmapsdir}/*.*
This page took 0.049657 seconds and 3 git commands to generate.