]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
5fb1bd66e137b7161ace03bfe71d1c736875bf9e
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20100109
5 %define         rel             1
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.1
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  e130b134a9e691ae36d2bbb117fc530b
16 Patch0:         %{name}-build.patch
17 URL:            http://cinelerra.org/
18 BuildRequires:  OpenEXR-devel >= 1.2.1
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  a52dec-libs-devel
21 BuildRequires:  alsa-lib-devel >= 1.0.8
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  esound-devel
25 BuildRequires:  ffmpeg-devel
26 BuildRequires:  fftw3-devel
27 BuildRequires:  freetype-devel >= 2.1.4
28 BuildRequires:  gettext-devel
29 BuildRequires:  lame-libs-devel >= 3.93.1
30 BuildRequires:  libavc1394-devel >= 0.5.1
31 BuildRequires:  libdv-devel
32 BuildRequires:  libiec61883-devel >= 1.0.0
33 #BuildRequires: libmpeg3-devel >= 1.7
34 BuildRequires:  libraw1394-devel >= 1.2.0
35 BuildRequires:  libsndfile-devel >= 1.0.11
36 BuildRequires:  libstdc++-devel >= 5:3.2.2
37 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
38 BuildRequires:  libtiff-devel >= 3.5.7
39 BuildRequires:  libtool
40 BuildRequires:  libuuid-devel
41 BuildRequires:  mjpegtools-devel
42 %ifarch %{ix86}
43 BuildRequires:  nasm
44 %endif
45 #BuildRequires: quicktime4linux-devel >= 2.2
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xorg-lib-libXext-devel
49 BuildRequires:  xorg-lib-libXv-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 Requires:       OpenEXR >= 1.2.1
52 Requires:       alsa-lib >= 1.0.8
53 Requires:       freetype >= 2.1.4
54 Requires:       libavc1394 >= 0.5.1
55 Requires:       libiec61883 >= 1.0.0
56 #Requires:      libmpeg3 >= 1.7
57 Requires:       libraw1394 >= 1.2.0
58 Requires:       libsndfile >= 1.0.11
59 Requires:       libtheora >= 1.0-0.alpha4
60 #Requires:      quicktime4linux >= 2.2
61 Obsoletes:      bcast
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _noautostrip    .*/microtheme.plugin
65
66 %description
67 There are two types of moviegoers: producers who create new content,
68 going back over their content at future points for further refinement,
69 and consumers who want to acquire the content and watch it. Cinelerra
70 is not intended for consumers. Cinelerra has many features for
71 uncompressed content, high resolution processing, and compositing,
72 with very few shortcuts. Producers need these features because of the
73 need to retouch many generations of footage with alterations to the
74 format, which makes Cinelerra very complex.
75
76 Cinelerra was meant to be a Broadcast 2000 replacement.
77
78 This is Community Version.
79
80 %description -l pl.UTF-8
81 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
82 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
83 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
84 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
85 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
86 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
87 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
88 modyfikacji formatu, co czyni program bardzo złożonym.
89
90 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
91
92 Wersja społecznościowa.
93
94 %prep
95 %setup -q -n %{name}
96 %patch0 -p1
97
98 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
99
100 %build
101 rm -f m4/*.m4 *.m4
102 touch config.rpath
103 %{__gettextize}
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoheader}
107 %{__automake}
108 %{__autoconf}
109
110 %configure \
111         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
112 %ifarch ppc
113         --enable-altivec \
114 %endif
115 %ifarch %{ix86} %{x8664}
116         --enable-mmx \
117         --enable-3dnow \
118 %endif
119         --enable-freetype2 \
120         --with-external-ffmpeg \
121         --with-alsa-prefix=%{_prefix} \
122         --with-fontsdir=%{_fontsdir} \
123         --with-plugindir=%{_libdir}/cinelerra
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
134
135 %find_lang cinelerra
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f cinelerra.lang
144 %defattr(644,root,root,755)
145 %doc doc/* README* TODO
146 %attr(755,root,root) %{_bindir}/*
147 %dir %{_libdir}/cinelerra
148 %attr(755,root,root) %{_libdir}/cinelerra/*.so
149 %{_libdir}/cinelerra/*.la
150 %{_libdir}/cinelerra/shapewipe
151 %{_libdir}/cinelerra/fonts
152 %attr(755,root,root) %{_libdir}/lib*.so.*
153 %{_desktopdir}/*.desktop
154 %{_pixmapsdir}/*.*
This page took 0.045053 seconds and 2 git commands to generate.