]> git.pld-linux.org Git - packages/cinelerra-cv.git/blame_incremental - cinelerra-cv.spec
- updated gettext BR
[packages/cinelerra-cv.git] / cinelerra-cv.spec
... / ...
CommitLineData
1# TODO:
2# - external libraries packages (is there any sense in that?)
3#
4%define snap 20121105
5%define rel 9
6Summary: Cinelerra - capturing, editing and production of audio/video material
7Summary(pl.UTF-8): Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8Name: cinelerra-cv
9Version: 2.2
10Release: 0.%{snap}.%{rel}
11License: GPL
12Group: X11/Applications
13# git clone git://git.cinelerra.org/CinelerraCV.git cinelerra-cv
14Source0: %{name}-%{snap}.tar.bz2
15# Source0-md5: 86559f96282802d0dc3006817a7c11e3
16Patch0: %{name}-build.patch
17Patch1: %{name}-desktop.patch
18# http://bugs.cinelerra.org/raw-attachment/ticket/949/remove-support-v4l-buzz-k2-6-38.diff
19Patch2: remove-support-v4l-buzz-k2-6-38.diff
20Patch3: %{name}-ffmpeg.patch
21Patch4: %{name}-format-security.patch
22Patch5: %{name}-ffmpeg2.patch
23URL: http://cinelerra.org/
24BuildRequires: OpenEXR-devel >= 1.2.1
25BuildRequires: OpenGL-GLU-devel
26BuildRequires: OpenGL-devel
27BuildRequires: a52dec-libs-devel
28BuildRequires: alsa-lib-devel >= 1.0.8
29BuildRequires: autoconf
30BuildRequires: automake
31BuildRequires: ffmpeg-devel >= 0.7.1
32BuildRequires: fftw3-devel
33BuildRequires: freetype-devel >= 2.1.4
34BuildRequires: gettext-tools
35BuildRequires: lame-libs-devel >= 3.93.1
36BuildRequires: libavc1394-devel >= 0.5.1
37BuildRequires: libdv-devel
38BuildRequires: libiec61883-devel >= 1.0.0
39#BuildRequires: libmpeg3-devel >= 1.7
40BuildRequires: libpng-devel >= 2:1.4.0
41BuildRequires: libraw1394-devel >= 1.2.0
42BuildRequires: libsndfile-devel >= 1.0.11
43BuildRequires: libstdc++-devel >= 5:3.2.2
44BuildRequires: libtheora-devel >= 1.0-0.alpha4
45BuildRequires: libtiff-devel >= 3.5.7
46BuildRequires: libtool
47BuildRequires: libuuid-devel
48BuildRequires: mjpegtools-devel
49BuildRequires: pkgconfig
50%ifarch %{ix86} %{x8664}
51BuildRequires: nasm
52%endif
53#BuildRequires: quicktime4linux-devel >= 2.2
54BuildRequires: sed >= 4.0
55BuildRequires: xorg-lib-libX11-devel
56BuildRequires: xorg-lib-libXext-devel
57BuildRequires: xorg-lib-libXv-devel
58BuildRequires: xorg-lib-libXxf86vm-devel
59Requires: OpenEXR >= 1.2.1
60Requires: alsa-lib >= 1.0.8
61Requires: freetype >= 2.1.4
62Requires: libavc1394 >= 0.5.1
63Requires: libiec61883 >= 1.0.0
64#Requires: libmpeg3 >= 1.7
65Requires: libraw1394 >= 1.2.0
66Requires: libsndfile >= 1.0.11
67Requires: libtheora >= 1.0-0.alpha4
68#Requires: quicktime4linux >= 2.2
69Obsoletes: bcast
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%define _noautostrip .*/microtheme.plugin
73
74%description
75There are two types of moviegoers: producers who create new content,
76going back over their content at future points for further refinement,
77and consumers who want to acquire the content and watch it. Cinelerra
78is not intended for consumers. Cinelerra has many features for
79uncompressed content, high resolution processing, and compositing,
80with very few shortcuts. Producers need these features because of the
81need to retouch many generations of footage with alterations to the
82format, which makes Cinelerra very complex.
83
84Cinelerra was meant to be a Broadcast 2000 replacement.
85
86This is Community Version.
87
88%description -l pl.UTF-8
89Są dwa rodzaje użytkowników zajmujących się filmami: producenci
90tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
91wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
92obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
93możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
94rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
95potrzebują tych możliwości ze względu na konieczność retuszowania oraz
96modyfikacji formatu, co czyni program bardzo złożonym.
97
98Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
99
100Wersja społecznościowa.
101
102%prep
103%setup -q -n %{name}
104%patch0 -p1
105%patch1 -p1
106#%patch2 -p1
107%patch3 -p1
108%patch4 -p1
109%patch5 -p0
110
111find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
112
113%build
114rm -f m4/*.m4 *.m4
115touch config.rpath
116%{__gettextize}
117%{__libtoolize}
118%{__aclocal} -I m4
119%{__autoheader}
120%{__automake}
121%{__autoconf}
122
123%configure \
124 CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
125 CXXFLAGS="%{rpmcxxflags} -D__STDC_CONSTANT_MACROS=1" \
126%ifarch ppc
127 --enable-altivec \
128%endif
129%ifarch %{ix86} %{x8664}
130 --enable-mmx \
131 --enable-3dnow \
132%endif
133 --disable-esd \
134 --enable-freetype2 \
135 --with-external-ffmpeg \
136 --with-alsa-prefix=%{_prefix} \
137 --with-fontsdir=%{_fontsdir} \
138 --with-plugindir=%{_libdir}/cinelerra
139
140%{__make}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145%{__make} install \
146 DESTDIR=$RPM_BUILD_ROOT
147
148install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
149
150%find_lang cinelerra
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post -p /sbin/ldconfig
156%postun -p /sbin/ldconfig
157
158%files -f cinelerra.lang
159%defattr(644,root,root,755)
160%doc doc/* README* TODO
161%attr(755,root,root) %{_bindir}/*
162%dir %{_libdir}/cinelerra
163%attr(755,root,root) %{_libdir}/cinelerra/*.so
164%{_libdir}/cinelerra/*.la
165%{_libdir}/cinelerra/shapewipe
166%{_libdir}/cinelerra/fonts
167%attr(755,root,root) %{_libdir}/lib*.so.*
168%{_desktopdir}/*.desktop
169%{_pixmapsdir}/*.*
This page took 0.048451 seconds and 4 git commands to generate.