]> git.pld-linux.org Git - packages/cilk.git/blob - cilk.spec
- tabs in preamble
[packages/cilk.git] / cilk.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        Cilk compiler
6 Summary(pl.UTF-8):      Kompilator Cilka
7 Name:           cilk
8 Version:        5.4.2.2
9 %define _rev    1708
10 Release:        0.1
11 License:        GPL v2 and LGPL
12 Group:          Development/Languages
13 Source0:        http://bradley.csail.mit.edu/~bradley/cilk/downloads/%{name}-%{version}_%{_rev}.tar.bz2
14 # Source0-md5:  1046f684ac72076106574fcc8326e612
15 URL:            http://supertech.lcs.mit.edu/cilk/
16 Patch0:         %{name}-update.patch
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  libtool
22 Requires:       gcc
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Cilk is a language for multithreaded parallel programming based on
27 ANSI C. Cilk is designed for general-purpose parallel programming, but
28 it is especially effective for exploiting dynamic, highly asynchronous
29 parallelism, which can be difficult to write in data-parallel or
30 message-passing style.
31
32 %description -l pl.UTF-8
33 Clik to język to wielowątkowego, równoległego programowania oparty na
34 ANSI C. Cilk został zaprojektowany do programowania równoległego
35 ogólnego przeznaczenia, ale jest szczególnie efektywny do
36 wykorzystywania dynamicznej, wysoce asynchronicznej równoległości,
37 kiedy może być trudno pisać w stylu z równoległymi danymi lub
38 przekazywaniem komunikatów.
39
40 %package static
41 Summary:        Static cilk libraries
42 Summary(pl.UTF-8):      Statyczne biblioteki cilka
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description static
47 Static cilk libraries.
48
49 %description static -l pl.UTF-8
50 Statyczne biblioteki cilka.
51
52 %prep
53 %setup -q -n %{version}
54 %patch0 -p1
55 %{!?with_tests:sed 's/ examples / /' -i Makefile.in}
56
57 %build
58 %{__libtoolize}
59 %{__aclocal} -I m4dir
60 %{__autoconf}
61 %{__autoheader}
62 %{__automake}
63
64 %configure
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS ChangeLog NEWS README THANKS
82 %attr(755,root,root) %{_bindir}/*
83 %attr(755,root,root) %{_libdir}/*.so.*.*.*
84 %attr(755,root,root) %{_libdir}/*.so
85 %{_libdir}/*.la
86 # contains libcilkrt0*.a
87 %{_libdir}/%{name}
88 %{_includedir}/%{name}
89
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/*.a
This page took 0.07893 seconds and 3 git commands to generate.