]> git.pld-linux.org Git - packages/cilk.git/blame - cilk.spec
- tabs in preamble
[packages/cilk.git] / cilk.spec
CommitLineData
f14f25d1 1#
2# Conditional build:
3%bcond_without tests # build without tests
4#
5Summary: Cilk compiler
b2c6c4fb 6Summary(pl.UTF-8): Kompilator Cilka
f14f25d1 7Name: cilk
8Version: 5.4.2.2
9%define _rev 1708
10Release: 0.1
11License: GPL v2 and LGPL
12Group: Development/Languages
13Source0: http://bradley.csail.mit.edu/~bradley/cilk/downloads/%{name}-%{version}_%{_rev}.tar.bz2
14# Source0-md5: 1046f684ac72076106574fcc8326e612
15URL: http://supertech.lcs.mit.edu/cilk/
7fb666bf 16Patch0: %{name}-update.patch
d6f1d0f5 17BuildRequires: autoconf
18BuildRequires: automake
4d29a260 19BuildRequires: bison
f14f25d1 20BuildRequires: flex
d6f1d0f5 21BuildRequires: libtool
f14f25d1 22Requires: gcc
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Cilk is a language for multithreaded parallel programming based on
27ANSI C. Cilk is designed for general-purpose parallel programming, but
28it is especially effective for exploiting dynamic, highly asynchronous
29parallelism, which can be difficult to write in data-parallel or
30message-passing style.
31
1301247d
JR
32%description -l pl.UTF-8
33Clik to język to wielowątkowego, równoległego programowania oparty na
34ANSI C. Cilk został zaprojektowany do programowania równoległego
35ogólnego przeznaczenia, ale jest szczególnie efektywny do
36wykorzystywania dynamicznej, wysoce asynchronicznej równoległości,
37kiedy może być trudno pisać w stylu z równoległymi danymi lub
38przekazywaniem komunikatów.
f14f25d1 39
40%package static
41Summary: Static cilk libraries
b2c6c4fb 42Summary(pl.UTF-8): Statyczne biblioteki cilka
f14f25d1 43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description static
47Static cilk libraries.
48
1301247d 49%description static -l pl.UTF-8
d1d99c07 50Statyczne biblioteki cilka.
f14f25d1 51
52%prep
53%setup -q -n %{version}
7fb666bf 54%patch0 -p1
f14f25d1 55%{!?with_tests:sed 's/ examples / /' -i Makefile.in}
56
57%build
c7f50b33 58%{__libtoolize}
59%{__aclocal} -I m4dir
60%{__autoconf}
61%{__autoheader}
62%{__automake}
f14f25d1 63
64%configure
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%{__make} install \
71 DESTDIR=$RPM_BUILD_ROOT
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post -p /sbin/ldconfig
77%postun -p /sbin/ldconfig
78
79%files
80%defattr(644,root,root,755)
81%doc AUTHORS ChangeLog NEWS README THANKS
82%attr(755,root,root) %{_bindir}/*
83%attr(755,root,root) %{_libdir}/*.so.*.*.*
f14f25d1 84%attr(755,root,root) %{_libdir}/*.so
85%{_libdir}/*.la
86# contains libcilkrt0*.a
87%{_libdir}/%{name}
62c539ed 88%{_includedir}/%{name}
f14f25d1 89
90%files static
91%defattr(644,root,root,755)
92%{_libdir}/*.a
This page took 0.096842 seconds and 4 git commands to generate.