]> git.pld-linux.org Git - packages/chrony.git/blob - chrony.spec
- updated to 4.5
[packages/chrony.git] / chrony.spec
1 Summary:        An NTP client/server
2 Name:           chrony
3 Version:        3.1
4 Release:        1
5 License:        GPL v2
6 Group:          Daemons
7 Source0:        http://download.tuxfamily.org/chrony/%{name}-%{version}.tar.gz
8 # Source0-md5:  f8d2ee78c55548bfbe95582c6a855cee
9 Source1:        %{name}.conf
10 Source2:        %{name}.keys
11 Source3:        %{name}d.sysconfig
12 Source4:        %{name}d.init
13 Source5:        %{name}.logrotate
14 URL:            http://chrony.tuxfamily.org/
15 BuildRequires:  asciidoc
16 BuildRequires:  bison
17 BuildRequires:  libcap-devel
18 BuildRequires:  nss-devel
19 BuildRequires:  readline-devel
20 BuildRequires:  rpmbuild(macros) >= 1.453
21 Requires(postun):       /usr/sbin/groupdel
22 Requires(postun):       /usr/sbin/userdel
23 Requires(pre):  /bin/id
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Provides:       group(ntp)
28 Provides:       ntpdaemon
29 Provides:       user(ntp)
30 Obsoletes:      ntpdaemon
31 Conflicts:      logrotate < 3.8.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _sysconfdir     /etc/ntp
35
36 # assume gcc 3.4 has it
37 %if "%{cc_version}" >= "3.4"
38 %define         specflags       -pie -fpie
39 %endif
40
41 %description
42 A client/server for the Network Time Protocol, this program keeps your
43 computer's clock accurate. It was specially designed to support
44 systems with dial-up Internet connections, and also supports computers
45 in permanently connected environments.
46
47 %prep
48 %setup -q
49
50 %build
51 # NOTE: It is not autoconf generated configre
52 CC="%{__cc}" \
53 CFLAGS="%{rpmcflags} -Wmissing-prototypes -Wall" \
54 CPPFLAGS="%{rpmcppflags}" \
55 ./configure \
56         --prefix=%{_prefix} \
57         --sysconfdir=%{_sysconfdir} \
58         --docdir=%{_docdir} \
59         --without-editline \
60
61 %{__make} getdate all docs \
62         ADOC=asciidoc
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} \
67         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{lib/ntp,log/chrony}}
68
69 %{__make} install install-docs \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 rm -rf $RPM_BUILD_ROOT%{_docdir}
73
74 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
75 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/keys
76 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/chronyd
77 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/chrony
78 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/chronyd
79
80 touch $RPM_BUILD_ROOT%{_localstatedir}/lib/ntp/{drift,rtc}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %pre
86 %groupadd -g 246 ntp
87 %useradd -u 246 -d %{_localstatedir}/lib/ntp -g ntp -c "NTP Daemon" ntp
88
89 %post
90 /sbin/chkconfig --add chronyd
91 %service chronyd restart
92
93 %preun
94 if [ "$1" = "0" ]; then
95         %service chronyd stop
96         /sbin/chkconfig --del chronyd
97 fi
98
99 %postun
100 if [ "$1" = "0" ]; then
101         %userremove ntp
102         %groupremove ntp
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %doc NEWS README FAQ examples/* doc/{faq,installation}.html
108 %dir %{_sysconfdir}
109 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.conf
110 %attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/keys
111 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/chronyd
112 %config(noreplace) /etc/logrotate.d/chrony
113 %attr(754,root,root) /etc/rc.d/init.d/chronyd
114 %attr(755,root,root) %{_bindir}/chronyc
115 %attr(755,root,root) %{_sbindir}/chronyd
116 %{_mandir}/man1/chronyc.1*
117 %{_mandir}/man5/chrony.conf.5*
118 %{_mandir}/man8/chronyd.8*
119
120 %dir %attr(770,root,ntp) /var/lib/ntp
121 %attr(640,ntp,ntp) %ghost /var/lib/ntp/drift
122 %attr(640,ntp,ntp) %ghost /var/lib/ntp/rtc
123
124 %dir %attr(770,ntp,ntp) /var/log/chrony
This page took 0.123016 seconds and 3 git commands to generate.