]> git.pld-linux.org Git - packages/chromium.git/commitdiff
- new
authorshadzik <shadzik@pld-linux.org>
Fri, 5 May 2006 13:16:40 +0000 (13:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    chromium-gcc3.patch -> 1.1
    chromium-proper-options.patch -> 1.1

chromium-gcc3.patch [new file with mode: 0644]
chromium-proper-options.patch [new file with mode: 0644]

diff --git a/chromium-gcc3.patch b/chromium-gcc3.patch
new file mode 100644 (file)
index 0000000..8eaa915
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ur Chromium-0.9/src/NCString.cpp Chromium-0.9.m/src/NCString.cpp
+--- src/NCString.cpp   2001-05-20 12:04:58.000000000 -0500
++++ src/NCString.cpp   2002-07-25 22:57:03.000000000 -0500
+@@ -5,6 +5,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <limits.h>
++#include <stdarg.h>
+ /**
+  * ctor
+--- src/MainGLUT.cpp.~1.6.~    2001-05-21 03:36:55.000000000 +0200
++++ src/MainGLUT.cpp   2004-12-30 01:22:00.734250944 +0100
+@@ -11,6 +11,7 @@
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <GL/glut.h>
diff --git a/chromium-proper-options.patch b/chromium-proper-options.patch
new file mode 100644 (file)
index 0000000..538d7b6
--- /dev/null
@@ -0,0 +1,33 @@
+--- scripts/Makefile.all.orig  2003-11-19 19:41:22.502256736 -0500
++++ scripts/Makefile.all       2003-11-19 19:41:25.414813960 -0500
+@@ -1,5 +1,4 @@
+ SUPPORT_DIRS  =        \
+-                      ./support/openal/ \
+                       ./support/glpng/src
+ CHROMIUM_DIRS =       \
+--- scripts/Makefile.no-setup.orig     2003-11-19 19:41:22.502256736 -0500
++++ scripts/Makefile.no-setup  2003-11-19 19:41:25.414813960 -0500
+@@ -1,5 +1,4 @@
+ SUPPORT_DIRS  =        \
+-                      ./support/openal/ \
+                       ./support/glpng/src
+ CHROMIUM_DIRS =       \
+--- src-setup/Audio.cpp.orig   2003-11-19 20:03:23.237474464 -0500
++++ src-setup/Audio.cpp        2003-11-19 20:03:49.838430504 -0500
+@@ -71,7 +71,14 @@
+       if(!initialized)
+       {
+               fprintf(stderr, "starting OpenAL...");
++#ifdef OLD_OPENAL
+               context_id = alcCreateContext(NULL);
++#else
++              ALCdevice *dev;
++              dev = alcOpenDevice( NULL );
++              context_id = alcCreateContext(dev, NULL);
++              alcMakeContextCurrent(context_id);
++#endif
+               initialized = (bool)context_id;
+               fprintf(stderr, "done.\n");
This page took 0.103312 seconds and 4 git commands to generate.