]> git.pld-linux.org Git - packages/chromium-bsu.git/commitdiff
- added many patches (see comments)
authorfastviper <fastviper@poczta.onet.pl>
Sat, 22 Dec 2001 11:32:01 +0000 (11:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added subpackage setup
- fixed some errors
- chromium now uses OpenAL
- package builds properly

Changed files:
    chromium-bsu.spec -> 1.5

chromium-bsu.spec

index fba5cb6dd04a0c7c10c4572f2e671e394a453cc7..400b048f877ac30cf2554dfb8951ec55d950d6a6 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Chromium B.S.U. is a fast paced, arcade-style space shooter
 Summary(pl):   Chromium B.S.U. to szybko tocz±ca siê strzelanina
 Name:          chromium
 Version:       0.9.12
-Release:       7
+Release:       8
 License:       Artistic
 Group:         X11/Applications/Games
 Group(de):     X11/Applikationen/Spiele
@@ -12,15 +12,48 @@ Source1:    http://www.reptilelabour.com/software/files/chromium/%{name}-data-%{ver
 Source2:       %{name}.desktop
 Source3:       %{name}-setup.desktop
 Source4:       %{name}.png
-Patch0:                %{name}-config.patch
+
+# This one allows definitions of all compile flags directly in .spec
+# by just commenting out those settings in Makefiles
+# This is patch from Mandrake Cooker
+Patch0:         chromium-0.9.12-fix-flags.patch
+# To be further investigated if this patch is needed
+# This is patch from Mandrake Cooker
+Patch1:         chromium-0.9.11-glibc-2.2.2.patch
+#Patch0 from RH obsoleted by much better idea from Mandrake
+#to setup OPENAL_OPT_FLAGS in spec (patch3 below)
+# This is patch from Mandrake Cooker
+#Patch0:       %{name}-config.patch
+Patch3:         chromium-0.9.12-fix-openal-configurecall.patch
+# This one fixes problems with ./configure (/bin/sh is NOT a link
+# to /bin/bash in PLD
+# This is patch from fastviper
+Patch4:         %{name}-configure_needs_bash.patch
+# As PLD doesn't have any QTDIR it's necessary to change Makefile
+# so that /usr/X11R6 could be one.
+# This is patch from fastviper
+Patch5:         %{name}-qt.patch
+# This patch comments out CC and CCX settings in Makefile allowing
+# use of nondefault compiler/linker. export CC from .spec
+# This is patch from fastviper
+Patch6:         %{name}-use_proper_CC.patch
+
+BuildRequires:  libogg-devel qt-devel SDL-devel libvorbis-devel
 URL:           http://www.reptilelabour.com/software/chromium/
 BuildPrereq:   SDL-devel >= 1.1.6
 BuildRequires: OpenGL-devel
 #BuildPrereq:  kdelibs-sound-devel
 Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
+
+%define         _prefix         /usr/X11R6/
 %define                _mandir         %{_prefix}/man
+%define                _bindir         %{_prefix}/bin
+%define         _gamesbindir    %{_bindir}
+%define         _gamesdatadir   %{_prefix}/share/games
+%define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
+%define         _noreqdep       libGL.so.1 libGLU.so.1 libGLcore.so.1
+
 
 %description
 You are captain of the cargo ship Chromium B.S.U., responsible for
@@ -53,33 +86,79 @@ flot
 - Autodestrukcja pozwala zachowaæ amunicjê - przed wysadzeniem siê
   my¶liwiec zwraca amunicjê tak, ¿e nastêpny mo¿e j± przej±æ.
 
+
+%package setup
+Summary:        Setup frontend for Chromium
+Summary(pl):   Graficzny konfigurator Chromium
+Group:          X11/Applications/Games
+Requires:       %{name} = %{version}-%{release}
+Requires:      qt
+
+%description setup
+This package contains the setup frontend (using QT) to ease
+configuration of Chromium, especially for its playlist features.
+
+%description setup -l pl
+Ten pakiet zawiera graficzny konfigurator (napisany w QT) u³atwiaj±cy
+ustalanie parametrów dla gry Chromium, szczególnie je¶li chodzi o 
+listê muzyki do odtwarzania.
+
 %prep
-%setup -q -n Chromium-0.9 -a 1
-%patch -p1
+%setup -q -n Chromium-0.9
+%patch0 -p0
+%patch1 -p0
+%patch3 -p0
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 find . -type d -name .xvpics -exec rm -rf {} \; ||:
 
+
 %build
-CFLAGS="%{rpmcflags}"
-%configure
+export CFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
+export CXXFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
+export CC=%{__cc}
+export CXX=%{__cc}
+export LINK=%{__cc}
+export DEFS="%{rpmcflags} -DGAMESBINDIR=\\\"%{_gamesbindir}\\\" \
+           -DPKGDATADIR=\\\"%{_gamesdatadir}/Chromium-0.9\\\" -DUSE_SDL \
+           `sdl-config --cflags` -DOLD_OPENAL -DAUDIO_OPENAL -D_REENTRANT \
+           -I../../include -I../support/openal/linux/include -I../support/openal/include"
+export OPENAL_CONFIG_OPTS="./configure %{_target_platform} --with-gcc=%{__cc}"
+export QTDIR=%{_prefix}
+./configure --enable-vorbis
 %{__make}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_applnkdir}/{Games/Arcade,Settings},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_applnkdir}/{Games/Arcade,Settings},%{_pixmapsdir},%{_gamesbindir},%{_gamesdatadir}}
 
-%{__make} install DESTDIR=RPM_BUILD_ROOT
+# It is enough to install one file
+#%{__make} install DESTDIR=RPM_BUILD_ROOT
+install bin/* $RPM_BUILD_ROOT/%{_gamesbindir}
 
-install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Games/Arcade/%{name}.desktop
+install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games/Arcade/%{name}.desktop
 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Settings/%{name}.desktop
 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
 
+#This installs datafiles
+tar zxvf %{SOURCE1} -C $RPM_BUILD_ROOT/%{_gamesdatadir}
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/*
-%{_pixmapsdir}/chromium.xpm
+%{_pixmapsdir}/chromium.png
 %{_applnkdir}/Games/Arcade/*
 %{_applnkdir}/Settings/*
-%{_prefix}/games/chromium
+#%{_prefix}/games/chromium
+%{_gamesdatadir}/*
+
+%files setup
+%defattr(644,root,root,755)
+%doc README
+%{_bindir}/chromium-setup
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.07625 seconds and 4 git commands to generate.