]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- pl
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
72cf1a31
JR
8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2 14%bcond_without sandboxing # with sandboxing
72cf1a31
JR
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
72cf1a31
JR
19%bcond_without system_ffmpeg # system ffmpeg
20%bcond_without system_harfbuzz # system harfbuzz
f822f236 21# http://bugs.gentoo.org/576370
72cf1a31
JR
22%bcond_with system_icu # system icu
23%bcond_without system_jsoncpp # system jsoncpp
24%bcond_without system_libexif # system libexif
25%bcond_without system_libmtp # system libmtp
26%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
27%bcond_without system_libwebp # system libwebp
4884fc99 28%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 29%bcond_with system_mesa # system Mesa
72cf1a31 30%bcond_without system_minizip # system minizip
62950103 31%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c 32# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
72cf1a31 33%bcond_with system_protobuf # system protobuf
be84bbd9 34%bcond_with system_re2 # system re2
72cf1a31
JR
35%bcond_without system_snappy # system snappy
36%bcond_without system_speex # system speex
37%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
38%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
39%bcond_with system_v8 # system v8
40%bcond_with system_libvpx # system libvpx, http://crbug.com/494939
ba685303 41%bcond_without system_yasm # system yasm
1c00315b 42%bcond_without system_zlib # system zlib
14c8ce0e 43%bcond_with tcmalloc # use tcmalloc
7e136323 44%bcond_without verbose # verbose build (V=1)
0c480b89 45
b3fc6cb2
ER
46%ifarch %{ix86}
47# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
48%undefine with_system_mesa
5e3c5baa
ER
49
50# unable build with debuginfo on 32bit build systems
313715ac
ER
51# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
52%undefine with_debuginfo
53%endif
54
55%ifarch %{x8664}
56# x86_64 systems fail with debugedit crashing
57# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 58%undefine with_debuginfo
b3fc6cb2
ER
59%endif
60
6d92f81c 61# TODO
b363f856 62# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 63# - use_system_skia
a3140cd1 64# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 65# - use_system_stlport (android specific)
a3140cd1 66
e53ecfb5 67# NOTES:
4fe038cb
ER
68# - mute BEEP mixer if you do not want to hear horrible system bell when
69# pressing home/end in url bar or more ^F search results on page.
7c638678 70# - space considerations:
0bb93ab2 71# - unpacked sources: ~490MiB
57a3f726 72# - built code: ~1.1GiB (x86_64/i686)
f1b276d4 73# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 74# - to look for new tarball, use update-source.sh script
f1b276d4 75
f822f236 76%define branch 50.0.2661
692f3a01 77%define basever 75
fabf9ba0 78%define patchver 102
a3140cd1 79%define gyp_rev 1014
11ad81c4 80Summary: A WebKit powered web browser
2244ebba 81Summary(pl.UTF-8): Przeglądarka WWW oparta na bibliotece WebKit
05f72ae2 82Name: chromium-browser
f73369da
ER
83%if "%{?patchver}" != ""
84Version: %{branch}.%{patchver}
85%else
86Version: %{branch}.%{basever}
87%endif
a3a51c7f 88Release: 3
5bb99ef4 89License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 90Group: X11/Applications/Networking
692f3a01 91Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
c69ea2b3 92# Source0-md5: f6ae41191ec560a0d1cd238ac2a618cf
692f3a01 93#Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
3c73e180
ER
94%if "%{?patchver}" != ""
95Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
fabf9ba0 96# Patch0-md5: a8bd6c3c0f6befac88c81632a9360761
3c73e180 97%endif
37ceaf05 98Source1: %{name}.default
8b53130d
ER
99Source2: %{name}.sh
100Source3: %{name}.desktop
56c6e811
ER
101Source5: find-lang.sh
102Source6: update-source.sh
103Source7: clean-source.sh
836b1cac 104Source8: get-source.sh
0562b864 105Source9: master_preferences.json
a198be7c 106# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 107Patch2: enable-video-decode-accel.patch
5aa5df39 108Patch7: dlopen_sonamed_gl.patch
4765ddf1 109Patch8: chromium_useragent.patch.in
1347c76c
AM
110# https://bugs.gentoo.org/show_bug.cgi?id=393471
111# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 112Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
113Patch15: nacl-build-irt.patch
114Patch16: nacl-linkingfix.patch
9516ca97 115Patch18: nacl-no-untar.patch
6897926c 116Patch24: nacl-verbose.patch
c5b396f3
ER
117Patch25: gnome3-volume-control.patch
118Patch26: master-prefs-path.patch
25d4e23c 119Patch28: system-mesa.patch
9cce36cb 120Patch31: system-jinja.patch
708e64c2 121Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 122Patch35: etc-dir.patch
6e3c39b4 123Patch36: angle.patch
a198be7c 124Patch38: vaapi_include.patch
221355ea 125Patch39: libsecret.patch
f0db7b91
ER
126Patch40: ffmpeg-generate-errors.patch
127Patch41: ffmpeg-generate.patch
8a0c4436 128Patch42: system-ffmpeg.patch
72cf1a31 129Patch43: cups22.patch
750b48f7 130URL: http://www.chromium.org/Home
ae3fe89f 131%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 132%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 133BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 134%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 135%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
136BuildRequires: alsa-lib-devel
137BuildRequires: atk-devel
138BuildRequires: bison
11ad81c4 139BuildRequires: bzip2-devel
5997e180
ER
140%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
141%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
142%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 143%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 144%{?with_cups:BuildRequires: cups-devel}
92965b0e 145BuildRequires: elfutils-devel
77f32fa3 146BuildRequires: expat-devel
7b0b1eb2 147%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.7.2}
8f5f6775 148%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 149BuildRequires: fontconfig-devel
f1b276d4 150BuildRequires: glib2-devel
05f72ae2 151BuildRequires: gperf
71d49434 152%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 153BuildRequires: gtest-devel
8b53130d 154BuildRequires: gtk+2-devel
01b4dc8e 155%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 156%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 157%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 158BuildRequires: hicolor-icon-theme
ed514974 159%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 160%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 161BuildRequires: libevent-devel
8456d676 162%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 163%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 164%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 165%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 166%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 167%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 168BuildRequires: libpng-devel
221355ea 169BuildRequires: libsecret-devel
e266589e 170%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 171BuildRequires: libstdc++-devel
ba685303 172%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
7b0b1eb2 173%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.5.0}
88171dca 174%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 175BuildRequires: libxml2-devel
11ad81c4 176BuildRequires: libxslt-devel
535cb410 177BuildRequires: man-db
62950103 178%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 179%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 180BuildRequires: nspr-devel
f1b276d4 181BuildRequires: nss-devel >= 1:3.12.3
8456d676 182%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 183BuildRequires: pam-devel
f1b276d4 184BuildRequires: pango-devel
ef121064 185BuildRequires: pciutils-devel
3a3b7da9 186BuildRequires: perl-JSON
48b341f5 187BuildRequires: perl-modules
188BuildRequires: pkgconfig
75a27c2e 189%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 190%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 191BuildRequires: python
e2f921c3 192BuildRequires: python-BeautifulSoup
46cdefee 193#BuildRequires: python-gyp >= 1-%{gyp_rev}
7791e59a 194BuildRequires: python-html5lib
9cce36cb 195BuildRequires: python-jinja2 >= 2.7
48b341f5 196BuildRequires: python-modules
e0a7fe40 197BuildRequires: python-ply >= 3.4
42d59afd 198%{?with_system_re2:BuildRequires: re2-devel >= 20151101}
0cad051b 199BuildRequires: rpm >= 4.4.9-56
ffad9a4f 200BuildRequires: rpm-build >= 4.6
f1b276d4 201BuildRequires: rpmbuild(macros) >= 1.453
f099161f 202%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 203BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 204%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 205%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 206%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 207BuildRequires: tar >= 1:1.22
0a424ee2 208BuildRequires: udev-devel
7d1152d4 209BuildRequires: usbutils
2303ed45 210BuildRequires: util-linux
c14cd342 211%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 212BuildRequires: which
f1b276d4 213BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 214BuildRequires: xorg-lib-libXtst-devel
836b1cac 215BuildRequires: xz
a3140cd1 216%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 217%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 218Requires: browser-plugins >= 2.0
0cad051b 219Requires: desktop-file-utils
8f5f6775 220%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
221# crashes if no fontconfig font present
222Requires: fonts-Type1-urw
0eb19b0b 223Requires: hicolor-icon-theme
56403697 224Requires: libevent >= 2.0.21
c1edaafa 225%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 226%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 227Requires: lsb-release
42d59afd 228%{?with_system_re2:Requires: re2 >= 20151101}
4b2f9b57 229%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 230Requires: shared-mime-info
f7b16691 231%{?with_system_sqlite:Requires: sqlite3(icu)}
5c9227ee 232Requires: uname(release) >= 3.17
4dc49133 233Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 234Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 235Provides: wwwbrowser
c3582150 236Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 237Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 238ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 239BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 240
319f81f7
ER
241# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
242# Note: these are for PLD Linux use ONLY.
243# For your own distribution, please get your own set of keys.
244%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
245%define google_default_client_id 724288223830.apps.googleusercontent.com
246%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
247
7ebeabb6 248%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 249
e7fa0817
ER
250# Usage: gyp_with BCOND_NAME [OPTION_NAME]
251%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 252
a323900c
ER
253%ifarch %{ix86}
254%define target_arch ia32
255%endif
256%ifarch %{x8664}
257%define target_arch x64
258%endif
259
f8597c6e
ER
260%define buildtype %{?debug:Debug}%{!?debug:Release}
261%define builddir out/%{buildtype}
262
6b113615
ER
263%if %{without debuginfo}
264%define _enable_debug_packages 0
265%endif
266
11ad81c4 267%description
80838854
ER
268Chromium is an open-source browser project that aims to build a safer,
269faster, and more stable way for all Internet users to experience the
270web.
271
272Chromium serves as a base for Google Chrome, which is Chromium
273rebranded (name and logo) with very few additions such as usage
274tracking and an auto-updater system.
275
2244ebba
JB
276%description -l pl.UTF-8
277Chromium to mający otwarte źródła projekt przeglądarki WWW, którego
278celem jest stworzenie bezpieczniejszego, szybszego, batdziej
279stabilnego sposobu korzystania przez użytkowników z Internetu.
280
281Chromium służy jako podstawa dla przeglądarki Google Chrome, która
282jest zrebrandowanym (z własną nazwą i logo) Chromium z kilkoma
283dodatkami, takimi jak śledzenie sposobu korzystania czy system
284automatycznych uaktualnień.
285
f1b276d4
ER
286%package l10n
287Summary: chromium-browser language packages
2244ebba 288Summary(pl.UTF-8): Pakiety językowe do przeglądarki Chromium
f1b276d4
ER
289Group: I18n
290Requires: %{name} = %{version}-%{release}
8da7b90b 291BuildArch: noarch
f1b276d4
ER
292
293%description l10n
294Chromium is an open-source browser project that aims to build a safer,
295faster, and more stable way for all Internet users to experience the
296web.
297
298This package contains language packages for 50 languages:
299
e7fa0817
ER
300ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
301he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
302pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
303zh-TW
f1b276d4 304
2244ebba
JB
305%description l10n -l pl.UTF-8
306Chromium to mający otwarte źródła projekt przeglądarki WWW, którego
307celem jest stworzenie bezpieczniejszego, szybszego, batdziej
308stabilnego sposobu korzystania przez użytkowników z Internetu.
309
310Ten pakiet zawiera zasoby językowa dla ponad 50 języków:
311
312ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
313he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
314pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
315zh-TW
316
f1b276d4 317%prep
3c73e180
ER
318%setup -qc
319%if "%{?patchver}" != ""
77bd7e0a 320cd chromium*-%{branch}.%{basever}
3c73e180
ER
321%patch0 -p1
322cd ..
323%endif
77bd7e0a 324mv chromium*-%{branch}.%{basever}/* .
589d90ea 325
05f72ae2
ER
326# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
327# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 328. ./chrome/VERSION
e00e4177
ER
329chrome=$MAJOR.$MINOR.$BUILD.$PATCH
330test "$chrome" = %{version}
a3140cd1 331
75f96a39 332gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 333test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 334
4765ddf1
ER
335# add chromium and pld to useragent
336%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
337sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
338 -e 's/@BUILD_DIST_NAME@/PLD/g' \
339 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 340 < %{PATCH8} | %{__patch} -p1
4765ddf1 341
8da7b90b 342%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
343ln -s %{SOURCE7} .
344
810e0294 345#%patch2 -p1 CHECK
7879021e 346%patch7 -p1
75f96a39 347%patch15 -p2
f4a8da6a 348%{!?with_libjpegturbo:%patch11 -p0}
5997e180 349%patch16 -p1
41d6a4b1 350%patch28 -p1
a323900c 351%patch25 -p1
3aa67e11 352%{?with_nacl:%patch18 -p1}
ffb05754 353%patch24 -p1
75f96a39 354%patch26 -p2
cb6dde87 355%patch31 -p0
708e64c2 356%patch32 -p1
d7fca4aa 357%patch35 -p1
6e3c39b4 358%patch36 -p1
810e0294 359#%patch38 -p1 CHECK
deef15b4 360%patch39 -p1
692f3a01
ER
361#%patch40 -p1 UPDATE
362#%patch41 -p1 CHECK
8a0c4436 363%patch42 -p1
72cf1a31 364%patch43 -p1
e9abb380 365
308e6041 366# https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
ff7c827f 367install -d chrome/test/data/webui
308e6041 368touch chrome/test/data/webui/i18n_process_css_test.html
e9abb380 369
f684992e
ER
370%{?with_dev:exit 0}
371
75a27c2e
ER
372sh -x clean-source.sh \
373 %{!?with_nacl:nacl=0} \
bbdce24d
ER
374 %{!?with_system_libvpx:libvpx=0} \
375 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 376 %{!?with_system_mesa:mesa=0} \
75a27c2e 377 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 378 %{!?with_system_re2:re2=0} \
7e634b46 379 %{!?with_system_snappy:snappy=0} \
5048b37a 380 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 381 %{!?with_system_v8:v8=0} \
0767a7a0 382 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 383 %{!?with_system_zlib:zlib=0} \
f177fdad 384 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 385 %{nil}
fded59be 386
e266589e 387%build
5997e180 388%if %{with nacl}
108c5f7c 389rm -rf native_client/toolchain/linux_x86_newlib
fded59be 390if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 391# Make symlinks for NaCL
108c5f7c 392install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 393
108c5f7c
ER
394cd native_client/toolchain/linux_x86_newlib
395ln -s x86_64-nacl/bin bin
396cd x86_64-nacl/bin
2e4113fd 397__cc='%{__cc}'
f64e73f6 398if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
399 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
400 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
401 %{__sed} -i -e '1i#!/bin/sh' gcc g++
402 chmod +x gcc g++
403else
404 ln -s %{_bindir}/x86_64-nacl-gcc gcc
405 ln -s %{_bindir}/x86_64-nacl-g++ g++
406fi
108c5f7c
ER
407ln -s gcc x86_64-nacl-gcc
408ln -s g++ x86_64-nacl-g++
409ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
410ln -s %{_bindir}/x86_64-nacl-ar ar
411ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 412ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 413ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 414ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 415ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 416ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
417ln -s %{_prefix}/x86_64-nacl/lib ../lib
418ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
419ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
420cd ../../../../..
fded59be 421fi
5997e180
ER
422%endif
423
a323900c 424%if %{without system_ffmpeg}
f8597c6e
ER
425if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
426 # Re-configure bundled ffmpeg
427 cd third_party/ffmpeg
50d701c6
ER
428 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
429 --branding Chromium
f8597c6e 430 chromium/scripts/copy_config.sh
6e3c39b4 431 chromium/scripts/generate_gyp.py
f8597c6e
ER
432 cd -
433fi
0c480b89 434%endif
a323900c 435
6e3c39b4
ER
436third_party/libaddressinput/chromium/tools/update-strings.py
437
a323900c
ER
438flags="
439 -Dtarget_arch=%{target_arch} \
440 -Dpython_arch=%{target_arch} \
12687dbd 441 -Dproprietary_codecs=1 \
6e3c39b4 442 -Dffmpeg_branding=Chromium \
b91ce587 443 -Dsystem_libdir=%{_lib} \
a323900c 444 -Dpython_ver=%{py_ver} \
7b454a31
AM
445%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
446 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 447%endif
f047b07c 448 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 449 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 450 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 451 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 452 -Dinclude_tests__=0 \
c0808220 453%if %{with nacl}
038f76b9 454 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
455 -Ddisable_glibc_untar=1 \
456 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
457 -Ddisable_glibc=1 \
458 -Ddisable_pnacl=1 \
459 -Dbuild_pnacl_newlib=0 \
c0808220 460%else
8fb1dc98 461 -Ddisable_pnacl_untar=1 \
c0808220
ER
462 -Ddisable_nacl=1 \
463%endif
a3140cd1
ER
464 %{!?with_sse2:-Ddisable_sse2=1} \
465 %{?with_selinux:-Dselinux=1} \
7d1152d4 466 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 467 -Dlinux_link_libpci=1 \
7879021e 468 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 469 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 470 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
471 -Dclang=0 \
472 -Dhost_clang=0 \
be84bbd9 473 -Dsysroot= \
14c8ce0e
ER
474 -Dlinux_use_bundled_binutils=0 \
475 -Dlinux_use_bundled_gold=0 \
05998197 476 -Dlinux_use_gold_flags=0 \
71581184 477 -Dlogging_like_official_build=1 \
319f81f7
ER
478 -Dgoogle_api_key=%{google_api_key} \
479 -Dgoogle_default_client_id=%{google_default_client_id} \
480 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 481 %{gyp_with cups} \
8dda6bbc 482 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 483 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
484 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
485 %{gyp_with pulseaudio} \
41d6a4b1 486 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 487 %{gyp_with system_flac} \
01b4dc8e 488 %{gyp_with system_harfbuzz} \
cb6dde87 489 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 490 %{gyp_with system_jsoncpp} \
62950103
ER
491 %{gyp_with system_libexif} \
492 %{gyp_with system_libmtp} \
9bd2659c 493 %{gyp_with system_libsrtp} \
581aec44 494 %{gyp_with system_libusb} \
88171dca 495 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 496 %{gyp_with system_libwebp} \
4884fc99 497 %{gyp_with system_libxnvctrl} \
7b8f219a 498 %{gyp_with system_mesa} \
126ea630 499 %{gyp_with system_minizip} \
62950103 500 %{gyp_with system_opus} \
75a27c2e 501 %{gyp_with system_protobuf} \
bbdce24d 502 %{gyp_with system_re2} \
7e634b46 503 %{gyp_with system_snappy} \
e7fa0817 504 %{gyp_with system_speex} \
914ee37c 505 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
506 %{gyp_with system_v8} \
507 %{gyp_with system_yasm} \
508 %{gyp_with system_zlib} \
0c480b89 509 -Duse_system_bzip2=1 \
62950103 510 -Duse_system_expat=1 \
f1b276d4 511 -Duse_system_libevent=1 \
0c480b89 512 -Duse_system_libjpeg=1 \
f1b276d4
ER
513 -Duse_system_libpng=1 \
514 -Duse_system_libxml=1 \
515 -Duse_system_libxslt=1 \
b363f856 516 -Duse_system_nspr=1 \
7f40f3f4 517 -Duse_system_xdg_utils=1 \
7879021e
ER
518"
519
520build/linux/unbundle/replace_gyp_files.py $flags
521
f8597c6e
ER
522%if %{with ninja}
523chkfile=%{builddir}/build.ninja
524%else
525chkfile=Makefile
526%endif
527test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
528test -e $chkfile || \
7879021e
ER
529 CC="%{__cc}" \
530 CXX="%{__cxx}" \
531 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
532 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
533 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
534 CC_host="%{__cc}" \
535 CXX_host="%{__cxx}" \
536 LD_host="%{__cxx}" \
537%{__python} build/gyp_chromium \
f8597c6e 538 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
539 --depth=. \
540 build/all.gyp \
541 $flags
11ad81c4 542
f8597c6e
ER
543%if %{with ninja}
544ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
545%else
b4d75247 546# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
547%{__make} -r \
548 BUILDTYPE=%{buildtype} \
f1b276d4 549 %{?with_verbose:V=1} \
f1b276d4
ER
550 CC.host="%{__cc}" \
551 CXX.host="%{__cxx}" \
b4d75247 552 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
553%endif
554 chrome %{?with_sandboxing:chrome_sandbox} \
555 %{nil}
11ad81c4 556
f8597c6e 557cd %{builddir}
535cb410
ER
558MANWIDTH=80 man ./chrome.1 > man.out
559%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
560
11ad81c4
AM
561%install
562rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
563install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
564 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
565 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
566 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 567
c9ba2fd5
ER
568%if %{without system_icu}
569cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
570%endif
571
f8597c6e 572cd %{builddir}
37ceaf05 573cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 574install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
575%{__sed} -i -e '
576 s,@libdir@,%{_libdir}/%{name},
577
578 /@OPTIONS@/ {
579 r options.txt
580 d
581 }
582' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 583cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 584cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
585ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
586ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 587cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 588install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 589install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
f0db7b91 590%if %{without system_ffmpeg} && 0
f1b276d4 591install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 592%endif
e7fa0817 593cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 594cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 595
8da7b90b 596%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 597
164020eb
ER
598%if %{with nacl}
599# Install Native Client files on platforms that support it.
600install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
601install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
602%ifarch %{x8664}
603install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
604%endif
605%ifarch %{ix86}
606install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
607%endif
608%endif
609
0c480b89
ER
610cd -
611
75f96a39 612for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
613 size=${icon##*/product_logo_}
614 size=${size%.png}
615
616 # this will skip non-numeric (22_mono_invert, 22_mono)
617 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
618 test -d "$dir" || continue
619
620 install -d $RPM_BUILD_ROOT$dir
621 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
622done
7f40f3f4 623
13840bc2
AM
624%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
625# http://code.google.com/p/chromium/issues/detail?id=24507
626gecko-mediaplayer*.so
627EOF
11ad81c4 628
589d90ea
ER
629# find locales
630%find_lang %{name}.lang
e7fa0817 631# always package en-US
f1b276d4 632%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 633
11ad81c4
AM
634%clean
635rm -rf $RPM_BUILD_ROOT
636
8da7b90b
ER
637%pretrans
638for d in locales resources; do
639 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
640 install -d %{_datadir}/%{name}
641 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
642 fi
643done
644exit 0
645
f1b276d4 646%post
0eb19b0b 647%update_icon_cache hicolor
b7a6e4ee 648%update_desktop_database
f1b276d4
ER
649%update_browser_plugins
650
651%postun
652if [ "$1" = 0 ]; then
0eb19b0b 653 %update_icon_cache hicolor
b0f560cc 654 %update_desktop_database
f1b276d4
ER
655 %update_browser_plugins
656fi
657
1d2b9616 658%files
11ad81c4 659%defattr(644,root,root,755)
75f96a39 660%doc AUTHORS LICENSE
f1b276d4
ER
661%{_browserpluginsconfdir}/browsers.d/%{name}.*
662%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
663%dir %{_sysconfdir}/%{name}
664%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 665%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
666%dir %{_sysconfdir}/%{name}/native-messaging-hosts
667%dir %{_sysconfdir}/%{name}/policies
668%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
669%attr(755,root,root) %{_bindir}/%{name}
670%{_mandir}/man1/%{name}.1*
11ad81c4 671%{_desktopdir}/*.desktop
0eb19b0b 672%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 673%dir %{_libdir}/%{name}
e9abb380 674%{_libdir}/%{name}/chrome*.pak
c9ba2fd5 675%{!?with_system_icu:%{_libdir}/%{name}/icudtl.dat}
c14cd342 676%{_libdir}/%{name}/content_resources.pak
f047b07c 677%{_libdir}/%{name}/keyboard_resources.pak
97fac491 678%{_libdir}/%{name}/resources.pak
fa8317a0
ER
679%{_libdir}/%{name}/natives_blob.bin
680%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
681%{_libdir}/%{name}/locales
682%{_libdir}/%{name}/resources
683
684%dir %{_datadir}/%{name}
685%dir %{_datadir}/%{name}/locales
686%{_datadir}/%{name}/locales/en-US.pak
687%dir %{_datadir}/%{name}/resources
688%{_datadir}/%{name}/resources/inspector
689
f1b276d4
ER
690%dir %{_libdir}/%{name}/plugins
691%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 692# These unique permissions are intentional and necessary for the sandboxing
d1a83042 693%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
694
695# ffmpeg libs
f0db7b91 696%if %{without system_ffmpeg} && 0
f1b276d4 697%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 698%endif
f1b276d4 699
164020eb
ER
700%if %{with nacl}
701%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
702%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
703%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
704%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
705%endif
706
f1b276d4
ER
707%files l10n -f %{name}.lang
708%defattr(644,root,root,755)
This page took 0.284746 seconds and 4 git commands to generate.