]> git.pld-linux.org Git - packages/chromium-browser-bin.git/commitdiff
- up to 5.0.387.0 snapshot r45531 (note: current linux dev channel is 5.0.375.191)
authorCaleb Maclennan <caleb@alerque.com>
Sat, 24 Apr 2010 13:36:59 +0000 (13:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added missing %files: resources for new web app tabs
- changed url and added check to make sure we are getting latest snapshot that passes upstream buildbot tests

Changed files:
    chromium-browser-bin.spec -> 1.28
    update-source.sh -> 1.13

chromium-browser-bin.spec
update-source.sh

index 40c84d0c206a1ee0edd61d45ad63caf9ef9e75c1..dbbab149bf945cf0470264bdb56d1cb8067c4719 100644 (file)
@@ -1,16 +1,16 @@
-%define                svnrev  43829
+%define                svnrev  45531
 %define                rel             1
 Summary:       A WebKit powered web browser
 Name:          chromium-browser-bin
-Version:       5.0.371.0
+Version:       5.0.387.0
 Release:       %{svnrev}.%{rel}
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
 # sh get_sources.sh
 Source0:       chromium-browser32-r%{svnrev}.zip
-# NoSource0-md5:       6fd3a056234c0a883012de4b62879e42
+# NoSource0-md5:       9e07f41b3135446bf5f18c453f12f09a
 Source1:       chromium-browser64-r%{svnrev}.zip
-# NoSource1-md5:       e8d1e7cc6b774c2d6bccea7405b7f656
+# NoSource1-md5:       17cec747e0f08cbf8b2a56390b20c3fe
 NoSource:      0
 NoSource:      1
 Source2:       chromium-browser.sh
@@ -155,6 +155,7 @@ fi
 %dir %{_libdir}/%{name}/plugins
 %dir %{_libdir}/%{name}/resources
 %{_libdir}/%{name}/resources/net_internals
+%{_libdir}/%{name}/resources/*_app
 %{_libdir}/%{name}/themes
 %attr(755,root,root) %{_libdir}/%{name}/chromium-browser
 
index fd085bfea97b0c6ee4fdc73513786897be5ca08d..381d6e55ed0e0e8b47a9f00209a16b2442e18c88 100644 (file)
@@ -7,8 +7,15 @@ if [ "$1" ]; then
        echo "Using $rev..."
 else
        echo -n "Fetching latest revno... "
-       rev=$(wget -q -O - http://build.chromium.org/buildbot/snapshots/chromium-rel-linux/LATEST)
+       rev=$(wget -q -O - http://build.chromium.org/buildbot/continuous/linux/LATEST/REVISION)
+       rev64=$(wget -q -O - http://build.chromium.org/buildbot/continuous/linux64/LATEST/REVISION)
+       if [ "$rev" != "$rev64" ] && [ $(uname -m) -eq "x86_64" ]; then
+               echo -n >&2 "Current 32bit build ($rev) does not match 64bit build ($rev64). The upstream buildbot probably failed. Usuing latest 64bit revision..."
+               rev=$rev64
+       fi
        echo "$rev"
+       # TODO: use release branches instead of trunk. Current release can be looked up like this:
+       #linuxdev=$(wget -q -O - http://omahaproxy.appspot.com | grep '^linux,dev' | cut -d, -f3)
 fi
 
 if [ ! -f chromium-browser32-r$rev.zip ]; then
This page took 0.075899 seconds and 4 git commands to generate.