]> git.pld-linux.org Git - packages/chromium-browser-bin.git/commitdiff
- auto version update by hint from Caleb Maclennan <caleb#alerque.com>
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 19 Mar 2010 12:36:10 +0000 (12:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    chromium-browser-bin.spec -> 1.23
    update-source.sh -> 1.11

chromium-browser-bin.spec
update-source.sh

index 0bdbf657ba1662a99d3eff11ce1af584f117917d..bc9bfa64485405375e5b128adcecdfde6777070c 100644 (file)
@@ -1,19 +1,18 @@
-# TODO
-# - find a way to check for version without having actually to run the browser
-#   with a $DISPLAY via about box
-%define                svnrev  37688
-%define                rel             0.1
+%define                svnrev  42096
+%define                rel             1
 Summary:       A WebKit powered web browser
 Name:          chromium-browser-bin
 Summary:       A WebKit powered web browser
 Name:          chromium-browser-bin
-Version:       5.0.312.0
-Release:       0.%{svnrev}.%{rel}
+Version:       5.0.359.0
+Release:       %{svnrev}.%{rel}
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
 # sh get_sources.sh
 Source0:       chromium-browser32-r%{svnrev}.zip
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
 # sh get_sources.sh
 Source0:       chromium-browser32-r%{svnrev}.zip
-# Source0-md5: 12ae79e7362b209984440c48d7f875db
+# NoSource0-md5:       c3aee19e7e33664894563f84e9d8f5c4
 Source1:       chromium-browser64-r%{svnrev}.zip
 Source1:       chromium-browser64-r%{svnrev}.zip
-# Source1-md5: d7519f6da0439512cea3a3d90a2c46bc
+# NoSource1-md5:       8612af021929073cc0bed0b20a5fe39a
+NoSource:      0
+NoSource:      1
 Source2:       chromium-browser.sh
 Source3:       chromium-browser.desktop
 Source4:       find-lang.sh
 Source2:       chromium-browser.sh
 Source3:       chromium-browser.desktop
 Source4:       find-lang.sh
@@ -58,6 +57,18 @@ web.
 This package contains 'inspector', allowing web developpers to inspect
 any element of a web page at runtime (html, javascript, css, ..)
 
 This package contains 'inspector', allowing web developpers to inspect
 any element of a web page at runtime (html, javascript, css, ..)
 
+%package bookmark_manager
+Summary:       Bookmark manager for the chromium-browser
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description bookmark_manager
+Chromium is an open-source browser project that aims to build a safer,
+faster, and more stable way for all Internet users to experience the
+web.
+
+This package contains bookmark manager for the chromium-browser.
+
 %package l10n
 Summary:       chromium-browser language packages
 Group:         I18n
 %package l10n
 Summary:       chromium-browser language packages
 Group:         I18n
@@ -168,5 +179,9 @@ fi
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/resources/inspector
 
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/resources/inspector
 
+%files bookmark_manager
+%defattr(644,root,root,755)
+%{_libdir}/%{name}/resources/bookmark_manager
+
 %files l10n -f %{name}.lang
 %defattr(644,root,root,755)
 %files l10n -f %{name}.lang
 %defattr(644,root,root,755)
index d08056dd3c3966f942fb40e456790f42ba67816f..f33aa54839bc9b896495b67dc05e3d1de769df9c 100644 (file)
@@ -1,4 +1,5 @@
 #!/bin/sh
 #!/bin/sh
+set -e
 
 if [ "$1" ]; then
        rev=$1
 
 if [ "$1" ]; then
        rev=$1
@@ -32,7 +33,19 @@ fi
 specfile=chromium-browser-bin.spec
 oldrev=$(awk '/^%define[       ]+svnrev[       ]+/{print $NF}' $specfile)
 if [ "$oldrev" != "$rev" ]; then
 specfile=chromium-browser-bin.spec
 oldrev=$(awk '/^%define[       ]+svnrev[       ]+/{print $NF}' $specfile)
 if [ "$oldrev" != "$rev" ]; then
-       echo "Updating $specfile for $rev"
-       sed -i -e "s/^\(%define[ \t]\+svnrev[ \t]\+\)[0-9]\+\$/\1$rev/" $specfile
+       # revno => VERSION hint by Caleb Maclennan <caleb#alerque.com>
+       wget -q -O VERSION.sh http://src.chromium.org/viewvc/chrome/trunk/src/chrome/VERSION?revision=$rev
+       if grep -Ev '^(MAJOR|MINOR|BUILD|PATCH)=[0-9]+$' VERSION.sh >&2; then
+               echo >&2 "I refuse to execute grabbed file for security concerns"
+               exit 1
+       fi
+       . ./VERSION.sh
+       version=$MAJOR.$MINOR.$BUILD.$PATCH
+
+       echo "Updating $specfile for $version r$rev"
+       sed -i -e "
+               s/^\(%define[ \t]\+svnrev[ \t]\+\)[0-9]\+\$/\1$rev/
+               s/^\(Version:[ \t]\+\)[.0-9]\+\$/\1$version/
+       " $specfile
        ../builder -ncs -5 $specfile
 fi
        ../builder -ncs -5 $specfile
 fi
This page took 0.065448 seconds and 4 git commands to generate.