]> git.pld-linux.org Git - packages/chromium-browser-bin.git/commitdiff
- package xdg-utils for desktop integration
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 23 Sep 2009 15:14:44 +0000 (15:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    chromium-browser-bin.spec -> 1.5
    chromium-browser.sh -> 1.1

chromium-browser-bin.spec
chromium-browser.sh [new file with mode: 0644]

index 36db61cbc0b94fdf987249037689935e65a44588..4e9ba217fd7958e98387f747683c49f78bf28f8b 100644 (file)
@@ -15,6 +15,7 @@ Source4:      find-lang.sh
 Requires:      browser-plugins >= 2.0
 Requires:      nspr
 Requires:      nss
+Requires:      xdg-utils
 Provides:      wwwbrowser
 ExclusiveArch: %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -40,7 +41,6 @@ Chromium is an open-source web browser, powered by WebKit.
 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
 
 mv chrome-linux/product_logo_48.png .
-mv chrome-linux/xdg-settings .
 mv chrome-linux/chromium-browser.1 .
 mv chrome-linux/chrome-wrapper .
 mv chrome-linux/{chrome,chromium-browser}
@@ -84,6 +84,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/resources
 %{_libdir}/%{name}/themes
 %attr(755,root,root) %{_libdir}/%{name}/chromium-browser
+
 # These unique permissions are intentional and necessary for the sandboxing
 %attr(4555,root,root) %{_libdir}/%{name}/chrome_sandbox
 
@@ -100,3 +101,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/chromium-browser-bin/libnssutil3.so.1d
 %attr(755,root,root) %{_libdir}/chromium-browser-bin/libsmime3.so.1d
 %attr(755,root,root) %{_libdir}/chromium-browser-bin/libssl3.so.1d
+
+# bundle a this copy until xdg-utils will have this itself
+%attr(755,root,root) %{_libdir}/%{name}/xdg-settings
diff --git a/chromium-browser.sh b/chromium-browser.sh
new file mode 100644 (file)
index 0000000..9775730
--- /dev/null
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+# Copyright (c) 2006-2009 The Chromium Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+# Always use our ffmpeg libs.
+# Also symlinkes for nss/nspr libs can be found from our dir.
+export LD_LIBRARY_PATH=/usr/lib64/chromium-browser-bin${LD_LIBRARY_PATH:+:"$LD_LIBRARY_PATH"}
+
+# for to find xdg-settings
+export PATH=/usr/lib64/chromium-browser-bin${PATH:+:"$PATH"}
+
+exec /usr/lib64/chromium-browser-bin/chromium-browser "$@"
This page took 0.065426 seconds and 4 git commands to generate.