]> git.pld-linux.org Git - packages/chromium-browser-bin.git/blobdiff - update-source.sh
set CHROME_DESKTOP="chromium-browser-bin.desktop"
[packages/chromium-browser-bin.git] / update-source.sh
old mode 100644 (file)
new mode 100755 (executable)
index e66ce72..c930834
@@ -1,9 +1,9 @@
 #!/bin/sh
 # Usage:
-# ./update-source.sh [spec|rev]
-#     Download latest binary tarball based on latest release from
-#     buildbot, current version referenced in spec file, or custom
-#     version number.
+# ./update-source.sh [spec|trunk|rev]
+#     Download latest binary tarball based on latest release documented
+#     in omaha proxy (or alternitavly the current version referenced in the
+#     spec file, or latest successfully trunk build, or custom version number.
 set -e
 dropin=
 specfile=chromium-browser-bin.spec
@@ -17,8 +17,8 @@ if [ "$1" == "spec" ]; then
        echo "Using $rev from spec file"
 elif [ "$1" == "trunk" ]; then
        echo "Fetching latest revno... "
-       #rev=$(wget -q -O - http://commondatastorage.googleapis.com/chromium-browser-continuous/Linux/LAST_CHANGE)
-       #rev64=$(wget -q -O - http://commondatastorage.googleapis.com/chromium-browser-continuous/Linux_x64/LAST_CHANGE)
+       rev=$(wget -q -O - http://commondatastorage.googleapis.com/chromium-browser-continuous/Linux/LAST_CHANGE)
+       rev64=$(wget -q -O - http://commondatastorage.googleapis.com/chromium-browser-continuous/Linux_x64/LAST_CHANGE)
        # be sure that we use same rev on both arch
        if [ "$rev" != "$rev64" ]; then
                echo "Current 32bit build ($rev) does not match 64bit build ($rev64)"
@@ -69,7 +69,8 @@ oldrev=$(awk '/^%define[      ]+svnrev[       ]+/{print $NF}' $specfile)
 if [ "$oldrev" != "$rev" ]; then
        if [ -z "$version" ]; then
                wget -q -O VERSION.sh http://src.chromium.org/viewvc/chrome/trunk/src/chrome/VERSION?revision=$rev
-               if grep -Ev '^(MAJOR|MINOR|BUILD|PATCH)=[0-9]+$' VERSION.sh >&2; then
+               echo REV=$rev >> VERSION.sh
+               if grep -Ev '^(MAJOR|MINOR|BUILD|PATCH|REV)=[0-9]+$' VERSION.sh >&2; then
                        echo >&2 "I refuse to execute garbled file due security concerns"
                        exit 1
                fi
This page took 0.073379 seconds and 4 git commands to generate.