]> git.pld-linux.org Git - packages/chkconfig.git/commitdiff
- fixed chkconfig-add patch (it just didn't work because of one missing change) chkconfig-1_2_22-3
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 5 Apr 2001 22:38:24 +0000 (22:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use %%rpm{c,ld}flags macros
- release 3

Changed files:
    chkconfig-add.patch -> 1.3
    chkconfig.spec -> 1.36

chkconfig-add.patch
chkconfig.spec

index 419bed48d1a77d34b84f41d064bfd71987758741..91618a3f1e985ce1b11608aabfcad15504458f46 100644 (file)
@@ -1,5 +1,6 @@
---- chkconfig-1.2.16/chkconfig.c.wiget Thu Jul 13 21:42:54 2000
-+++ chkconfig-1.2.16/chkconfig.c       Wed Nov 29 12:31:44 2000
+diff -Nur chkconfig-1.2.22.orig/chkconfig.c chkconfig-1.2.22/chkconfig.c
+--- chkconfig-1.2.22.orig/chkconfig.c  Sat Dec 30 05:25:26 2000
++++ chkconfig-1.2.22/chkconfig.c       Thu Apr  5 23:39:20 2001
 @@ -12,6 +12,7 @@
  #include <unistd.h>
  
@@ -8,7 +9,7 @@
  
  #define _(String) gettext((String)) 
  
-@@ -75,12 +76,10 @@
+@@ -74,12 +75,10 @@
      if (s.type == TYPE_XINETD) return 0;
      
      for (i = 0; i < 7; i++) {
      }
  
      return 0;
---- chkconfig-1.2.16/leveldb.c.wiget   Wed Aug 30 23:35:52 2000
-+++ chkconfig-1.2.16/leveldb.c Wed Nov 29 12:40:20 2000
+@@ -246,7 +245,7 @@
+ }
+ int main(int argc, char ** argv) {
+-    int listItem = 0, addItem = 0, delItem = 0;
++    int listItem = 0, delItem = 0;
+     int rc, i, x;
+     char * levels = NULL;
+     int help=0, version=0;
+diff -Nur chkconfig-1.2.22.orig/leveldb.c chkconfig-1.2.22/leveldb.c
+--- chkconfig-1.2.22.orig/leveldb.c    Fri Feb  2 18:51:01 2001
++++ chkconfig-1.2.22/leveldb.c Thu Apr  5 23:39:01 2001
 @@ -11,6 +11,10 @@
  #include <stdio.h>
  #include <string.h>
@@ -44,7 +55,7 @@
  
      sprintf(filename, RUNLEVELS "/init.d/%s", name);
  
-@@ -316,6 +322,21 @@
+@@ -316,6 +323,21 @@
      } 
  
      serv.name = strdup(name);
index 4b0ec80e8fd8cab23901acae762e48d267440e8f..4c00823c3018348857328e42ae7e901d900e86f7 100644 (file)
@@ -6,7 +6,7 @@ Summary(pt):    Ferramenta para atualizar e listar servi
 Summary(tr):   Sistem servis bilgilerini sorgular ve yeniler
 Name:          chkconfig
 Version:       1.2.22
-Release:       2
+Release:       3
 License:       GPL
 Group:         Applications/System
 Group(de):     Applikationen/System
@@ -97,8 +97,8 @@ LIBMHACK=-lm
 %endif
 
 %{__make} \
-       OPTIMIZE="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
-       LDFLAGS="%{!?debug:-s}" \
+       OPTIMIZE="%{rpmcflags}" \
+       LDFLAGS="%{rpmldflags}" \
        LIBMHACK="$LIBMHACK"
 
 %install
This page took 0.090973 seconds and 4 git commands to generate.