]> git.pld-linux.org Git - packages/chkconfig.git/blobdiff - chkconfig.spec
unbreak systemd-sysv-install symlink; rel 2
[packages/chkconfig.git] / chkconfig.spec
index f3bd7c0dab537bc1e2102100d7a66a44fd1de533..af7821ba7b3be7a90feaf057f7a97c630af380cf 100644 (file)
@@ -1,7 +1,3 @@
-#
-# TODO:
-#              - update add,noxinet,pl.po-update patches
-#
 Summary:       Updates and queries runlevel information for system services
 Summary(de.UTF-8):     Aktualisiert runlevel-Informationen für Systemdienste und fragt diese ab
 Summary(es.UTF-8):     Herramienta para actualizar y listar servicios del sistema, por nivel de ejecución (runlevel)
@@ -13,27 +9,25 @@ Summary(ru.UTF-8):   Системная утилита для управления
 Summary(tr.UTF-8):     Sistem servis bilgilerini sorgular ve yeniler
 Summary(uk.UTF-8):     Системна утиліта для керування ієрархією /etc/rc.d
 Name:          chkconfig
-Version:       1.3.20
-Release:       0.4
-Epoch:         1
-License:       GPL
+Version:       1.25
+Release:       2
+Epoch:         2
+License:       GPL v2
 Group:         Applications/System
-Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: a993765a3fcd0c0cd891e16022e35d13
-#Patch0:               %{name}-add.patch
-#Patch1:               %{name}-noxinet.patch
-#Patch2:               %{name}-pl.po-update.patch
-Patch5:                %{name}-more_readable.patch
-Patch6:                %{name}-rc.d.patch
-Patch7:                %{name}-nostatic.patch
-Patch8:                %{name}-optflags.patch
-Patch9:                %{name}-pl.patch
-#BuildRequires:        autoconf
-#BuildRequires:        automake
-BuildRequires: gettext-devel
+#Source0Download: https://github.com/fedora-sysv/chkconfig/releases
+Source0:       https://github.com/fedora-sysv/chkconfig/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 12a7b241ba7d3730b9dc389115be50ee
+Patch0:                %{name}-add.patch
+Patch1:                %{name}-noxinet.patch
+Patch2:                %{name}-rc.d.patch
+Patch3:                %{name}-optflags.patch
+Patch4:                %{name}-pl.patch
+Patch5:                %{name}-split-usr.patch
+URL:           https://github.com/fedora-sysv/chkconfig
+BuildRequires: gettext-tools
+BuildRequires: libselinux-devel
 BuildRequires: newt-devel
 BuildRequires: popt-devel
-#BuildRequires:        slang-devel >= 2.0.0
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -148,7 +142,7 @@ Group:              Applications/System
 alternatives creates, removes, maintains and displays information
 about the symbolic links comprising the alternatives system. The
 alternatives system is a reimplementation of the Debian alternatives
-system. It was rewritten primarily to remove the dependence on perl;
+system. It was rewritten primarily to remove the dependence on Perl;
 it is intended to be a drop in replacement for Debian's
 update-alternatives script.
 
@@ -157,38 +151,23 @@ alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
 dowiązaniach symbolicznych obejmujących system alternatyw. System
 alternatyw to reimplementacja systemu alternatyw ("alternatives") z
 Debiana. Została napisana głównie w celu usunięcia zależności od
-perla; ma być zamiennikiem skryptu update-alternatives z Debiana.
+Perla; ma być zamiennikiem skryptu update-alternatives z Debiana.
 
 %prep
 %setup -q
-#%patch0 -p1
-#%patch1 -p1
-#%patch2 -p1
-#%patch3 -p1
-#%patch4 -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 %patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
-%patch9 -p1
-
-#mv -f po/{eu_ES,eu}.po
-mv -f po/{no,nb}.po
-mv -f po/{sr,sr@Latn}.po
-#mv -f po/{zh,zh_TW}.po
-#mv -f po/{zh_CN.GB2312,zh_CN}.po
 
 %build
-%if 0
-%{__aclocal}
-%{__autoconf}
-%{__automake}
-%configure \
-       --with-max-level=6
-%endif
 %{__make} \
        CC="%{__cc}" \
-       OPTFLAGS="%{rpmcflags}"
+       OPTFLAGS="%{rpmcppflags} %{rpmcflags}" \
+       OPTLDFLAGS="%{rpmldflags}" \
+       SYSTEMDUTILDIR=/lib/systemd
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -196,18 +175,12 @@ install -d $RPM_BUILD_ROOT{/etc/{rc.d/{init,rc{0,1,2,3,4,5,6}}.d,env.d},/sbin}
 
 %{__make} install \
        MANDIR=%{_mandir} \
-       instroot=$RPM_BUILD_ROOT
+       SYSTEMDUTILDIR=/lib/systemd \
+       DESTDIR=$RPM_BUILD_ROOT
 
-%find_lang %{name}
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bal
 
-cat <<EOF > $RPM_BUILD_ROOT/etc/env.d/CHKCONFIG_ON
-# display custom string instead of "on" (or its translation)
-#CHKCONFIG_ON="*****"
-EOF
-cat <<EOF > $RPM_BUILD_ROOT/etc/env.d/CHKCONFIG_OFF
-# display custom string instead of "off" (or its translation)
-#CHKCONFIG_OFF="-----"
-EOF
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -215,8 +188,8 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) /sbin/chkconfig
+%attr(755,root,root) /lib/systemd/systemd-sysv-install
 %{_mandir}/man8/chkconfig.8*
-%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
 
 %files -n ntsysv
 %defattr(644,root,root,755)
@@ -230,3 +203,4 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/update-alternatives
 %dir /var/lib/alternatives
 %{_mandir}/man8/alternatives.8*
+%{_mandir}/man8/update-alternatives.8*
This page took 0.051517 seconds and 4 git commands to generate.