]> git.pld-linux.org Git - packages/chkconfig.git/blobdiff - chkconfig.spec
- drop patches unusable in this version (will remove from cvs when all patches reviewed)
[packages/chkconfig.git] / chkconfig.spec
index ec2a3a0bc5c5a04f4992ed15d4b45c710ed5b3b7..ebbb303ebdb66117bdcdd779e281706882743370 100644 (file)
@@ -1,9 +1,3 @@
-
-%bcond_with mr # Use asteriskes and dashes in all languages
-               # for `chkconfig --list` command (aplies more_readable.patch).
-               # Note: it makes the program inconsistent with the rest
-               # of the world (some people say).
-
 Summary:       Updates and queries runlevel information for system services
 Summary(de):   Aktualisiert runlevel-Informationen für Systemdienste und fragt diese ab
 Summary(es):   Herramienta para actualizar y listar servicios del sistema, por nivel de ejecución (runlevel)
@@ -15,25 +9,25 @@ Summary(ru): 
 Summary(tr):   Sistem servis bilgilerini sorgular ve yeniler
 Summary(uk):   óÉÓÔÅÍÎÁ ÕÔÉ̦ÔÁ ÄÌÑ ËÅÒÕ×ÁÎÎÑ ¦¤ÒÁÒȦ¤À /etc/rc.d
 Name:          chkconfig
-Version:       1.2.24h
-Release:       10%{?with_mr:+mr}
+Version:       1.3.20
+Release:       0.2
 Epoch:         1
 License:       GPL
 Group:         Applications/System
-Source0:       http://www.buttsoft.com/~thumper/downloads/%{name}/%{name}-%{version}.tar.gz
-# Source0-md5: 032eae68329d07d0844775486ac74668
-Patch0:                %{name}-add.patch
-Patch1:                %{name}-noxinet.patch
-Patch2:                %{name}-pl.po-update.patch
-Patch3:                %{name}-ponames.patch
-Patch4:                %{name}-link.patch
+Source0:       %{name}-%{version}.tar.gz
+# Source0-md5: a993765a3fcd0c0cd891e16022e35d13
+#Patch0:               %{name}-add.patch
+#Patch1:               %{name}-noxinet.patch
+#Patch2:               %{name}-pl.po-update.patch
 Patch5:                %{name}-more_readable.patch
-BuildRequires: autoconf
-BuildRequires: automake
+Patch6:                %{name}-rc.d.patch
+Patch7:                %{name}-nostatic.patch
+#BuildRequires:        autoconf
+#BuildRequires:        automake
 BuildRequires: gettext-devel
 BuildRequires: newt-devel
 BuildRequires: popt-devel
-BuildRequires: slang-devel
+#BuildRequires:        slang-devel >= 2.0.0
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -139,40 +133,64 @@ ntsysv - 
 ËÁÔÁÌÏǦנ/etc/rc.d, ËÏÔÒ¦ ËÅÒÕÀÔØ ÚÁÐÕÓËÏÍ ÔÁ ÚÕÐÉÎËÏÀ ÓÉÓÔÅÍÎÉÈ
 ÓÅÒצӦ×.
 
+%package -n alternatives
+Summary:       Maintain symbolic links determining default commands
+Group:         Applications/System
+
+%description -n alternatives
+alternatives creates, removes, maintains and displays information
+about the symbolic links comprising  the alternatives  system. The
+alternatives system is a reimplementation of the Debian alternatives
+system. It was rewritten primarily to remove the dependence on perl;
+it is intended to be a drop in  replacement  for Debian's
+update-dependencies script.
+
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%{?with_mr:%patch5 -p1}
-
-mv -f po/{eu_ES,eu}.po
+#%patch0 -p1
+#%patch1 -p1
+#%patch2 -p1
+#%patch3 -p1
+#%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+
+#mv -f po/{eu_ES,eu}.po
 mv -f po/{no,nb}.po
 mv -f po/{sr,sr@Latn}.po
-mv -f po/{zh,zh_TW}.po
-mv -f po/{zh_CN.GB2312,zh_CN}.po
+#mv -f po/{zh,zh_TW}.po
+#mv -f po/{zh_CN.GB2312,zh_CN}.po
 
 %build
+%if 0
 %{__aclocal}
 %{__autoconf}
 %{__automake}
 %configure \
        --with-max-level=6
-%{__make}
+%endif
+%{__make} CC="%{__cc}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,/sbin}
+install -d $RPM_BUILD_ROOT{/etc/{rc.d/{init,rc{0,1,2,3,4,5,6}}.d,env.d},/sbin}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-mv $RPM_BUILD_ROOT%{_sbindir}/chkconfig $RPM_BUILD_ROOT/sbin
+       MANDIR=%{_mandir} \
+       instroot=$RPM_BUILD_ROOT
 
 %find_lang %{name}
 
+cat <<EOF > $RPM_BUILD_ROOT/etc/env.d/CHKCONFIG_ON
+# display custom string instead of "on" (or its translation)
+#CHKCONFIG_ON="*****"
+EOF
+cat <<EOF > $RPM_BUILD_ROOT/etc/env.d/CHKCONFIG_OFF
+# display custom string instead of "off" (or its translation)
+#CHKCONFIG_OFF="-----"
+EOF
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -180,8 +198,17 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) /sbin/chkconfig
 %{_mandir}/man8/chkconfig.8*
+%attr(644,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
 
 %files -n ntsysv
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/ntsysv
 %{_mandir}/man8/ntsysv.8*
+
+%files -n alternatives
+%defattr(644,root,root,755)
+%dir %{_sysconfdir}/alternatives
+%attr(755,root,root) %{_sbindir}/alternatives
+%attr(755,root,root) %{_sbindir}/update-alternatives
+%dir /var/lib/alternatives
+%{_mandir}/man8/alternatives.8*
This page took 0.099747 seconds and 4 git commands to generate.