]> git.pld-linux.org Git - packages/cherokee.git/commitdiff
- 0.6.1
authorPatryk Zawadzki <patrys@room-303.com>
Thu, 17 Apr 2008 15:57:26 +0000 (15:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use guardian as default daemon
- works
- TODO: package %{_libdir}/libcherokee*

Changed files:
    cherokee-config.patch -> 1.2
    cherokee-php-path.patch -> 1.2
    cherokee.init -> 1.9
    cherokee.spec -> 1.16

cherokee-config.patch
cherokee-php-path.patch
cherokee.init
cherokee.spec

index 87f0b13cf06a62f6e46250c4c78e8bd66eda4e4b..e93d6d4d0fc35cc4949dccf27ab43b21d2068d5a 100644 (file)
@@ -1,13 +1,11 @@
---- cherokee-0.4.29/cherokee.conf.sample.pre.old       2005-10-20 00:27:03.000000000 +0300
-+++ cherokee-0.4.29/cherokee.conf.sample.pre   2005-12-31 16:32:18.000000000 +0200
-@@ -35,8 +35,8 @@
- ## Eg: User 65534
- ##     Group 65534
- ##
--#User nobody
--#Group nogroup
-+User cherokee
-+Group cherokee
+--- cherokee-0.6.1/cherokee.conf.sample.pre~   2008-03-18 22:09:32.000000000 +0100
++++ cherokee-0.6.1/cherokee.conf.sample.pre    2008-04-17 17:30:36.373880993 +0200
+@@ -8,6 +8,8 @@
  
- ##
- ## Chroot:
+ # Server
+ #
++server!user = cherokee
++server!group = cherokee
+ server!port = 80
+ server!port_tls = 443
+ server!timeout = 60
index 6e29c276d516e8ea4c773655c6d0ecd4c7f74ff5..0dc6ee4740c619d1b70d5dd2b58301142c8363f0 100644 (file)
@@ -1,21 +1,11 @@
---- cherokee-0.4.29/cherokee/handler_phpcgi.c~ 2005-11-05 12:18:17.000000000 +0200
-+++ cherokee-0.4.29/cherokee/handler_phpcgi.c  2005-12-31 16:40:31.000000000 +0200
-@@ -55,16 +55,12 @@
- static char *php_paths[] = {
--      "/usr/lib/cgi-bin/",
--      "/usr/local/bin/",
-+      "/usr/bin/",
-       NULL
- };
- static char *php_names[] = {
--      "php", 
--      "php5", 
--      "php4", 
--      "php3",
-+      "php.cgi", 
-       NULL
- };
+--- cherokee-0.6.1/cherokee/handler_phpcgi.c~  2008-04-17 16:41:42.000000000 +0200
++++ cherokee-0.6.1/cherokee/handler_phpcgi.c   2008-04-17 16:45:23.471106094 +0200
+@@ -71,7 +71,7 @@
+       "php", 
+       "php5", 
+       "php4", 
+-      "php-cgi",
++      "php.cgi",
+ #else
+       "PHP.EXE",
+ #endif
index 3539b14ff820610ca52e5f960574f824d56a9978..482a398cf9b5bf54cb04fd6356ea27ef46dab779 100644 (file)
@@ -37,13 +37,10 @@ case "$1" in
                # it offers no stdout/stderr logging. workaround
                exec 2>>/var/log/cherokee/cherokee.log
                exec 1>&2
-               start-stop-daemon --start --exec /usr/sbin/cherokee --pidfile /var/run/cherokee.pid -- -b
+               start-stop-daemon --start --exec /usr/sbin/cherokee-guardian -- -b
                )
                RETVAL=$?
                if [ $RETVAL -eq 0 ]; then
-                       # the pidfile written is wrong when cherokee -b is used. damn
-                       pid=$(/sbin/pidof cherokee)
-                       echo $pid > /var/run/cherokee.pid
                        touch /var/lock/subsys/cherokee
                        ok
                else
@@ -57,10 +54,10 @@ case "$1" in
        if [ -f /var/lock/subsys/cherokee ]; then
                # Stop daemons.
                msg_stopping "Cherokee Web Server"
-               start-stop-daemon --stop --pidfile /var/run/cherokee.pid --oknodo --exec /usr/sbin/cherokee
+               start-stop-daemon --stop --pidfile /var/run/cherokee-guardian.pid --oknodo --exec /usr/sbin/cherokee-guardian
                RETVAL=$?
                if [ $RETVAL -eq 0 ]; then
-                       rm -f /var/run/cherokee.pid /var/lock/subsys/cherokee >/dev/null 2>&1
+                       rm -f /var/lock/subsys/cherokee >/dev/null 2>&1
                        ok
                else
                        fail
index 4e8ad0e672bbff6c6b6431a33529d7bfed6a6d70..c3858063353b6d4dfe03e9c52f559785e3d8a719 100644 (file)
@@ -2,7 +2,6 @@
 # Conditional build:
 %bcond_without php             # adds PHP support
 %bcond_with    mono            # adds ASPX support
-%bcond_with    gnomevfs        # compile the gnomevfs handler (broken)
 %bcond_without gnutls          # build with tls=gnutls
 %bcond_with    openssl         # build with tls=openssl
 #
 Summary:       Fast, Flexible and Lightweight Web server
 Summary(pl.UTF-8):     Cherokee - serwer WWW
 Name:          cherokee
-Version:       0.4.29
-Release:       0.15
+Version:       0.6.1
+Release:       0.1
 License:       GPL v2
 Group:         Networking/Daemons
-Source0:       http://www.0x50.org/download/0.4/0.4.29/%{name}-%{version}.tar.gz
-# Source0-md5: 854e6e61a69781746496012658d8ef98
+Source0:       http://www.cherokee-project.com/download/0.6/0.6.1/%{name}-%{version}.tar.gz
+# Source0-md5: 49044d6c9c50a6726a4e6c3c7f8ea544
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Patch0:                %{name}-config.patch
@@ -26,12 +25,14 @@ URL:                http://www.0x50.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: fcgi-devel
-%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
 %{?with_gnutls:BuildRequires:  gnutls-devel >= 0.9.99}
+BuildRequires: mysql-devel
+BuildRequires: openldap-devel
 %{?with_openssl:BuildRequires: openssl-devel}
 BuildRequires: pam-devel
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
+BuildRequires: python-docutils
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: zlib-devel
 Requires(post,postun): /sbin/ldconfig
@@ -96,7 +97,6 @@ Pliki nagłówkowe dla serwera WWW Cherokee.
        --enable-os-string="PLD Linux" \
        --with-wwwroot=%{_wwwroot} \
        --disable-static \
-       %{?with_gnomevfs:--enable-gnomevfs} \
        %{?with_tls:--enable-tls=%{?with_gnutls:gnutls}%{?with_openssl:openssl}} \
        --enable-pthreads \
        %{?with_php:--with-php=%{_prefix}} \
@@ -116,7 +116,7 @@ install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 
 # users don't need this
 mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
-mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee_logrotate
+#mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee_logrotate
 
 # modules dlopened by *.so
 rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
@@ -159,18 +159,12 @@ fi
 %doc AUTHORS ChangeLog TODO html
 %dir %attr(750,root,root) %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icons.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/advanced.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.compression.types
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.types
 %dir %attr(750,root,root) %{_sysconfdir}/mods-available
 %dir %attr(750,root,root) %{_sysconfdir}/mods-enabled
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mods-available/admin
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mods-available/ssl
 %dir %attr(750,root,root) %{_sysconfdir}/sites-available
 %dir %attr(750,root,root) %{_sysconfdir}/sites-enabled
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites-available/default
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites-available/example.com
-%config(missingok) %{_sysconfdir}/sites-enabled/default
 %dir %attr(750,root,root) %{_sysconfdir}/ssl
 
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cherokee
@@ -178,9 +172,12 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/cherokee
 
 %attr(755,root,root) %{_bindir}/cget
+%attr(755,root,root) %{_bindir}/cherokee_tweak
+%attr(755,root,root) %{_bindir}/spawn-fcgi
 %attr(755,root,root) %{_sbindir}/cherokee
+%attr(755,root,root) %{_sbindir}/cherokee-guardian
 %attr(755,root,root) %{_sbindir}/cherokee-panic
-%attr(755,root,root) %{_sbindir}/cherokee_logrotate
+%attr(755,root,root) %{_sbindir}/cherokee-admin
 
 %dir %{_libdir}/cherokee
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_admin.so
@@ -190,17 +187,22 @@ fi
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_fcgi.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_ldap.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_mirror.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_mysql.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_nn.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_phpcgi.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
-%attr(755,root,root) %{_libdir}/cherokee/libplugin_read_config.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_round_robin.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_scgi.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_w3c.so
 %attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
This page took 0.114479 seconds and 4 git commands to generate.