]> git.pld-linux.org Git - packages/cherokee.git/blobdiff - cherokee.spec
Version: 1.2.103
[packages/cherokee.git] / cherokee.spec
index 4b29ab685ab30a5c2c5d721c8ecb69957f305a42..34ecb8035a6a57a79e840882ba8acb62f76aadb2 100644 (file)
 Summary:       Fast, Flexible and Lightweight Web server
 Summary(pl.UTF-8):     Cherokee - serwer WWW
 Name:          cherokee
-Version:       1.0.10
+Version:       1.2.103
 Release:       1
 License:       GPL v2
 Group:         Networking/Daemons
-Source0:       http://www.cherokee-project.com/download/1.0/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: bca6dc0ec3eedd1c6e35bce5885bacdc
-Source1:       %{name}.init
-Source2:       %{name}.sysconfig
-Source3:       %{name}.upstart
+Source0:       https://github.com/cherokee/webserver/archive/v%{version}.zip
+# Source0-md5: 9e6d8e0dd95808d365d32ecb0a9b80fe
+# the last snapshot from https://github.com/cherokee/CTK
+Source1:       CTK-20120806.tar.xz
+# Source1-md5: 567f087cd6cdf10b89047535cbe94f8e
+Source2:       %{name}.init
+Source3:       %{name}.sysconfig
+Source4:       %{name}.upstart
 Patch0:                %{name}-config.patch
-Patch1:                %{name}-php-path.patch
-Patch2:                %{name}-panic_path.patch
+Patch1:                %{name}-panic_path.patch
+Patch2:                ffmpeg0.11.patch
 URL:           http://www.cherokee-project.com/
 %{?with_geoip:BuildRequires:   GeoIP-devel}
 BuildRequires: autoconf
 BuildRequires: automake
-%{?with_ffmpeg:BuildRequires:  ffmpeg-devel}
+%{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 1.0}
 BuildRequires: gettext-devel
 BuildRequires: libtool
 %{?with_mysql:BuildRequires:   mysql-devel}
@@ -43,7 +46,7 @@ BuildRequires:        python-docutils
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.561
 BuildRequires: zlib-devel
-Requires(post,preun):  rc-scripts >= 0.4.3.2
+Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
@@ -51,12 +54,14 @@ Requires(pre):      /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      rc-scripts >= 0.4.3.0
 Suggests:      %{name}-admin = %{version}-%{release}
 Suggests:      php(fcgi)
 Provides:      group(cherokee)
 Provides:      group(http)
 Provides:      user(cherokee)
 Provides:      webserver
+Provides:      webserver(indexfile)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/cherokee
@@ -131,10 +136,10 @@ Cherokee web server libraries.
 Biblioteki serwera WWW Cherokee.
 
 %prep
-%setup -q
+%setup -qn webserver-%{version} -a1
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
+#%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -142,8 +147,9 @@ Biblioteki serwera WWW Cherokee.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-export PHPCGI=%{_bindir}/php.fcgi
+po/admin/generate_POTFILESin.py > po/admin/POTFILES.in
 %configure \
+       --with-php=/usr/bin/php.cgi \
        --disable-static \
        --enable-os-string="PLD Linux" \
        --sysconfdir=/etc \
@@ -154,6 +160,11 @@ export PHPCGI=%{_bindir}/php.fcgi
        %{!?with_mysql:--without-mysql} \
        %{!?with_ffmpeg:--without-ffmpeg} \
        %{!?with_ldap:--without-ldap}
+
+# workaround for missing pot file and no way to build it
+touch po/admin/cherokee.pot
+touch po/admin/*.po
+
 %{__make}
 
 %install
@@ -163,9 +174,9 @@ install -d $RPM_BUILD_ROOT{/etc/{init,pam.d,sysconfig,rc.d/init.d},/var/log/%{na
 %{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/init/%{name}.conf
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
+install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/%{name}.conf
 
 # users don't need this
 mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
@@ -184,7 +195,11 @@ rm $RPM_BUILD_ROOT/etc/cherokee/cherokee.conf.perf_sample
 # and stay after package removal
 %py_comp $RPM_BUILD_ROOT%{_datadir}/cherokee/admin/
 
+# seems like this is not needed on Linux
+rm $RPM_BUILD_ROOT%{_bindir}/cherokee-macos-askpass
+
 mv $RPM_BUILD_ROOT%{_localedir}/{sv_SE,sv}
+mv $RPM_BUILD_ROOT%{_localedir}/{jp,ja}
 %find_lang %{name}
 
 
@@ -198,9 +213,11 @@ rm -rf $RPM_BUILD_ROOT
 %addusertogroup cherokee http
 
 %post
+if [ "$1" = "2" -a -e %{_sysconfdir}/cherokee.conf ]; then
+       %{_datadir}/%{name}/admin/upgrade_config.py %{_sysconfdir}/cherokee.conf
+fi
 /sbin/chkconfig --add %{name}
 %service %{name} restart "Cherokee webserver"
-exit 0
 
 %preun
 if [ "$1" = "0" ]; then
@@ -226,7 +243,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog html performance.conf.sample
+%doc AUTHORS html performance.conf.sample
 %dir %attr(750,root,root) %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
 
@@ -255,13 +272,14 @@ fi
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_deflate.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_directory.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_drop.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_empty_gif.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_error_nn.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_evhost.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_exists.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_extensions.so
-#%attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
+%attr(755,root,root) %{_libdir}/cherokee/libplugin_failover.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_fcgi.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_from.so
@@ -294,7 +312,9 @@ fi
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_secdownload.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ssi.so
+%if %{with ffmpeg}
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_streaming.so
+%endif
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_target_ip.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_tls.so
 %attr(755,root,root) %{_libdir}/cherokee/libplugin_url_arg.so
@@ -329,7 +349,9 @@ fi
 %files admin -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/cherokee-admin
+%attr(755,root,root) %{_bindir}/cherokee-admin-launcher
 %{_mandir}/man1/cherokee-admin.1*
+%{_mandir}/man1/cherokee-admin-launcher.1*
 %dir %{_datadir}/cherokee/admin
 %{_datadir}/cherokee/admin/cherokee.conf.sample
 %{_datadir}/cherokee/admin/performance.conf.sample
@@ -348,9 +370,12 @@ fi
 %dir %{_datadir}/cherokee/admin/wizards
 %{_datadir}/cherokee/admin/wizards/*.py
 %{_datadir}/cherokee/admin/wizards/*.pyc
-%dir %{_datadir}/cherokee/admin/market
-%{_datadir}/cherokee/admin/market/*.py
-%{_datadir}/cherokee/admin/market/*.pyc
+#%dir %{_datadir}/cherokee/admin/market
+#%{_datadir}/cherokee/admin/market/*.py
+#%{_datadir}/cherokee/admin/market/*.pyc
+%dir %{_datadir}/cherokee/admin/icons
+%{_datadir}/cherokee/admin/icons/*.png
+%{_datadir}/cherokee/admin/icons/*.svg
 
 %files libs
 %defattr(644,root,root,755)
This page took 0.094292 seconds and 4 git commands to generate.