]> git.pld-linux.org Git - packages/cherokee.git/blame - cherokee.spec
- Release: 1
[packages/cherokee.git] / cherokee.spec
CommitLineData
0f615d6e 1#
abf5f06b 2# TODO:
0f615d6e
JK
3# - think about moving modules to subpackages. At least, those with extra
4# dependencies.
01abcdff
JB
5#
6# Conditional build:
3319fba3 7%bcond_without geoip # without GeoIP support
56ea9d0b
JK
8%bcond_without mysql # without MySQL support
9%bcond_without ldap # without LDAP support
10%bcond_without ffmpeg # without ffmpeg support
01d41beb 11#
01d41beb 12Summary: Fast, Flexible and Lightweight Web server
56ec7482 13Summary(pl.UTF-8): Cherokee - serwer WWW
0e85b34f 14Name: cherokee
3b7d94a5 15Version: 0.99.44
0f615d6e 16Release: 1
01d41beb 17License: GPL v2
8c503f01 18Group: Networking/Daemons
d8832580 19Source0: http://www.cherokee-project.com/download/0.99/%{version}/%{name}-%{version}.tar.gz
3b7d94a5 20# Source0-md5: 268e7130c12b441523de963f95b9b85d
01d41beb
ER
21Source1: %{name}.init
22Source2: %{name}.sysconfig
1bdedc57
ER
23Patch0: %{name}-config.patch
24Patch1: %{name}-php-path.patch
3b5f252d 25Patch2: %{name}-panic_path.patch
72ce7982 26URL: http://www.cherokee-project.com/
90a7df58 27%{?with_geoip:BuildRequires: GeoIP-devel}
1bdedc57
ER
28BuildRequires: autoconf
29BuildRequires: automake
56ea9d0b 30%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
3319fba3 31BuildRequires: libtool
56ea9d0b
JK
32%{?with_mysql:BuildRequires: mysql-devel}
33%{?with_ldap:BuildRequires: openldap-devel}
abf5f06b 34BuildRequires: openssl-devel
cfbc51f9 35BuildRequires: pam-devel
01d41beb 36BuildRequires: pcre-devel
abf5f06b 37BuildRequires: php-fcgi
cfbc51f9 38BuildRequires: pkgconfig
8c2165c6 39BuildRequires: python-docutils
3319fba3 40BuildRequires: rpm-pythonprov
1bdedc57 41BuildRequires: rpmbuild(macros) >= 1.268
cfbc51f9 42BuildRequires: zlib-devel
1bdedc57
ER
43Requires(post,preun): rc-scripts
44Requires(postun): /usr/sbin/groupdel
45Requires(postun): /usr/sbin/userdel
46Requires(pre): /bin/id
47Requires(pre): /usr/bin/getgid
48Requires(pre): /usr/sbin/groupadd
49Requires(pre): /usr/sbin/useradd
d8be9859 50Requires: %{name}-libs = %{version}-%{release}
3319fba3 51Suggests: php-fcgi
e8c0b4db 52Suggests: %{name}-admin = %{version}-%{release}
1bdedc57
ER
53Provides: group(cherokee)
54Provides: group(http)
55Provides: user(cherokee)
bdfcbc7b 56Provides: webserver
8c503f01 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0e85b34f 58
01d41beb
ER
59%define _sysconfdir /etc/cherokee
60%define _wwwhome /home/services/%{name}
61%define _wwwroot %{_wwwhome}/html
62
0e85b34f 63%description
01d41beb
ER
64Cherokee is a flexible, very fast, lightweight Web server. It is
65implemented entirely in C, and has no dependencies beyond a standard C
a40f27e9 66library. It is embeddable and extensible with plug-ins. It supports
abf5f06b 67on-the-fly configuration by reading files or strings, TLS/SSL via
68OpenSSL, virtual hosts, authentication, cache friendly features, PHP,
69custom error management, and much more.
0e85b34f 70
fd499fdf 71%description -l pl.UTF-8
a40f27e9 72Cherokee to elastyczny, bardzo szybki i lekki serwer WWW. Jest
fd499fdf
JR
73zaimplementowany całkowicie w C i nie ma zależności poza standardową
74biblioteką C. Jest osadzalny i rozbudowywalny poprzez wtyczki.
75Obsługuje konfigurację w locie poprzez odczyt plików lub łańcuchów
abf5f06b 76znaków, TLS/SSL poprzez OpenSSL, hosty wirtualne, uwierzytelnianie,
77opcje związane z pamięcią podręczną, PHP, własne zarządzanie błędami i
78wiele więcej.
8c503f01 79
e8c0b4db
JK
80%package admin
81Summary: Cherokee web server administration interface
82Summary(pl.UTF-8): Interfejs administracyjny serwera WWW Cherokee
83Group: Networking/Daemons
84Requires: python
85Requires: python-modules
86Requires: %{name} = %{version}-%{release}
d8be9859 87
e8c0b4db
JK
88%description admin
89Cherokee web server administration interface.
d8be9859 90
e8c0b4db
JK
91%description admin -l pl.UTF-8
92Interfejs administracyjny serwera WWW Cherokee.
d8be9859 93
0e85b34f 94%package devel
8c503f01 95Summary: Header files for Cherokee web server
56ec7482 96Summary(pl.UTF-8): Pliki nagłówkowe dla serwera WWW Cherokee
8c503f01 97Group: Development/Libraries
d8be9859 98Requires: %{name}-libs = %{version}-%{release}
0e85b34f 99
100%description devel
8c503f01
JB
101Header files for Cherokee web server.
102
fd499fdf
JR
103%description devel -l pl.UTF-8
104Pliki nagłówkowe dla serwera WWW Cherokee.
0e85b34f 105
e8c0b4db
JK
106%package libs
107Summary: Cherokee web server libraries
108Summary(pl.UTF-8): Biblioteki serwera WWW Cherokee
109Group: Libraries
110
111%description libs
112Cherokee web server libraries.
113
114%description libs -l pl.UTF-8
115Biblioteki serwera WWW Cherokee.
116
0e85b34f 117%prep
118%setup -q
1bdedc57
ER
119%patch0 -p1
120%patch1 -p1
3b5f252d 121%patch2 -p1
0e85b34f 122
123%build
3319fba3 124%{__libtoolize}
1bdedc57
ER
125%{__aclocal} -I m4
126%{__autoconf}
127%{__autoheader}
128%{__automake}
abf5f06b 129export PHPCGI=%{_bindir}/php.fcgi
0e85b34f 130%configure \
cfbc51f9 131 --disable-static \
3319fba3 132 --enable-os-string="PLD Linux" \
3319fba3
KK
133 --sysconfdir=/etc \
134 --with-wwwroot=%{_wwwroot} \
abf5f06b 135 --with-wwwuser=cherokee \
136 --with-wwwgroup=http \
56ea9d0b
JK
137 %{!?with_geoip:--without-geoip} \
138 %{!?with_mysql:--without-mysql} \
139 %{!?with_ffmpeg:--without-ffmpeg} \
140 %{!?with_ldap:--without-ldap}
0e85b34f 141%{__make}
142
143%install
144rm -rf $RPM_BUILD_ROOT
2911a3cb 145install -d $RPM_BUILD_ROOT{/etc/{pam.d,sysconfig,rc.d/init.d},/var/log/%{name}}
8c503f01
JB
146
147%{__make} install \
148 DESTDIR=$RPM_BUILD_ROOT
149
01d41beb
ER
150install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
151install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
152
1bdedc57
ER
153# users don't need this
154mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
1bdedc57 155
cfbc51f9
JB
156# modules dlopened by *.so
157rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
158
01d41beb
ER
159# unify manual dir
160rm -rf html
161mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
162
3b7d94a5
JK
163# provided via %doc
164rm $RPM_BUILD_ROOT/etc/cherokee/cherokee.conf.perf_sample
165
0bb5c2e0 166mv $RPM_BUILD_ROOT%{_localedir}/{sv_SE,sv}
3b7d94a5
JK
167%find_lang %{name}
168
8c503f01
JB
169%clean
170rm -rf $RPM_BUILD_ROOT
0e85b34f 171
1bdedc57
ER
172%pre
173%groupadd -g 161 cherokee
174%groupadd -g 51 http
175%useradd -u 161 -d %{_wwwhome} -c "Cherokee User" -g cherokee cherokee
176%addusertogroup cherokee http
177
01d41beb 178%post
01d41beb 179/sbin/chkconfig --add %{name}
c61a601c
ER
180%service %{name} restart "Cherokee webserver"
181exit 0
01d41beb
ER
182
183%preun
184if [ "$1" = "0" ]; then
185 %service %{name} stop
186 /sbin/chkconfig --del %{name}
187fi
188
1bdedc57 189%postun
1bdedc57 190if [ "$1" = "0" ]; then
c61a601c
ER
191 %userremove cherokee
192 %groupremove cherokee
1bdedc57
ER
193 %groupremove http
194fi
cfbc51f9 195
d8be9859
JB
196%post libs -p /sbin/ldconfig
197%postun libs -p /sbin/ldconfig
198
e8c0b4db 199%files
0e85b34f 200%defattr(644,root,root,755)
3b7d94a5 201%doc AUTHORS ChangeLog html contrib/*to*.py performance.conf.sample
0adbe1dc
ER
202%dir %attr(750,root,root) %{_sysconfdir}
203%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
01d41beb 204
2911a3cb 205%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cherokee
01d41beb
ER
206%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cherokee
207%attr(754,root,root) /etc/rc.d/init.d/cherokee
208
209%attr(755,root,root) %{_bindir}/cget
72ce7982 210%attr(755,root,root) %{_bindir}/cherokee-tweak
01d41beb 211%attr(755,root,root) %{_sbindir}/cherokee
3319fba3
KK
212%attr(755,root,root) %{_sbindir}/cherokee-panic
213%attr(755,root,root) %{_sbindir}/cherokee-worker
01d41beb 214
0e85b34f 215%dir %{_libdir}/cherokee
1bdedc57 216%attr(755,root,root) %{_libdir}/cherokee/libplugin_admin.so
72ce7982 217%attr(755,root,root) %{_libdir}/cherokee/libplugin_and.so
abf5f06b 218%attr(755,root,root) %{_libdir}/cherokee/libplugin_authlist.so
219%attr(755,root,root) %{_libdir}/cherokee/libplugin_bind.so
01d41beb
ER
220%attr(755,root,root) %{_libdir}/cherokee/libplugin_cgi.so
221%attr(755,root,root) %{_libdir}/cherokee/libplugin_combined.so
222%attr(755,root,root) %{_libdir}/cherokee/libplugin_common.so
3319fba3 223%attr(755,root,root) %{_libdir}/cherokee/libplugin_custom_error.so
abf5f06b 224%attr(755,root,root) %{_libdir}/cherokee/libplugin_custom.so
56ea9d0b 225%{?with_mysql:%attr(755,root,root) %{_libdir}/cherokee/libplugin_dbslayer.so}
3319fba3 226%attr(755,root,root) %{_libdir}/cherokee/libplugin_deflate.so
72ce7982 227%attr(755,root,root) %{_libdir}/cherokee/libplugin_directory.so
01d41beb 228%attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
abf5f06b 229%attr(755,root,root) %{_libdir}/cherokee/libplugin_empty_gif.so
3319fba3 230%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_nn.so
01d41beb 231%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
abf5f06b 232%attr(755,root,root) %{_libdir}/cherokee/libplugin_evhost.so
233%attr(755,root,root) %{_libdir}/cherokee/libplugin_exists.so
72ce7982 234%attr(755,root,root) %{_libdir}/cherokee/libplugin_extensions.so
3b7d94a5 235#%attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
8c2165c6 236%attr(755,root,root) %{_libdir}/cherokee/libplugin_fcgi.so
01d41beb 237%attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
abf5f06b 238%attr(755,root,root) %{_libdir}/cherokee/libplugin_from.so
239%attr(755,root,root) %{_libdir}/cherokee/libplugin_fullpath.so
0a169935 240%{?with_geoip:%attr(755,root,root) %{_libdir}/cherokee/libplugin_geoip.so}
01d41beb 241%attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
72ce7982 242%attr(755,root,root) %{_libdir}/cherokee/libplugin_header.so
01d41beb
ER
243%attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
244%attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
abf5f06b 245%attr(755,root,root) %{_libdir}/cherokee/libplugin_ip_hash.so
56ea9d0b 246%{?with_ldap:%attr(755,root,root) %{_libdir}/cherokee/libplugin_ldap.so}
abf5f06b 247%attr(755,root,root) %{_libdir}/cherokee/libplugin_libssl.so
248%attr(755,root,root) %{_libdir}/cherokee/libplugin_method.so
56ea9d0b 249%{?with_mysql:%attr(755,root,root) %{_libdir}/cherokee/libplugin_mysql.so}
01d41beb 250%attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
72ce7982
PZ
251%attr(755,root,root) %{_libdir}/cherokee/libplugin_not.so
252%attr(755,root,root) %{_libdir}/cherokee/libplugin_or.so
01d41beb 253%attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
01d41beb 254%attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
3b7d94a5
JK
255%attr(755,root,root) %{_libdir}/cherokee/libplugin_post_report.so
256%attr(755,root,root) %{_libdir}/cherokee/libplugin_post_track.so
3319fba3 257%attr(755,root,root) %{_libdir}/cherokee/libplugin_proxy.so
01d41beb 258%attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
abf5f06b 259%attr(755,root,root) %{_libdir}/cherokee/libplugin_rehost.so
260%attr(755,root,root) %{_libdir}/cherokee/libplugin_render_rrd.so
72ce7982 261%attr(755,root,root) %{_libdir}/cherokee/libplugin_request.so
8c2165c6 262%attr(755,root,root) %{_libdir}/cherokee/libplugin_round_robin.so
abf5f06b 263%attr(755,root,root) %{_libdir}/cherokee/libplugin_rrd.so
8c2165c6 264%attr(755,root,root) %{_libdir}/cherokee/libplugin_scgi.so
abf5f06b 265%attr(755,root,root) %{_libdir}/cherokee/libplugin_secdownload.so
01d41beb 266%attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
abf5f06b 267%attr(755,root,root) %{_libdir}/cherokee/libplugin_ssi.so
268%attr(755,root,root) %{_libdir}/cherokee/libplugin_streaming.so
269%attr(755,root,root) %{_libdir}/cherokee/libplugin_target_ip.so
3b7d94a5 270%attr(755,root,root) %{_libdir}/cherokee/libplugin_url_arg.so
abf5f06b 271%attr(755,root,root) %{_libdir}/cherokee/libplugin_uwsgi.so
272%attr(755,root,root) %{_libdir}/cherokee/libplugin_wildcard.so
01d41beb 273
01d41beb 274%{_mandir}/man1/cget.1*
72ce7982 275%{_mandir}/man1/cherokee.1*
3319fba3
KK
276%{_mandir}/man1/cherokee-tweak.1*
277%{_mandir}/man1/cherokee-worker.1*
01d41beb 278
72ce7982 279%dir %{_datadir}/cherokee
72ce7982
PZ
280%{_datadir}/cherokee/deps
281%{_datadir}/cherokee/icons
72ce7982 282%{_datadir}/cherokee/themes
01d41beb
ER
283
284%dir %{_wwwhome}
0adbe1dc
ER
285%dir %{_wwwroot}
286%config(missingok) %{_wwwroot}/*
287
3319fba3 288%dir %attr(750,cherokee,logs) /var/log/%{name}
0e85b34f 289
0bb5c2e0
JK
290%dir %attr(771,root,cherokee) /var/lib/%{name}
291%dir %attr(771,cherokee,cherokee) /var/lib/%{name}/graphs
292%dir %attr(771,cherokee,cherokee) /var/lib/%{name}/graphs/images
293
e8c0b4db
JK
294%files admin -f %{name}.lang
295%defattr(644,root,root,755)
296%attr(755,root,root) %{_sbindir}/cherokee-admin
297%{_mandir}/man1/cherokee-admin.1*
298%dir %{_datadir}/cherokee/admin
299%{_datadir}/cherokee/admin/cherokee.conf.sample
300%{_datadir}/cherokee/admin/performance.conf.sample
301%{_datadir}/cherokee/admin/*.html
302%attr(755,root,root) %{_datadir}/cherokee/admin/*.py
303%{_datadir}/cherokee/admin/static
304
d8be9859
JB
305%files libs
306%defattr(644,root,root,755)
307%attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
308%attr(755,root,root) %ghost %{_libdir}/libcherokee-base.so.0
309%attr(755,root,root) %{_libdir}/libcherokee-client.so.*.*.*
310%attr(755,root,root) %ghost %{_libdir}/libcherokee-client.so.0
311%attr(755,root,root) %{_libdir}/libcherokee-config.so.*.*.*
312%attr(755,root,root) %ghost %{_libdir}/libcherokee-config.so.0
313%attr(755,root,root) %{_libdir}/libcherokee-server.so.*.*.*
314%attr(755,root,root) %ghost %{_libdir}/libcherokee-server.so.0
315
0e85b34f 316%files devel
8c503f01 317%defattr(644,root,root,755)
0e85b34f 318%attr(755,root,root) %{_bindir}/cherokee-config
72ce7982 319%attr(755,root,root) %{_libdir}/libcherokee-base.so
72ce7982 320%attr(755,root,root) %{_libdir}/libcherokee-client.so
72ce7982 321%attr(755,root,root) %{_libdir}/libcherokee-config.so
72ce7982 322%attr(755,root,root) %{_libdir}/libcherokee-server.so
d8be9859
JB
323%{_libdir}/libcherokee-base.la
324%{_libdir}/libcherokee-client.la
325%{_libdir}/libcherokee-config.la
326%{_libdir}/libcherokee-server.la
8c503f01
JB
327%{_includedir}/cherokee
328%{_pkgconfigdir}/cherokee.pc
329%{_aclocaldir}/cherokee.m4
330%{_mandir}/man1/cherokee-config.1*
This page took 0.612749 seconds and 4 git commands to generate.