]> git.pld-linux.org Git - packages/cherokee.git/blame - cherokee.spec
- updated for 0.99.29
[packages/cherokee.git] / cherokee.spec
CommitLineData
01abcdff
JB
1#
2# Conditional build:
3319fba3 3%bcond_without geoip # without GeoIP support
01abcdff
JB
4%bcond_without gnutls # build with tls=gnutls
5%bcond_with openssl # build with tls=openssl
01d41beb
ER
6#
7%if %{with gnutls} || %{with openssl}
8%define with_tls 1
9%endif
10Summary: Fast, Flexible and Lightweight Web server
56ec7482 11Summary(pl.UTF-8): Cherokee - serwer WWW
0e85b34f 12Name: cherokee
d8832580 13Version: 0.99.29
14Release: 0.1
01d41beb 15License: GPL v2
8c503f01 16Group: Networking/Daemons
d8832580 17Source0: http://www.cherokee-project.com/download/0.99/%{version}/%{name}-%{version}.tar.gz
18# Source0-md5: 236f17981c0c8908f6911fda239fc3a4
01d41beb
ER
19Source1: %{name}.init
20Source2: %{name}.sysconfig
1bdedc57
ER
21Patch0: %{name}-config.patch
22Patch1: %{name}-php-path.patch
3b5f252d 23Patch2: %{name}-panic_path.patch
72ce7982 24URL: http://www.cherokee-project.com/
90a7df58 25%{?with_geoip:BuildRequires: GeoIP-devel}
1bdedc57
ER
26BuildRequires: autoconf
27BuildRequires: automake
01d41beb 28%{?with_gnutls:BuildRequires: gnutls-devel >= 0.9.99}
3319fba3 29BuildRequires: libtool
8c2165c6
PZ
30BuildRequires: mysql-devel
31BuildRequires: openldap-devel
01d41beb 32%{?with_openssl:BuildRequires: openssl-devel}
cfbc51f9 33BuildRequires: pam-devel
01d41beb 34BuildRequires: pcre-devel
cfbc51f9 35BuildRequires: pkgconfig
8c2165c6 36BuildRequires: python-docutils
3319fba3 37BuildRequires: rpm-pythonprov
1bdedc57 38BuildRequires: rpmbuild(macros) >= 1.268
cfbc51f9 39BuildRequires: zlib-devel
1bdedc57
ER
40Requires(post,preun): rc-scripts
41Requires(postun): /usr/sbin/groupdel
42Requires(postun): /usr/sbin/userdel
43Requires(pre): /bin/id
44Requires(pre): /usr/bin/getgid
45Requires(pre): /usr/sbin/groupadd
46Requires(pre): /usr/sbin/useradd
d8be9859 47Requires: %{name}-libs = %{version}-%{release}
3319fba3 48Suggests: php-fcgi
1bdedc57
ER
49Provides: group(cherokee)
50Provides: group(http)
51Provides: user(cherokee)
bdfcbc7b 52Provides: webserver
8c503f01 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0e85b34f 54
01d41beb
ER
55%define _sysconfdir /etc/cherokee
56%define _wwwhome /home/services/%{name}
57%define _wwwroot %{_wwwhome}/html
58
0e85b34f 59%description
01d41beb
ER
60Cherokee is a flexible, very fast, lightweight Web server. It is
61implemented entirely in C, and has no dependencies beyond a standard C
a40f27e9 62library. It is embeddable and extensible with plug-ins. It supports
01d41beb
ER
63on-the-fly configuration by reading files or strings, TLS/SSL (via
64GNUTLS or OpenSSL), virtual hosts, authentication, cache friendly
65features, PHP, custom error management, and much more.
0e85b34f 66
fd499fdf 67%description -l pl.UTF-8
a40f27e9 68Cherokee to elastyczny, bardzo szybki i lekki serwer WWW. Jest
fd499fdf
JR
69zaimplementowany całkowicie w C i nie ma zależności poza standardową
70biblioteką C. Jest osadzalny i rozbudowywalny poprzez wtyczki.
71Obsługuje konfigurację w locie poprzez odczyt plików lub łańcuchów
72znaków, TLS/SSL (poprzez GNUTLS lub OpenSSL), hosty wirtualne,
73uwierzytelnianie, opcje związane z pamięcią podręczną, PHP, własne
74zarządzanie błędami i wiele więcej.
8c503f01 75
d8be9859
JB
76%package libs
77Summary: Cherokee web server libraries
78Summary(pl.UTF-8): Biblioteki serwera WWW Cherokee
79Group: Libraries
80
81%description libs
82Cherokee web server libraries.
83
84%description libs -l pl.UTF-8
85Biblioteki serwera WWW Cherokee.
86
0e85b34f 87%package devel
8c503f01 88Summary: Header files for Cherokee web server
56ec7482 89Summary(pl.UTF-8): Pliki nagłówkowe dla serwera WWW Cherokee
8c503f01 90Group: Development/Libraries
d8be9859 91Requires: %{name}-libs = %{version}-%{release}
0e85b34f 92
93%description devel
8c503f01
JB
94Header files for Cherokee web server.
95
fd499fdf
JR
96%description devel -l pl.UTF-8
97Pliki nagłówkowe dla serwera WWW Cherokee.
0e85b34f 98
99%prep
100%setup -q
1bdedc57
ER
101%patch0 -p1
102%patch1 -p1
3b5f252d 103%patch2 -p1
0e85b34f 104
105%build
3319fba3 106%{__libtoolize}
1bdedc57
ER
107%{__aclocal} -I m4
108%{__autoconf}
109%{__autoheader}
110%{__automake}
0e85b34f 111%configure \
cfbc51f9 112 --disable-static \
3319fba3 113 --enable-os-string="PLD Linux" \
01d41beb 114 %{?with_tls:--enable-tls=%{?with_gnutls:gnutls}%{?with_openssl:openssl}} \
3319fba3
KK
115 --sysconfdir=/etc \
116 --with-wwwroot=%{_wwwroot} \
0a169935 117 %{!?with_geoip:--without-geoip} \
3319fba3 118 PHPCGI=%{_bindir}/php.fcgi
01d41beb 119
0e85b34f 120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
2911a3cb 124install -d $RPM_BUILD_ROOT{/etc/{pam.d,sysconfig,rc.d/init.d},/var/log/%{name}}
8c503f01
JB
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
01d41beb
ER
129install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
130install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
131
1bdedc57
ER
132# users don't need this
133mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
1bdedc57 134
cfbc51f9
JB
135# modules dlopened by *.so
136rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
137
01d41beb
ER
138# unify manual dir
139rm -rf html
140mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
141
8c503f01
JB
142%clean
143rm -rf $RPM_BUILD_ROOT
0e85b34f 144
1bdedc57
ER
145%pre
146%groupadd -g 161 cherokee
147%groupadd -g 51 http
148%useradd -u 161 -d %{_wwwhome} -c "Cherokee User" -g cherokee cherokee
149%addusertogroup cherokee http
150
01d41beb 151%post
01d41beb 152/sbin/chkconfig --add %{name}
c61a601c
ER
153%service %{name} restart "Cherokee webserver"
154exit 0
01d41beb
ER
155
156%preun
157if [ "$1" = "0" ]; then
158 %service %{name} stop
159 /sbin/chkconfig --del %{name}
160fi
161
1bdedc57 162%postun
1bdedc57 163if [ "$1" = "0" ]; then
c61a601c
ER
164 %userremove cherokee
165 %groupremove cherokee
1bdedc57
ER
166 %groupremove http
167fi
cfbc51f9 168
d8be9859
JB
169%post libs -p /sbin/ldconfig
170%postun libs -p /sbin/ldconfig
171
0e85b34f 172%files
173%defattr(644,root,root,755)
3319fba3 174%doc AUTHORS ChangeLog TODO html contrib/*to*.py
0adbe1dc
ER
175%dir %attr(750,root,root) %{_sysconfdir}
176%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
0adbe1dc 177%dir %attr(750,root,root) %{_sysconfdir}/ssl
01d41beb 178
2911a3cb 179%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cherokee
01d41beb
ER
180%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cherokee
181%attr(754,root,root) /etc/rc.d/init.d/cherokee
182
183%attr(755,root,root) %{_bindir}/cget
72ce7982 184%attr(755,root,root) %{_bindir}/cherokee-tweak
8c2165c6 185%attr(755,root,root) %{_bindir}/spawn-fcgi
01d41beb 186%attr(755,root,root) %{_sbindir}/cherokee
8c2165c6 187%attr(755,root,root) %{_sbindir}/cherokee-admin
3319fba3
KK
188%attr(755,root,root) %{_sbindir}/cherokee-panic
189%attr(755,root,root) %{_sbindir}/cherokee-worker
01d41beb 190
0e85b34f 191%dir %{_libdir}/cherokee
1bdedc57 192%attr(755,root,root) %{_libdir}/cherokee/libplugin_admin.so
72ce7982 193%attr(755,root,root) %{_libdir}/cherokee/libplugin_and.so
01d41beb
ER
194%attr(755,root,root) %{_libdir}/cherokee/libplugin_cgi.so
195%attr(755,root,root) %{_libdir}/cherokee/libplugin_combined.so
196%attr(755,root,root) %{_libdir}/cherokee/libplugin_common.so
3319fba3
KK
197%attr(755,root,root) %{_libdir}/cherokee/libplugin_custom_error.so
198%attr(755,root,root) %{_libdir}/cherokee/libplugin_dbslayer.so
199%attr(755,root,root) %{_libdir}/cherokee/libplugin_deflate.so
72ce7982 200%attr(755,root,root) %{_libdir}/cherokee/libplugin_directory.so
01d41beb 201%attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
3319fba3 202%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_nn.so
01d41beb 203%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
72ce7982 204%attr(755,root,root) %{_libdir}/cherokee/libplugin_extensions.so
01d41beb 205%attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
8c2165c6 206%attr(755,root,root) %{_libdir}/cherokee/libplugin_fcgi.so
01d41beb 207%attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
0a169935 208%{?with_geoip:%attr(755,root,root) %{_libdir}/cherokee/libplugin_geoip.so}
01d41beb 209%attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
72ce7982 210%attr(755,root,root) %{_libdir}/cherokee/libplugin_header.so
01d41beb
ER
211%attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
212%attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
8c2165c6
PZ
213%attr(755,root,root) %{_libdir}/cherokee/libplugin_ldap.so
214%attr(755,root,root) %{_libdir}/cherokee/libplugin_mirror.so
215%attr(755,root,root) %{_libdir}/cherokee/libplugin_mysql.so
01d41beb 216%attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
72ce7982
PZ
217%attr(755,root,root) %{_libdir}/cherokee/libplugin_not.so
218%attr(755,root,root) %{_libdir}/cherokee/libplugin_or.so
01d41beb
ER
219%attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
220%attr(755,root,root) %{_libdir}/cherokee/libplugin_phpcgi.so
221%attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
3319fba3 222%attr(755,root,root) %{_libdir}/cherokee/libplugin_proxy.so
01d41beb 223%attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
72ce7982 224%attr(755,root,root) %{_libdir}/cherokee/libplugin_request.so
8c2165c6
PZ
225%attr(755,root,root) %{_libdir}/cherokee/libplugin_round_robin.so
226%attr(755,root,root) %{_libdir}/cherokee/libplugin_scgi.so
01d41beb
ER
227%attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
228%attr(755,root,root) %{_libdir}/cherokee/libplugin_w3c.so
01d41beb 229
01d41beb 230%{_mandir}/man1/cget.1*
72ce7982
PZ
231%{_mandir}/man1/cherokee.1*
232%{_mandir}/man1/cherokee-admin.1*
3319fba3
KK
233%{_mandir}/man1/cherokee-tweak.1*
234%{_mandir}/man1/cherokee-worker.1*
235# Conflicts: lighttpd
236#%%{_mandir}/man1/spawn-fcgi.1*
01d41beb 237
72ce7982
PZ
238%dir %{_datadir}/cherokee
239%dir %{_datadir}/cherokee/admin
240%{_datadir}/cherokee/admin/cherokee.conf.sample
241%{_datadir}/cherokee/admin/*.html
242%attr(755,root,root) %{_datadir}/cherokee/admin/*.py
243%{_datadir}/cherokee/admin/static
244%{_datadir}/cherokee/deps
245%{_datadir}/cherokee/icons
246%{_datadir}/cherokee/mime_types.txt
247%{_datadir}/cherokee/themes
01d41beb
ER
248
249%dir %{_wwwhome}
0adbe1dc
ER
250%dir %{_wwwroot}
251%config(missingok) %{_wwwroot}/*
252
3319fba3 253%dir %attr(750,cherokee,logs) /var/log/%{name}
0e85b34f 254
d8be9859
JB
255%files libs
256%defattr(644,root,root,755)
257%attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
258%attr(755,root,root) %ghost %{_libdir}/libcherokee-base.so.0
259%attr(755,root,root) %{_libdir}/libcherokee-client.so.*.*.*
260%attr(755,root,root) %ghost %{_libdir}/libcherokee-client.so.0
261%attr(755,root,root) %{_libdir}/libcherokee-config.so.*.*.*
262%attr(755,root,root) %ghost %{_libdir}/libcherokee-config.so.0
263%attr(755,root,root) %{_libdir}/libcherokee-server.so.*.*.*
264%attr(755,root,root) %ghost %{_libdir}/libcherokee-server.so.0
265
0e85b34f 266%files devel
8c503f01 267%defattr(644,root,root,755)
0e85b34f 268%attr(755,root,root) %{_bindir}/cherokee-config
72ce7982 269%attr(755,root,root) %{_libdir}/libcherokee-base.so
72ce7982 270%attr(755,root,root) %{_libdir}/libcherokee-client.so
72ce7982 271%attr(755,root,root) %{_libdir}/libcherokee-config.so
72ce7982 272%attr(755,root,root) %{_libdir}/libcherokee-server.so
d8be9859
JB
273%{_libdir}/libcherokee-base.la
274%{_libdir}/libcherokee-client.la
275%{_libdir}/libcherokee-config.la
276%{_libdir}/libcherokee-server.la
8c503f01
JB
277%{_includedir}/cherokee
278%{_pkgconfigdir}/cherokee.pc
279%{_aclocaldir}/cherokee.m4
280%{_mandir}/man1/cherokee-config.1*
This page took 0.162432 seconds and 4 git commands to generate.