]> git.pld-linux.org Git - packages/chef.git/commitdiff
updated patches
authorElan Ruusamäe <glen@delfi.ee>
Wed, 1 Jun 2016 21:02:04 +0000 (00:02 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 1 Jun 2016 21:02:04 +0000 (00:02 +0300)
FHS.patch
chef.spec
optional-plist.patch
poldek.patch

index dbb20b6f695c3b29c1632e6511d96690859fa357..a0de2243fbdd93ae0b7465a415398dff1cc6a773 100644 (file)
--- a/FHS.patch
+++ b/FHS.patch
@@ -1,40 +1,3 @@
---- chef-11.14.2/lib/chef/config.rb    2014-12-04 18:09:43.557089359 +0200
-+++ chef-11.14.2/lib/chef/config.rb    2014-12-04 18:40:15.075764026 +0200
-@@ -181,7 +181,7 @@
-     # Location of cookbooks on disk. String or array of strings.
-     # Defaults to <chef_repo_path>/cookbooks.  If chef_repo_path
--    # is not specified, this is set to [/var/chef/cookbooks, /var/chef/site-cookbooks]).
-+    # is not specified, this is set to [/var/lib/chef/cookbooks, /var/lib/chef/site-cookbooks]).
-     default(:cookbook_path) do
-       if self.configuration[:chef_repo_path]
-         derive_path_from_chef_repo_path('cookbooks')
-@@ -241,9 +241,9 @@
-         "#{config_dir}local-mode-cache"
-       else
-         primary_cache_root = platform_specific_path("/var")
--        primary_cache_path = platform_specific_path("/var/chef")
--        # Use /var/chef as the cache path only if that folder exists and we can read and write
--        # into it, or /var exists and we can read and write into it (we'll create /var/chef later).
-+        primary_cache_path = platform_specific_path("/var/cache/chef")
-+        # Use /var/cache/chef as the cache path only if that folder exists and we can read and write
-+        # into it, or /var exists and we can read and write into it (we'll create /var/cache/chef later).
-         # Otherwise, we'll create .chef under the user's home directory and use that as
-         # the cache path.
-         unless path_accessible?(primary_cache_path) || path_accessible?(primary_cache_root)
-@@ -268,10 +268,10 @@
-     default(:checksum_path) { path_join(cache_path, "checksums") }
-     # Where chef's cache files should be stored
--    default(:file_cache_path) { path_join(cache_path, "cache") }
-+    default(:file_cache_path) { cache_path }
-     # Where backups of chef-managed files should go
--    default(:file_backup_path) { path_join(cache_path, "backup") }
-+    default(:file_backup_path) { '/var/lib/chef/backup' }
-     # The chef-client (or solo) lockfile.
-     #
 --- chef-11.8.0/lib/chef/handler/json_file.rb~ 2013-12-21 17:25:17.000000000 +0200
 +++ chef-11.8.0/lib/chef/handler/json_file.rb  2013-12-21 17:25:58.665209433 +0200
 @@ -27,7 +27,7 @@
index 1387a8d3f9d12107cdbc9f84775ab16cc36f881a..47afd1b706cb2a4b0cc2b4ac208a647bf89fc1f9 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -109,7 +109,7 @@ subcommand is documented in its own manual page.
 %prep
 %setup -q
 gzip -d metadata
-%patch0 -p1
+#%patch0 -p1 # UPDATE
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
index cbaf5d80e44df929f9f7ef3c3444ee41efa6ca4b..f52de0f46472c6964cf2155d1358b9afa0657c95 100644 (file)
@@ -1,35 +1,34 @@
---- chef-11.14.6/lib/chef/provider/user/dscl.rb~       2014-12-05 12:56:20.000000000 +0200
-+++ chef-11.14.6/lib/chef/provider/user/dscl.rb        2014-12-05 13:04:42.684470417 +0200
+--- chef-12.10.24/lib/chef/provider/user/dscl.rb~      2016-06-01 23:58:45.000000000 +0300
++++ chef-12.10.24/lib/chef/provider/user/dscl.rb       2016-06-02 00:00:22.479841208 +0300
 @@ -19,7 +19,6 @@
- require 'mixlib/shellout'
- require 'chef/provider/user'
- require 'openssl'
--require 'plist'
+ require "mixlib/shellout"
+ require "chef/provider/user"
+ require "openssl"
+-require "plist"
+ require "chef/util/path_helper"
  
  class Chef
-   class Provider
-@@ -125,6 +124,8 @@
+@@ -130,6 +129,7 @@
  
                # Calling shell_out directly since we want to give an input stream
                shadow_hash_xml = convert_binary_plist_to_xml(shadow_hash_binary.string)
-+
-+              require 'plist'
-               shadow_hash = Plist::parse_xml(shadow_hash_xml)
++              require "plist"
+               shadow_hash = Plist.parse_xml(shadow_hash_xml)
  
                if shadow_hash["SALTED-SHA512"]
-@@ -558,6 +559,7 @@
+@@ -589,6 +589,7 @@
            begin
-             user_plist_file = "#{USER_PLIST_DIRECTORY}/#{@new_resource.username}.plist"
+             user_plist_file = "#{USER_PLIST_DIRECTORY}/#{new_resource.username}.plist"
              user_plist_info = run_plutil("convert xml1 -o - #{user_plist_file}")
-+            require 'plist'
-             user_info = Plist::parse_xml(user_plist_info)
++            require "plist"
+             user_info = Plist.parse_xml(user_plist_info)
            rescue Chef::Exceptions::PlistUtilCommandFailed
            end
-@@ -571,6 +573,7 @@
+@@ -601,6 +602,7 @@
+         # in DSCL_PROPERTY_MAP to the disk.
          #
          def save_user_info(user_info)
-           user_plist_file = "#{USER_PLIST_DIRECTORY}/#{@new_resource.username}.plist"
-+          require 'plist'
++          require "plist"
+           user_plist_file = "#{USER_PLIST_DIRECTORY}/#{new_resource.username}.plist"
            Plist::Emit.save_plist(user_info, user_plist_file)
            run_plutil("convert binary1 #{user_plist_file}")
-         end
index 7f8209b056fb23a575e5225cb92b2b9f32faaba1..dfe39f74bb2c0fdaf4958fef3dc56660e61e2ae8 100644 (file)
@@ -129,16 +129,16 @@ https://github.com/opscode/chef/pull/1225
 +    end
 +  end
 +end
---- chef-11.14.2/lib/chef/providers.rb~        2014-12-04 18:38:06.000000000 +0200
-+++ chef-11.14.2/lib/chef/providers.rb 2014-12-04 18:38:39.567794339 +0200
-@@ -62,6 +62,7 @@
- require 'chef/provider/package/macports'
- require 'chef/provider/package/pacman'
- require 'chef/provider/package/portage'
-+require 'chef/provider/package/poldek'
- require 'chef/provider/package/paludis'
- require 'chef/provider/package/rpm'
- require 'chef/provider/package/rubygems'
+--- chef-12.10.24/lib/chef/providers.rb~       2016-06-01 23:57:35.000000000 +0300
++++ chef-12.10.24/lib/chef/providers.rb        2016-06-01 23:58:15.093249546 +0300
+@@ -72,6 +72,7 @@
+ require "chef/provider/package/macports"
+ require "chef/provider/package/openbsd"
+ require "chef/provider/package/pacman"
++require "chef/provider/package/poldek"
+ require "chef/provider/package/portage"
+ require "chef/provider/package/paludis"
+ require "chef/provider/package/rpm"
 --- chef-11.12.8/lib/chef/resource/poldek_package.rb   1970-01-01 02:00:00.000000000 +0200
 +++ chef-11.12.8.poldek/lib/chef/resource/poldek_package.rb    2014-12-04 18:27:24.438414927 +0200
 @@ -0,0 +1,34 @@
This page took 0.116386 seconds and 4 git commands to generate.