]> git.pld-linux.org Git - packages/chef.git/commitdiff
fix optional plist
authorElan Ruusamäe <glen@delfi.ee>
Thu, 2 Jun 2016 19:43:01 +0000 (22:43 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 2 Jun 2016 19:43:03 +0000 (22:43 +0300)
chef.spec
optional-plist.patch

index 401388d149d216ad454b6bfcad4dc086db15bbed..7ed2efc053585f9f61070b3152babd49fe848f77 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -8,7 +8,7 @@
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       12.10.24
-Release:       0.7
+Release:       0.8
 License:       Apache v2.0
 Group:         Networking/Admin
 Source0:       https://github.com/chef/chef/archive/v%{version}/%{name}-%{version}.tar.gz
index f52de0f46472c6964cf2155d1358b9afa0657c95..38c8071b74adfcc5586e2c162a4855998f3f6237 100644 (file)
            user_plist_file = "#{USER_PLIST_DIRECTORY}/#{new_resource.username}.plist"
            Plist::Emit.save_plist(user_info, user_plist_file)
            run_plutil("convert binary1 #{user_plist_file}")
+--- ./lib/chef/provider/launchd.rb~    2016-04-27 20:57:14.000000000 +0300
++++ ./lib/chef/provider/launchd.rb     2016-06-02 22:33:01.049679641 +0300
+@@ -21,7 +21,6 @@
+ require "chef/resource/file"
+ require "chef/resource/cookbook_file"
+ require "chef/resource/macosx_service"
+-require "plist"
+ require "forwardable"
+ class Chef
+@@ -150,6 +149,7 @@
+       end
+       def content
++        require "plist"
+         plist_hash = new_resource.hash || gen_hash
+         Plist::Emit.dump(plist_hash) unless plist_hash.nil?
+       end
This page took 0.066653 seconds and 4 git commands to generate.