]> git.pld-linux.org Git - packages/charles.git/commitdiff
- use system activation, oro
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 20 May 2011 06:02:01 +0000 (06:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    charles.spec -> 1.13

charles.spec

index ad7e38bbe88aca0f7c0fc4e994078435ee653d9b..8395f6b166ae2ddb6850f784e2fa95220e1061b2 100644 (file)
@@ -1,10 +1,12 @@
 # I have no access to full version, so I'm packaging trial version only.
 # If you have full tarball, add with(out?)_trial bcond
+# TODO:
+# - activation.jar link becames invalid if BR jdk and runtime jdk are different as it linked from jvm dir
 
 # Conditional build:
 %bcond_without trial           # build from full tarball
 
-%define                rel     0.1
+%define                rel     0.2
 %include       /usr/lib/rpm/macros.java
 Summary:       Web debugging proxy application
 Name:          charles
@@ -12,15 +14,20 @@ Version:    3.5.2
 Release:       %{rel}
 License:       Proprietary, not distributable
 Group:         Networking/Daemons
-Source0:       http://www.charlesproxy.com/assets/release/%{version}/charles.tar.gz
+Source0:       http://www.charlesproxy.com/assets/release/%{version}/%{name}.tar.gz
 # NoSource0-md5:       49498a331ae53fc1bb02c21d8bcd3be9
 NoSource:      0
 Source1:       %{name}.sh
 URL:           http://www.charlesproxy.com/
+BuildRequires: java(jaf)
+BuildRequires: java-oro >= 1.4
+BuildRequires: jpackage-utils
 BuildRequires: rpm-javaprov
 BuildRequires: rpmbuild(macros) >= 1.300
+Requires:      java(jaf)
+Requires:      java-oro >= 1.4
 Requires:      jpackage-utils
-Requires:      jre-X11
+Requires:      jre-X11 >= 1.4
 ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -36,6 +43,15 @@ the HTTP headers (which contain the cookies and caching information).
 %prep
 %setup -q -n %{name}
 
+rm lib/jakarta-oro-2.0.8.jar
+rm lib/activation.jar
+
+%build
+for jar in activation oro; do
+       jar=$(find-jar $jar)
+       ln -s $jar lib
+done
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
This page took 0.055739 seconds and 4 git commands to generate.