]> git.pld-linux.org Git - packages/charles.git/blame - charles.spec
- unified
[packages/charles.git] / charles.spec
CommitLineData
d211014a 1# I have no access to full version, so I'm packaging trial version only.
2# If you have full tarball, add with(out?)_trial bcond
d211014a 3
fd314aaf
ER
4# Conditional build:
5%bcond_without trial # build from full tarball
6
7%define rel 0.1
8%include /usr/lib/rpm/macros.java
d211014a 9Summary: Web debugging proxy application
10Name: charles
11Version: 3.4.1
fd314aaf 12Release: %{rel}%{?with_trial:trial}
d211014a 13License: Proprietary, not distributable
fd314aaf
ER
14Group: Networking/Daemons
15Source0: http://www.charlesproxy.com/assets/release/%{version}/%{name}.tar.gz
d211014a 16# Source0-md5: bcab2cd381d8f5ae9ffed08a0a89b76d
17NoSource: 0
18Source1: %{name}.sh
19URL: http://www.charlesproxy.com/
20BuildRequires: jpackage-utils
21BuildRequires: rpm-javaprov
22BuildRequires: rpmbuild(macros) >= 1.300
23Requires: jpackage-utils
f99057c3 24Requires: jre-X11
d211014a 25ExclusiveArch: %{ix86}
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
fd314aaf
ER
28# already stripped
29%define _enable_debug_packages 0
30
d211014a 31%description
32Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
33developer to view all of the HTTP and SSL / HTTPS traffic between
34their machine and the Internet. This includes requests, responses and
35the HTTP headers (which contain the cookies and caching information).
36
37%prep
38%setup -q -n %{name}
39
40%install
41rm -rf $RPM_BUILD_ROOT
42install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
fd314aaf
ER
43cp -a lib/*.jar $RPM_BUILD_ROOT%{_javadir}/%{name}
44install -p lib/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
45install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
d211014a 46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
d211014a 52%attr(755,root,root) %{_bindir}/%{name}
fd314aaf
ER
53%{_javadir}/%{name}
54%dir %{_libdir}/%{name}
55%attr(755,root,root) %{_libdir}/%{name}/libjdic.so
This page took 1.228909 seconds and 4 git commands to generate.