- specify explicitly which lua version should be used
authorKacper Kornet <draenog@pld-linux.org>
Wed, 5 Mar 2014 19:07:14 +0000 (19:07 +0000)
committerKacper Kornet <draenog@pld-linux.org>
Wed, 5 Mar 2014 19:07:14 +0000 (19:07 +0000)
cgit-lua.patch [deleted file]
cgit.spec

diff --git a/cgit-lua.patch b/cgit-lua.patch
deleted file mode 100644 (file)
index 5236484..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -uNr cgit-0.10.1.old/cgit.mk cgit-0.10.1/cgit.mk
---- cgit-0.10.1.old/cgit.mk    2014-02-28 00:12:08.000000000 +0100
-+++ cgit-0.10.1/cgit.mk        2014-03-01 19:02:59.424624275 +0100
-@@ -30,7 +30,7 @@
-       CGIT_CFLAGS += -DNO_LUA
- else
- ifeq ($(LUA_PKGCONFIG),)
--      LUA_PKGCONFIG := $(shell for pc in luajit lua lua5.2 lua5.1; do \
-+      LUA_PKGCONFIG := $(shell for pc in lua5.2 lua51 lua50; do \
-                       pkg-config --exists $$pc 2>/dev/null && echo $$pc && break; \
-                       done)
-       LUA_MODE := autodetected
index 62b1277..4fea420 100644 (file)
--- a/cgit.spec
+++ b/cgit.spec
@@ -11,10 +11,9 @@ Source1:     %{name}.conf
 Source2:       %{name}-repo.conf
 Source3:       %{name}-apache.conf
 Patch0:                %{name}-system-git.patch
-Patch1:                %{name}-lua.patch
 URL:           http://git.zx2c4.com/cgit/about/
 BuildRequires: git-core-devel >= 1.9.0
-BuildRequires: lua-devel >= 5.0
+BuildRequires: lua52-devel
 BuildRequires: openssl-devel
 BuildConflicts:        zlib-devel = 1.2.5-1
 Requires:      webapps
@@ -44,7 +43,6 @@ HTML zapisany jest na dysku dla kolejnych żądań.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 cp  %{_includedir}/git-core/{Makefile,config.*} git
 
 %build
@@ -54,6 +52,7 @@ cp  %{_includedir}/git-core/{Makefile,config.*} git
        CFLAGS="%{rpmcflags} -I/usr/include/git-core" \
        LDFLAGS="%{rpmldflags}" \
        LIBDIR=%{_libdir} \
+       LUA_PKGCONFIG=lua5.2 \
        CGIT_CONFIG="%{webappdir}/%{webapp}.conf" \
        CGIT_SCRIPT_PATH="%{cgibindir}"
 
This page took 0.14802 seconds and 4 git commands to generate.