]> git.pld-linux.org Git - packages/cgit.git/blob - cgit.spec
- added lua support
[packages/cgit.git] / cgit.spec
1 Summary:        cgit - a fast webinterface to git
2 Summary(pl.UTF-8):      cgit - szybki interfejs WWW do gita
3 Name:           cgit
4 Version:        0.10
5 Release:        2
6 License:        GPL v2
7 Group:          Development/Tools
8 Source0:        http://git.zx2c4.com/cgit/snapshot/%{name}-%{version}.tar.xz
9 # Source0-md5:  19944c17ecea1b1d1944718ce8ce6b61
10 Source1:        %{name}.conf
11 Source2:        %{name}-repo.conf
12 Source3:        %{name}-apache.conf
13 Patch0:         %{name}-system-git.patch
14 Patch1:         %{name}-lua.patch
15 URL:            http://git.zx2c4.com/cgit/about/
16 BuildRequires:  git-core-devel >= 1.8.5
17 BuildRequires:  lua-devel >= 5.0
18 BuildRequires:  openssl-devel
19 BuildConflicts: zlib-devel = 1.2.5-1
20 Requires:       webapps
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         webapp          cgit
24 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
25 %define         appdir          %{_datadir}/%{webapp}
26 %define         cgibindir       %{_prefix}/lib/cgi-bin
27
28 %define         _noautoreqfiles %{_libdir}/cgit/filters
29
30 %description
31 Cgit is a CGI application implemented in C: it's basically (yet)
32 another git command, used to generate HTML. Cgit is not forking: all
33 git operations are performed by linking with libgit.a. It uses a
34 built-in cache: the generated HTML is stored on disk for the benefit
35 of later requests.
36
37 %description -l pl.UTF-8
38 Cgit to napisana w C aplikacja CGI - zasadniczo jest to (kolejny)
39 interfejs do gita, generujący kod HTML. Cgit jest aplikacją
40 nieforkującą - wszystkie operacje na repozytoriach wykonywane są z
41 użyciem biblioteki. Aplikacja ta korzysta z cache - wygenerowany kod
42 HTML zapisany jest na dysku dla kolejnych żądań.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48 cp  %{_includedir}/git-core/{Makefile,config.*} git
49
50 %build
51 %{__make} \
52         V=1 \
53         CC="%{__cc}" \
54         CFLAGS="%{rpmcflags} -I/usr/include/git-core" \
55         LDFLAGS="%{rpmldflags}" \
56         LIBDIR=%{_libdir} \
57         CGIT_CONFIG="%{webappdir}/%{webapp}.conf" \
58         CGIT_SCRIPT_PATH="%{cgibindir}"
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 # The same CFLAGS as in %build  stage has to be passed to avoid
64 # "new build flags" logic in Makefile
65 %{__make} install \
66         V=1 \
67         DESTDIR=$RPM_BUILD_ROOT \
68         prefix=%{_prefix} \
69         CFLAGS="%{rpmcflags} -I/usr/include/git-core" \
70         CGIT_CONFIG="%{webappdir}/%{webapp}.conf" \
71         CGIT_DATA_PATH="%{appdir}" \
72         CGIT_SCRIPT_PATH="%{cgibindir}"
73
74 # cache
75 install -d $RPM_BUILD_ROOT/var/cache/cgit
76
77 # webapp stuff
78 install -d $RPM_BUILD_ROOT%{webappdir}
79 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}
80 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}
81 install %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/apache.conf
82 install %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %triggerin -- apache1 < 1.3.37-3, apache1-base
88 %webapp_register apache %{webapp}
89
90 %triggerun -- apache1 < 1.3.37-3, apache1-base
91 %webapp_unregister apache %{webapp}
92
93 %triggerin -- apache-base
94 %webapp_register httpd %{webapp}
95
96 %triggerun -- apache-base
97 %webapp_unregister httpd %{webapp}
98
99 %files
100 %defattr(644,root,root,755)
101 %doc README cgitrc.5.txt
102 %dir %{webappdir}
103 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/cgit.conf
104 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/cgit-repo.conf
105 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
106 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
107 %attr(755,root,root) %{cgibindir}/cgit.cgi
108 %attr(770,root,http) /var/cache/cgit
109 %{appdir}
110 %dir %{_prefix}/lib/cgit
111 %dir %{_prefix}/lib/cgit/filters
112 %attr(755,root,root) %{_prefix}/lib/cgit/filters/about-formatting.sh
113 %attr(755,root,root) %{_prefix}/lib/cgit/filters/commit-links.sh
114 %attr(655,root,root) %{_prefix}/lib/cgit/filters/email-gravatar.lua
115 %attr(755,root,root) %{_prefix}/lib/cgit/filters/email-gravatar.py
116 %attr(655,root,root) %{_prefix}/lib/cgit/filters/simple-authentication.lua
117 %attr(755,root,root) %{_prefix}/lib/cgit/filters/syntax-highlighting.py
118 %attr(755,root,root) %{_prefix}/lib/cgit/filters/syntax-highlighting.sh
119 %dir %{_prefix}/lib/cgit/filters/html-converters
120 %attr(755,root,root) %{_prefix}/lib/cgit/filters/html-converters/man2html
121 %attr(755,root,root) %{_prefix}/lib/cgit/filters/html-converters/md2html
122 %attr(755,root,root) %{_prefix}/lib/cgit/filters/html-converters/rst2html
123 %attr(755,root,root) %{_prefix}/lib/cgit/filters/html-converters/txt2html
124 %dir %{_prefix}/lib/cgit/filters/html-converters/resources
125 %attr(755,root,root) %{_prefix}/lib/cgit/filters/html-converters/resources/markdown.pl
126 %attr(655,root,root) %{_prefix}/lib/cgit/filters/html-converters/resources/rst-template.txt
This page took 0.065179 seconds and 3 git commands to generate.