]> git.pld-linux.org Git - packages/cgit.git/blame - cgit.spec
- use override
[packages/cgit.git] / cgit.spec
CommitLineData
bf1ce868
AG
1#
2# Conditional build
3%bcond_with verbose # verbose build (V=1)
4#
5Summary: cgit - a fast webinterface to git
6Summary(pl.UTF-8): cgit - szybki interfejs webowy do git-a
7Name: cgit
8Version: 0.8.1
9Release: 0.0.1
10License: GPL v2
11Group: Development/Tools
12Source0: http://hjemli.net/git/cgit/snapshot/%{name}-%{version}.tar.bz2
13# Source0-md5: 654850ded01dd2f6b732aa7c1b0856dc
14Patch0: %{name}-system-git.patch
15Patch1: %{name}-override-cflags.patch
16Source1: %{name}.conf
17Source2: %{name}-repo.conf
18Source3: %{name}-httpd.conf
19URL: http://hjemli.net/git/cgit
20BuildRequires: git-core-devel >= 1.6.0.5-2
21BuildRequires: openssl-devel
22Requires: webapps
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define webapp cgit
26%define webappdir %{_sysconfdir}/webapps/%{webapp}
27%define appdir %{_datadir}/%{webapp}
28%define cgibindir %{_prefix}/lib/cgi-bin
29
30%description
31Cgit is a CGI application implemented in C: it's basically (yet)
32another git command, used to generate html. Cgit is not forking: all
33git operations are performed by linking with libgit.a. It uses a
34built-in cache: the generated html is stored on disk for the benefit
35of later requests.
36
37%description -l pl.UTF-8
38Cgit to: napisana w C aplikacja CGI - zasadniczo jest to (kolejny)
39interfejs do git-a, generujący kod html. Cgit jest aplikacją
40nieforkującą - wszystkie operacje na repozytoriach wykonywane są z
41użyciem biblioteki. Aplikacja ta korzysta z cache - wygenerowany kod
42htl zapisany jest na dysku dla kolejnych żądań.
43
44%prep
45%setup -q
46%patch0 -p1
47%patch1 -p1
48
49%build
50%{__make} \
51 CC="%{__cc}" \
52 CFLAGS="%{rpmcflags} -I/usr/include/git-core" \
53 LDFLAGS="%{rpmldflags}" \
54 CGIT_CONFIG="%{webappdir}/%{webapp}.conf" \
55 CGIT_SCRIPT_PATH="%{cgibindir}" \
56 %{?with_verbose:V=1}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT \
63 CGIT_CONFIG="%{webappdir}/%{webapp.conf}" \
64 CGIT_SCRIPT_PATH="%{cgibindir}" \
65 %{?with_verbose:V=1}
66
67# css and logo
68install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
69mv $RPM_BUILD_ROOT%{cgibindir}/%{name}.{css,png} $RPM_BUILD_ROOT%{appdir}
70
71# cache
72install -d $RPM_BUILD_ROOT/var/cache/cgit
73
74# webapp stuff
75install -d $RPM_BUILD_ROOT%{webappdir}
76install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}
77install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}
78install %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/apache.conf
79install %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%triggerin -- apache1 < 1.3.37-3, apache1-base
85%webapp_register apache %{webapp}
86
87%triggerun -- apache1 < 1.3.37-3, apache1-base
88%webapp_unregister apache %{webapp}
89
90%triggerin -- apache < 2.2.0, apache-base
91%webapp_register httpd %{webapp}
92
93%triggerun -- apache < 2.2.0, apache-base
94%webapp_unregister httpd %{webapp}
95
96%files
97%defattr(644,root,root,755)
98%doc README cgitrc.5.txt
99%dir %{webappdir}
100%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/cgit.conf
101%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/cgit-repo.conf
102%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
103%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
104%attr(755,root,root) %{cgibindir}/cgit.cgi
105%attr(770,root,http) /var/cache/cgit
106%{appdir}
This page took 0.060802 seconds and 4 git commands to generate.