]> git.pld-linux.org Git - packages/cgicc.git/blob - cgicc.spec
- updated to 3.2.20
[packages/cgicc.git] / cgicc.spec
1 # TODO: - provide subpackages with cgi and fastcgi demos
2 #
3 # Conditional build:
4 %bcond_without  static_libs # don't build static libraries
5
6 Summary:        A C++ library for CGI programming
7 Summary(pl.UTF-8):      Biblioteka C++ do programowania CGI
8 Name:           cgicc
9 Version:        3.2.19
10 Release:        1
11 License:        LGPL v3+ (library), FDL v1.1+ (documentation)
12 Group:          Libraries
13 Source0:        http://ftp.gnu.org/gnu/cgicc/%{name}-%{version}.tar.gz
14 # Source0-md5:  a795531556aef314018834981a1466c9
15 Patch0:         %{name}-link.patch
16 URL:            http://www.gnu.org/software/cgicc/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:1.5
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 GNU cgicc is a C++ class library that greatly simplifies the creation
26 of CGI applications for the World Wide Web. cgicc performs the
27 following functions:
28 - Parses both GET and POST form data transparently.
29 - Provides string, integer, floating-point and single- and
30   multiple-choice retrieval methods for form data.
31 - Provides methods for saving and restoring CGI environments to aid in
32   application debugging.
33 - Provides full on-the-fly HTML generation capabilities, with support
34   for cookies.
35 - Supports HTTP file upload.
36 - Compatible with FastCGI.
37
38 %description -l pl.UTF-8
39 GNU cgicc to biblioteka klas C++ znacznie upraszczająca tworzenie
40 aplikacji CGI dla WWW. cgicc wykonuje następujące funkcje:
41 - w sposób przezroczysty analizuje dane z formularzy GET i POST
42 - udostępnia metody uzyskiwania łańcuchów znaków, liczb całkowitych i
43   zmiennoprzecinkowych oraz opcji jednokrotnego i wielokrotnego wyboru z
44   danych formularzy
45 - udostępnia metody do zapisu i odtwarzania środowiska CGI pomagające
46   przy śledzeniu aplikacji
47 - udostępnia pełne możliwości generowania HTML-a w locie, z obsługą
48   ciasteczek
49 - obsługuje wysyłanie plików po HTTP
50 - jest kompatybilna z FastCGI.
51
52 %package devel
53 Summary:        A C++ library for CGI programming - header files
54 Summary(pl.UTF-8):      Biblioteka C++ do programowania CGI - pliki nagłówkowe
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       libstdc++-devel
58
59 %description devel
60 Header files for cgicc library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki cgicc.
64
65 %package static
66 Summary:        A C++ library for CGI programming - static version
67 Summary(pl.UTF-8):      Biblioteka C++ do programowania CGI - wersja statyczna
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static version of cgicc library.
73
74 %description static -l pl.UTF-8
75 Statyczna wersja biblioteki cgicc.
76
77 %package apidocs
78 Summary:        API documentation for cgicc library
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki cgicc
80 Group:          Documentation
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description apidocs
86 API documentation for cgicc library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki cgicc.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --disable-demos \
103         %{!?with_static_libs:--disable-static}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # packaged as %doc in -apidocs
113 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/%{name}-%{version}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS BUGS ChangeLog NEWS README THANKS doc/html/*
124 %attr(755,root,root) %{_libdir}/libcgicc.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libcgicc.so.3
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/cgicc-config
130 %attr(755,root,root) %{_libdir}/libcgicc.so
131 %{_libdir}/libcgicc.la
132 %{_includedir}/cgicc
133 %{_pkgconfigdir}/cgicc.pc
134 %{_aclocaldir}/cgicc.m4
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libcgicc.a
140 %endif
141
142 %files apidocs
143 %defattr(644,root,root,755)
144 %doc doc/html/*
This page took 0.138559 seconds and 3 git commands to generate.