]> git.pld-linux.org Git - packages/cgi.tcl.git/blob - cgi.tcl.spec
- tabs in preamble
[packages/cgi.tcl.git] / cgi.tcl.spec
1 %define         _mainver        1.8
2 Summary:        Tool Command Language embeddable scripting language, with shared libraries
3 Summary(pl.UTF-8):      Tool Command Language - język skryptowy z bibliotekami dynamicznymi
4 Name:           cgi.tcl
5 Version:        1.8.0
6 Release:        1
7 License:        Public Domain
8 Group:          Development/Languages/Tcl
9 Source0:        http://expect.nist.gov/%{name}/cgi.tcl.tar.gz
10 # Source0-md5:  51aa4cbcd401d760a7c5621c28b78125
11 Patch0:         %{name}-DESTDIR.patch
12 URL:            http://expect.nist.gov/cgi.tcl/
13 BuildRequires:  autoconf
14 BuildRequires:  tcl
15 Requires:       tcl
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _packagedir     %{_libdir}/tcl8.3/cgi%{_mainver}
19
20 %description
21 cgi.tcl is the CGI support library for Tcl programmers. The library is
22 very thorough - it supports forms, tables, cookies, file upload,
23 plug-ins, JavaScript, Netscape extensions, etc, etc. It also provides
24 very convenient support for debugging and handling CGI errors. cgi.tcl
25 can also be used for generating static HTML. This enables you to get
26 programming features into HTML, such as variables, if/then/else, file
27 I/O, etc. For example, HTML lacks variables so if you repeatedly use a
28 link on a page and one day the link changes, you've got to update
29 every use of the link, possibly on hundreds of pages. By storing the
30 link in a Tcl variable, you can just change the one place where the
31 variable is defined. This makes maintenance much easier. This is just
32 a tiny example of the benefits cgi.tcl provides.
33
34 %description -l pl.UTF-8
35 cgi.tcl to biblioteka obsługi CGI dla programistów Tcl. Biblioteka ma
36 dużą funkcjonalność - obsługuje formularze, tabelki, ciasteczka,
37 upload plików, wtyczki, JavaScript, rozszerzenia Netscape itp.
38 Udostępnia także bardzo wygodne wsparcie dla odpluskwiania i obsługi
39 błędów CGI. cgi.tcl może być używane także do generowania statycznego
40 HTML-a. Pozwala to na umieszczanie w HTML-u elementów programów w
41 HTML-u, takich jak zmienne, if/then/else, operacje na plikach itp. Na
42 przykład, HTML nie ma zmiennych, więc jeśli używa się tego samego
43 odnośnika wielokrotnie na stronie, i w pewnym momencie on się zmienia,
44 trzeba uaktualnić każde użycie tego odnośnika, być może na setkach
45 stron. Dzięki zapisaniu odnośnika w zmiennej Tcl, wystarczy zmienić
46 tylko to miejsce, gdzie zmienna jest zdefiniowana. Znacznie ułatwia to
47 utrzymywanie stron. Jest to tylko mały przykład zalet cgi.tcl.
48
49 %prep
50 %setup  -q -n %{name}-%{_mainver}
51 %patch0 -p1
52
53 %build
54 %{__autoconf}
55 %configure
56
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         SCRIPTDIR=%{_packagedir} \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc HISTORY README doc/*.txt example
72 %{_packagedir}/*.tcl
73 %{_mandir}/man3/*
This page took 0.097161 seconds and 3 git commands to generate.