]> git.pld-linux.org Git - packages/cgi.tcl.git/blame - cgi.tcl.spec
- tabs in preamble
[packages/cgi.tcl.git] / cgi.tcl.spec
CommitLineData
dd08df4e 1%define _mainver 1.8
917e5272 2Summary: Tool Command Language embeddable scripting language, with shared libraries
fd1cb956 3Summary(pl.UTF-8): Tool Command Language - język skryptowy z bibliotekami dynamicznymi
917e5272 4Name: cgi.tcl
8798b898 5Version: 1.8.0
917e5272
PG
6Release: 1
7License: Public Domain
8Group: Development/Languages/Tcl
dd08df4e 9Source0: http://expect.nist.gov/%{name}/cgi.tcl.tar.gz
b7e25342 10# Source0-md5: 51aa4cbcd401d760a7c5621c28b78125
917e5272
PG
11Patch0: %{name}-DESTDIR.patch
12URL: http://expect.nist.gov/cgi.tcl/
13BuildRequires: autoconf
7c14aef7 14BuildRequires: tcl
917e5272
PG
15Requires: tcl
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _packagedir %{_libdir}/tcl8.3/cgi%{_mainver}
19
20%description
21cgi.tcl is the CGI support library for Tcl programmers. The library is
22very thorough - it supports forms, tables, cookies, file upload,
23plug-ins, JavaScript, Netscape extensions, etc, etc. It also provides
24very convenient support for debugging and handling CGI errors. cgi.tcl
e66d3ad8
JB
25can also be used for generating static HTML. This enables you to get
26programming features into HTML, such as variables, if/then/else, file
27I/O, etc. For example, HTML lacks variables so if you repeatedly use a
28link on a page and one day the link changes, you've got to update
29every use of the link, possibly on hundreds of pages. By storing the
30link in a Tcl variable, you can just change the one place where the
31variable is defined. This makes maintenance much easier. This is just
32a tiny example of the benefits cgi.tcl provides.
33
a724d73a
JR
34%description -l pl.UTF-8
35cgi.tcl to biblioteka obsługi CGI dla programistów Tcl. Biblioteka ma
36dużą funkcjonalność - obsługuje formularze, tabelki, ciasteczka,
37upload plików, wtyczki, JavaScript, rozszerzenia Netscape itp.
38Udostępnia także bardzo wygodne wsparcie dla odpluskwiania i obsługi
39błędów CGI. cgi.tcl może być używane także do generowania statycznego
40HTML-a. Pozwala to na umieszczanie w HTML-u elementów programów w
c1128fd8 41HTML-u, takich jak zmienne, if/then/else, operacje na plikach itp. Na
a724d73a
JR
42przykład, HTML nie ma zmiennych, więc jeśli używa się tego samego
43odnośnika wielokrotnie na stronie, i w pewnym momencie on się zmienia,
44trzeba uaktualnić każde użycie tego odnośnika, być może na setkach
45stron. Dzięki zapisaniu odnośnika w zmiennej Tcl, wystarczy zmienić
46tylko to miejsce, gdzie zmienna jest zdefiniowana. Znacznie ułatwia to
47utrzymywanie stron. Jest to tylko mały przykład zalet cgi.tcl.
917e5272
PG
48
49%prep
50%setup -q -n %{name}-%{_mainver}
51%patch0 -p1
52
53%build
54%{__autoconf}
55%configure
56
57%{__make}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__make} install \
63 SCRIPTDIR=%{_packagedir} \
64 DESTDIR=$RPM_BUILD_ROOT
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc HISTORY README doc/*.txt example
dd08df4e 72%{_packagedir}/*.tcl
917e5272 73%{_mandir}/man3/*
This page took 0.061698 seconds and 4 git commands to generate.