]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- removed obsolete patches
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Feb 2022 10:18:26 +0000 (11:18 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Feb 2022 10:19:01 +0000 (11:19 +0100)
- updated deps
- addded patches from Gentoo to build with systemd zstd and do not require virtualenv

boost.patch [deleted file]
ceph-fio.patch [deleted file]
ceph-includes.patch [deleted file]
ceph-init-fix.patch [deleted file]
ceph-python.patch
ceph-rocksdb.patch [deleted file]
ceph-types.patch [deleted file]
ceph-zfs.patch [deleted file]
ceph.spec
no-virtualenvs.patch [new file with mode: 0644]
system-zstd.patch [new file with mode: 0644]

diff --git a/boost.patch b/boost.patch
deleted file mode 100644 (file)
index af61e2f..0000000
+++ /dev/null
@@ -1,226 +0,0 @@
-Regressed by https://github.com/boostorg/date_time/commit/f9f2aaf5216c
-
-src/rbd_replay/Replayer.cc:353:65: error: no matching conversion for functional-style cast from 'float' to 'boost::posix_time::microseconds' (aka 'subsecond_duration<boost::posix_time::time_duration, 1000000>')
-    boost::system_time sub_release_time(action_completed_time + boost::posix_time::microseconds(dep.time_delta * m_latency_multiplier / 1000));
-                                                                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-/usr/local/include/boost/date_time/time_duration.hpp:270:30: note: candidate constructor (the implicit copy constructor) not viable: no known conversion from 'float' to 'const boost::date_time::subsecond_duration<boost::posix_time::time_duration, 1000000>' for 1st argument
-  class BOOST_SYMBOL_VISIBLE subsecond_duration : public base_duration
-                             ^
-/usr/local/include/boost/date_time/time_duration.hpp:270:30: note: candidate constructor (the implicit move constructor) not viable: no known conversion from 'float' to 'boost::date_time::subsecond_duration<boost::posix_time::time_duration, 1000000>' for 1st argument
-/usr/local/include/boost/date_time/time_duration.hpp:286:59: note: candidate template ignored: disabled by 'enable_if' [with T = float]
-                                typename boost::enable_if<boost::is_integral<T>, void>::type* = 0) :
-                                                          ^
-
-src/test/librbd/test_mock_Journal.cc:485:42: error: reference to '_1' is ambiguous
-      std::bind(&invoke_replay_complete, _1, 0));
-                                         ^
-/usr/local/include/boost/bind/placeholders.hpp:46:38: note: candidate found by name lookup is 'boost::placeholders::_1'
-BOOST_STATIC_CONSTEXPR boost::arg<1> _1;
-                                     ^
-/usr/include/c++/v1/functional:2021:21: note: candidate found by name lookup is 'std::__1::placeholders::_1'
-constexpr __ph<1>   _1{};
-                    ^
-
---- src/rbd_replay/Replayer.cc.orig    2018-02-26 21:47:18 UTC
-+++ src/rbd_replay/Replayer.cc
-@@ -350,7 +350,7 @@ void Replayer::wait_for_actions(const action::Dependen
-     dout(DEPGRAPH_LEVEL) << "Finished waiting for " << dep.id << " after " << micros << " microseconds" << dendl;
-     // Apparently the nanoseconds constructor is optional:
-     // http://www.boost.org/doc/libs/1_46_0/doc/html/date_time/details.html#compile_options
--    boost::system_time sub_release_time(action_completed_time + boost::posix_time::microseconds(dep.time_delta * m_latency_multiplier / 1000));
-+    boost::system_time sub_release_time(action_completed_time + boost::posix_time::microseconds(long(dep.time_delta * m_latency_multiplier / 1000)));
-     if (sub_release_time > release_time) {
-       release_time = sub_release_time;
-     }
---- src/mon/MDSMonitor.cc.orig 2020-05-28 07:26:02.363159480 +0200
-+++ src/mon/MDSMonitor.cc      2020-05-28 07:28:02.559174989 +0200
-@@ -15,6 +15,7 @@
- #include <sstream>
- #include <boost/utility.hpp>
- #include <boost/regex.hpp>
-+#include <boost/next_prior.hpp>
- #include "MDSMonitor.h"
- #include "FSCommands.h"
---- CMakeLists.txt.orig        2020-01-30 21:52:36.000000000 +0100
-+++ CMakeLists.txt     2020-05-28 16:50:46.412927163 +0200
-@@ -563,7 +563,7 @@
- set(BOOST_HEADER_COMPONENTS container)
- if(WITH_MGR)
--      list(APPEND BOOST_COMPONENTS python)
-+      list(APPEND BOOST_COMPONENTS python27)
- endif()
- if(WITH_BOOST_CONTEXT)
-   list(APPEND BOOST_COMPONENTS context coroutine)
---- src/CMakeLists.txt.orig    2020-01-30 21:52:36.000000000 +0100
-+++ src/CMakeLists.txt 2020-05-28 20:58:47.848974172 +0200
-@@ -722,7 +722,7 @@
-                  $<TARGET_OBJECTS:heap_profiler_objs>)
-   target_include_directories(ceph-mgr PRIVATE "${PYTHON_INCLUDE_DIRS}")
-   target_link_libraries(ceph-mgr osdc client global-static common
--      Boost::python ${PYTHON_LIBRARIES} ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS} ${ALLOC_LIBS})
-+      Boost::python27 ${PYTHON_LIBRARIES} ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS} ${ALLOC_LIBS})
-   install(TARGETS ceph-mgr DESTINATION bin)
- endif (WITH_MGR)
---- src/test/librbd/test_mock_Journal.cc.orig  2020-01-30 21:52:36.000000000 +0100
-+++ src/test/librbd/test_mock_Journal.cc       2020-05-29 06:26:16.934514447 +0200
-@@ -482,7 +482,7 @@
-     expect_get_max_append_size(mock_journaler, 1 << 16);
-     expect_start_replay(
-       mock_image_ctx, mock_journaler,
--      std::bind(&invoke_replay_complete, _1, 0));
-+      std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-     MockJournalReplay mock_journal_replay;
-     expect_stop_replay(mock_journaler);
-@@ -531,7 +531,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_ready, _1));
-+    std::bind(&invoke_replay_ready, std::placeholders::_1));
-   ::journal::MockReplayEntry mock_replay_entry;
-   MockJournalReplay mock_journal_replay;
-@@ -540,11 +540,11 @@
-   expect_try_pop_front(mock_image_ctx, mock_journaler, true, mock_replay_entry);
-   expect_replay_process(mock_journal_replay);
-   expect_try_pop_front(mock_image_ctx, mock_journaler, false, mock_replay_entry,
--                       std::bind(&invoke_replay_ready, _1));
-+                       std::bind(&invoke_replay_ready, std::placeholders::_1));
-   expect_try_pop_front(mock_image_ctx, mock_journaler, true, mock_replay_entry);
-   expect_replay_process(mock_journal_replay);
-   expect_try_pop_front(mock_image_ctx, mock_journaler, false, mock_replay_entry,
--                       std::bind(&invoke_replay_complete, _1, 0));
-+                       std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   expect_shut_down_replay(mock_image_ctx, mock_journal_replay, 0);
-@@ -601,7 +601,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_complete, _1, -EINVAL));
-+    std::bind(&invoke_replay_complete, std::placeholders::_1, -EINVAL));
-   MockJournalReplay mock_journal_replay;
-   expect_stop_replay(mock_journaler);
-@@ -616,7 +616,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_complete, _1, 0));
-+    std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   expect_shut_down_replay(mock_image_ctx, mock_journal_replay, 0);
-@@ -649,14 +649,14 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_ready, _1));
-+    std::bind(&invoke_replay_ready, std::placeholders::_1));
-   ::journal::MockReplayEntry mock_replay_entry;
-   MockJournalReplay mock_journal_replay;
-   expect_try_pop_front(mock_image_ctx, mock_journaler, true, mock_replay_entry);
-   expect_replay_process(mock_journal_replay);
-   expect_try_pop_front(mock_image_ctx, mock_journaler, false, mock_replay_entry,
--                       std::bind(&invoke_replay_complete, _1, 0));
-+                       std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   expect_shut_down_replay(mock_image_ctx, mock_journal_replay, -EINVAL);
-   expect_flush_commit_position(mock_journaler);
-@@ -669,7 +669,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_complete, _1, 0));
-+    std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   expect_shut_down_replay(mock_image_ctx, mock_journal_replay, 0);
-@@ -702,7 +702,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_ready, _1));
-+    std::bind(&invoke_replay_ready, std::placeholders::_1));
-   ::journal::MockReplayEntry mock_replay_entry;
-   MockJournalReplay mock_journal_replay;
-@@ -720,7 +720,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_complete, _1, 0));
-+    std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   expect_shut_down_replay(mock_image_ctx, mock_journal_replay, 0);
-   expect_flush_commit_position(mock_journaler);
-@@ -752,7 +752,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_complete, _1, 0));
-+    std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   MockJournalReplay mock_journal_replay;
-   expect_stop_replay(mock_journaler);
-@@ -786,7 +786,7 @@
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_ready, _1));
-+    std::bind(&invoke_replay_ready, std::placeholders::_1));
-   ::journal::MockReplayEntry mock_replay_entry;
-   MockJournalReplay mock_journal_replay;
-@@ -813,7 +813,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler, {
--      std::bind(&invoke_replay_complete, _1, 0)
-+      std::bind(&invoke_replay_complete, std::placeholders::_1, 0)
-     });
-   expect_stop_replay(mock_journaler);
-@@ -868,14 +868,14 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_ready, _1));
-+    std::bind(&invoke_replay_ready, std::placeholders::_1));
-   ::journal::MockReplayEntry mock_replay_entry;
-   MockJournalReplay mock_journal_replay;
-   expect_try_pop_front(mock_image_ctx, mock_journaler, true, mock_replay_entry);
-   expect_replay_process(mock_journal_replay);
-   expect_try_pop_front(mock_image_ctx, mock_journaler, false, mock_replay_entry,
--                       std::bind(&invoke_replay_complete, _1, 0));
-+                       std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   Context *on_flush = nullptr;
-@@ -892,7 +892,7 @@
-   expect_get_max_append_size(mock_journaler, 1 << 16);
-   expect_start_replay(
-     mock_image_ctx, mock_journaler,
--    std::bind(&invoke_replay_complete, _1, 0));
-+    std::bind(&invoke_replay_complete, std::placeholders::_1, 0));
-   expect_stop_replay(mock_journaler);
-   expect_shut_down_replay(mock_image_ctx, mock_journal_replay, 0);
---- src/test/lazy-omap-stats/lazy_omap_stats_test.cc.orig      2020-01-30 21:52:36.000000000 +0100
-+++ src/test/lazy-omap-stats/lazy_omap_stats_test.cc   2020-05-29 08:04:42.179189658 +0200
-@@ -331,7 +331,7 @@
-   vector<string> tokens(tok.begin(), tok.end());
-   auto it = find(tokens.begin(), tokens.end(), label);
-   if (it != tokens.end()) {
--    return distance(tokens.begin(), it);
-+    return std::distance(tokens.begin(), it);
-   }
-   cerr << "find_index failed to find index for " << label << endl;
diff --git a/ceph-fio.patch b/ceph-fio.patch
deleted file mode 100644 (file)
index 67a455a..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- ceph-12.2.13/src/test/fio/fio_ceph_objectstore.cc.orig     2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/test/fio/fio_ceph_objectstore.cc  2020-05-31 08:19:04.978377543 +0200
-@@ -340,7 +340,7 @@
-   }
- };
--int fio_ceph_os_queue(thread_data* td, io_u* u)
-+fio_q_status fio_ceph_os_queue(thread_data* td, io_u* u)
- {
-   fio_ro_check(td, u);
---- ceph-12.2.13/src/test/fio/CMakeLists.txt.orig      2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/test/fio/CMakeLists.txt   2020-06-05 06:18:00.642074789 +0200
-@@ -15,4 +15,4 @@
- endif()
- target_link_libraries(fio_ceph_objectstore os global)
--install(TARGETS fio_ceph_objectstore DESTINATION lib)
-+install(TARGETS fio_ceph_objectstore DESTINATION lib${LIB_SUFFIX})
diff --git a/ceph-includes.patch b/ceph-includes.patch
deleted file mode 100644 (file)
index 7353415..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- ceph-12.2.13/src/common/bit_str.h.orig     2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/common/bit_str.h  2020-05-31 19:08:32.698492649 +0200
-@@ -14,7 +14,9 @@
- #ifndef CEPH_COMMON_BIT_STR_H
- #define CEPH_COMMON_BIT_STR_H
-+#include <cstdint>
- #include <functional>
-+#include <ostream>
- namespace ceph {
-   class Formatter;
diff --git a/ceph-init-fix.patch b/ceph-init-fix.patch
deleted file mode 100644 (file)
index b4752be..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -up ceph-0.46/src/init-ceph.in.orig ceph-0.46/src/init-ceph.in
---- ceph-0.46/src/init-ceph.in.orig    2012-04-24 16:06:39.000000000 -0400
-+++ ceph-0.46/src/init-ceph.in 2012-05-09 16:41:36.500004052 -0400
-@@ -1,11 +1,11 @@
- #!/bin/sh
- # Start/stop ceph daemons
--# chkconfig: 2345 60 80
-+# chkconfig: - 60 80
- ### BEGIN INIT INFO
- # Provides:          ceph
--# Default-Start:     2 3 4 5
--# Default-Stop:      0 1 6
-+# Default-Start:
-+# Default-Stop:
- # Required-Start:    $remote_fs $named $network $time
- # Required-Stop:     $remote_fs $named $network $time
- # Short-Description: Start Ceph distributed file system daemons at boot time
index 2a3971ef79720d008e0b39b1362de77a5157fc1b..54fae5dc9904f4c06f48c03753b642c88c60ca70 100644 (file)
@@ -1,14 +1,29 @@
---- ceph-12.2.13/cmake/modules/Distutils.cmake.orig    2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/cmake/modules/Distutils.cmake 2020-05-29 22:15:43.919231143 +0200
-@@ -17,10 +17,7 @@
+--- ceph-16.2.7/cmake/modules/Distutils.cmake~ 2021-12-07 17:15:49.000000000 +0100
++++ ceph-16.2.7/cmake/modules/Distutils.cmake  2022-02-12 11:15:17.620439748 +0100
+@@ -19,12 +19,10 @@
    install(CODE "
      set(options --prefix=${CMAKE_INSTALL_PREFIX})
      if(DEFINED ENV{DESTDIR})
 -      if(EXISTS /etc/debian_version)
 -        list(APPEND options --install-layout=deb)
+-      endif()
+       list(APPEND options
+         --root=\$ENV{DESTDIR}
+-        --single-version-externally-managed)
++        --single-version-externally-managed
++      --optimize=2)
+     endif()
+     if(NOT \"${DU_INSTALL_SCRIPT}\" STREQUAL \"\")
+       list(APPEND options --install-script=${DU_INSTALL_SCRIPT})
+@@ -109,10 +107,7 @@
+     set(options --prefix=${CMAKE_INSTALL_PREFIX})
+     if(DEFINED ENV{DESTDIR})
+-      if(EXISTS /etc/debian_version)
+-        list(APPEND options --install-layout=deb)
 -      endif()
 -      list(APPEND options --root=\$ENV{DESTDIR})
 +      list(APPEND options --root=\$ENV{DESTDIR} --optimize=2)
-       if(NOT \"${DU_INSTALL_SCRIPT}\" STREQUAL \"\")
-         list(APPEND options --install-script=${DU_INSTALL_SCRIPT})
-       endif()
+     else()
+       list(APPEND options --root=/)
+     endif()
diff --git a/ceph-rocksdb.patch b/ceph-rocksdb.patch
deleted file mode 100644 (file)
index edb5f18..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
---- ceph-12.2.13/src/kv/RocksDBStore.cc.orig   2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/kv/RocksDBStore.cc        2020-05-28 18:54:37.329337101 +0200
-@@ -522,7 +522,7 @@
-   // considering performance overhead, default is disabled
-   if (g_conf->rocksdb_perf) {
-     rocksdb::SetPerfLevel(rocksdb::PerfLevel::kEnableTimeExceptForMutex);
--    rocksdb::perf_context.Reset();
-+    rocksdb::get_perf_context()->Reset();
-   }
-   RocksDBTransactionImpl * _t =
-@@ -549,13 +549,13 @@
-     utime_t write_wal_time;
-     utime_t write_pre_and_post_process_time;
-     write_wal_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_wal_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_wal_time)/1000000000);
-     write_memtable_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_memtable_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_memtable_time)/1000000000);
-     write_delay_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_delay_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_delay_time)/1000000000);
-     write_pre_and_post_process_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_pre_and_post_process_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_pre_and_post_process_time)/1000000000);
-     logger->tinc(l_rocksdb_write_memtable_time, write_memtable_time);
-     logger->tinc(l_rocksdb_write_delay_time, write_delay_time);
-     logger->tinc(l_rocksdb_write_wal_time, write_wal_time);
-@@ -575,7 +575,7 @@
-   // considering performance overhead, default is disabled
-   if (g_conf->rocksdb_perf) {
-     rocksdb::SetPerfLevel(rocksdb::PerfLevel::kEnableTimeExceptForMutex);
--    rocksdb::perf_context.Reset();
-+    rocksdb::get_perf_context()->Reset();
-   }
-   RocksDBTransactionImpl * _t =
-@@ -603,13 +603,13 @@
-     utime_t write_wal_time;
-     utime_t write_pre_and_post_process_time;
-     write_wal_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_wal_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_wal_time)/1000000000);
-     write_memtable_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_memtable_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_memtable_time)/1000000000);
-     write_delay_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_delay_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_delay_time)/1000000000);
-     write_pre_and_post_process_time.set_from_double(
--      static_cast<double>(rocksdb::perf_context.write_pre_and_post_process_time)/1000000000);
-+      static_cast<double>(rocksdb::get_perf_context()->write_pre_and_post_process_time)/1000000000);
-     logger->tinc(l_rocksdb_write_memtable_time, write_memtable_time);
-     logger->tinc(l_rocksdb_write_delay_time, write_delay_time);
-     logger->tinc(l_rocksdb_write_wal_time, write_wal_time);
diff --git a/ceph-types.patch b/ceph-types.patch
deleted file mode 100644 (file)
index 8d0b063..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
---- ceph-12.2.13/src/osd/PrimaryLogPG.cc.orig  2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/osd/PrimaryLogPG.cc       2020-05-28 12:18:59.914600378 +0200
-@@ -1582,7 +1582,7 @@
-   if (limit != eversion_t() &&
-       limit != pg_trim_to &&
-       pg_log.get_log().approx_size() > target) {
--    size_t num_to_trim = std::min(pg_log.get_log().approx_size() - target,
-+    size_t num_to_trim = std::min(static_cast<uint64_t>(pg_log.get_log().approx_size() - target),
-                              cct->_conf->osd_pg_log_trim_max);
-     if (num_to_trim < cct->_conf->osd_pg_log_trim_min &&
-         cct->_conf->osd_pg_log_trim_max >= cct->_conf->osd_pg_log_trim_min) {
-@@ -1628,7 +1628,7 @@
-       pg_log.get_log().approx_size() > target) {
-     dout(10) << __func__ << " approx pg log length =  "
-              << pg_log.get_log().approx_size() << dendl;
--    size_t num_to_trim = std::min(pg_log.get_log().approx_size() - target,
-+    size_t num_to_trim = std::min(static_cast<uint64_t>(pg_log.get_log().approx_size() - target),
-                                 cct->_conf->osd_pg_log_trim_max);
-     dout(10) << __func__ << " num_to_trim =  " << num_to_trim << dendl;
-     if (num_to_trim < cct->_conf->osd_pg_log_trim_min &&
---- ceph-12.2.13/src/os/filestore/FileStore.h.orig     2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/os/filestore/FileStore.h  2020-06-03 14:29:43.325143770 +0200
-@@ -57,7 +57,7 @@
- #if defined(__linux__)
- # ifndef BTRFS_SUPER_MAGIC
--#define BTRFS_SUPER_MAGIC 0x9123683EL
-+#define BTRFS_SUPER_MAGIC 0x9123683EUL
- # endif
- # ifndef XFS_SUPER_MAGIC
- #define XFS_SUPER_MAGIC 0x58465342L
---- ceph-12.2.13/src/os/filestore/FileStore.cc.orig    2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/os/filestore/FileStore.cc 2020-06-03 21:27:26.387210803 +0200
-@@ -779,7 +779,7 @@
- FileStoreBackend *FileStoreBackend::create(long f_type, FileStore *fs)
- {
--  switch (f_type) {
-+  switch (static_cast<uint32_t>(f_type)) {
- #if defined(__linux__)
-   case BTRFS_SUPER_MAGIC:
-     return new BtrfsFileStoreBackend(fs);
-@@ -808,7 +808,7 @@
-         << " (magic 0x" << std::hex << f_type << std::dec << ")"
-         << dendl;
--  switch (f_type) {
-+  switch (static_cast<uint32_t>(f_type)) {
- #if defined(__linux__)
-   case BTRFS_SUPER_MAGIC:
-     if (!m_disable_wbthrottle){
-@@ -922,7 +922,7 @@
-   }
- #if defined(__linux__)
--  if (basefs.f_type == BTRFS_SUPER_MAGIC &&
-+  if (static_cast<uint32_t>(basefs.f_type) == BTRFS_SUPER_MAGIC &&
-       !g_ceph_context->check_experimental_feature_enabled("btrfs")) {
-     derr << __FUNC__ << ": deprecated btrfs support is not enabled" << dendl;
-     goto close_fsid_fd;
-@@ -1208,7 +1208,7 @@
-   blk_size = st.f_bsize;
- #if defined(__linux__)
--  if (st.f_type == BTRFS_SUPER_MAGIC &&
-+  if (static_cast<uint32_t>(st.f_type) == BTRFS_SUPER_MAGIC &&
-       !g_ceph_context->check_experimental_feature_enabled("btrfs")) {
-     derr <<__FUNC__ << ": deprecated btrfs support is not enabled" << dendl;
-     return -EPERM;
-@@ -5949,7 +5949,7 @@
-   uint32_t fs_xattrs;
-   uint32_t fs_xattr_max_value_size;
--  switch (m_fs_type) {
-+  switch (static_cast<uint32_t>(m_fs_type)) {
- #if defined(__linux__)
-   case XFS_SUPER_MAGIC:
-     fs_xattr_size = cct->_conf->filestore_max_inline_xattr_size_xfs;
diff --git a/ceph-zfs.patch b/ceph-zfs.patch
deleted file mode 100644 (file)
index 35b27b4..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- ceph-12.2.13/src/os/fs/ZFS.cc.orig 2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/os/fs/ZFS.cc      2020-05-31 17:23:41.051356069 +0200
-@@ -79,5 +79,5 @@
- int ZFS::iter_snapshots_sorted(ZFS::Handle *h, ZFS::iter_func f, void *d)
- {
--  return ::zfs_iter_snapshots_sorted((zfs_handle_t*)h, (zfs_iter_f)f, d);
-+  return ::zfs_iter_snapshots_sorted((zfs_handle_t*)h, (zfs_iter_f)f, d, 0, 0);
- }
---- ceph-12.2.13/src/test/filestore/TestFileStore.cc.orig      2020-01-30 21:52:36.000000000 +0100
-+++ ceph-12.2.13/src/test/filestore/TestFileStore.cc   2020-05-31 21:49:43.249209757 +0200
-@@ -56,7 +56,7 @@
- #ifdef HAVE_LIBZFS
-   {
-     map<string,string> pm;
--    FileStore fs("a", "b");
-+    FileStore fs(g_ceph_context, "a", "b");
-     TestFileStore::create_backend(fs, ZFS_SUPER_MAGIC);
-     fs.collect_metadata(&pm);
-     ASSERT_EQ(pm["filestore_backend"], "zfs");
index 68832d48672c3f27cd218903ef0757d40f9d8bee..987e7321d211dbef0cd2fc0c92808cc652b9a745 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -42,16 +42,12 @@ Source0:    http://download.ceph.com/tarballs/%{name}-%{version}.tar.gz
 # Source0-md5: 3cb3d259e59920b0d7145537f338aeec
 Source1:       ceph.sysconfig
 Source3:       ceph.tmpfiles
-Patch0:                %{name}-init-fix.patch
-Patch3:                %{name}-python.patch
-Patch4:                %{name}-types.patch
-Patch5:                %{name}-tcmalloc.patch
-Patch6:                %{name}-rocksdb.patch
-Patch7:                %{name}-fcgi.patch
-Patch8:                %{name}-fio.patch
-Patch9:                %{name}-zfs.patch
-Patch10:       %{name}-includes.patch
-Patch11:       string-includes.patch
+Patch0:                %{name}-python.patch
+Patch1:                %{name}-tcmalloc.patch
+Patch2:                %{name}-fcgi.patch
+Patch3:                string-includes.patch
+Patch4:                no-virtualenvs.patch
+Patch5:                system-zstd.patch
 URL:           https://ceph.io/
 %{?with_accelio:BuildRequires: accelio-devel}
 %{?with_babeltrace:BuildRequires:      babeltrace-devel}
@@ -101,23 +97,19 @@ BuildRequires:     pkgconfig
 %{?with_pmem:BuildRequires:    pmdk-devel}
 BuildRequires: python3 >= 1:2.7
 BuildRequires: python3-devel >= 1:2.7
+BuildRequires: python3-tox >= 2.9.1
 BuildRequires: python3-Cython
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-Cython
-# upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
 %{?with_system_rocksdb:BuildRequires:  rocksdb-devel >= 5.6.0}
 BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: sed >= 4.0
 BuildRequires: snappy-devel
-BuildRequires: sphinx-pdg-2 >= 1.0
+BuildRequires: sphinx-pdg >= 3.0
 BuildRequires: udev-devel
-#BuildRequires:        virtualenv  for tests
 %{?with_dpdk:BuildRequires:    xorg-lib-libpciaccess-devel}
 BuildRequires: xfsprogs-devel
 %ifarch %{x8664}
 BuildRequires: yasm
 %endif
-# zfs patch updates to 0.8.0 API
 %{?with_zfs:BuildRequires:     zfs-devel >= 0.8.0}
 BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
@@ -276,15 +268,11 @@ uruchamiania demonów.
 %prep
 %setup -q
 %patch0 -p1
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
-#%patch6 -p1
-%patch7 -p1
-#%patch8 -p1
-#%patch9 -p1
-#%patch10 -p1
-%patch11 -p1
+#patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 #%{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
 #      src/{ceph-create-keys,ceph-rest-api,mount.fuse.ceph} \
@@ -299,7 +287,7 @@ cd build
        -DFIO_INCLUDE_DIR=/usr/include/fio \
        -DWITH_PYTHON3=%{py3_ver} \
        -DPYTHON=%{__python3} \
-       -DSPHINX_BUILD=/usr/bin/sphinx-build-2 \
+       -DSPHINX_BUILD=/usr/bin/sphinx-build \
        %{!?with_babeltrace:-DWITH_BABELTRACE=OFF} \
        %{?with_java:-DWITH_CEPHFS_JAVA=ON} \
        %{?with_java:-DJAVA_JVM_LIBRARY:PATH=%{_jvmdir}/java/lib/server/libjvm.so} \
@@ -312,6 +300,7 @@ cd build
        -DWITH_OCF=ON \
        %{?with_pmem:-DWITH_PMEM=ON} \
        %{?with_fcgi:-DWITH_RADOSGW_FCGI_FRONTEND=ON} \
+       -DWITH_MGR_DASHBOARD_FRONTEND=OFF \
        %{?with_spdk:-DWITH_SPDK=ON} \
        -DWITH_SYSTEM_BOOST=ON \
        %{?with_system_rocksdb:-DWITH_SYSTEM_ROCKSDB=ON} \
@@ -321,7 +310,7 @@ cd build
        -DWITH_REENTRANT_STRSIGNAL=ON \
        %{!?with_tests:-DWITH_TESTS=OFF}
 
-%{__make} -k
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
diff --git a/no-virtualenvs.patch b/no-virtualenvs.patch
new file mode 100644 (file)
index 0000000..977a3ab
--- /dev/null
@@ -0,0 +1,74 @@
+diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
+index d26d003c779..bc962e3aa73 100644
+--- a/cmake/modules/AddCephTest.cmake
++++ b/cmake/modules/AddCephTest.cmake
+@@ -70,14 +70,6 @@ function(add_tox_test name)
+   endif()
+   string(REPLACE ";" "," tox_envs "${tox_envs}")
+   find_package(Python3 QUIET REQUIRED)
+-  add_custom_command(
+-    OUTPUT ${venv_path}/bin/activate
+-    COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python="${Python3_EXECUTABLE}" ${venv_path}
+-    WORKING_DIRECTORY ${tox_path}
+-    COMMENT "preparing venv for ${name}")
+-  add_custom_target(${name}-venv
+-    DEPENDS ${venv_path}/bin/activate)
+-  add_dependencies(tests ${name}-venv)
+   add_test(
+     NAME ${test_name}
+     COMMAND ${CMAKE_SOURCE_DIR}/src/script/run_tox.sh
+diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
+index 9166553dc73..9a6c87595b9 100644
+--- a/src/ceph-volume/CMakeLists.txt
++++ b/src/ceph-volume/CMakeLists.txt
+@@ -8,22 +8,6 @@ if(FREEBSD)
+   add_subdirectory(plugin/zfs)
+ endif()
+-# Required for running ceph-volume inventory in a vstart environment
+-set(CEPH_VOLUME_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-volume-virtualenv)
+-
+-add_custom_command(
+-  OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
+-  COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
+-  WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+-  COMMENT "ceph-volume venv is being created")
+-
+-add_custom_command(
+-  OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume
+-  DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/python
+-  COMMAND . ${CEPH_VOLUME_VIRTUALENV}/bin/activate && ${CEPH_VOLUME_VIRTUALENV}/bin/python setup.py develop && deactivate
+-  WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+-  COMMENT "${CMAKE_SOURCE_DIR}/src/ceph-volume")
+-
+ add_custom_target(ceph-volume-venv-setup
+   DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
+diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
+index 9b3432213a0..973b185f5de 100644
+--- a/src/pybind/mgr/dashboard/CMakeLists.txt
++++ b/src/pybind/mgr/dashboard/CMakeLists.txt
+@@ -5,9 +5,6 @@ function(add_npm_command)
+   set(multi_kw COMMAND DEPENDS)
+   cmake_parse_arguments(NC "${options}" "${single_kw}" "${multi_kw}" ${ARGN})
+   string(REPLACE ";" " " command "${NC_COMMAND}")
+-  if(NC_NODEENV)
+-    string(REGEX REPLACE "^(.*(npm|npx) .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
+-  endif()
+   string(REPLACE " " ";" command "${command}")
+   add_custom_command(
+     OUTPUT "${NC_OUTPUT}"
+@@ -51,11 +48,8 @@ else(WITH_SYSTEM_NPM)
+     set(node_mirror_opt "--mirror=$ENV{NODE_MIRROR}")
+   endif()
+   add_custom_command(
+-    OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
+-    COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
+-    COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
+-    COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv --verbose ${node_mirror_opt} -p --node=12.18.2
+-    COMMAND mkdir ${mgr-dashboard-nodeenv-dir}/.npm
++    OUTPUT "/bin/npm"
++    COMMAND /bin/nodeenv ${node_mirror_opt} -p --node=12.18.2
+     WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+     COMMENT "dashboard nodeenv is being installed"
+     )
diff --git a/system-zstd.patch b/system-zstd.patch
new file mode 100644 (file)
index 0000000..c50cca4
--- /dev/null
@@ -0,0 +1,40 @@
+diff --git a/src/compressor/zstd/CMakeLists.txt b/src/compressor/zstd/CMakeLists.txt
+index b53b0d9444..5bf5796da2 100644
+--- a/src/compressor/zstd/CMakeLists.txt
++++ b/src/compressor/zstd/CMakeLists.txt
+@@ -1,34 +1,11 @@
+ # zstd
+-# libzstd - build it statically
+-set(ZSTD_C_FLAGS "-fPIC -Wno-unused-variable -O3")
+-
+-include(ExternalProject)
+-ExternalProject_Add(zstd_ext
+-  SOURCE_DIR ${CMAKE_SOURCE_DIR}/src/zstd/build/cmake
+-  CMAKE_ARGS -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
+-             -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
+-             -DCMAKE_C_FLAGS=${ZSTD_C_FLAGS}
+-             -DCMAKE_AR=${CMAKE_AR}
+-             -DCMAKE_POSITION_INDEPENDENT_CODE=${ENABLE_SHARED}
+-             -G${CMAKE_GENERATOR}
+-  BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/libzstd
+-  BUILD_COMMAND ${CMAKE_COMMAND} --build <BINARY_DIR> --target libzstd_static
+-  BUILD_BYPRODUCTS "${CMAKE_CURRENT_BINARY_DIR}/libzstd/lib/libzstd.a"
+-  INSTALL_COMMAND "true")
+-
+-add_library(zstd STATIC IMPORTED)
+-set_target_properties(zstd PROPERTIES
+-  INTERFACE_INCLUDE_DIRECTORIES "${CMAKE_SOURCE_DIR}/src/zstd/lib"
+-  IMPORTED_LOCATION "${CMAKE_CURRENT_BINARY_DIR}/libzstd/lib/libzstd.a")
+-add_dependencies(zstd zstd_ext)
+-
+ set(zstd_sources
+   CompressionPluginZstd.cc
+ )
+ add_library(ceph_zstd SHARED ${zstd_sources})
+-target_link_libraries(ceph_zstd PRIVATE zstd $<$<PLATFORM_ID:Windows>:ceph-common>)
++target_link_libraries(ceph_zstd zstd)
+ set_target_properties(ceph_zstd PROPERTIES
+   VERSION 2.0.0
+   SOVERSION 2
This page took 0.27499 seconds and 4 git commands to generate.