]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- enhanced zfs patch, added includes patch (more build fixes)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 31 May 2020 19:58:46 +0000 (21:58 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 31 May 2020 19:58:46 +0000 (21:58 +0200)
ceph-includes.patch [new file with mode: 0644]
ceph-zfs.patch
ceph.spec

diff --git a/ceph-includes.patch b/ceph-includes.patch
new file mode 100644 (file)
index 0000000..1c10a3b
--- /dev/null
@@ -0,0 +1,12 @@
+--- ../BUILD/ceph-12.2.13/src/common/bit_str.h.orig    2020-01-30 21:52:36.000000000 +0100
++++ ../BUILD/ceph-12.2.13/src/common/bit_str.h 2020-05-31 19:08:32.698492649 +0200
+@@ -14,7 +14,9 @@
+ #ifndef CEPH_COMMON_BIT_STR_H
+ #define CEPH_COMMON_BIT_STR_H
++#include <cstdint>
+ #include <functional>
++#include <ostream>
+ namespace ceph {
+   class Formatter;
index fb8ef3fa820002b5d1b1bd1287489a08fe71074c..35b27b412410ff56f7e0d019c4471f6955d835fa 100644 (file)
@@ -7,3 +7,14 @@
 -  return ::zfs_iter_snapshots_sorted((zfs_handle_t*)h, (zfs_iter_f)f, d);
 +  return ::zfs_iter_snapshots_sorted((zfs_handle_t*)h, (zfs_iter_f)f, d, 0, 0);
  }
+--- ceph-12.2.13/src/test/filestore/TestFileStore.cc.orig      2020-01-30 21:52:36.000000000 +0100
++++ ceph-12.2.13/src/test/filestore/TestFileStore.cc   2020-05-31 21:49:43.249209757 +0200
+@@ -56,7 +56,7 @@
+ #ifdef HAVE_LIBZFS
+   {
+     map<string,string> pm;
+-    FileStore fs("a", "b");
++    FileStore fs(g_ceph_context, "a", "b");
+     TestFileStore::create_backend(fs, ZFS_SUPER_MAGIC);
+     fs.collect_metadata(&pm);
+     ASSERT_EQ(pm["filestore_backend"], "zfs");
index 9cb792600735623461246115129a85355cee555c..6081c51b3e9328b9ab601daaad60a20e92efb151 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -52,6 +52,7 @@ Patch6:               %{name}-rocksdb.patch
 Patch7:                %{name}-fcgi.patch
 Patch8:                %{name}-fio.patch
 Patch9:                %{name}-zfs.patch
+Patch10:       %{name}-includes.patch
 URL:           https://ceph.io/
 %{?with_accelio:BuildRequires: accelio-devel}
 %{?with_babeltrace:BuildRequires:      babeltrace-devel}
@@ -279,6 +280,7 @@ uruchamiania demonów.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
        src/{ceph-create-keys,ceph-rest-api,mount.fuse.ceph} \
This page took 0.248617 seconds and 4 git commands to generate.