]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- enhanced types patch wrt. unsigned 32-bit constant
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 4 Jun 2020 04:28:48 +0000 (06:28 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 4 Jun 2020 04:28:48 +0000 (06:28 +0200)
- fixed files, BR: python3-Cython

ceph-types.patch
ceph.spec

index 8b55026410592e7f6f437de23a2c2194898a9f58..8d0b063ee92509b03caa5120b5da7d1281f019ab 100644 (file)
                                  cct->_conf->osd_pg_log_trim_max);
      dout(10) << __func__ << " num_to_trim =  " << num_to_trim << dendl;
      if (num_to_trim < cct->_conf->osd_pg_log_trim_min &&
                                  cct->_conf->osd_pg_log_trim_max);
      dout(10) << __func__ << " num_to_trim =  " << num_to_trim << dendl;
      if (num_to_trim < cct->_conf->osd_pg_log_trim_min &&
+--- ceph-12.2.13/src/os/filestore/FileStore.h.orig     2020-01-30 21:52:36.000000000 +0100
++++ ceph-12.2.13/src/os/filestore/FileStore.h  2020-06-03 14:29:43.325143770 +0200
+@@ -57,7 +57,7 @@
+ #if defined(__linux__)
+ # ifndef BTRFS_SUPER_MAGIC
+-#define BTRFS_SUPER_MAGIC 0x9123683EL
++#define BTRFS_SUPER_MAGIC 0x9123683EUL
+ # endif
+ # ifndef XFS_SUPER_MAGIC
+ #define XFS_SUPER_MAGIC 0x58465342L
+--- ceph-12.2.13/src/os/filestore/FileStore.cc.orig    2020-01-30 21:52:36.000000000 +0100
++++ ceph-12.2.13/src/os/filestore/FileStore.cc 2020-06-03 21:27:26.387210803 +0200
+@@ -779,7 +779,7 @@
+ FileStoreBackend *FileStoreBackend::create(long f_type, FileStore *fs)
+ {
+-  switch (f_type) {
++  switch (static_cast<uint32_t>(f_type)) {
+ #if defined(__linux__)
+   case BTRFS_SUPER_MAGIC:
+     return new BtrfsFileStoreBackend(fs);
+@@ -808,7 +808,7 @@
+         << " (magic 0x" << std::hex << f_type << std::dec << ")"
+         << dendl;
+-  switch (f_type) {
++  switch (static_cast<uint32_t>(f_type)) {
+ #if defined(__linux__)
+   case BTRFS_SUPER_MAGIC:
+     if (!m_disable_wbthrottle){
+@@ -922,7 +922,7 @@
+   }
+ #if defined(__linux__)
+-  if (basefs.f_type == BTRFS_SUPER_MAGIC &&
++  if (static_cast<uint32_t>(basefs.f_type) == BTRFS_SUPER_MAGIC &&
+       !g_ceph_context->check_experimental_feature_enabled("btrfs")) {
+     derr << __FUNC__ << ": deprecated btrfs support is not enabled" << dendl;
+     goto close_fsid_fd;
+@@ -1208,7 +1208,7 @@
+   blk_size = st.f_bsize;
+ #if defined(__linux__)
+-  if (st.f_type == BTRFS_SUPER_MAGIC &&
++  if (static_cast<uint32_t>(st.f_type) == BTRFS_SUPER_MAGIC &&
+       !g_ceph_context->check_experimental_feature_enabled("btrfs")) {
+     derr <<__FUNC__ << ": deprecated btrfs support is not enabled" << dendl;
+     return -EPERM;
+@@ -5949,7 +5949,7 @@
+   uint32_t fs_xattrs;
+   uint32_t fs_xattr_max_value_size;
+-  switch (m_fs_type) {
++  switch (static_cast<uint32_t>(m_fs_type)) {
+ #if defined(__linux__)
+   case XFS_SUPER_MAGIC:
+     fs_xattr_size = cct->_conf->filestore_max_inline_xattr_size_xfs;
index 931498df0ab8a58364b3ed8e2073e12dc22b3469..173d32bf82d3e3f9a5d80aedd5256dd6c32ea0fe 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -99,6 +99,7 @@ BuildRequires:        python >= 1:2.7
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-Cython
 BuildRequires: python3-devel >= 1:3.2
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-Cython
 BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-Cython
 # upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
 %{?with_system_rocksdb:BuildRequires:  rocksdb-devel >= 5.6.0}
 BuildRequires: rpmbuild(macros) >= 1.671
 # upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
 %{?with_system_rocksdb:BuildRequires:  rocksdb-devel >= 5.6.0}
 BuildRequires: rpmbuild(macros) >= 1.671
@@ -475,9 +476,9 @@ fi
 %if "%{_libexecdir}" != "%{_libdir}"
 %dir %{_libexecdir}/ceph
 %endif
 %if "%{_libexecdir}" != "%{_libdir}"
 %dir %{_libexecdir}/ceph
 %endif
-%attr(755,root,root) %{_libexecdir}/ceph/ceph-monstore-update-crush.sh
+%{_libexecdir}/ceph/ceph_common.sh
 %attr(755,root,root) %{_libexecdir}/ceph/ceph-osd-prestart.sh
 %attr(755,root,root) %{_libexecdir}/ceph/ceph-osd-prestart.sh
-%{_libdir}/ceph/ceph_common.sh
+%attr(755,root,root) %{_libdir}/ceph/ceph-monstore-update-crush.sh
 %{_libdir}/ceph/mgr
 %dir %{_libdir}/ceph/compressor
 %attr(755,root,root) %{_libdir}/ceph/compressor/libceph_lz4.so*
 %{_libdir}/ceph/mgr
 %dir %{_libdir}/ceph/compressor
 %attr(755,root,root) %{_libdir}/ceph/compressor/libceph_lz4.so*
This page took 0.188344 seconds and 4 git commands to generate.