]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- updated to 0.87 auto/th/ceph-0.87-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 20 Oct 2014 18:36:28 +0000 (20:36 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 20 Oct 2014 18:36:28 +0000 (20:36 +0200)
- added boost patch (fixes build with boost 1.56)

ceph-boost.patch [new file with mode: 0644]
ceph.spec

diff --git a/ceph-boost.patch b/ceph-boost.patch
new file mode 100644 (file)
index 0000000..d87ff2d
--- /dev/null
@@ -0,0 +1,25 @@
+--- ceph-0.87/src/osd/ECBackend.cc.orig        2014-10-14 14:22:35.000000000 +0200
++++ ceph-0.87/src/osd/ECBackend.cc     2014-10-19 20:21:00.537672741 +0200
+@@ -81,7 +81,7 @@
+   lhs << "read_result_t(r=" << rhs.r
+       << ", errors=" << rhs.errors;
+   if (rhs.attrs) {
+-    lhs << ", attrs=" << rhs.attrs;
++    lhs << ", attrs=" << rhs.attrs.get();
+   } else {
+     lhs << ", noattrs";
+   }
+--- ceph-0.87/src/osd/ReplicatedPG.cc.orig     2014-10-14 14:22:35.000000000 +0200
++++ ceph-0.87/src/osd/ReplicatedPG.cc  2014-10-19 20:23:41.797665908 +0200
+@@ -5271,7 +5271,10 @@
+   for (list<OpContext::NotifyAck>::iterator p = ctx->notify_acks.begin();
+        p != ctx->notify_acks.end();
+        ++p) {
+-    dout(10) << "notify_ack " << make_pair(p->watch_cookie, p->notify_id) << dendl;
++    if (p->watch_cookie)
++    dout(10) << "notify_ack " << make_pair(p->watch_cookie.get(), p->notify_id) << dendl;
++    else
++    dout(10) << "notify_ack " << make_pair("NULL", p->notify_id) << dendl;
+     for (map<pair<uint64_t, entity_name_t>, WatchRef>::iterator i =
+          ctx->obc->watchers.begin();
+        i != ctx->obc->watchers.end();
index f4f723be99ae991c4f11c95c2e4918ae553d1297..aa39b3d4d7d9990a3726eee1917bd0d266bf7087 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -1,23 +1,26 @@
-# TODO: --with-kinetic?
 #
 # Conditional build:
 %bcond_without java    # Java binding
+%bcond_with    kinetic # Kinetic storage support [needs update for internal API changes]
+%bcond_with    rocksdb # RocksDB storage support [needs update for internal API changes]
 %bcond_with    zfs     # ZFS support
 #
 Summary:       User space components of the Ceph file system
 Summary(pl.UTF-8):     Działające w przestrzeni użytkownika elementy systemu plików Ceph
 Name:          ceph
-Version:       0.84
+Version:       0.87
 Release:       1
 License:       LGPL v2.1 (libraries), GPL v2 (some programs)
 Group:         Base
 Source0:       http://ceph.com/download/%{name}-%{version}.tar.bz2
-# Source0-md5: c7d8c8483cf1cef4dfb529500ed7ea93
+# Source0-md5: 172d232cbf4fdf760933265ddcbce5eb
 Patch0:                %{name}-init-fix.patch
 Patch1:                %{name}.logrotate.patch
+Patch2:                %{name}-boost.patch
 URL:           http://ceph.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
+BuildRequires: babeltrace-devel
 BuildRequires: boost-devel >= 1.34
 BuildRequires: cryptopp-devel
 BuildRequires: curl-devel
@@ -28,6 +31,7 @@ BuildRequires:        gdbm-devel
 BuildRequires: jdk
 %endif
 BuildRequires: keyutils-devel
+%{?with_kinetic:BuildRequires: kinetic-cpp-client}
 BuildRequires: leveldb-devel >= 1.2
 BuildRequires: libaio-devel
 BuildRequires: libatomic_ops
@@ -43,6 +47,7 @@ BuildRequires:        libuuid-devel
 BuildRequires: perl-base
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.4
+%{?with_rocksdb:BuildRequires: rocksdb-devel}
 BuildRequires: rpmbuild(macros) >= 1.228
 BuildRequires: snappy-devel
 BuildRequires: udev-devel
@@ -181,6 +186,7 @@ Agenci OCF do monitorowania procesów Cepha.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -196,6 +202,8 @@ Agenci OCF do monitorowania procesów Cepha.
        ac_cv_prog_uudecode_base64=no \
        --sbindir=/sbin \
        --with-cryptopp \
+       %{?with_kinetic:--with-kinetic} \
+       %{?with_rocksdb:--with-librocksdb} \
        %{?with_zfs:--with-libzfs} \
        --with-ocf \
        --with-radosgw \
@@ -272,8 +280,7 @@ fi
 %attr(755,root,root) %{_bindir}/ceph-rest-api
 %attr(755,root,root) %{_bindir}/ceph-run
 %attr(755,root,root) %{_bindir}/ceph-syn
-%attr(755,root,root) %{_bindir}/ceph_filestore_dump
-%attr(755,root,root) %{_bindir}/ceph_filestore_tool
+%attr(755,root,root) %{_bindir}/ceph_objectstore_tool
 %attr(755,root,root) %{_bindir}/ceph_mon_store_converter
 %attr(755,root,root) %{_bindir}/cephfs
 %attr(755,root,root) %{_bindir}/cephfs-journal-tool
@@ -284,6 +291,8 @@ fi
 %attr(755,root,root) %{_bindir}/rados
 %attr(755,root,root) %{_bindir}/rbd
 %attr(755,root,root) %{_bindir}/rbd-fuse
+%attr(755,root,root) %{_bindir}/rbd-replay
+%attr(755,root,root) %{_bindir}/rbd-replay-prep
 %attr(755,root,root) /sbin/ceph-create-keys
 %attr(755,root,root) /sbin/ceph-disk
 %attr(755,root,root) /sbin/ceph-disk-activate
@@ -303,7 +312,9 @@ fi
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_generic.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse3.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse4.so*
+%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_lrc.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_entry_point.so*
+%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_version.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_generic.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse3.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse4.so*
@@ -349,6 +360,8 @@ fi
 %{_mandir}/man8/radosgw-admin.8*
 %{_mandir}/man8/rbd.8*
 %{_mandir}/man8/rbd-fuse.8*
+%{_mandir}/man8/rbd-replay.8*
+%{_mandir}/man8/rbd-replay-prep.8*
 
 %dir %{_localstatedir}/lib/ceph
 %dir %{_localstatedir}/lib/ceph/tmp
This page took 0.15108 seconds and 4 git commands to generate.