]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- updated to 0.92
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 10 Feb 2015 15:02:20 +0000 (16:02 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 10 Feb 2015 15:02:20 +0000 (16:02 +0100)
- removed obsolete boost patch
- added link patch (fixes libradosstripper linking)

ceph-boost.patch [deleted file]
ceph-link.patch [new file with mode: 0644]
ceph.spec

diff --git a/ceph-boost.patch b/ceph-boost.patch
deleted file mode 100644 (file)
index d87ff2d..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- ceph-0.87/src/osd/ECBackend.cc.orig        2014-10-14 14:22:35.000000000 +0200
-+++ ceph-0.87/src/osd/ECBackend.cc     2014-10-19 20:21:00.537672741 +0200
-@@ -81,7 +81,7 @@
-   lhs << "read_result_t(r=" << rhs.r
-       << ", errors=" << rhs.errors;
-   if (rhs.attrs) {
--    lhs << ", attrs=" << rhs.attrs;
-+    lhs << ", attrs=" << rhs.attrs.get();
-   } else {
-     lhs << ", noattrs";
-   }
---- ceph-0.87/src/osd/ReplicatedPG.cc.orig     2014-10-14 14:22:35.000000000 +0200
-+++ ceph-0.87/src/osd/ReplicatedPG.cc  2014-10-19 20:23:41.797665908 +0200
-@@ -5271,7 +5271,10 @@
-   for (list<OpContext::NotifyAck>::iterator p = ctx->notify_acks.begin();
-        p != ctx->notify_acks.end();
-        ++p) {
--    dout(10) << "notify_ack " << make_pair(p->watch_cookie, p->notify_id) << dendl;
-+    if (p->watch_cookie)
-+    dout(10) << "notify_ack " << make_pair(p->watch_cookie.get(), p->notify_id) << dendl;
-+    else
-+    dout(10) << "notify_ack " << make_pair("NULL", p->notify_id) << dendl;
-     for (map<pair<uint64_t, entity_name_t>, WatchRef>::iterator i =
-          ctx->obc->watchers.begin();
-        i != ctx->obc->watchers.end();
diff --git a/ceph-link.patch b/ceph-link.patch
new file mode 100644 (file)
index 0000000..948fb63
--- /dev/null
@@ -0,0 +1,11 @@
+--- ceph-0.92/src/libradosstriper/Makefile.am.orig     2015-02-02 22:32:32.000000000 +0100
++++ ceph-0.92/src/libradosstriper/Makefile.am  2015-02-07 18:25:15.007810402 +0100
+@@ -6,7 +6,7 @@
+ # We need this to avoid basename conflicts with the libradosstriper build tests in test/Makefile.am
+ libradosstriper_la_CXXFLAGS = ${AM_CXXFLAGS}
+-LIBRADOSSTRIPER_DEPS = $(LIBRADOS_DEPS)
++LIBRADOSSTRIPER_DEPS = $(top_builddir)/src/librados.la $(LIBRADOS_DEPS)
+ libradosstriper_la_LIBADD = $(LIBRADOSSTRIPER_DEPS)
+ libradosstriper_la_LDFLAGS = ${AM_LDFLAGS} -version-info 1:0:0
+ if LINUX
index 1b9911af0abaf9d5cf03bd28b2b0da89658b262e..310e86eb63c3e114098168177c20b36f7a9fd511 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -1,10 +1,12 @@
 #
 # Conditional build:
-%bcond_without java    # Java binding
-%bcond_with    kinetic # Kinetic storage support [needs update for internal API changes]
-%bcond_with    rocksdb # RocksDB storage support [needs update for internal API changes]
-%bcond_with    zfs     # ZFS support
-%bcond_without tcmalloc        # don't use tcmalloc
+%bcond_without java            # Java binding
+%bcond_with    kinetic         # Kinetic storage support [needs update for internal API changes]
+%bcond_with    rocksdb         # RocksDB storage support [needs update for internal API changes]
+%bcond_with    zfs             # ZFS support
+%bcond_without lttng           # LTTng tracing
+%bcond_without babeltrace      # Babeltrace traces support
+%bcond_without tcmalloc        # tcmalloc allocator
 
 %ifarch x32
 %undefine      with_tcmalloc
 Summary:       User space components of the Ceph file system
 Summary(pl.UTF-8):     Działające w przestrzeni użytkownika elementy systemu plików Ceph
 Name:          ceph
-Version:       0.87
-Release:       3
+Version:       0.92
+Release:       1
 License:       LGPL v2.1 (libraries), GPL v2 (some programs)
 Group:         Base
 Source0:       http://ceph.com/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 172d232cbf4fdf760933265ddcbce5eb
+# Source0-md5: e8385508ee9a54f1cf56c1bcc1ec2b77
 Patch0:                %{name}-init-fix.patch
 Patch1:                %{name}.logrotate.patch
-Patch2:                %{name}-boost.patch
+Patch2:                %{name}-link.patch
 URL:           http://ceph.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
-BuildRequires: babeltrace-devel
+%{?with_babeltrace:BuildRequires:      babeltrace-devel}
 BuildRequires: boost-devel >= 1.34
 BuildRequires: curl-devel
 BuildRequires: expat-devel >= 1.95
@@ -48,6 +50,7 @@ BuildRequires:        libstdc++-devel
 %{?with_tcmalloc:BuildRequires:        libtcmalloc-devel}
 BuildRequires: libtool >= 2:1.5
 BuildRequires: libuuid-devel
+%{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: nss-devel
 BuildRequires: perl-base
 BuildRequires: pkgconfig
@@ -206,12 +209,14 @@ Agenci OCF do monitorowania procesów Cepha.
        %{?with_zfs:LIBZFS_CFLAGS="-I/usr/include/libzfs -I/usr/include/libspl"} \
        ac_cv_prog_uudecode_base64=no \
        --sbindir=/sbin \
+       %{!?with_babeltrace:--without-babeltrace} \
        --without-cryptopp \
        --with-nss \
        %{!?with_tcmalloc:--without-tcmalloc} \
        %{?with_kinetic:--with-kinetic} \
        %{?with_rocksdb:--with-librocksdb} \
        %{?with_zfs:--with-libzfs} \
+       %{!?with_lttng:--without-lttng} \
        --with-ocf \
        --with-radosgw \
        --with-system-leveldb \
@@ -281,13 +286,13 @@ fi
 %attr(755,root,root) %{_bindir}/ceph-dencoder
 %attr(755,root,root) %{_bindir}/ceph-mds
 %attr(755,root,root) %{_bindir}/ceph-mon
+%attr(755,root,root) %{_bindir}/ceph-objectstore-tool
 %attr(755,root,root) %{_bindir}/ceph-osd
 %attr(755,root,root) %{_bindir}/ceph-post-file
 %attr(755,root,root) %{_bindir}/ceph-rbdnamer
 %attr(755,root,root) %{_bindir}/ceph-rest-api
 %attr(755,root,root) %{_bindir}/ceph-run
 %attr(755,root,root) %{_bindir}/ceph-syn
-%attr(755,root,root) %{_bindir}/ceph_objectstore_tool
 %attr(755,root,root) %{_bindir}/ceph_mon_store_converter
 %attr(755,root,root) %{_bindir}/cephfs
 %attr(755,root,root) %{_bindir}/cephfs-journal-tool
@@ -299,6 +304,7 @@ fi
 %attr(755,root,root) %{_bindir}/rbd
 %attr(755,root,root) %{_bindir}/rbd-fuse
 %attr(755,root,root) %{_bindir}/rbd-replay
+%attr(755,root,root) %{_bindir}/rbd-replay-many
 %attr(755,root,root) %{_bindir}/rbd-replay-prep
 %attr(755,root,root) /sbin/ceph-create-keys
 %attr(755,root,root) /sbin/ceph-disk
@@ -320,12 +326,20 @@ fi
 %endif
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_generic.so*
+%ifarch arm
+%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_neon.so*
+%endif
+%ifarch %{ix86} %{x8664} x32
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse3.so*
+%endif
+%ifarch %{x8664} x32
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse4.so*
+%endif
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_lrc.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_entry_point.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_version.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_generic.so*
+%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_neon.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse3.so*
 %attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse4.so*
 %dir %{_libdir}/rados-classes
@@ -351,6 +365,8 @@ fi
 %{_mandir}/man8/ceph-conf.8*
 %{_mandir}/man8/ceph-debugpack.8*
 %{_mandir}/man8/ceph-dencoder.8*
+%{_mandir}/man8/ceph-deploy.8*
+%{_mandir}/man8/ceph-disk.8*
 %{_mandir}/man8/ceph-mds.8*
 %{_mandir}/man8/ceph-mon.8*
 %{_mandir}/man8/ceph-osd.8*
@@ -371,6 +387,7 @@ fi
 %{_mandir}/man8/rbd.8*
 %{_mandir}/man8/rbd-fuse.8*
 %{_mandir}/man8/rbd-replay.8*
+%{_mandir}/man8/rbd-replay-many.8*
 %{_mandir}/man8/rbd-replay-prep.8*
 
 %dir %{_localstatedir}/lib/ceph
This page took 0.045485 seconds and 4 git commands to generate.