]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- added zfs patch (adjust for zfs 0.8.0 API change)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 31 May 2020 16:02:15 +0000 (18:02 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 31 May 2020 16:02:15 +0000 (18:02 +0200)
ceph-zfs.patch [new file with mode: 0644]
ceph.spec

diff --git a/ceph-zfs.patch b/ceph-zfs.patch
new file mode 100644 (file)
index 0000000..fb8ef3f
--- /dev/null
@@ -0,0 +1,9 @@
+--- ceph-12.2.13/src/os/fs/ZFS.cc.orig 2020-01-30 21:52:36.000000000 +0100
++++ ceph-12.2.13/src/os/fs/ZFS.cc      2020-05-31 17:23:41.051356069 +0200
+@@ -79,5 +79,5 @@
+ int ZFS::iter_snapshots_sorted(ZFS::Handle *h, ZFS::iter_func f, void *d)
+ {
+-  return ::zfs_iter_snapshots_sorted((zfs_handle_t*)h, (zfs_iter_f)f, d);
++  return ::zfs_iter_snapshots_sorted((zfs_handle_t*)h, (zfs_iter_f)f, d, 0, 0);
+ }
index 8bd105bd8642a5ebb6b1819caf8e8839ca99feb8..682681acf6a90be39399e20157ca758bb5814bff 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -51,6 +51,7 @@ Patch5:               %{name}-tcmalloc.patch
 Patch6:                %{name}-rocksdb.patch
 Patch7:                %{name}-fcgi.patch
 Patch8:                %{name}-fio.patch
+Patch9:                %{name}-zfs.patch
 URL:           https://ceph.io/
 %{?with_accelio:BuildRequires: accelio-devel}
 %{?with_babeltrace:BuildRequires:      babeltrace-devel}
@@ -96,7 +97,8 @@ BuildRequires:        python >= 1:2.7
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-Cython
 BuildRequires: python3-devel >= 1:3.2
-%{?with_rocksdb:BuildRequires: rocksdb-devel >= 3.0.0}
+# upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
+%{?with_system_rocksdb:BuildRequires:  rocksdb-devel >= 5.6.0}
 BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: sed >= 4.0
 BuildRequires: snappy-devel
@@ -108,7 +110,8 @@ BuildRequires:      xfsprogs-devel
 %ifarch %{x8664}
 BuildRequires: yasm
 %endif
-%{?with_zfs:BuildRequires:     zfs-devel}
+# zfs patch updates to 0.8.0 API
+%{?with_zfs:BuildRequires:     zfs-devel >= 0.8.0}
 BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(preun):       rc-scripts
@@ -250,7 +253,9 @@ Summary:    FIO engine module for Ceph ObjectStore
 Summary(pl.UTF-8):     Moduł silnika FIO do używania Ceph ObjectStore
 Group:         Libraries
 Requires:      %{name}-libs = %{version}-%{release}
+%if %{with fio}
 %requires_ge_to        fio fio-devel
+%endif
 
 %description -n fio-ceph-objectstore
 This FIO engine allows you to mount and use a ceph object store
@@ -272,6 +277,7 @@ uruchamiania demonów.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
        src/{ceph-create-keys,ceph-rest-api,mount.fuse.ceph} \
This page took 0.208439 seconds and 4 git commands to generate.