]> git.pld-linux.org Git - packages/ceph.git/blob - ceph.spec
- use system leveldb and libs3 (the latter only for rest-bench, which is not installe...
[packages/ceph.git] / ceph.spec
1 #
2 # Conditional build:
3 %bcond_with     hadoop  # Hadoop client (requires JNI)
4 #
5 Summary:        User space components of the Ceph file system
6 Summary(pl.UTF-8):      Działające w przestrzeni użytkownika elementy systemu plików Ceph
7 Name:           ceph
8 Version:        0.52
9 Release:        1
10 License:        LGPL v2.1 (libraries), GPL v2 (some programs)
11 Group:          Base
12 Source0:        http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
13 # Source0-md5:  b3b9c8e7160d69cdf735628342a8dee0
14 Patch0:         %{name}-init-fix.patch
15 Patch1:         %{name}.logrotate.patch
16 Patch2:         %{name}-link.patch
17 URL:            http://ceph.newdream.net/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  boost-devel >= 1.34
21 BuildRequires:  cryptopp-devel
22 BuildRequires:  curl-devel
23 BuildRequires:  expat-devel >= 1.95
24 BuildRequires:  fcgi-devel
25 BuildRequires:  gdbm-devel
26 %{?with_hadoop:BuildRequires:   jdk}
27 BuildRequires:  keyutils-devel
28 BuildRequires:  leveldb-devel
29 BuildRequires:  libaio-devel
30 BuildRequires:  libatomic_ops
31 BuildRequires:  libedit-devel >= 2.11
32 BuildRequires:  libfuse-devel
33 BuildRequires:  libltdl-devel
34 BuildRequires:  libs3-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtcmalloc-devel
37 BuildRequires:  libtool >= 2:1.5
38 BuildRequires:  libuuid-devel
39 BuildRequires:  perl-base
40 BuildRequires:  pkgconfig
41 BuildRequires:  python >= 1:2.4
42 BuildRequires:  rpmbuild(macros) >= 1.228
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  snappy-devel
45 Requires(post,preun):   /sbin/chkconfig
46 Requires(preun):        rc-scripts
47 Requires:       %{name}-libs = %{version}-%{release}
48 Obsoletes:      gcephtool
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         skip_post_check_so      libcls_.*.so.*
52
53 %description
54 Ceph is a distributed network file system designed to provide
55 excellent performance, reliability, and scalability.
56
57 %description -l pl.UTF-8
58 Ceph to rozproszony sieciowy system plików zaprojektowany z myślą o
59 dobrej wydajności, wiarygodności i skalowalności.
60
61 %package libs
62 Summary:        Ceph shared libraries
63 Summary(pl.UTF-8):      Biblioteki współdzielone Cepha
64 Group:          Libraries
65
66 %description libs
67 Ceph shared libraries.
68
69 %description libs -l pl.UTF-8
70 Biblioteki współdzielone Cepha.
71
72 %package devel
73 Summary:        Ceph header files
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Cepha
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77
78 %description devel
79 This package contains the headers needed to develop programs that use
80 Ceph.
81
82 %description devel -l pl.UTF-8
83 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
84 wykorzystujących Cepha.
85
86 %package static
87 Summary:        Ceph static libraries
88 Summary(pl.UTF-8):      Biblioteki statyczne Cepha
89 License:        LGPLv2
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 This package contains static Ceph libraries.
95
96 %description static -l pl.UTF-8
97 Ten pakiet zawiera biblioteki statyczne Cepha.
98
99 %package -n python-ceph
100 Summary:        Ceph Python bindings
101 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek Cepha
102 Group:          Development/Languages/Python
103 Requires:       %{name}-libs = %{version}-%{release}
104
105 %description -n python-ceph
106 Ceph Python bindings.
107
108 %description -n python-ceph -l pl.UTF-8
109 Wiązania Pythona do bibliotek Cepha.
110
111 %package fuse
112 Summary:        Ceph FUSE-based client
113 Summary(pl.UTF-8):      Klient Cepha oparty na FUSE
114 Group:          Base
115 Requires:       %{name} = %{version}-%{release}
116
117 %description fuse
118 FUSE based client for Ceph distributed network file system.
119
120 %description fuse -l pl.UTF-8
121 Oparty na FUSE klient rozproszonego sieciowego systemu plików Ceph.
122
123 %package radosgw
124 Summary:        rados REST gateway
125 Summary(pl.UTF-8):      Bramka REST-owa rados
126 Group:          Applications/System
127 #Requires:      apache-mod_fcgid
128
129 %description radosgw
130 radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
131 implemented as a FastCGI module using libfcgi, and can be used in
132 conjunction with any FastCGI capable web server.
133
134 %description radosgw -l pl.UTF-8
135 radosgw to REST-owa bramka HTTP S3 do przechowalni obiektów RADOS.
136 Jest zaimplementowana jako moduł FastCGI wykorzystujący libfcgi i może
137 być używana w połączeniu z dowolnym serwerem WWW obsługującym FastCGI.
138
139 %package obsync
140 Summary:        Synchronize data between cloud object storage providers or a local directory
141 Summary(pl.UTF-8):      Synchronizacja danych między obiektami przechowywanymi w chmurze i katalogami lokalnymi
142 Group:          Applications/Networking
143 Requires:       python
144 Requires:       python-boto
145
146 %description obsync
147 obsync is a tool to synchronize objects between cloud object storage
148 providers, such as Amazon S3 (or compatible services), a Ceph RADOS
149 cluster, or a local directory.
150
151 %description obsync -l pl.UTF-8
152 obsync to narzędzie do synchronizacji obiektów między systemami
153 przechowującymi obiekty w chmurze, takimi jak Amazon S3 (lub serwisy
154 kompatybilne) a klastrem Ceph RADOS lub katalogiem lokalnym.
155
156 %package ocf
157 Summary:        OCF Resource Agents for Ceph processes
158 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów Cepha
159 Group:          Applications/System
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       resource-agents
162
163 %description ocf
164 OCF Resource Agents for Ceph processes.
165
166 %description ocf -l pl.UTF-8
167 Agenci OCF do monitorowania procesów Cepha.
168
169 %prep
170 %setup -q
171 %patch0 -p1
172 %patch1 -p0
173 %patch2 -p1
174
175 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' src/obsync/obsync
176
177 %build
178 %{__libtoolize}
179 %{__aclocal}
180 %{__autoconf}
181 %{__autoheader}
182 %{__automake}
183 %configure \
184         --sbindir=/sbin \
185         --with-cryptopp \
186         --with-hadoop%{!?with_hadoop:=no} \
187         --with-ocf \
188         --with-radosgw \
189         --with-system-leveldb \
190         --with-system-libs3 \
191         --disable-silent-rules
192
193 %{__make}
194
195 %install
196 rm -rf $RPM_BUILD_ROOT
197 install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib/ceph/tmp,log/ceph/stat} \
198         $RPM_BUILD_ROOT%{_sysconfdir}/{ceph,bash_completion.d,logrotate.d,rc.d/init.d}
199 %{__make} install \
200         DESTDIR=$RPM_BUILD_ROOT
201
202 install -p src/init-ceph $RPM_BUILD_ROOT/etc/rc.d/init.d/ceph
203 install -p src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ceph
204
205 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rados-classes/*.{a,la}
206 %py_postclean
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %post
212 /sbin/chkconfig --add ceph
213 %service ceph restart
214
215 %preun
216 if [ "$1" = "0" ] ; then
217         %service ceph stop
218         /sbin/chkconfig --del ceph
219 fi
220
221 %post   libs -p /sbin/ldconfig
222 %postun libs -p /sbin/ldconfig
223
224 %files
225 %defattr(644,root,root,755)
226 # COPYING specifies licenses of individual parts
227 %doc AUTHORS COPYING README src/sample.ceph.conf src/sample.fetch_config
228 %attr(754,root,root) /etc/rc.d/init.d/ceph
229 %dir %{_sysconfdir}/ceph
230 %attr(755,root,root) %{_bindir}/ceph
231 %attr(755,root,root) %{_bindir}/cephfs
232 %attr(755,root,root) %{_bindir}/ceph-conf
233 %attr(755,root,root) %{_bindir}/ceph-clsinfo
234 %attr(755,root,root) %{_bindir}/ceph-dencoder
235 %attr(755,root,root) %{_bindir}/crushtool
236 %attr(755,root,root) %{_bindir}/monmaptool
237 %attr(755,root,root) %{_bindir}/osdmaptool
238 %attr(755,root,root) %{_bindir}/ceph-authtool
239 %attr(755,root,root) %{_bindir}/ceph-syn
240 %attr(755,root,root) %{_bindir}/ceph-run
241 %attr(755,root,root) %{_bindir}/ceph-mon
242 %attr(755,root,root) %{_bindir}/ceph-mds
243 %attr(755,root,root) %{_bindir}/ceph-osd
244 %attr(755,root,root) %{_bindir}/ceph-rbdnamer
245 %attr(755,root,root) %{_bindir}/librados-config
246 %attr(755,root,root) %{_bindir}/rados
247 %attr(755,root,root) %{_bindir}/rbd
248 %attr(755,root,root) %{_bindir}/ceph-debugpack
249 %attr(755,root,root) %{_bindir}/ceph-coverage
250 %dir %{_libdir}/rados-classes
251 %attr(755,root,root) %{_libdir}/rados-classes/libcls_lock.so*
252 %attr(755,root,root) %{_libdir}/rados-classes/libcls_rbd.so*
253 %attr(755,root,root) %{_libdir}/rados-classes/libcls_rgw.so*
254 %attr(755,root,root) /sbin/ceph-disk-activate
255 %attr(755,root,root) /sbin/ceph-disk-prepare
256 %attr(755,root,root) /sbin/mkcephfs
257 %attr(755,root,root) /sbin/mount.ceph
258 %dir %{_libdir}/ceph
259 %attr(755,root,root) %{_libdir}/ceph/ceph_common.sh
260 %config(noreplace) /etc/logrotate.d/ceph
261 %config(noreplace) %{_sysconfdir}/bash_completion.d/rados
262 %config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
263 %config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
264 %{_mandir}/man8/ceph.8*
265 %{_mandir}/man8/ceph-authtool.8*
266 %{_mandir}/man8/ceph-clsinfo.8*
267 %{_mandir}/man8/ceph-conf.8*
268 %{_mandir}/man8/ceph-debugpack.8*
269 %{_mandir}/man8/ceph-dencoder.8*
270 %{_mandir}/man8/ceph-mds.8*
271 %{_mandir}/man8/ceph-mon.8*
272 %{_mandir}/man8/ceph-osd.8*
273 %{_mandir}/man8/ceph-rbdnamer.8*
274 %{_mandir}/man8/ceph-run.8*
275 %{_mandir}/man8/ceph-syn.8*
276 %{_mandir}/man8/cephfs.8*
277 %{_mandir}/man8/crushtool.8*
278 %{_mandir}/man8/librados-config.8*
279 %{_mandir}/man8/mkcephfs.8*
280 %{_mandir}/man8/monmaptool.8*
281 %{_mandir}/man8/mount.ceph.8*
282 %{_mandir}/man8/osdmaptool.8*
283 %{_mandir}/man8/rados.8*
284 %{_mandir}/man8/radosgw.8*
285 %{_mandir}/man8/radosgw-admin.8*
286 %{_mandir}/man8/rbd.8*
287
288 %dir %{_localstatedir}/lib/ceph
289 %dir %{_localstatedir}/lib/ceph/tmp
290 %dir %{_localstatedir}/log/ceph
291
292 %files libs
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/libcephfs.so.*.*.*
295 %attr(755,root,root) %ghost %{_libdir}/libcephfs.so.1
296 %attr(755,root,root) %{_libdir}/librados.so.*.*.*
297 %attr(755,root,root) %ghost %{_libdir}/librados.so.2
298 %attr(755,root,root) %{_libdir}/librbd.so.*.*.*
299 %attr(755,root,root) %ghost %{_libdir}/librbd.so.1
300
301 %files devel
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/libcephfs.so
304 %attr(755,root,root) %{_libdir}/librados.so
305 %attr(755,root,root) %{_libdir}/librbd.so
306 %{_libdir}/libcephfs.la
307 %{_libdir}/librados.la
308 %{_libdir}/librbd.la
309 %{_includedir}/cephfs
310 %{_includedir}/rados
311 %{_includedir}/rbd
312
313 %files static
314 %defattr(644,root,root,755)
315 %{_libdir}/libcephfs.a
316 %{_libdir}/librados.a
317 %{_libdir}/librbd.a
318
319 %files -n python-ceph
320 %defattr(644,root,root,755)
321 %{py_sitescriptdir}/rados.py[co]
322 %{py_sitescriptdir}/rbd.py[co]
323
324 %files fuse
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_bindir}/ceph-fuse
327 %{_mandir}/man8/ceph-fuse.8*
328
329 %files radosgw
330 %defattr(644,root,root,755)
331 %attr(755,root,root) %{_bindir}/radosgw
332 %attr(755,root,root) %{_bindir}/radosgw-admin
333 %{_sysconfdir}/bash_completion.d/radosgw-admin
334
335 %files obsync
336 %defattr(644,root,root,755)
337 %attr(755,root,root) %{_bindir}/obsync
338 %attr(755,root,root) %{_bindir}/boto_tool
339 %{_mandir}/man1/obsync.1*
340
341 %files ocf
342 %defattr(644,root,root,755)
343 %dir %{_prefix}/lib/ocf/resource.d/ceph
344 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/ceph
345 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/mds
346 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/mon
347 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/osd
348 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
This page took 0.060837 seconds and 3 git commands to generate.