]> git.pld-linux.org Git - packages/ceph.git/blame - ceph.spec
- don't package java unit tests, fix java deps and paths, rel 9
[packages/ceph.git] / ceph.spec
CommitLineData
b6163d67 1# TODO:
bbcdc7ce
JB
2# - proper init scripts if non-systemd boot is too be supported
3# (upstream scripts seem overcomplicated and hardly useful)
4# - run as non-root user
b6163d67 5#
19c20e80
JR
6# Note on versioning: http://docs.ceph.com/docs/master/releases/
7#
714b93ed 8# Conditional build:
7f577810 9%bcond_without java # Java binding
bbcdc7ce 10%bcond_with accelio # Accelio transport support [needs update for internal API changes]
1b11728e
JB
11%bcond_with cryptopp # use cryptopp instead of NSS crypto/SSL
12%bcond_with dpdk # DPDK messaging (requires cryptopp instead of nss)
f25d96c8 13%bcond_without fcgi # RADOS Gateway FCGI frontend
4429ac83 14%bcond_with fio # FIO engines support
1b11728e
JB
15%bcond_without pmem # PMDK (persistent memory) support
16%bcond_with spdk # Ceph SPDK support (DPDK based)
17%bcond_without system_rocksdb # system RocksDB storage support
f25d96c8 18%bcond_without zfs # ZFS support [not ready for zfs 0.8.x]
7f577810
JB
19%bcond_without lttng # LTTng tracing
20%bcond_without babeltrace # Babeltrace traces support
21%bcond_without tcmalloc # tcmalloc allocator
c37aec31 22%bcond_with tests # build tests
6fce7056
JR
23
24%ifarch x32
25%undefine with_tcmalloc
26%endif
1b11728e
JB
27%ifnarch %{x8664} aarch64
28%undefine with_pmem
29%endif
30%if %{without cryptopp} && %{with dpdk}
31%error DPDK requires cryptopp
32%endif
714b93ed 33#
2a1a6301 34Summary: User space components of the Ceph file system
e5fc70df 35Summary(pl.UTF-8): Działające w przestrzeni użytkownika elementy systemu plików Ceph
2a1a6301 36Name: ceph
1b11728e 37Version: 12.2.13
b5d07312 38Release: 9
9e1f65de 39License: LGPL v2.1 (libraries), GPL v2 (some programs)
2a1a6301 40Group: Base
4447516f 41Source0: http://download.ceph.com/tarballs/%{name}-%{version}.tar.gz
1b11728e 42# Source0-md5: 38bd01cf8224c9ca081298e19ab6e5a1
b6163d67 43Source1: ceph.sysconfig
bbcdc7ce 44Source3: ceph.tmpfiles
2a1a6301 45Patch0: %{name}-init-fix.patch
1b11728e
JB
46Patch2: boost.patch
47Patch3: %{name}-python.patch
48Patch4: %{name}-types.patch
49Patch5: %{name}-tcmalloc.patch
50Patch6: %{name}-rocksdb.patch
51Patch7: %{name}-fcgi.patch
79dc5cad 52Patch8: %{name}-fio.patch
101b8bdd 53Patch9: %{name}-zfs.patch
acdfce6f 54Patch10: %{name}-includes.patch
e3919159 55URL: https://ceph.io/
477a1b20 56%{?with_accelio:BuildRequires: accelio-devel}
7f577810 57%{?with_babeltrace:BuildRequires: babeltrace-devel}
1b11728e 58BuildRequires: boost-devel >= 1.66
9d117238 59BuildRequires: boost-python-devel >= 1.66
1b11728e
JB
60BuildRequires: cmake >= 2.8.11
61%{?with_cryptopp:BuildRequires: cryptopp-devel}
2a1a6301 62BuildRequires: curl-devel
1b11728e
JB
63%if %{with dpdk} || %{with spdk}
64BuildRequires: dpdk-devel
65%endif
714b93ed 66BuildRequires: expat-devel >= 1.95
1b11728e
JB
67%{?with_fcgi:BuildRequires: fcgi-devel}
68%{?with_fio:BuildRequires: fio-devel}
2a1a6301 69BuildRequires: gdbm-devel
7db8c214 70%if %{with java}
4f42482b 71BuildRequires: jdk
b5d07312 72BuildRequires: jre-X11
4f42482b 73%endif
2a1a6301 74BuildRequires: keyutils-devel
548e0d3f 75BuildRequires: leveldb-devel >= 1.2
714b93ed 76BuildRequires: libaio-devel
2a1a6301 77BuildRequires: libatomic_ops
548e0d3f 78BuildRequires: libblkid-devel >= 2.17
714b93ed 79BuildRequires: libedit-devel >= 2.11
2a1a6301 80BuildRequires: libfuse-devel
1b11728e 81# +RDMA?
477a1b20 82%{?with_accelio:BuildRequires: libibverbs-devel}
2a1a6301 83BuildRequires: libltdl-devel
477a1b20 84%{?with_accelio:BuildRequires: librdmacm-devel}
bbcdc7ce 85BuildRequires: libstdc++-devel >= 6:4.7
6fce7056 86%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
714b93ed 87BuildRequires: libtool >= 2:1.5
2a1a6301 88BuildRequires: libuuid-devel
bbcdc7ce 89BuildRequires: libxml2-devel >= 2.0
7f577810 90%{?with_lttng:BuildRequires: lttng-ust-devel}
1b11728e
JB
91BuildRequires: lz4-devel >= 1:1.7
92%{!?with_cryptopp:BuildRequires: nss-devel >= 3}
bbcdc7ce
JB
93BuildRequires: openldap-devel
94BuildRequires: openssl-devel
e5fc70df 95BuildRequires: perl-base
2a1a6301 96BuildRequires: pkgconfig
1b11728e 97%{?with_pmem:BuildRequires: pmdk-devel}
bbcdc7ce 98BuildRequires: python >= 1:2.7
1b11728e 99BuildRequires: python-devel >= 1:2.7
bbcdc7ce 100BuildRequires: python-Cython
1b11728e 101BuildRequires: python3-devel >= 1:3.2
a92d2e05 102BuildRequires: python3-Cython
101b8bdd
JB
103# upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
104%{?with_system_rocksdb:BuildRequires: rocksdb-devel >= 5.6.0}
bef2a0ad 105BuildRequires: rpmbuild(macros) >= 1.671
e3919159 106BuildRequires: sed >= 4.0
f965be58 107BuildRequires: snappy-devel
bbcdc7ce 108BuildRequires: sphinx-pdg-2 >= 1.0
548e0d3f 109BuildRequires: udev-devel
1b11728e 110#BuildRequires: virtualenv for tests
b1fa8ffe 111%{?with_dpdk:BuildRequires: xorg-lib-libpciaccess-devel}
fa260b6c 112BuildRequires: xfsprogs-devel
7db8c214
JB
113%ifarch %{x8664}
114BuildRequires: yasm
115%endif
101b8bdd
JB
116# zfs patch updates to 0.8.0 API
117%{?with_zfs:BuildRequires: zfs-devel >= 0.8.0}
bbcdc7ce 118BuildRequires: zlib-devel
2a1a6301
JR
119Requires(post,preun): /sbin/chkconfig
120Requires(preun): rc-scripts
121Requires: %{name}-libs = %{version}-%{release}
7cabda16 122Requires: python-%{name} = %{version}-%{release}
bef2a0ad 123Requires: systemd-units >= 38
60d5543f 124Obsoletes: gcephtool
7db8c214 125Obsoletes: hadoop-cephfs
2a1a6301
JR
126BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
2d841236 128%define skip_post_check_so libceph_crypto_isal.so.* libceph_lz4.so.* libceph_snappy.so.* libceph_zlib.so.* libceph_zstd.so.* libcls_.*.so.* libec_.*.so.*
2a1a6301
JR
129
130%description
131Ceph is a distributed network file system designed to provide
132excellent performance, reliability, and scalability.
133
e5fc70df
JB
134%description -l pl.UTF-8
135Ceph to rozproszony sieciowy system plików zaprojektowany z myślą o
136dobrej wydajności, wiarygodności i skalowalności.
137
2a1a6301
JR
138%package libs
139Summary: Ceph shared libraries
e5fc70df 140Summary(pl.UTF-8): Biblioteki współdzielone Cepha
2a1a6301
JR
141Group: Libraries
142
143%description libs
144Ceph shared libraries.
145
e5fc70df
JB
146%description libs -l pl.UTF-8
147Biblioteki współdzielone Cepha.
2a1a6301
JR
148
149%package devel
e5fc70df
JB
150Summary: Ceph header files
151Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Cepha
96c29907 152License: LGPL v2.1
2a1a6301
JR
153Group: Development/Libraries
154Requires: %{name}-libs = %{version}-%{release}
1b11728e 155Requires: boost-devel >= 1.66
bbcdc7ce
JB
156Requires: curl-devel
157Requires: expat-devel
158Requires: fcgi-devel
159Requires: nss-devel >= 3
96c29907
JB
160Requires: leveldb-devel
161Requires: libatomic_ops
bbcdc7ce
JB
162Requires: libblkid-devel >= 2.17
163Requires: libstdc++-devel >= 6:4.7
96c29907 164Requires: libuuid-devel
bbcdc7ce
JB
165%{?with_lttng:Requires: lttng-ust-devel}
166Requires: openldap-devel
1b11728e 167Obsoletes: ceph-static < 12
2a1a6301
JR
168
169%description devel
170This package contains the headers needed to develop programs that use
171Ceph.
172
e5fc70df
JB
173%description devel -l pl.UTF-8
174Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
175wykorzystujących Cepha.
176
e5fc70df 177%package -n python-ceph
1b11728e
JB
178Summary: Ceph Python 2 bindings
179Summary(pl.UTF-8): Wiązania Pythona 2 do bibliotek Cepha
e5fc70df
JB
180Group: Development/Languages/Python
181Requires: %{name}-libs = %{version}-%{release}
182
183%description -n python-ceph
1b11728e 184Ceph Python 2 bindings.
e5fc70df
JB
185
186%description -n python-ceph -l pl.UTF-8
1b11728e
JB
187Wiązania Pythona 2 do bibliotek Cepha.
188
189%package -n python3-ceph
190Summary: Ceph Python 3 bindings
191Summary(pl.UTF-8): Wiązania Pythona 3 do bibliotek Cepha
192Group: Development/Languages/Python
193Requires: %{name}-libs = %{version}-%{release}
194
195%description -n python3-ceph
196Ceph Python 3 bindings.
197
198%description -n python3-ceph -l pl.UTF-8
199Wiązania Pythona 3 do bibliotek Cepha.
e5fc70df 200
4f42482b
JB
201%package -n java-cephfs
202Summary: CephFS Java bindings
203Summary(pl.UTF-8): Wiązania Javy do biblioteki CephFS
204Group: Libraries/Java
205Requires: %{name}-libs = %{version}-%{release}
206
207%description -n java-cephfs
208CephFS Java bindings.
209
210%description -n java-cephfs -l pl.UTF-8
211Wiązania Javy do biblioteki CephFS.
212
e5fc70df
JB
213%package fuse
214Summary: Ceph FUSE-based client
215Summary(pl.UTF-8): Klient Cepha oparty na FUSE
216Group: Base
217Requires: %{name} = %{version}-%{release}
218
219%description fuse
220FUSE based client for Ceph distributed network file system.
221
222%description fuse -l pl.UTF-8
223Oparty na FUSE klient rozproszonego sieciowego systemu plików Ceph.
224
2a1a6301
JR
225%package radosgw
226Summary: rados REST gateway
e5fc70df
JB
227Summary(pl.UTF-8): Bramka REST-owa rados
228Group: Applications/System
2a1a6301
JR
229#Requires: apache-mod_fcgid
230
231%description radosgw
232radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
233implemented as a FastCGI module using libfcgi, and can be used in
234conjunction with any FastCGI capable web server.
235
e5fc70df
JB
236%description radosgw -l pl.UTF-8
237radosgw to REST-owa bramka HTTP S3 do przechowalni obiektów RADOS.
238Jest zaimplementowana jako moduł FastCGI wykorzystujący libfcgi i może
239być używana w połączeniu z dowolnym serwerem WWW obsługującym FastCGI.
240
245cb856 241%package resource-agents
8029515d
JB
242Summary: OCF Resource Agents for Ceph processes
243Summary(pl.UTF-8): Agenci OCF do monitorowania procesów Cepha
244Group: Applications/System
245Requires: %{name} = %{version}-%{release}
246Requires: resource-agents
247
245cb856 248%description resource-agents
8029515d
JB
249OCF Resource Agents for Ceph processes.
250
245cb856 251%description resource-agents -l pl.UTF-8
8029515d
JB
252Agenci OCF do monitorowania procesów Cepha.
253
9911b50d
JP
254%package test
255Summary: Ceph benchmarks and test tools
256Summary(pl.UTF-8): Narzędzia testowe oraz do mierzenia wydajności dla Ceph
257Group: Applications/System
258Requires: %{name} = %{version}-%{release}
259
260%description test
261Ceph benchmarks and test tools.
262
263%description test -l pl.UTF-8
264Narzędzia testowe oraz do mierzenia wydajności dla Ceph.
265
79dc5cad
JB
266%package -n fio-ceph-objectstore
267Summary: FIO engine module for Ceph ObjectStore
268Summary(pl.UTF-8): Moduł silnika FIO do używania Ceph ObjectStore
269Group: Libraries
270Requires: %{name}-libs = %{version}-%{release}
101b8bdd 271%if %{with fio}
79dc5cad 272%requires_ge_to fio fio-devel
101b8bdd 273%endif
79dc5cad
JB
274
275%description -n fio-ceph-objectstore
276This FIO engine allows you to mount and use a ceph object store
277directly, without having to build a ceph cluster or start any daemons.
278
279%description -n fio-ceph-objectstore -l pl.UTF-8
280Ten silnik FIO pozwala na bezpośrednie montowanie i używanie
281przestrzeni obiektów ceph, bez potrzeby budowania klastra ceph czy
282uruchamiania demonów.
283
2a1a6301
JR
284%prep
285%setup -q
286%patch0 -p1
1b11728e
JB
287%patch2 -p0
288%patch3 -p1
bbcdc7ce
JB
289%patch4 -p1
290%patch5 -p1
1b11728e
JB
291%patch6 -p1
292%patch7 -p1
79dc5cad 293%patch8 -p1
101b8bdd 294%patch9 -p1
acdfce6f 295%patch10 -p1
2a1a6301 296
e3919159 297%{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
1b11728e 298 src/{ceph-create-keys,ceph-rest-api,mount.fuse.ceph} \
bbcdc7ce
JB
299 src/brag/client/ceph-brag \
300 src/ceph-disk/ceph_disk/main.py
e3919159 301
2a1a6301 302%build
1b11728e
JB
303install -d build
304cd build
305%cmake .. \
306 -DALLOCATOR="%{?with_tcmalloc:tcmalloc}%{!?with_tcmalloc:libc}" \
307 -DFIO_INCLUDE_DIR=/usr/include/fio \
308 -DPYTHON=%{__python} \
309 -DSPHINX_BUILD=/usr/bin/sphinx-build-2 \
310 %{!?with_babeltrace:-DWITH_BABELTRACE=OFF} \
311 %{?with_java:-DWITH_CEPHFS_JAVA=ON} \
b5d07312 312 %{?with_java:-DJAVA_JVM_LIBRARY:PATH=%{_jvmdir}/java/lib/server/libjvm.so} \
1b11728e
JB
313 %{?with_dpdk:-DWITH_DPDK=ON} \
314 %{?with_fio:-DWITH_FIO=ON} \
315 %{!?with_lttng:-DWITH_LTTNG=OFF} \
316 -DWITH_LZ4=ON \
317 %{?with_cryptopp:-DWITH_NSS=OFF} \
318 -DWITH_OCF=ON \
319 %{?with_pmem:-DWITH_PMEM=ON} \
320 %{?with_fcgi:-DWITH_RADOSGW_FCGI_FRONTEND=ON} \
321 %{?with_spdk:-DWITH_SPDK=ON} \
322 -DWITH_SYSTEM_BOOST=ON \
323 %{?with_system_rocksdb:-DWITH_SYSTEM_ROCKSDB=ON} \
324 -DWITH_SYSTEMD=ON \
325 %{?with_accelio:-DWITH_XIO=ON} \
f73f6ee6 326 %{?with_zfs:-DWITH_ZFS=ON} \
c37aec31
JP
327 -DWITH_REENTRANT_STRSIGNAL=ON \
328 %{!?with_tests:-DWITH_TESTS=OFF}
1b11728e
JB
329
330%{__make}
2a1a6301
JR
331
332%install
333rm -rf $RPM_BUILD_ROOT
1b11728e
JB
334install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib/ceph/{tmp,mon,osd,mds,mgr,radosgw,bootstrap-{osd,mds,rgw,mgr,rbd}},log/ceph/stat,run/ceph} \
335 $RPM_BUILD_ROOT%{_sysconfdir}/{ceph,bash_completion.d,logrotate.d,rc.d,sysconfig} \
336 $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir},/etc/systemd/system/ceph.target.wants,/sbin}
4f42482b 337
1b11728e
JB
338%{__make} -C build install \
339 DESTDIR=$RPM_BUILD_ROOT
2a1a6301 340
1b11728e
JB
341# sanitize paths; no config options for cmake
342%{__mv} $RPM_BUILD_ROOT/etc/init.d $RPM_BUILD_ROOT/etc/rc.d
343%{__mv} $RPM_BUILD_ROOT%{_libexecdir}/systemd/system/* $RPM_BUILD_ROOT%{systemdunitdir}
344%{__mv} $RPM_BUILD_ROOT%{_sbindir}/mount.* $RPM_BUILD_ROOT/sbin
345
346cp -p src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ceph
2a1a6301 347
bbcdc7ce 348cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/ceph
b6163d67 349ln -sf /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/ceph.service
bbcdc7ce 350cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/ceph.conf
b6163d67 351
1b11728e
JB
352%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
353%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
354%py_postclean
4f42482b 355
1b11728e
JB
356%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
357%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
245cb856 358
c37aec31 359%if %{with tests}
1b11728e
JB
360# tests
361%{__rm} $RPM_BUILD_ROOT%{_bindir}/ceph_test_*
c37aec31 362%endif
1b11728e
JB
363# packaged as %doc
364%{__rm} $RPM_BUILD_ROOT%{_docdir}/sample.ceph.conf
365# cleanup
366%{__rm} $RPM_BUILD_ROOT%{_libdir}/ceph/mgr/{.gitignore,dashboard/HACKING.rst,dashboard/static/AdminLTE-2.3.7/{.gitignore,.jshintrc,README.md}}
2a1a6301
JR
367
368%clean
369rm -rf $RPM_BUILD_ROOT
370
371%post
372/sbin/chkconfig --add ceph
373%service ceph restart
374
bef2a0ad
JK
375# actual services are to be enabled on cluster deployment
376%systemd_post %{name}.target
377
2a1a6301
JR
378%preun
379if [ "$1" = "0" ] ; then
72daa1da
JR
380 %service ceph stop
381 /sbin/chkconfig --del ceph
2a1a6301 382fi
bef2a0ad
JK
383%systemd_preun %{name}.target
384
385%postun
386%systemd_reload
2a1a6301 387
e5fc70df
JB
388%post libs -p /sbin/ldconfig
389%postun libs -p /sbin/ldconfig
2a1a6301 390
4f42482b
JB
391%post -n java-cephfs -p /sbin/ldconfig
392%postun -n java-cephfs -p /sbin/ldconfig
393
2a1a6301
JR
394%files
395%defattr(644,root,root,755)
9e1f65de 396# COPYING specifies licenses of individual parts
1b11728e 397%doc AUTHORS COPYING PendingReleaseNotes README.md src/sample.ceph.conf doc/{release-notes,releases}.rst
2a1a6301 398%attr(754,root,root) /etc/rc.d/init.d/ceph
bef2a0ad
JK
399%config(noreplace) /etc/sysconfig/ceph
400%dir /etc/systemd/system/ceph.target.wants
bbcdc7ce
JB
401%{systemdunitdir}/ceph.service
402%{systemdunitdir}/ceph.target
bbcdc7ce 403%{systemdunitdir}/ceph-disk@.service
1b11728e
JB
404%{systemdunitdir}/ceph-fuse.target
405%{systemdunitdir}/ceph-fuse@.service
bbcdc7ce 406%{systemdunitdir}/ceph-mds.target
bef2a0ad 407%{systemdunitdir}/ceph-mds@.service
1b11728e
JB
408%{systemdunitdir}/ceph-mgr.target
409%{systemdunitdir}/ceph-mgr@.service
bbcdc7ce 410%{systemdunitdir}/ceph-mon.target
bef2a0ad 411%{systemdunitdir}/ceph-mon@.service
bbcdc7ce 412%{systemdunitdir}/ceph-osd.target
bef2a0ad 413%{systemdunitdir}/ceph-osd@.service
bbcdc7ce
JB
414%{systemdunitdir}/ceph-rbd-mirror.target
415%{systemdunitdir}/ceph-rbd-mirror@.service
1b11728e 416%{systemdunitdir}/ceph-volume@.service
bbcdc7ce 417%{systemdunitdir}/rbdmap.service
bef2a0ad 418%{systemdtmpfilesdir}/ceph.conf
2a1a6301
JR
419%dir %{_sysconfdir}/ceph
420%attr(755,root,root) %{_bindir}/ceph
8c5712e2 421%attr(755,root,root) %{_bindir}/ceph-authtool
1b11728e 422%attr(755,root,root) %{_bindir}/ceph-bluestore-tool
fa260b6c 423%attr(755,root,root) %{_bindir}/ceph-brag
2a1a6301 424%attr(755,root,root) %{_bindir}/ceph-clsinfo
8c5712e2 425%attr(755,root,root) %{_bindir}/ceph-conf
d91e5335 426%attr(755,root,root) %{_bindir}/ceph-crush-location
60d5543f 427%attr(755,root,root) %{_bindir}/ceph-dencoder
bbcdc7ce 428%attr(755,root,root) %{_bindir}/ceph-detect-init
2a1a6301 429%attr(755,root,root) %{_bindir}/ceph-mds
1b11728e 430%attr(755,root,root) %{_bindir}/ceph-mgr
8c5712e2 431%attr(755,root,root) %{_bindir}/ceph-mon
7f577810 432%attr(755,root,root) %{_bindir}/ceph-objectstore-tool
2a1a6301 433%attr(755,root,root) %{_bindir}/ceph-osd
5e39e43e 434%attr(755,root,root) %{_bindir}/ceph-post-file
2a1a6301 435%attr(755,root,root) %{_bindir}/ceph-rbdnamer
4f411dc5 436%attr(755,root,root) %{_bindir}/ceph-rest-api
8c5712e2
JB
437%attr(755,root,root) %{_bindir}/ceph-run
438%attr(755,root,root) %{_bindir}/ceph-syn
bbcdc7ce 439%attr(755,root,root) %{_bindir}/cephfs-data-scan
ae4b5127 440%attr(755,root,root) %{_bindir}/cephfs-journal-tool
b431df60 441%attr(755,root,root) %{_bindir}/cephfs-table-tool
8c5712e2 442%attr(755,root,root) %{_bindir}/crushtool
2a1a6301 443%attr(755,root,root) %{_bindir}/librados-config
8c5712e2
JB
444%attr(755,root,root) %{_bindir}/monmaptool
445%attr(755,root,root) %{_bindir}/osdmaptool
2a1a6301
JR
446%attr(755,root,root) %{_bindir}/rados
447%attr(755,root,root) %{_bindir}/rbd
8c5712e2 448%attr(755,root,root) %{_bindir}/rbd-fuse
bbcdc7ce
JB
449%attr(755,root,root) %{_bindir}/rbd-mirror
450%attr(755,root,root) %{_bindir}/rbd-nbd
9a1a508c 451%attr(755,root,root) %{_bindir}/rbd-replay
7f577810 452%attr(755,root,root) %{_bindir}/rbd-replay-many
9a1a508c 453%attr(755,root,root) %{_bindir}/rbd-replay-prep
bbcdc7ce 454%attr(755,root,root) %{_bindir}/rbdmap
1b11728e 455%attr(755,root,root) %{_sbindir}/ceph-create-keys
bbcdc7ce 456%attr(755,root,root) %{_sbindir}/ceph-disk
1b11728e
JB
457%attr(755,root,root) %{_sbindir}/ceph-volume
458%attr(755,root,root) %{_sbindir}/ceph-volume-systemd
4f42482b
JB
459%attr(755,root,root) /sbin/mount.ceph
460%attr(755,root,root) /sbin/mount.fuse.ceph
e3919159 461%if "%{_libexecdir}" != "%{_libdir}"
c1965bc2 462%dir %{_libexecdir}/ceph
e3919159 463%endif
a92d2e05 464%{_libexecdir}/ceph/ceph_common.sh
c1965bc2 465%attr(755,root,root) %{_libexecdir}/ceph/ceph-osd-prestart.sh
1b11728e 466%{_libdir}/ceph/mgr
bbcdc7ce 467%dir %{_libdir}/ceph/compressor
1b11728e 468%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_lz4.so*
bbcdc7ce
JB
469%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_snappy.so*
470%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_zlib.so*
1b11728e 471%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_zstd.so*
d65c5c24
JB
472%ifarch %{x8664}
473%dir %{_libdir}/ceph/crypto
474%attr(755,root,root) %{_libdir}/ceph/crypto/libceph_crypto_isal.so*
475%endif
c408d7b3 476%dir %{_libdir}/ceph/erasure-code
58dc957f 477%ifarch %{x8664}
066d8601 478%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_isa.so*
6fce7056 479%endif
c408d7b3 480%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure.so*
0509a77e 481%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_generic.so*
bbcdc7ce 482%ifarch %{arm}
7f577810
JB
483%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_neon.so*
484%endif
485%ifarch %{ix86} %{x8664} x32
0509a77e
JB
486%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse3.so*
487%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse4.so*
7f577810 488%endif
9a1a508c 489%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_lrc.so*
b431df60 490%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec.so*
bbcdc7ce
JB
491%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec_generic.so*
492%ifarch %{ix86} %{x8664} x32
493%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec_sse3.so*
1b11728e 494%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec_sse4.so*
bbcdc7ce 495%endif
2a1a6301 496%dir %{_libdir}/rados-classes
1b11728e
JB
497%attr(755,root,root) %{_libdir}/rados-classes/libcls_cephfs.so*
498%attr(755,root,root) %{_libdir}/rados-classes/libcls_hello.so*
499%attr(755,root,root) %{_libdir}/rados-classes/libcls_journal.so*
500%attr(755,root,root) %{_libdir}/rados-classes/libcls_kvs.so*
501%attr(755,root,root) %{_libdir}/rados-classes/libcls_lock.so*
502%attr(755,root,root) %{_libdir}/rados-classes/libcls_log.so*
503%attr(755,root,root) %{_libdir}/rados-classes/libcls_lua.so*
504%attr(755,root,root) %{_libdir}/rados-classes/libcls_numops.so*
505%attr(755,root,root) %{_libdir}/rados-classes/libcls_rbd.so*
506%attr(755,root,root) %{_libdir}/rados-classes/libcls_refcount.so*
507%attr(755,root,root) %{_libdir}/rados-classes/libcls_replica_log.so*
508%attr(755,root,root) %{_libdir}/rados-classes/libcls_rgw.so*
509%attr(755,root,root) %{_libdir}/rados-classes/libcls_sdk.so*
510%attr(755,root,root) %{_libdir}/rados-classes/libcls_statelog.so*
511%attr(755,root,root) %{_libdir}/rados-classes/libcls_timeindex.so*
512%attr(755,root,root) %{_libdir}/rados-classes/libcls_user.so*
513%attr(755,root,root) %{_libdir}/rados-classes/libcls_version.so*
5e39e43e 514%{_datadir}/ceph
2a1a6301
JR
515%config(noreplace) /etc/logrotate.d/ceph
516%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
517%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
518%config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
519%{_mandir}/man8/ceph.8*
520%{_mandir}/man8/ceph-authtool.8*
1b11728e 521%{_mandir}/man8/ceph-bluestore-tool.8*
2a1a6301
JR
522%{_mandir}/man8/ceph-clsinfo.8*
523%{_mandir}/man8/ceph-conf.8*
63709ae0 524%{_mandir}/man8/ceph-create-keys.8*
60d5543f 525%{_mandir}/man8/ceph-dencoder.8*
7f577810 526%{_mandir}/man8/ceph-deploy.8*
bbcdc7ce 527%{_mandir}/man8/ceph-detect-init.8*
7f577810 528%{_mandir}/man8/ceph-disk.8*
2a1a6301
JR
529%{_mandir}/man8/ceph-mds.8*
530%{_mandir}/man8/ceph-mon.8*
531%{_mandir}/man8/ceph-osd.8*
5e39e43e 532%{_mandir}/man8/ceph-post-file.8*
60d5543f 533%{_mandir}/man8/ceph-rbdnamer.8*
4f411dc5 534%{_mandir}/man8/ceph-rest-api.8*
2a1a6301
JR
535%{_mandir}/man8/ceph-run.8*
536%{_mandir}/man8/ceph-syn.8*
1b11728e
JB
537%{_mandir}/man8/ceph-volume.8*
538%{_mandir}/man8/ceph-volume-systemd.8*
2a1a6301
JR
539%{_mandir}/man8/crushtool.8*
540%{_mandir}/man8/librados-config.8*
2a1a6301
JR
541%{_mandir}/man8/monmaptool.8*
542%{_mandir}/man8/mount.ceph.8*
543%{_mandir}/man8/osdmaptool.8*
544%{_mandir}/man8/rados.8*
2a1a6301 545%{_mandir}/man8/rbd.8*
8c5712e2 546%{_mandir}/man8/rbd-fuse.8*
bbcdc7ce
JB
547%{_mandir}/man8/rbd-mirror.8*
548%{_mandir}/man8/rbd-nbd.8*
9a1a508c 549%{_mandir}/man8/rbd-replay.8*
7f577810 550%{_mandir}/man8/rbd-replay-many.8*
9a1a508c 551%{_mandir}/man8/rbd-replay-prep.8*
bbcdc7ce 552%{_mandir}/man8/rbdmap.8*
60d5543f 553
2a1a6301 554%dir %{_localstatedir}/lib/ceph
1b11728e
JB
555%dir %{_localstatedir}/lib/ceph/bootstrap-mds
556%dir %{_localstatedir}/lib/ceph/bootstrap-mgr
557%dir %{_localstatedir}/lib/ceph/bootstrap-osd
558%dir %{_localstatedir}/lib/ceph/bootstrap-rbd
559%dir %{_localstatedir}/lib/ceph/bootstrap-rgw
b6163d67 560%dir %{_localstatedir}/lib/ceph/mds
1b11728e 561%dir %{_localstatedir}/lib/ceph/mgr
b6163d67
JK
562%dir %{_localstatedir}/lib/ceph/mon
563%dir %{_localstatedir}/lib/ceph/osd
2a1a6301
JR
564%dir %{_localstatedir}/lib/ceph/tmp
565%dir %{_localstatedir}/log/ceph
bef2a0ad 566%dir %{_localstatedir}/run/ceph
2a1a6301
JR
567
568%files libs
569%defattr(644,root,root,755)
570%attr(755,root,root) %{_libdir}/libcephfs.so.*.*.*
1b11728e 571%attr(755,root,root) %ghost %{_libdir}/libcephfs.so.2
4447516f
JB
572%attr(755,root,root) %{_libdir}/libos_tp.so.*.*.*
573%attr(755,root,root) %ghost %{_libdir}/libos_tp.so.1
574%attr(755,root,root) %{_libdir}/libosd_tp.so.*.*.*
575%attr(755,root,root) %ghost %{_libdir}/libosd_tp.so.1
2a1a6301
JR
576%attr(755,root,root) %{_libdir}/librados.so.*.*.*
577%attr(755,root,root) %ghost %{_libdir}/librados.so.2
4447516f
JB
578%attr(755,root,root) %{_libdir}/librados_tp.so.*.*.*
579%attr(755,root,root) %ghost %{_libdir}/librados_tp.so.2
548e0d3f
JB
580%attr(755,root,root) %{_libdir}/libradosstriper.so.*.*.*
581%attr(755,root,root) %ghost %{_libdir}/libradosstriper.so.1
2a1a6301
JR
582%attr(755,root,root) %{_libdir}/librbd.so.*.*.*
583%attr(755,root,root) %ghost %{_libdir}/librbd.so.1
4447516f
JB
584%attr(755,root,root) %{_libdir}/librbd_tp.so.*.*.*
585%attr(755,root,root) %ghost %{_libdir}/librbd_tp.so.1
bbcdc7ce
JB
586%attr(755,root,root) %{_libdir}/librgw.so.*.*.*
587%attr(755,root,root) %ghost %{_libdir}/librgw.so.2
5b8dadc9
JB
588%dir %{_libdir}/ceph
589%attr(755,root,root) %{_libdir}/ceph/libceph-common.so.0
2a1a6301 590
2a1a6301
JR
591%files devel
592%defattr(644,root,root,755)
2a1a6301 593%attr(755,root,root) %{_libdir}/libcephfs.so
4447516f
JB
594%attr(755,root,root) %{_libdir}/libos_tp.so
595%attr(755,root,root) %{_libdir}/libosd_tp.so
2a1a6301 596%attr(755,root,root) %{_libdir}/librados.so
4447516f 597%attr(755,root,root) %{_libdir}/librados_tp.so
548e0d3f 598%attr(755,root,root) %{_libdir}/libradosstriper.so
2a1a6301 599%attr(755,root,root) %{_libdir}/librbd.so
4447516f 600%attr(755,root,root) %{_libdir}/librbd_tp.so
bbcdc7ce 601%attr(755,root,root) %{_libdir}/librgw.so
5b8dadc9 602%attr(755,root,root) %{_libdir}/ceph/libceph-common.so
e5fc70df
JB
603%{_includedir}/cephfs
604%{_includedir}/rados
548e0d3f 605%{_includedir}/radosstriper
e5fc70df 606%{_includedir}/rbd
2a1a6301 607
e5fc70df
JB
608%files -n python-ceph
609%defattr(644,root,root,755)
bbcdc7ce
JB
610%attr(755,root,root) %{py_sitedir}/cephfs.so
611%attr(755,root,root) %{py_sitedir}/rados.so
612%attr(755,root,root) %{py_sitedir}/rbd.so
1b11728e 613%attr(755,root,root) %{py_sitedir}/rgw.so
bbcdc7ce 614%{py_sitedir}/ceph_detect_init
bbcdc7ce 615%{py_sitedir}/ceph_detect_init-1.0.1-py*.egg-info
1b11728e 616%{py_sitedir}/ceph_disk
bbcdc7ce 617%{py_sitedir}/ceph_disk-1.0.0-py*.egg-info
1b11728e
JB
618%{py_sitedir}/ceph_volume
619%{py_sitedir}/ceph_volume-1.0.0-py*.egg-info
620%{py_sitedir}/cephfs-2.0.0-py*.egg-info
621%{py_sitedir}/rados-2.0.0-py*.egg-info
622%{py_sitedir}/rbd-2.0.0-py*.egg-info
623%{py_sitedir}/rgw-2.0.0-py*.egg-info
67f1bff3 624%{py_sitescriptdir}/ceph_argparse.py[co]
bbcdc7ce 625%{py_sitescriptdir}/ceph_daemon.py[co]
4f411dc5 626%{py_sitescriptdir}/ceph_rest_api.py[co]
bbcdc7ce 627%{py_sitescriptdir}/ceph_volume_client.py[co]
e5fc70df 628
1b11728e
JB
629%files -n python3-ceph
630%defattr(644,root,root,755)
631%attr(755,root,root) %{py3_sitedir}/cephfs.cpython-*.so
632%attr(755,root,root) %{py3_sitedir}/rados.cpython-*.so
633%attr(755,root,root) %{py3_sitedir}/rbd.cpython-*.so
634%attr(755,root,root) %{py3_sitedir}/rgw.cpython-*.so
635%{py3_sitedir}/cephfs-2.0.0-py*.egg-info
636%{py3_sitedir}/rados-2.0.0-py*.egg-info
637%{py3_sitedir}/rbd-2.0.0-py*.egg-info
638%{py3_sitedir}/rgw-2.0.0-py*.egg-info
639%{py3_sitescriptdir}/ceph_argparse.py
640%{py3_sitescriptdir}/ceph_daemon.py
641%{py3_sitescriptdir}/ceph_volume_client.py
642%{py3_sitescriptdir}/__pycache__/ceph_argparse.cpython-*.py[co]
643%{py3_sitescriptdir}/__pycache__/ceph_daemon.cpython-*.py[co]
644%{py3_sitescriptdir}/__pycache__/ceph_volume_client.cpython-*.py[co]
645
4f42482b
JB
646%if %{with java}
647%files -n java-cephfs
648%defattr(644,root,root,755)
649%attr(755,root,root) %{_libdir}/libcephfs_jni.so.*.*.*
650%attr(755,root,root) %ghost %{_libdir}/libcephfs_jni.so.1
651%attr(755,root,root) %{_libdir}/libcephfs_jni.so
652%{_javadir}/libcephfs.jar
653%endif
654
e5fc70df
JB
655%files fuse
656%defattr(644,root,root,755)
e5fc70df
JB
657%attr(755,root,root) %{_bindir}/ceph-fuse
658%{_mandir}/man8/ceph-fuse.8*
659
2a1a6301
JR
660%files radosgw
661%defattr(644,root,root,755)
662%attr(755,root,root) %{_bindir}/radosgw
663%attr(755,root,root) %{_bindir}/radosgw-admin
1b11728e 664%attr(755,root,root) %{_bindir}/radosgw-es
bbcdc7ce
JB
665%attr(755,root,root) %{_bindir}/radosgw-object-expirer
666%attr(755,root,root) %{_bindir}/radosgw-token
667%{systemdunitdir}/ceph-radosgw.target
668%{systemdunitdir}/ceph-radosgw@.service
2a1a6301 669%{_sysconfdir}/bash_completion.d/radosgw-admin
1b11728e
JB
670%dir %{_localstatedir}/lib/ceph/radosgw
671%{_mandir}/man8/radosgw.8*
672%{_mandir}/man8/radosgw-admin.8*
2a1a6301 673
245cb856 674%files resource-agents
8029515d
JB
675%defattr(644,root,root,755)
676%dir %{_prefix}/lib/ocf/resource.d/ceph
8029515d 677%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
79dc5cad 678
9911b50d
JP
679%if %{with test}
680%files test
681%defattr(644,root,root,755)
682%attr(755,root,root) %{_bindir}/ceph-client-debug
683%attr(755,root,root) %{_bindir}/ceph-coverage
684%attr(755,root,root) %{_bindir}/ceph-debugpack
685%attr(755,root,root) %{_bindir}/ceph-kvstore-tool
686%attr(755,root,root) %{_bindir}/ceph-monstore-tool
687%attr(755,root,root) %{_bindir}/ceph-osdomap-tool
688%attr(755,root,root) %{_bindir}/ceph_bench_log
689%attr(755,root,root) %{_bindir}/ceph_erasure_code
690%attr(755,root,root) %{_bindir}/ceph_erasure_code_benchmark
691%attr(755,root,root) %{_bindir}/ceph_kvstorebench
692%attr(755,root,root) %{_bindir}/ceph_multi_stress_watch
693%attr(755,root,root) %{_bindir}/ceph_objectstore_bench
694%attr(755,root,root) %{_bindir}/ceph_omapbench
695%attr(755,root,root) %{_bindir}/ceph_perf_local
696%attr(755,root,root) %{_bindir}/ceph_perf_msgr_client
697%attr(755,root,root) %{_bindir}/ceph_perf_msgr_server
698%attr(755,root,root) %{_bindir}/ceph_perf_objectstore
699%attr(755,root,root) %{_bindir}/ceph_psim
700%attr(755,root,root) %{_bindir}/ceph_radosacl
701%attr(755,root,root) %{_bindir}/ceph_rgw_jsonparser
702%attr(755,root,root) %{_bindir}/ceph_rgw_multiparser
703%attr(755,root,root) %{_bindir}/ceph_scratchtool
704%attr(755,root,root) %{_bindir}/ceph_scratchtoolpp
705%attr(755,root,root) %{_bindir}/ceph_smalliobench
706%attr(755,root,root) %{_bindir}/ceph_smalliobenchdumb
707%attr(755,root,root) %{_bindir}/ceph_smalliobenchfs
708%attr(755,root,root) %{_bindir}/ceph_smalliobenchrbd
709%attr(755,root,root) %{_bindir}/ceph_test_*
710%attr(755,root,root) %{_bindir}/ceph_tpbench
711%attr(755,root,root) %{_bindir}/ceph_xattr_bench
712%attr(755,root,root) %{_libdir}/ceph/ceph-monstore-update-crush.sh
713%{_mandir}/man8/ceph-debugpack.8*
714%{_mandir}/man8/ceph-kvstore-tool.8*
715%endif
716
79dc5cad
JB
717%if %{with fio}
718%files -n fio-ceph-objectstore
719%defattr(644,root,root,755)
720%doc src/test/fio/{README.md,ceph-*.conf,ceph-*.fio}
721%attr(755,root,root) %{_libdir}/libfio_ceph_objectstore.so
722%endif
This page took 0.194149 seconds and 4 git commands to generate.