]> git.pld-linux.org Git - packages/ceph.git/blame - ceph.spec
- up to 0.94.2
[packages/ceph.git] / ceph.spec
CommitLineData
b6163d67
JK
1# TODO:
2# - accelio libxio (BR: accelio libibverbs-devel librdmacm-devel
3# - proper init scripts if non-systemd boot is too be supported
4# (upstream scripts seem overcomplicated and hardly useful)
bef2a0ad 5# - run as non-root user
b6163d67 6#
714b93ed
JB
7#
8# Conditional build:
7f577810
JB
9%bcond_without java # Java binding
10%bcond_with kinetic # Kinetic storage support [needs update for internal API changes]
11%bcond_with rocksdb # RocksDB storage support [needs update for internal API changes]
12%bcond_with zfs # ZFS support
13%bcond_without lttng # LTTng tracing
14%bcond_without babeltrace # Babeltrace traces support
15%bcond_without tcmalloc # tcmalloc allocator
6fce7056
JR
16
17%ifarch x32
18%undefine with_tcmalloc
19%endif
714b93ed 20#
2a1a6301 21Summary: User space components of the Ceph file system
e5fc70df 22Summary(pl.UTF-8): Działające w przestrzeni użytkownika elementy systemu plików Ceph
2a1a6301 23Name: ceph
492b9f08
AM
24Version: 0.94.2
25Release: 1
9e1f65de 26License: LGPL v2.1 (libraries), GPL v2 (some programs)
2a1a6301 27Group: Base
c408d7b3 28Source0: http://ceph.com/download/%{name}-%{version}.tar.bz2
492b9f08 29# Source0-md5: 249648d35e634adaaeec727408ca6092
b6163d67
JK
30Source1: ceph.sysconfig
31# based on files from https://github.com/ceph/ceph/tree/master/systemd
32Source10: cephctl
33Source11: ceph-mds@.service
34Source12: ceph-mon@.service
35Source13: ceph-osd@.service
36Source14: ceph.target
37Source15: ceph.tmpfiles
2a1a6301
JR
38Patch0: %{name}-init-fix.patch
39Patch1: %{name}.logrotate.patch
7f577810 40Patch2: %{name}-link.patch
b431df60 41Patch3: %{name}-ac.patch
c408d7b3 42URL: http://ceph.com/
714b93ed
JB
43BuildRequires: autoconf >= 2.59
44BuildRequires: automake
7f577810 45%{?with_babeltrace:BuildRequires: babeltrace-devel}
714b93ed 46BuildRequires: boost-devel >= 1.34
2a1a6301 47BuildRequires: curl-devel
714b93ed 48BuildRequires: expat-devel >= 1.95
2a1a6301
JR
49BuildRequires: fcgi-devel
50BuildRequires: gdbm-devel
7db8c214 51%if %{with java}
4f42482b
JB
52BuildRequires: jdk
53%endif
2a1a6301 54BuildRequires: keyutils-devel
9a1a508c 55%{?with_kinetic:BuildRequires: kinetic-cpp-client}
548e0d3f 56BuildRequires: leveldb-devel >= 1.2
714b93ed 57BuildRequires: libaio-devel
2a1a6301 58BuildRequires: libatomic_ops
548e0d3f 59BuildRequires: libblkid-devel >= 2.17
714b93ed 60BuildRequires: libedit-devel >= 2.11
2a1a6301
JR
61BuildRequires: libfuse-devel
62BuildRequires: libltdl-devel
f965be58 63BuildRequires: libs3-devel
2a1a6301 64BuildRequires: libstdc++-devel
6fce7056 65%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
714b93ed 66BuildRequires: libtool >= 2:1.5
2a1a6301 67BuildRequires: libuuid-devel
7f577810 68%{?with_lttng:BuildRequires: lttng-ust-devel}
6fce7056 69BuildRequires: nss-devel
e5fc70df 70BuildRequires: perl-base
2a1a6301 71BuildRequires: pkgconfig
714b93ed 72BuildRequires: python >= 1:2.4
9a1a508c 73%{?with_rocksdb:BuildRequires: rocksdb-devel}
bef2a0ad 74BuildRequires: rpmbuild(macros) >= 1.671
f965be58 75BuildRequires: snappy-devel
548e0d3f 76BuildRequires: udev-devel
fa260b6c 77BuildRequires: xfsprogs-devel
7db8c214
JB
78%ifarch %{x8664}
79BuildRequires: yasm
80%endif
430360a9 81%{?with_zfs:BuildRequires: zfs-devel}
2a1a6301
JR
82Requires(post,preun): /sbin/chkconfig
83Requires(preun): rc-scripts
84Requires: %{name}-libs = %{version}-%{release}
7cabda16 85Requires: python-%{name} = %{version}-%{release}
bef2a0ad 86Requires: systemd-units >= 38
60d5543f 87Obsoletes: gcephtool
7db8c214 88Obsoletes: hadoop-cephfs
2a1a6301
JR
89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
7db8c214 91%define skip_post_check_so libcls_.*.so.* libec_.*.so.*
2a1a6301
JR
92
93%description
94Ceph is a distributed network file system designed to provide
95excellent performance, reliability, and scalability.
96
e5fc70df
JB
97%description -l pl.UTF-8
98Ceph to rozproszony sieciowy system plików zaprojektowany z myślą o
99dobrej wydajności, wiarygodności i skalowalności.
100
2a1a6301
JR
101%package libs
102Summary: Ceph shared libraries
e5fc70df 103Summary(pl.UTF-8): Biblioteki współdzielone Cepha
2a1a6301
JR
104Group: Libraries
105
106%description libs
107Ceph shared libraries.
108
e5fc70df
JB
109%description libs -l pl.UTF-8
110Biblioteki współdzielone Cepha.
2a1a6301
JR
111
112%package devel
e5fc70df
JB
113Summary: Ceph header files
114Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Cepha
96c29907 115License: LGPL v2.1
2a1a6301
JR
116Group: Development/Libraries
117Requires: %{name}-libs = %{version}-%{release}
96c29907 118Requires: boost-devel >= 1.34
6fce7056 119Requires: nss-devel
96c29907
JB
120Requires: leveldb-devel
121Requires: libatomic_ops
122Requires: libuuid-devel
2a1a6301
JR
123
124%description devel
125This package contains the headers needed to develop programs that use
126Ceph.
127
e5fc70df
JB
128%description devel -l pl.UTF-8
129Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
130wykorzystujących Cepha.
131
2a1a6301
JR
132%package static
133Summary: Ceph static libraries
e5fc70df 134Summary(pl.UTF-8): Biblioteki statyczne Cepha
96c29907 135License: LGPL v2.1
2a1a6301
JR
136Group: Development/Libraries
137Requires: %{name}-devel = %{version}-%{release}
138
139%description static
140This package contains static Ceph libraries.
141
e5fc70df
JB
142%description static -l pl.UTF-8
143Ten pakiet zawiera biblioteki statyczne Cepha.
144
145%package -n python-ceph
146Summary: Ceph Python bindings
147Summary(pl.UTF-8): Wiązania Pythona do bibliotek Cepha
148Group: Development/Languages/Python
149Requires: %{name}-libs = %{version}-%{release}
150
151%description -n python-ceph
152Ceph Python bindings.
153
154%description -n python-ceph -l pl.UTF-8
155Wiązania Pythona do bibliotek Cepha.
156
4f42482b
JB
157%package -n java-cephfs
158Summary: CephFS Java bindings
159Summary(pl.UTF-8): Wiązania Javy do biblioteki CephFS
160Group: Libraries/Java
161Requires: %{name}-libs = %{version}-%{release}
162
163%description -n java-cephfs
164CephFS Java bindings.
165
166%description -n java-cephfs -l pl.UTF-8
167Wiązania Javy do biblioteki CephFS.
168
e5fc70df
JB
169%package fuse
170Summary: Ceph FUSE-based client
171Summary(pl.UTF-8): Klient Cepha oparty na FUSE
172Group: Base
173Requires: %{name} = %{version}-%{release}
174
175%description fuse
176FUSE based client for Ceph distributed network file system.
177
178%description fuse -l pl.UTF-8
179Oparty na FUSE klient rozproszonego sieciowego systemu plików Ceph.
180
2a1a6301
JR
181%package radosgw
182Summary: rados REST gateway
e5fc70df
JB
183Summary(pl.UTF-8): Bramka REST-owa rados
184Group: Applications/System
2a1a6301
JR
185#Requires: apache-mod_fcgid
186
187%description radosgw
188radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
189implemented as a FastCGI module using libfcgi, and can be used in
190conjunction with any FastCGI capable web server.
191
e5fc70df
JB
192%description radosgw -l pl.UTF-8
193radosgw to REST-owa bramka HTTP S3 do przechowalni obiektów RADOS.
194Jest zaimplementowana jako moduł FastCGI wykorzystujący libfcgi i może
195być używana w połączeniu z dowolnym serwerem WWW obsługującym FastCGI.
196
245cb856 197%package resource-agents
8029515d
JB
198Summary: OCF Resource Agents for Ceph processes
199Summary(pl.UTF-8): Agenci OCF do monitorowania procesów Cepha
200Group: Applications/System
201Requires: %{name} = %{version}-%{release}
202Requires: resource-agents
203
245cb856 204%description resource-agents
8029515d
JB
205OCF Resource Agents for Ceph processes.
206
245cb856 207%description resource-agents -l pl.UTF-8
8029515d
JB
208Agenci OCF do monitorowania procesów Cepha.
209
2a1a6301
JR
210%prep
211%setup -q
212%patch0 -p1
96a54cb4 213%patch1 -p1
9a1a508c 214%patch2 -p1
b431df60 215%patch3 -p1
2a1a6301
JR
216
217%build
218%{__libtoolize}
d078b205 219%{__aclocal} -I m4
2a1a6301
JR
220%{__autoconf}
221%{__autoheader}
222%{__automake}
c1654e29
JB
223# ac_cv_prog_uudecode_base64=no is a hack to compile Test.class instead of
224# using included one which fails with Sun/Oracle JDK 1.6
2a1a6301 225%configure \
ac843c96 226 %{?with_java:JAVAC=/usr/bin/javac} \
ae4b5127 227 %{?with_zfs:LIBZFS_CFLAGS="-I/usr/include/libzfs -I/usr/include/libspl"} \
c1654e29 228 ac_cv_prog_uudecode_base64=no \
2a1a6301 229 --sbindir=/sbin \
7f577810 230 %{!?with_babeltrace:--without-babeltrace} \
6fce7056
JR
231 --without-cryptopp \
232 --with-nss \
233 %{!?with_tcmalloc:--without-tcmalloc} \
9a1a508c
JB
234 %{?with_kinetic:--with-kinetic} \
235 %{?with_rocksdb:--with-librocksdb} \
430360a9 236 %{?with_zfs:--with-libzfs} \
7f577810 237 %{!?with_lttng:--without-lttng} \
8029515d 238 --with-ocf \
2a1a6301 239 --with-radosgw \
f965be58
JB
240 --with-system-leveldb \
241 --with-system-libs3 \
4f42482b 242 %{?with_java:--enable-cephfs-java --with-jdk-dir=%{_jvmdir}/java} \
714b93ed 243 --disable-silent-rules
2a1a6301 244
5e0a173c 245%{__make} -j1
2a1a6301
JR
246
247%install
248rm -rf $RPM_BUILD_ROOT
bef2a0ad
JK
249install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib/ceph/{tmp,mon,osd,mds},log/ceph/stat,run/ceph} \
250 $RPM_BUILD_ROOT%{_sysconfdir}/{ceph,bash_completion.d,logrotate.d,rc.d/init.d,sysconfig} \
251 $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir},/etc/systemd/system/ceph.target.wants}
4f42482b 252
2a1a6301 253%{__make} install \
4f42482b
JB
254 DESTDIR=$RPM_BUILD_ROOT \
255 javadir=%{_javadir}
2a1a6301
JR
256
257install -p src/init-ceph $RPM_BUILD_ROOT/etc/rc.d/init.d/ceph
258install -p src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ceph
259
bef2a0ad 260install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/ceph
b6163d67
JK
261install %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}
262install %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}
263ln -sf /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/ceph.service
264install %{SOURCE15} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/ceph.conf
265
7e46b55b 266# loadable modules
c408d7b3 267%{__rm} $RPM_BUILD_ROOT%{_libdir}/ceph/erasure-code/*.{a,la}
c8a22313 268%{__rm} $RPM_BUILD_ROOT%{_libdir}/rados-classes/*.{a,la}
4f42482b
JB
269%if %{with java}
270%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcephfs_jni.{la,a}
271%endif
272
7e46b55b
JB
273# packaged as %doc
274%{__rm} $RPM_BUILD_ROOT%{_docdir}/ceph/sample.{ceph.conf,fetch_config}
245cb856 275
714b93ed 276%py_postclean
2a1a6301
JR
277
278%clean
279rm -rf $RPM_BUILD_ROOT
280
281%post
282/sbin/chkconfig --add ceph
283%service ceph restart
284
bef2a0ad
JK
285# actual services are to be enabled on cluster deployment
286%systemd_post %{name}.target
287
2a1a6301
JR
288%preun
289if [ "$1" = "0" ] ; then
72daa1da
JR
290 %service ceph stop
291 /sbin/chkconfig --del ceph
2a1a6301 292fi
bef2a0ad
JK
293%systemd_preun %{name}.target
294
295%postun
296%systemd_reload
2a1a6301 297
e5fc70df
JB
298%post libs -p /sbin/ldconfig
299%postun libs -p /sbin/ldconfig
2a1a6301 300
4f42482b
JB
301%post -n java-cephfs -p /sbin/ldconfig
302%postun -n java-cephfs -p /sbin/ldconfig
303
2a1a6301
JR
304%files
305%defattr(644,root,root,755)
9e1f65de
JB
306# COPYING specifies licenses of individual parts
307%doc AUTHORS COPYING README src/sample.ceph.conf src/sample.fetch_config
2a1a6301 308%attr(754,root,root) /etc/rc.d/init.d/ceph
bef2a0ad
JK
309%config(noreplace) /etc/sysconfig/ceph
310%dir /etc/systemd/system/ceph.target.wants
311%{systemdunitdir}/ceph-mds@.service
312%{systemdunitdir}/ceph-mon@.service
313%{systemdunitdir}/ceph-osd@.service
314%{systemdunitdir}/ceph.service
315%{systemdunitdir}/ceph.target
316%{systemdtmpfilesdir}/ceph.conf
2a1a6301
JR
317%dir %{_sysconfdir}/ceph
318%attr(755,root,root) %{_bindir}/ceph
8c5712e2 319%attr(755,root,root) %{_bindir}/ceph-authtool
fa260b6c 320%attr(755,root,root) %{_bindir}/ceph-brag
2a1a6301 321%attr(755,root,root) %{_bindir}/ceph-clsinfo
8c5712e2
JB
322%attr(755,root,root) %{_bindir}/ceph-conf
323%attr(755,root,root) %{_bindir}/ceph-coverage
d91e5335 324%attr(755,root,root) %{_bindir}/ceph-crush-location
8c5712e2 325%attr(755,root,root) %{_bindir}/ceph-debugpack
60d5543f 326%attr(755,root,root) %{_bindir}/ceph-dencoder
2a1a6301 327%attr(755,root,root) %{_bindir}/ceph-mds
8c5712e2 328%attr(755,root,root) %{_bindir}/ceph-mon
7f577810 329%attr(755,root,root) %{_bindir}/ceph-objectstore-tool
2a1a6301 330%attr(755,root,root) %{_bindir}/ceph-osd
5e39e43e 331%attr(755,root,root) %{_bindir}/ceph-post-file
2a1a6301 332%attr(755,root,root) %{_bindir}/ceph-rbdnamer
4f411dc5 333%attr(755,root,root) %{_bindir}/ceph-rest-api
8c5712e2
JB
334%attr(755,root,root) %{_bindir}/ceph-run
335%attr(755,root,root) %{_bindir}/ceph-syn
bef2a0ad 336%attr(755,root,root) %{_bindir}/cephctl
8c5712e2 337%attr(755,root,root) %{_bindir}/cephfs
ae4b5127 338%attr(755,root,root) %{_bindir}/cephfs-journal-tool
b431df60 339%attr(755,root,root) %{_bindir}/cephfs-table-tool
8c5712e2 340%attr(755,root,root) %{_bindir}/crushtool
2a1a6301 341%attr(755,root,root) %{_bindir}/librados-config
8c5712e2
JB
342%attr(755,root,root) %{_bindir}/monmaptool
343%attr(755,root,root) %{_bindir}/osdmaptool
2a1a6301
JR
344%attr(755,root,root) %{_bindir}/rados
345%attr(755,root,root) %{_bindir}/rbd
8c5712e2 346%attr(755,root,root) %{_bindir}/rbd-fuse
9a1a508c 347%attr(755,root,root) %{_bindir}/rbd-replay
7f577810 348%attr(755,root,root) %{_bindir}/rbd-replay-many
9a1a508c 349%attr(755,root,root) %{_bindir}/rbd-replay-prep
8dda6d30
JB
350%attr(755,root,root) /sbin/ceph-create-keys
351%attr(755,root,root) /sbin/ceph-disk
352%attr(755,root,root) /sbin/ceph-disk-activate
353%attr(755,root,root) /sbin/ceph-disk-prepare
354%attr(755,root,root) /sbin/ceph-disk-udev
4f42482b
JB
355%attr(755,root,root) /sbin/mount.ceph
356%attr(755,root,root) /sbin/mount.fuse.ceph
c408d7b3 357%dir %{_libdir}/ceph
548e0d3f 358%attr(755,root,root) %{_libdir}/ceph/ceph-osd-prestart.sh
c408d7b3
JB
359%{_libdir}/ceph/ceph_common.sh
360%dir %{_libdir}/ceph/erasure-code
361%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_example.so*
362%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_fail_to_initialize.so*
363%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_fail_to_register.so*
364%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_hangs.so*
58dc957f 365%ifarch %{x8664}
066d8601 366%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_isa.so*
6fce7056 367%endif
c408d7b3 368%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure.so*
0509a77e 369%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_generic.so*
7f577810
JB
370%ifarch arm
371%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_neon.so*
372%endif
373%ifarch %{ix86} %{x8664} x32
0509a77e 374%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse3.so*
7f577810
JB
375%endif
376%ifarch %{x8664} x32
0509a77e 377%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse4.so*
7f577810 378%endif
9a1a508c 379%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_lrc.so*
c408d7b3 380%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_entry_point.so*
9a1a508c 381%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_version.so*
b431df60 382%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec.so*
0509a77e 383%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_generic.so*
7f577810 384%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_neon.so*
0509a77e
JB
385%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse3.so*
386%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse4.so*
2a1a6301 387%dir %{_libdir}/rados-classes
5e39e43e 388%attr(755,root,root) %{_libdir}/rados-classes/libcls_hello.so*
7e46b55b 389%attr(755,root,root) %{_libdir}/rados-classes/libcls_kvs.so*
60d5543f 390%attr(755,root,root) %{_libdir}/rados-classes/libcls_lock.so*
4f411dc5 391%attr(755,root,root) %{_libdir}/rados-classes/libcls_log.so*
2a1a6301 392%attr(755,root,root) %{_libdir}/rados-classes/libcls_rbd.so*
7e46b55b 393%attr(755,root,root) %{_libdir}/rados-classes/libcls_refcount.so*
4f411dc5 394%attr(755,root,root) %{_libdir}/rados-classes/libcls_replica_log.so*
2a1a6301 395%attr(755,root,root) %{_libdir}/rados-classes/libcls_rgw.so*
4f411dc5 396%attr(755,root,root) %{_libdir}/rados-classes/libcls_statelog.so*
c8a22313 397%attr(755,root,root) %{_libdir}/rados-classes/libcls_user.so*
4f411dc5 398%attr(755,root,root) %{_libdir}/rados-classes/libcls_version.so*
5e39e43e 399%{_datadir}/ceph
2a1a6301
JR
400%config(noreplace) /etc/logrotate.d/ceph
401%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
402%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
403%config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
404%{_mandir}/man8/ceph.8*
405%{_mandir}/man8/ceph-authtool.8*
406%{_mandir}/man8/ceph-clsinfo.8*
407%{_mandir}/man8/ceph-conf.8*
408%{_mandir}/man8/ceph-debugpack.8*
60d5543f 409%{_mandir}/man8/ceph-dencoder.8*
7f577810
JB
410%{_mandir}/man8/ceph-deploy.8*
411%{_mandir}/man8/ceph-disk.8*
2a1a6301
JR
412%{_mandir}/man8/ceph-mds.8*
413%{_mandir}/man8/ceph-mon.8*
414%{_mandir}/man8/ceph-osd.8*
5e39e43e 415%{_mandir}/man8/ceph-post-file.8*
60d5543f 416%{_mandir}/man8/ceph-rbdnamer.8*
4f411dc5 417%{_mandir}/man8/ceph-rest-api.8*
2a1a6301
JR
418%{_mandir}/man8/ceph-run.8*
419%{_mandir}/man8/ceph-syn.8*
420%{_mandir}/man8/cephfs.8*
421%{_mandir}/man8/crushtool.8*
422%{_mandir}/man8/librados-config.8*
2a1a6301
JR
423%{_mandir}/man8/monmaptool.8*
424%{_mandir}/man8/mount.ceph.8*
425%{_mandir}/man8/osdmaptool.8*
426%{_mandir}/man8/rados.8*
427%{_mandir}/man8/radosgw.8*
428%{_mandir}/man8/radosgw-admin.8*
429%{_mandir}/man8/rbd.8*
8c5712e2 430%{_mandir}/man8/rbd-fuse.8*
9a1a508c 431%{_mandir}/man8/rbd-replay.8*
7f577810 432%{_mandir}/man8/rbd-replay-many.8*
9a1a508c 433%{_mandir}/man8/rbd-replay-prep.8*
60d5543f 434
2a1a6301 435%dir %{_localstatedir}/lib/ceph
b6163d67
JK
436%dir %{_localstatedir}/lib/ceph/mds
437%dir %{_localstatedir}/lib/ceph/mon
438%dir %{_localstatedir}/lib/ceph/osd
2a1a6301
JR
439%dir %{_localstatedir}/lib/ceph/tmp
440%dir %{_localstatedir}/log/ceph
bef2a0ad 441%dir %{_localstatedir}/run/ceph
2a1a6301
JR
442
443%files libs
444%defattr(644,root,root,755)
445%attr(755,root,root) %{_libdir}/libcephfs.so.*.*.*
446%attr(755,root,root) %ghost %{_libdir}/libcephfs.so.1
447%attr(755,root,root) %{_libdir}/librados.so.*.*.*
448%attr(755,root,root) %ghost %{_libdir}/librados.so.2
548e0d3f
JB
449%attr(755,root,root) %{_libdir}/libradosstriper.so.*.*.*
450%attr(755,root,root) %ghost %{_libdir}/libradosstriper.so.1
2a1a6301
JR
451%attr(755,root,root) %{_libdir}/librbd.so.*.*.*
452%attr(755,root,root) %ghost %{_libdir}/librbd.so.1
2a1a6301 453
2a1a6301
JR
454%files devel
455%defattr(644,root,root,755)
2a1a6301
JR
456%attr(755,root,root) %{_libdir}/libcephfs.so
457%attr(755,root,root) %{_libdir}/librados.so
548e0d3f 458%attr(755,root,root) %{_libdir}/libradosstriper.so
2a1a6301
JR
459%attr(755,root,root) %{_libdir}/librbd.so
460%{_libdir}/libcephfs.la
461%{_libdir}/librados.la
548e0d3f 462%{_libdir}/libradosstriper.la
2a1a6301 463%{_libdir}/librbd.la
e5fc70df
JB
464%{_includedir}/cephfs
465%{_includedir}/rados
548e0d3f 466%{_includedir}/radosstriper
e5fc70df 467%{_includedir}/rbd
2a1a6301
JR
468
469%files static
470%defattr(644,root,root,755)
471%{_libdir}/libcephfs.a
472%{_libdir}/librados.a
548e0d3f 473%{_libdir}/libradosstriper.a
2a1a6301
JR
474%{_libdir}/librbd.a
475
e5fc70df
JB
476%files -n python-ceph
477%defattr(644,root,root,755)
67f1bff3 478%{py_sitescriptdir}/ceph_argparse.py[co]
4f411dc5 479%{py_sitescriptdir}/ceph_rest_api.py[co]
e54009d4 480%{py_sitescriptdir}/cephfs.py[co]
714b93ed
JB
481%{py_sitescriptdir}/rados.py[co]
482%{py_sitescriptdir}/rbd.py[co]
e5fc70df 483
4f42482b
JB
484%if %{with java}
485%files -n java-cephfs
486%defattr(644,root,root,755)
487%attr(755,root,root) %{_libdir}/libcephfs_jni.so.*.*.*
488%attr(755,root,root) %ghost %{_libdir}/libcephfs_jni.so.1
489%attr(755,root,root) %{_libdir}/libcephfs_jni.so
490%{_javadir}/libcephfs.jar
491%endif
492
e5fc70df
JB
493%files fuse
494%defattr(644,root,root,755)
e5fc70df
JB
495%attr(755,root,root) %{_bindir}/ceph-fuse
496%{_mandir}/man8/ceph-fuse.8*
497
2a1a6301
JR
498%files radosgw
499%defattr(644,root,root,755)
500%attr(755,root,root) %{_bindir}/radosgw
501%attr(755,root,root) %{_bindir}/radosgw-admin
502%{_sysconfdir}/bash_completion.d/radosgw-admin
503
245cb856 504%files resource-agents
8029515d
JB
505%defattr(644,root,root,755)
506%dir %{_prefix}/lib/ocf/resource.d/ceph
507%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/ceph
508%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/mds
509%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/mon
510%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/osd
511%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
This page took 0.206198 seconds and 4 git commands to generate.