]> git.pld-linux.org Git - packages/ceph.git/blame - ceph.spec
- added zfs patch (adjust for zfs 0.8.0 API change)
[packages/ceph.git] / ceph.spec
CommitLineData
b6163d67 1# TODO:
bbcdc7ce
JB
2# - proper init scripts if non-systemd boot is too be supported
3# (upstream scripts seem overcomplicated and hardly useful)
4# - run as non-root user
b6163d67 5#
19c20e80
JR
6# Note on versioning: http://docs.ceph.com/docs/master/releases/
7#
714b93ed 8# Conditional build:
7f577810 9%bcond_without java # Java binding
bbcdc7ce 10%bcond_with accelio # Accelio transport support [needs update for internal API changes]
1b11728e
JB
11%bcond_with cryptopp # use cryptopp instead of NSS crypto/SSL
12%bcond_with dpdk # DPDK messaging (requires cryptopp instead of nss)
13%bcond_with fcgi # RADOS Gateway FCGI frontend
14%bcond_with fio # FIO engines support
15%bcond_without pmem # PMDK (persistent memory) support
16%bcond_with spdk # Ceph SPDK support (DPDK based)
17%bcond_without system_rocksdb # system RocksDB storage support
bbcdc7ce 18%bcond_with zfs # ZFS support [not ready for zfs 0.8.x]
7f577810
JB
19%bcond_without lttng # LTTng tracing
20%bcond_without babeltrace # Babeltrace traces support
21%bcond_without tcmalloc # tcmalloc allocator
6fce7056
JR
22
23%ifarch x32
24%undefine with_tcmalloc
25%endif
1b11728e
JB
26%ifnarch %{x8664} aarch64
27%undefine with_pmem
28%endif
29%if %{without cryptopp} && %{with dpdk}
30%error DPDK requires cryptopp
31%endif
714b93ed 32#
2a1a6301 33Summary: User space components of the Ceph file system
e5fc70df 34Summary(pl.UTF-8): Działające w przestrzeni użytkownika elementy systemu plików Ceph
2a1a6301 35Name: ceph
1b11728e 36Version: 12.2.13
bbcdc7ce 37Release: 1
9e1f65de 38License: LGPL v2.1 (libraries), GPL v2 (some programs)
2a1a6301 39Group: Base
4447516f 40Source0: http://download.ceph.com/tarballs/%{name}-%{version}.tar.gz
1b11728e 41# Source0-md5: 38bd01cf8224c9ca081298e19ab6e5a1
b6163d67 42Source1: ceph.sysconfig
bbcdc7ce
JB
43Source2: cephctl
44Source3: ceph.tmpfiles
2a1a6301
JR
45Patch0: %{name}-init-fix.patch
46Patch1: %{name}.logrotate.patch
1b11728e
JB
47Patch2: boost.patch
48Patch3: %{name}-python.patch
49Patch4: %{name}-types.patch
50Patch5: %{name}-tcmalloc.patch
51Patch6: %{name}-rocksdb.patch
52Patch7: %{name}-fcgi.patch
79dc5cad 53Patch8: %{name}-fio.patch
101b8bdd 54Patch9: %{name}-zfs.patch
e3919159 55URL: https://ceph.io/
477a1b20 56%{?with_accelio:BuildRequires: accelio-devel}
7f577810 57%{?with_babeltrace:BuildRequires: babeltrace-devel}
1b11728e
JB
58BuildRequires: boost-devel >= 1.66
59BuildRequires: cmake >= 2.8.11
60%{?with_cryptopp:BuildRequires: cryptopp-devel}
2a1a6301 61BuildRequires: curl-devel
1b11728e
JB
62%if %{with dpdk} || %{with spdk}
63BuildRequires: dpdk-devel
64%endif
714b93ed 65BuildRequires: expat-devel >= 1.95
1b11728e
JB
66%{?with_fcgi:BuildRequires: fcgi-devel}
67%{?with_fio:BuildRequires: fio-devel}
2a1a6301 68BuildRequires: gdbm-devel
7db8c214 69%if %{with java}
4f42482b
JB
70BuildRequires: jdk
71%endif
2a1a6301 72BuildRequires: keyutils-devel
548e0d3f 73BuildRequires: leveldb-devel >= 1.2
714b93ed 74BuildRequires: libaio-devel
2a1a6301 75BuildRequires: libatomic_ops
548e0d3f 76BuildRequires: libblkid-devel >= 2.17
714b93ed 77BuildRequires: libedit-devel >= 2.11
2a1a6301 78BuildRequires: libfuse-devel
1b11728e 79# +RDMA?
477a1b20 80%{?with_accelio:BuildRequires: libibverbs-devel}
2a1a6301 81BuildRequires: libltdl-devel
477a1b20 82%{?with_accelio:BuildRequires: librdmacm-devel}
bbcdc7ce 83BuildRequires: libstdc++-devel >= 6:4.7
6fce7056 84%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
714b93ed 85BuildRequires: libtool >= 2:1.5
2a1a6301 86BuildRequires: libuuid-devel
bbcdc7ce 87BuildRequires: libxml2-devel >= 2.0
7f577810 88%{?with_lttng:BuildRequires: lttng-ust-devel}
1b11728e
JB
89BuildRequires: lz4-devel >= 1:1.7
90%{!?with_cryptopp:BuildRequires: nss-devel >= 3}
bbcdc7ce
JB
91BuildRequires: openldap-devel
92BuildRequires: openssl-devel
e5fc70df 93BuildRequires: perl-base
2a1a6301 94BuildRequires: pkgconfig
1b11728e 95%{?with_pmem:BuildRequires: pmdk-devel}
bbcdc7ce 96BuildRequires: python >= 1:2.7
1b11728e 97BuildRequires: python-devel >= 1:2.7
bbcdc7ce 98BuildRequires: python-Cython
1b11728e 99BuildRequires: python3-devel >= 1:3.2
101b8bdd
JB
100# upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
101%{?with_system_rocksdb:BuildRequires: rocksdb-devel >= 5.6.0}
bef2a0ad 102BuildRequires: rpmbuild(macros) >= 1.671
e3919159 103BuildRequires: sed >= 4.0
f965be58 104BuildRequires: snappy-devel
bbcdc7ce 105BuildRequires: sphinx-pdg-2 >= 1.0
548e0d3f 106BuildRequires: udev-devel
1b11728e 107#BuildRequires: virtualenv for tests
b1fa8ffe 108%{?with_dpdk:BuildRequires: xorg-lib-libpciaccess-devel}
fa260b6c 109BuildRequires: xfsprogs-devel
7db8c214
JB
110%ifarch %{x8664}
111BuildRequires: yasm
112%endif
101b8bdd
JB
113# zfs patch updates to 0.8.0 API
114%{?with_zfs:BuildRequires: zfs-devel >= 0.8.0}
bbcdc7ce 115BuildRequires: zlib-devel
2a1a6301
JR
116Requires(post,preun): /sbin/chkconfig
117Requires(preun): rc-scripts
118Requires: %{name}-libs = %{version}-%{release}
7cabda16 119Requires: python-%{name} = %{version}-%{release}
bef2a0ad 120Requires: systemd-units >= 38
60d5543f 121Obsoletes: gcephtool
7db8c214 122Obsoletes: hadoop-cephfs
2a1a6301
JR
123BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
1b11728e 125%define skip_post_check_so libceph_lz4.so.* libceph_snappy.so.* libceph_zlib.so.* libceph_zstd.so.* libcls_.*.so.* libec_.*.so.*
2a1a6301
JR
126
127%description
128Ceph is a distributed network file system designed to provide
129excellent performance, reliability, and scalability.
130
e5fc70df
JB
131%description -l pl.UTF-8
132Ceph to rozproszony sieciowy system plików zaprojektowany z myślą o
133dobrej wydajności, wiarygodności i skalowalności.
134
2a1a6301
JR
135%package libs
136Summary: Ceph shared libraries
e5fc70df 137Summary(pl.UTF-8): Biblioteki współdzielone Cepha
2a1a6301
JR
138Group: Libraries
139
140%description libs
141Ceph shared libraries.
142
e5fc70df
JB
143%description libs -l pl.UTF-8
144Biblioteki współdzielone Cepha.
2a1a6301
JR
145
146%package devel
e5fc70df
JB
147Summary: Ceph header files
148Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Cepha
96c29907 149License: LGPL v2.1
2a1a6301
JR
150Group: Development/Libraries
151Requires: %{name}-libs = %{version}-%{release}
1b11728e 152Requires: boost-devel >= 1.66
bbcdc7ce
JB
153Requires: curl-devel
154Requires: expat-devel
155Requires: fcgi-devel
156Requires: nss-devel >= 3
96c29907
JB
157Requires: leveldb-devel
158Requires: libatomic_ops
bbcdc7ce
JB
159Requires: libblkid-devel >= 2.17
160Requires: libstdc++-devel >= 6:4.7
96c29907 161Requires: libuuid-devel
bbcdc7ce
JB
162%{?with_lttng:Requires: lttng-ust-devel}
163Requires: openldap-devel
1b11728e 164Obsoletes: ceph-static < 12
2a1a6301
JR
165
166%description devel
167This package contains the headers needed to develop programs that use
168Ceph.
169
e5fc70df
JB
170%description devel -l pl.UTF-8
171Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
172wykorzystujących Cepha.
173
e5fc70df 174%package -n python-ceph
1b11728e
JB
175Summary: Ceph Python 2 bindings
176Summary(pl.UTF-8): Wiązania Pythona 2 do bibliotek Cepha
e5fc70df
JB
177Group: Development/Languages/Python
178Requires: %{name}-libs = %{version}-%{release}
179
180%description -n python-ceph
1b11728e 181Ceph Python 2 bindings.
e5fc70df
JB
182
183%description -n python-ceph -l pl.UTF-8
1b11728e
JB
184Wiązania Pythona 2 do bibliotek Cepha.
185
186%package -n python3-ceph
187Summary: Ceph Python 3 bindings
188Summary(pl.UTF-8): Wiązania Pythona 3 do bibliotek Cepha
189Group: Development/Languages/Python
190Requires: %{name}-libs = %{version}-%{release}
191
192%description -n python3-ceph
193Ceph Python 3 bindings.
194
195%description -n python3-ceph -l pl.UTF-8
196Wiązania Pythona 3 do bibliotek Cepha.
e5fc70df 197
4f42482b
JB
198%package -n java-cephfs
199Summary: CephFS Java bindings
200Summary(pl.UTF-8): Wiązania Javy do biblioteki CephFS
201Group: Libraries/Java
202Requires: %{name}-libs = %{version}-%{release}
203
204%description -n java-cephfs
205CephFS Java bindings.
206
207%description -n java-cephfs -l pl.UTF-8
208Wiązania Javy do biblioteki CephFS.
209
e5fc70df
JB
210%package fuse
211Summary: Ceph FUSE-based client
212Summary(pl.UTF-8): Klient Cepha oparty na FUSE
213Group: Base
214Requires: %{name} = %{version}-%{release}
215
216%description fuse
217FUSE based client for Ceph distributed network file system.
218
219%description fuse -l pl.UTF-8
220Oparty na FUSE klient rozproszonego sieciowego systemu plików Ceph.
221
2a1a6301
JR
222%package radosgw
223Summary: rados REST gateway
e5fc70df
JB
224Summary(pl.UTF-8): Bramka REST-owa rados
225Group: Applications/System
2a1a6301
JR
226#Requires: apache-mod_fcgid
227
228%description radosgw
229radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
230implemented as a FastCGI module using libfcgi, and can be used in
231conjunction with any FastCGI capable web server.
232
e5fc70df
JB
233%description radosgw -l pl.UTF-8
234radosgw to REST-owa bramka HTTP S3 do przechowalni obiektów RADOS.
235Jest zaimplementowana jako moduł FastCGI wykorzystujący libfcgi i może
236być używana w połączeniu z dowolnym serwerem WWW obsługującym FastCGI.
237
245cb856 238%package resource-agents
8029515d
JB
239Summary: OCF Resource Agents for Ceph processes
240Summary(pl.UTF-8): Agenci OCF do monitorowania procesów Cepha
241Group: Applications/System
242Requires: %{name} = %{version}-%{release}
243Requires: resource-agents
244
245cb856 245%description resource-agents
8029515d
JB
246OCF Resource Agents for Ceph processes.
247
245cb856 248%description resource-agents -l pl.UTF-8
8029515d
JB
249Agenci OCF do monitorowania procesów Cepha.
250
79dc5cad
JB
251%package -n fio-ceph-objectstore
252Summary: FIO engine module for Ceph ObjectStore
253Summary(pl.UTF-8): Moduł silnika FIO do używania Ceph ObjectStore
254Group: Libraries
255Requires: %{name}-libs = %{version}-%{release}
101b8bdd 256%if %{with fio}
79dc5cad 257%requires_ge_to fio fio-devel
101b8bdd 258%endif
79dc5cad
JB
259
260%description -n fio-ceph-objectstore
261This FIO engine allows you to mount and use a ceph object store
262directly, without having to build a ceph cluster or start any daemons.
263
264%description -n fio-ceph-objectstore -l pl.UTF-8
265Ten silnik FIO pozwala na bezpośrednie montowanie i używanie
266przestrzeni obiektów ceph, bez potrzeby budowania klastra ceph czy
267uruchamiania demonów.
268
2a1a6301
JR
269%prep
270%setup -q
271%patch0 -p1
96a54cb4 272%patch1 -p1
1b11728e
JB
273%patch2 -p0
274%patch3 -p1
bbcdc7ce
JB
275%patch4 -p1
276%patch5 -p1
1b11728e
JB
277%patch6 -p1
278%patch7 -p1
79dc5cad 279%patch8 -p1
101b8bdd 280%patch9 -p1
2a1a6301 281
e3919159 282%{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
1b11728e 283 src/{ceph-create-keys,ceph-rest-api,mount.fuse.ceph} \
bbcdc7ce
JB
284 src/brag/client/ceph-brag \
285 src/ceph-disk/ceph_disk/main.py
e3919159 286
2a1a6301 287%build
1b11728e
JB
288install -d build
289cd build
290%cmake .. \
291 -DALLOCATOR="%{?with_tcmalloc:tcmalloc}%{!?with_tcmalloc:libc}" \
292 -DFIO_INCLUDE_DIR=/usr/include/fio \
293 -DPYTHON=%{__python} \
294 -DSPHINX_BUILD=/usr/bin/sphinx-build-2 \
295 %{!?with_babeltrace:-DWITH_BABELTRACE=OFF} \
296 %{?with_java:-DWITH_CEPHFS_JAVA=ON} \
297 %{?with_dpdk:-DWITH_DPDK=ON} \
298 %{?with_fio:-DWITH_FIO=ON} \
299 %{!?with_lttng:-DWITH_LTTNG=OFF} \
300 -DWITH_LZ4=ON \
301 %{?with_cryptopp:-DWITH_NSS=OFF} \
302 -DWITH_OCF=ON \
303 %{?with_pmem:-DWITH_PMEM=ON} \
304 %{?with_fcgi:-DWITH_RADOSGW_FCGI_FRONTEND=ON} \
305 %{?with_spdk:-DWITH_SPDK=ON} \
306 -DWITH_SYSTEM_BOOST=ON \
307 %{?with_system_rocksdb:-DWITH_SYSTEM_ROCKSDB=ON} \
308 -DWITH_SYSTEMD=ON \
309 %{?with_accelio:-DWITH_XIO=ON} \
310 %{?with_zfs:-DWITH_ZFS=ON}
311
312%{__make}
2a1a6301
JR
313
314%install
315rm -rf $RPM_BUILD_ROOT
1b11728e
JB
316install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib/ceph/{tmp,mon,osd,mds,mgr,radosgw,bootstrap-{osd,mds,rgw,mgr,rbd}},log/ceph/stat,run/ceph} \
317 $RPM_BUILD_ROOT%{_sysconfdir}/{ceph,bash_completion.d,logrotate.d,rc.d,sysconfig} \
318 $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir},/etc/systemd/system/ceph.target.wants,/sbin}
4f42482b 319
1b11728e
JB
320%{__make} -C build install \
321 DESTDIR=$RPM_BUILD_ROOT
2a1a6301 322
1b11728e
JB
323# sanitize paths; no config options for cmake
324%{__mv} $RPM_BUILD_ROOT/etc/init.d $RPM_BUILD_ROOT/etc/rc.d
325%{__mv} $RPM_BUILD_ROOT%{_libexecdir}/systemd/system/* $RPM_BUILD_ROOT%{systemdunitdir}
326%{__mv} $RPM_BUILD_ROOT%{_sbindir}/mount.* $RPM_BUILD_ROOT/sbin
327
328cp -p src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ceph
2a1a6301 329
bbcdc7ce
JB
330cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/ceph
331install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
b6163d67 332ln -sf /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/ceph.service
bbcdc7ce 333cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/ceph.conf
b6163d67 334
1b11728e
JB
335%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
336%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
337%py_postclean
4f42482b 338
1b11728e
JB
339%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
340%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
245cb856 341
1b11728e
JB
342# tests
343%{__rm} $RPM_BUILD_ROOT%{_bindir}/ceph_test_*
344# packaged as %doc
345%{__rm} $RPM_BUILD_ROOT%{_docdir}/sample.ceph.conf
346# cleanup
347%{__rm} $RPM_BUILD_ROOT%{_libdir}/ceph/mgr/{.gitignore,dashboard/HACKING.rst,dashboard/static/AdminLTE-2.3.7/{.gitignore,.jshintrc,README.md}}
2a1a6301
JR
348
349%clean
350rm -rf $RPM_BUILD_ROOT
351
352%post
353/sbin/chkconfig --add ceph
354%service ceph restart
355
bef2a0ad
JK
356# actual services are to be enabled on cluster deployment
357%systemd_post %{name}.target
358
2a1a6301
JR
359%preun
360if [ "$1" = "0" ] ; then
72daa1da
JR
361 %service ceph stop
362 /sbin/chkconfig --del ceph
2a1a6301 363fi
bef2a0ad
JK
364%systemd_preun %{name}.target
365
366%postun
367%systemd_reload
2a1a6301 368
e5fc70df
JB
369%post libs -p /sbin/ldconfig
370%postun libs -p /sbin/ldconfig
2a1a6301 371
4f42482b
JB
372%post -n java-cephfs -p /sbin/ldconfig
373%postun -n java-cephfs -p /sbin/ldconfig
374
2a1a6301
JR
375%files
376%defattr(644,root,root,755)
9e1f65de 377# COPYING specifies licenses of individual parts
1b11728e 378%doc AUTHORS COPYING PendingReleaseNotes README.md src/sample.ceph.conf doc/{release-notes,releases}.rst
2a1a6301 379%attr(754,root,root) /etc/rc.d/init.d/ceph
bef2a0ad
JK
380%config(noreplace) /etc/sysconfig/ceph
381%dir /etc/systemd/system/ceph.target.wants
bbcdc7ce
JB
382%{systemdunitdir}/ceph.service
383%{systemdunitdir}/ceph.target
bbcdc7ce 384%{systemdunitdir}/ceph-disk@.service
1b11728e
JB
385%{systemdunitdir}/ceph-fuse.target
386%{systemdunitdir}/ceph-fuse@.service
bbcdc7ce 387%{systemdunitdir}/ceph-mds.target
bef2a0ad 388%{systemdunitdir}/ceph-mds@.service
1b11728e
JB
389%{systemdunitdir}/ceph-mgr.target
390%{systemdunitdir}/ceph-mgr@.service
bbcdc7ce 391%{systemdunitdir}/ceph-mon.target
bef2a0ad 392%{systemdunitdir}/ceph-mon@.service
bbcdc7ce 393%{systemdunitdir}/ceph-osd.target
bef2a0ad 394%{systemdunitdir}/ceph-osd@.service
bbcdc7ce
JB
395%{systemdunitdir}/ceph-rbd-mirror.target
396%{systemdunitdir}/ceph-rbd-mirror@.service
1b11728e 397%{systemdunitdir}/ceph-volume@.service
bbcdc7ce 398%{systemdunitdir}/rbdmap.service
bef2a0ad 399%{systemdtmpfilesdir}/ceph.conf
2a1a6301
JR
400%dir %{_sysconfdir}/ceph
401%attr(755,root,root) %{_bindir}/ceph
8c5712e2 402%attr(755,root,root) %{_bindir}/ceph-authtool
1b11728e 403%attr(755,root,root) %{_bindir}/ceph-bluestore-tool
fa260b6c 404%attr(755,root,root) %{_bindir}/ceph-brag
1b11728e 405%attr(755,root,root) %{_bindir}/ceph-client-debug
2a1a6301 406%attr(755,root,root) %{_bindir}/ceph-clsinfo
8c5712e2
JB
407%attr(755,root,root) %{_bindir}/ceph-conf
408%attr(755,root,root) %{_bindir}/ceph-coverage
d91e5335 409%attr(755,root,root) %{_bindir}/ceph-crush-location
8c5712e2 410%attr(755,root,root) %{_bindir}/ceph-debugpack
60d5543f 411%attr(755,root,root) %{_bindir}/ceph-dencoder
bbcdc7ce 412%attr(755,root,root) %{_bindir}/ceph-detect-init
1b11728e 413%attr(755,root,root) %{_bindir}/ceph-kvstore-tool
2a1a6301 414%attr(755,root,root) %{_bindir}/ceph-mds
1b11728e 415%attr(755,root,root) %{_bindir}/ceph-mgr
8c5712e2 416%attr(755,root,root) %{_bindir}/ceph-mon
1b11728e 417%attr(755,root,root) %{_bindir}/ceph-monstore-tool
7f577810 418%attr(755,root,root) %{_bindir}/ceph-objectstore-tool
2a1a6301 419%attr(755,root,root) %{_bindir}/ceph-osd
1b11728e 420%attr(755,root,root) %{_bindir}/ceph-osdomap-tool
5e39e43e 421%attr(755,root,root) %{_bindir}/ceph-post-file
2a1a6301 422%attr(755,root,root) %{_bindir}/ceph-rbdnamer
4f411dc5 423%attr(755,root,root) %{_bindir}/ceph-rest-api
8c5712e2
JB
424%attr(755,root,root) %{_bindir}/ceph-run
425%attr(755,root,root) %{_bindir}/ceph-syn
1b11728e
JB
426%attr(755,root,root) %{_bindir}/ceph_bench_log
427%attr(755,root,root) %{_bindir}/ceph_erasure_code
428%attr(755,root,root) %{_bindir}/ceph_erasure_code_benchmark
429%attr(755,root,root) %{_bindir}/ceph_kvstorebench
430%attr(755,root,root) %{_bindir}/ceph_multi_stress_watch
431%attr(755,root,root) %{_bindir}/ceph_objectstore_bench
432%attr(755,root,root) %{_bindir}/ceph_omapbench
433%attr(755,root,root) %{_bindir}/ceph_perf_local
434%attr(755,root,root) %{_bindir}/ceph_perf_msgr_client
435%attr(755,root,root) %{_bindir}/ceph_perf_msgr_server
436%attr(755,root,root) %{_bindir}/ceph_perf_objectstore
437%attr(755,root,root) %{_bindir}/ceph_psim
438%attr(755,root,root) %{_bindir}/ceph_radosacl
439%attr(755,root,root) %{_bindir}/ceph_rgw_jsonparser
440%attr(755,root,root) %{_bindir}/ceph_rgw_multiparser
441%attr(755,root,root) %{_bindir}/ceph_scratchtool
442%attr(755,root,root) %{_bindir}/ceph_scratchtoolpp
443%attr(755,root,root) %{_bindir}/ceph_smalliobench
444%attr(755,root,root) %{_bindir}/ceph_smalliobenchdumb
445%attr(755,root,root) %{_bindir}/ceph_smalliobenchfs
446%attr(755,root,root) %{_bindir}/ceph_smalliobenchrbd
447%attr(755,root,root) %{_bindir}/ceph_tpbench
448%attr(755,root,root) %{_bindir}/ceph_xattr_bench
bef2a0ad 449%attr(755,root,root) %{_bindir}/cephctl
bbcdc7ce 450%attr(755,root,root) %{_bindir}/cephfs-data-scan
ae4b5127 451%attr(755,root,root) %{_bindir}/cephfs-journal-tool
b431df60 452%attr(755,root,root) %{_bindir}/cephfs-table-tool
8c5712e2 453%attr(755,root,root) %{_bindir}/crushtool
2a1a6301 454%attr(755,root,root) %{_bindir}/librados-config
8c5712e2
JB
455%attr(755,root,root) %{_bindir}/monmaptool
456%attr(755,root,root) %{_bindir}/osdmaptool
2a1a6301
JR
457%attr(755,root,root) %{_bindir}/rados
458%attr(755,root,root) %{_bindir}/rbd
8c5712e2 459%attr(755,root,root) %{_bindir}/rbd-fuse
bbcdc7ce
JB
460%attr(755,root,root) %{_bindir}/rbd-mirror
461%attr(755,root,root) %{_bindir}/rbd-nbd
9a1a508c 462%attr(755,root,root) %{_bindir}/rbd-replay
7f577810 463%attr(755,root,root) %{_bindir}/rbd-replay-many
9a1a508c 464%attr(755,root,root) %{_bindir}/rbd-replay-prep
bbcdc7ce 465%attr(755,root,root) %{_bindir}/rbdmap
1b11728e 466%attr(755,root,root) %{_sbindir}/ceph-create-keys
bbcdc7ce 467%attr(755,root,root) %{_sbindir}/ceph-disk
1b11728e
JB
468%attr(755,root,root) %{_sbindir}/ceph-volume
469%attr(755,root,root) %{_sbindir}/ceph-volume-systemd
4f42482b
JB
470%attr(755,root,root) /sbin/mount.ceph
471%attr(755,root,root) /sbin/mount.fuse.ceph
e3919159 472%if "%{_libexecdir}" != "%{_libdir}"
c1965bc2 473%dir %{_libexecdir}/ceph
e3919159 474%endif
bbcdc7ce 475%attr(755,root,root) %{_libexecdir}/ceph/ceph-monstore-update-crush.sh
c1965bc2 476%attr(755,root,root) %{_libexecdir}/ceph/ceph-osd-prestart.sh
c408d7b3 477%{_libdir}/ceph/ceph_common.sh
1b11728e 478%{_libdir}/ceph/mgr
bbcdc7ce 479%dir %{_libdir}/ceph/compressor
1b11728e 480%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_lz4.so*
bbcdc7ce
JB
481%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_snappy.so*
482%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_zlib.so*
1b11728e 483%attr(755,root,root) %{_libdir}/ceph/compressor/libceph_zstd.so*
c408d7b3 484%dir %{_libdir}/ceph/erasure-code
58dc957f 485%ifarch %{x8664}
066d8601 486%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_isa.so*
6fce7056 487%endif
c408d7b3 488%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure.so*
0509a77e 489%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_generic.so*
bbcdc7ce 490%ifarch %{arm}
7f577810
JB
491%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_neon.so*
492%endif
493%ifarch %{ix86} %{x8664} x32
0509a77e
JB
494%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse3.so*
495%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse4.so*
7f577810 496%endif
9a1a508c 497%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_lrc.so*
b431df60 498%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec.so*
bbcdc7ce
JB
499%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec_generic.so*
500%ifarch %{ix86} %{x8664} x32
501%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec_sse3.so*
1b11728e 502%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec_sse4.so*
bbcdc7ce 503%endif
2a1a6301 504%dir %{_libdir}/rados-classes
1b11728e
JB
505%attr(755,root,root) %{_libdir}/rados-classes/libcls_cephfs.so*
506%attr(755,root,root) %{_libdir}/rados-classes/libcls_hello.so*
507%attr(755,root,root) %{_libdir}/rados-classes/libcls_journal.so*
508%attr(755,root,root) %{_libdir}/rados-classes/libcls_kvs.so*
509%attr(755,root,root) %{_libdir}/rados-classes/libcls_lock.so*
510%attr(755,root,root) %{_libdir}/rados-classes/libcls_log.so*
511%attr(755,root,root) %{_libdir}/rados-classes/libcls_lua.so*
512%attr(755,root,root) %{_libdir}/rados-classes/libcls_numops.so*
513%attr(755,root,root) %{_libdir}/rados-classes/libcls_rbd.so*
514%attr(755,root,root) %{_libdir}/rados-classes/libcls_refcount.so*
515%attr(755,root,root) %{_libdir}/rados-classes/libcls_replica_log.so*
516%attr(755,root,root) %{_libdir}/rados-classes/libcls_rgw.so*
517%attr(755,root,root) %{_libdir}/rados-classes/libcls_sdk.so*
518%attr(755,root,root) %{_libdir}/rados-classes/libcls_statelog.so*
519%attr(755,root,root) %{_libdir}/rados-classes/libcls_timeindex.so*
520%attr(755,root,root) %{_libdir}/rados-classes/libcls_user.so*
521%attr(755,root,root) %{_libdir}/rados-classes/libcls_version.so*
5e39e43e 522%{_datadir}/ceph
2a1a6301
JR
523%config(noreplace) /etc/logrotate.d/ceph
524%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
525%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
526%config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
527%{_mandir}/man8/ceph.8*
528%{_mandir}/man8/ceph-authtool.8*
1b11728e 529%{_mandir}/man8/ceph-bluestore-tool.8*
2a1a6301
JR
530%{_mandir}/man8/ceph-clsinfo.8*
531%{_mandir}/man8/ceph-conf.8*
63709ae0 532%{_mandir}/man8/ceph-create-keys.8*
2a1a6301 533%{_mandir}/man8/ceph-debugpack.8*
60d5543f 534%{_mandir}/man8/ceph-dencoder.8*
7f577810 535%{_mandir}/man8/ceph-deploy.8*
bbcdc7ce 536%{_mandir}/man8/ceph-detect-init.8*
7f577810 537%{_mandir}/man8/ceph-disk.8*
1b11728e 538%{_mandir}/man8/ceph-kvstore-tool.8*
2a1a6301
JR
539%{_mandir}/man8/ceph-mds.8*
540%{_mandir}/man8/ceph-mon.8*
541%{_mandir}/man8/ceph-osd.8*
5e39e43e 542%{_mandir}/man8/ceph-post-file.8*
60d5543f 543%{_mandir}/man8/ceph-rbdnamer.8*
4f411dc5 544%{_mandir}/man8/ceph-rest-api.8*
2a1a6301
JR
545%{_mandir}/man8/ceph-run.8*
546%{_mandir}/man8/ceph-syn.8*
1b11728e
JB
547%{_mandir}/man8/ceph-volume.8*
548%{_mandir}/man8/ceph-volume-systemd.8*
2a1a6301
JR
549%{_mandir}/man8/crushtool.8*
550%{_mandir}/man8/librados-config.8*
2a1a6301
JR
551%{_mandir}/man8/monmaptool.8*
552%{_mandir}/man8/mount.ceph.8*
553%{_mandir}/man8/osdmaptool.8*
554%{_mandir}/man8/rados.8*
2a1a6301 555%{_mandir}/man8/rbd.8*
8c5712e2 556%{_mandir}/man8/rbd-fuse.8*
bbcdc7ce
JB
557%{_mandir}/man8/rbd-mirror.8*
558%{_mandir}/man8/rbd-nbd.8*
9a1a508c 559%{_mandir}/man8/rbd-replay.8*
7f577810 560%{_mandir}/man8/rbd-replay-many.8*
9a1a508c 561%{_mandir}/man8/rbd-replay-prep.8*
bbcdc7ce 562%{_mandir}/man8/rbdmap.8*
60d5543f 563
2a1a6301 564%dir %{_localstatedir}/lib/ceph
1b11728e
JB
565%dir %{_localstatedir}/lib/ceph/bootstrap-mds
566%dir %{_localstatedir}/lib/ceph/bootstrap-mgr
567%dir %{_localstatedir}/lib/ceph/bootstrap-osd
568%dir %{_localstatedir}/lib/ceph/bootstrap-rbd
569%dir %{_localstatedir}/lib/ceph/bootstrap-rgw
b6163d67 570%dir %{_localstatedir}/lib/ceph/mds
1b11728e 571%dir %{_localstatedir}/lib/ceph/mgr
b6163d67
JK
572%dir %{_localstatedir}/lib/ceph/mon
573%dir %{_localstatedir}/lib/ceph/osd
2a1a6301
JR
574%dir %{_localstatedir}/lib/ceph/tmp
575%dir %{_localstatedir}/log/ceph
bef2a0ad 576%dir %{_localstatedir}/run/ceph
2a1a6301
JR
577
578%files libs
579%defattr(644,root,root,755)
580%attr(755,root,root) %{_libdir}/libcephfs.so.*.*.*
1b11728e 581%attr(755,root,root) %ghost %{_libdir}/libcephfs.so.2
4447516f
JB
582%attr(755,root,root) %{_libdir}/libos_tp.so.*.*.*
583%attr(755,root,root) %ghost %{_libdir}/libos_tp.so.1
584%attr(755,root,root) %{_libdir}/libosd_tp.so.*.*.*
585%attr(755,root,root) %ghost %{_libdir}/libosd_tp.so.1
2a1a6301
JR
586%attr(755,root,root) %{_libdir}/librados.so.*.*.*
587%attr(755,root,root) %ghost %{_libdir}/librados.so.2
4447516f
JB
588%attr(755,root,root) %{_libdir}/librados_tp.so.*.*.*
589%attr(755,root,root) %ghost %{_libdir}/librados_tp.so.2
548e0d3f
JB
590%attr(755,root,root) %{_libdir}/libradosstriper.so.*.*.*
591%attr(755,root,root) %ghost %{_libdir}/libradosstriper.so.1
2a1a6301
JR
592%attr(755,root,root) %{_libdir}/librbd.so.*.*.*
593%attr(755,root,root) %ghost %{_libdir}/librbd.so.1
4447516f
JB
594%attr(755,root,root) %{_libdir}/librbd_tp.so.*.*.*
595%attr(755,root,root) %ghost %{_libdir}/librbd_tp.so.1
bbcdc7ce
JB
596%attr(755,root,root) %{_libdir}/librgw.so.*.*.*
597%attr(755,root,root) %ghost %{_libdir}/librgw.so.2
5b8dadc9
JB
598%dir %{_libdir}/ceph
599%attr(755,root,root) %{_libdir}/ceph/libceph-common.so.0
2a1a6301 600
2a1a6301
JR
601%files devel
602%defattr(644,root,root,755)
2a1a6301 603%attr(755,root,root) %{_libdir}/libcephfs.so
4447516f
JB
604%attr(755,root,root) %{_libdir}/libos_tp.so
605%attr(755,root,root) %{_libdir}/libosd_tp.so
2a1a6301 606%attr(755,root,root) %{_libdir}/librados.so
4447516f 607%attr(755,root,root) %{_libdir}/librados_tp.so
548e0d3f 608%attr(755,root,root) %{_libdir}/libradosstriper.so
2a1a6301 609%attr(755,root,root) %{_libdir}/librbd.so
4447516f 610%attr(755,root,root) %{_libdir}/librbd_tp.so
bbcdc7ce 611%attr(755,root,root) %{_libdir}/librgw.so
5b8dadc9 612%attr(755,root,root) %{_libdir}/ceph/libceph-common.so
e5fc70df
JB
613%{_includedir}/cephfs
614%{_includedir}/rados
548e0d3f 615%{_includedir}/radosstriper
e5fc70df 616%{_includedir}/rbd
2a1a6301 617
e5fc70df
JB
618%files -n python-ceph
619%defattr(644,root,root,755)
bbcdc7ce
JB
620%attr(755,root,root) %{py_sitedir}/cephfs.so
621%attr(755,root,root) %{py_sitedir}/rados.so
622%attr(755,root,root) %{py_sitedir}/rbd.so
1b11728e 623%attr(755,root,root) %{py_sitedir}/rgw.so
bbcdc7ce 624%{py_sitedir}/ceph_detect_init
bbcdc7ce 625%{py_sitedir}/ceph_detect_init-1.0.1-py*.egg-info
1b11728e 626%{py_sitedir}/ceph_disk
bbcdc7ce 627%{py_sitedir}/ceph_disk-1.0.0-py*.egg-info
1b11728e
JB
628%{py_sitedir}/ceph_volume
629%{py_sitedir}/ceph_volume-1.0.0-py*.egg-info
630%{py_sitedir}/cephfs-2.0.0-py*.egg-info
631%{py_sitedir}/rados-2.0.0-py*.egg-info
632%{py_sitedir}/rbd-2.0.0-py*.egg-info
633%{py_sitedir}/rgw-2.0.0-py*.egg-info
67f1bff3 634%{py_sitescriptdir}/ceph_argparse.py[co]
bbcdc7ce 635%{py_sitescriptdir}/ceph_daemon.py[co]
4f411dc5 636%{py_sitescriptdir}/ceph_rest_api.py[co]
bbcdc7ce 637%{py_sitescriptdir}/ceph_volume_client.py[co]
e5fc70df 638
1b11728e
JB
639%files -n python3-ceph
640%defattr(644,root,root,755)
641%attr(755,root,root) %{py3_sitedir}/cephfs.cpython-*.so
642%attr(755,root,root) %{py3_sitedir}/rados.cpython-*.so
643%attr(755,root,root) %{py3_sitedir}/rbd.cpython-*.so
644%attr(755,root,root) %{py3_sitedir}/rgw.cpython-*.so
645%{py3_sitedir}/cephfs-2.0.0-py*.egg-info
646%{py3_sitedir}/rados-2.0.0-py*.egg-info
647%{py3_sitedir}/rbd-2.0.0-py*.egg-info
648%{py3_sitedir}/rgw-2.0.0-py*.egg-info
649%{py3_sitescriptdir}/ceph_argparse.py
650%{py3_sitescriptdir}/ceph_daemon.py
651%{py3_sitescriptdir}/ceph_volume_client.py
652%{py3_sitescriptdir}/__pycache__/ceph_argparse.cpython-*.py[co]
653%{py3_sitescriptdir}/__pycache__/ceph_daemon.cpython-*.py[co]
654%{py3_sitescriptdir}/__pycache__/ceph_volume_client.cpython-*.py[co]
655
4f42482b
JB
656%if %{with java}
657%files -n java-cephfs
658%defattr(644,root,root,755)
659%attr(755,root,root) %{_libdir}/libcephfs_jni.so.*.*.*
660%attr(755,root,root) %ghost %{_libdir}/libcephfs_jni.so.1
661%attr(755,root,root) %{_libdir}/libcephfs_jni.so
662%{_javadir}/libcephfs.jar
1b11728e 663%{_javadir}/libcephfs-test.jar
4f42482b
JB
664%endif
665
e5fc70df
JB
666%files fuse
667%defattr(644,root,root,755)
e5fc70df
JB
668%attr(755,root,root) %{_bindir}/ceph-fuse
669%{_mandir}/man8/ceph-fuse.8*
670
2a1a6301
JR
671%files radosgw
672%defattr(644,root,root,755)
673%attr(755,root,root) %{_bindir}/radosgw
674%attr(755,root,root) %{_bindir}/radosgw-admin
1b11728e 675%attr(755,root,root) %{_bindir}/radosgw-es
bbcdc7ce
JB
676%attr(755,root,root) %{_bindir}/radosgw-object-expirer
677%attr(755,root,root) %{_bindir}/radosgw-token
678%{systemdunitdir}/ceph-radosgw.target
679%{systemdunitdir}/ceph-radosgw@.service
2a1a6301 680%{_sysconfdir}/bash_completion.d/radosgw-admin
1b11728e
JB
681%dir %{_localstatedir}/lib/ceph/radosgw
682%{_mandir}/man8/radosgw.8*
683%{_mandir}/man8/radosgw-admin.8*
2a1a6301 684
245cb856 685%files resource-agents
8029515d
JB
686%defattr(644,root,root,755)
687%dir %{_prefix}/lib/ocf/resource.d/ceph
8029515d 688%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
79dc5cad
JB
689
690%if %{with fio}
691%files -n fio-ceph-objectstore
692%defattr(644,root,root,755)
693%doc src/test/fio/{README.md,ceph-*.conf,ceph-*.fio}
694%attr(755,root,root) %{_libdir}/libfio_ceph_objectstore.so
695%endif
This page took 0.164298 seconds and 4 git commands to generate.