]> git.pld-linux.org Git - packages/ceph.git/blame - ceph.spec
- added accelio bcond
[packages/ceph.git] / ceph.spec
CommitLineData
b6163d67 1# TODO:
b6163d67
JK
2# - proper init scripts if non-systemd boot is too be supported
3# (upstream scripts seem overcomplicated and hardly useful)
bef2a0ad 4# - run as non-root user
b6163d67 5#
714b93ed
JB
6#
7# Conditional build:
7f577810 8%bcond_without java # Java binding
477a1b20 9%bcond_with accelio # Accelio transport support
7f577810
JB
10%bcond_with kinetic # Kinetic storage support [needs update for internal API changes]
11%bcond_with rocksdb # RocksDB storage support [needs update for internal API changes]
12%bcond_with zfs # ZFS support
13%bcond_without lttng # LTTng tracing
14%bcond_without babeltrace # Babeltrace traces support
15%bcond_without tcmalloc # tcmalloc allocator
6fce7056
JR
16
17%ifarch x32
18%undefine with_tcmalloc
19%endif
714b93ed 20#
2a1a6301 21Summary: User space components of the Ceph file system
e5fc70df 22Summary(pl.UTF-8): Działające w przestrzeni użytkownika elementy systemu plików Ceph
2a1a6301 23Name: ceph
492b9f08 24Version: 0.94.2
eab7d9fa 25Release: 2
9e1f65de 26License: LGPL v2.1 (libraries), GPL v2 (some programs)
2a1a6301 27Group: Base
c408d7b3 28Source0: http://ceph.com/download/%{name}-%{version}.tar.bz2
492b9f08 29# Source0-md5: 249648d35e634adaaeec727408ca6092
b6163d67
JK
30Source1: ceph.sysconfig
31# based on files from https://github.com/ceph/ceph/tree/master/systemd
32Source10: cephctl
33Source11: ceph-mds@.service
34Source12: ceph-mon@.service
35Source13: ceph-osd@.service
36Source14: ceph.target
37Source15: ceph.tmpfiles
2a1a6301
JR
38Patch0: %{name}-init-fix.patch
39Patch1: %{name}.logrotate.patch
7f577810 40Patch2: %{name}-link.patch
b431df60 41Patch3: %{name}-ac.patch
eab7d9fa 42Patch4: %{name}-boost.patch
c408d7b3 43URL: http://ceph.com/
477a1b20 44%{?with_accelio:BuildRequires: accelio-devel}
714b93ed
JB
45BuildRequires: autoconf >= 2.59
46BuildRequires: automake
7f577810 47%{?with_babeltrace:BuildRequires: babeltrace-devel}
714b93ed 48BuildRequires: boost-devel >= 1.34
2a1a6301 49BuildRequires: curl-devel
714b93ed 50BuildRequires: expat-devel >= 1.95
2a1a6301
JR
51BuildRequires: fcgi-devel
52BuildRequires: gdbm-devel
7db8c214 53%if %{with java}
4f42482b
JB
54BuildRequires: jdk
55%endif
2a1a6301 56BuildRequires: keyutils-devel
9a1a508c 57%{?with_kinetic:BuildRequires: kinetic-cpp-client}
548e0d3f 58BuildRequires: leveldb-devel >= 1.2
714b93ed 59BuildRequires: libaio-devel
2a1a6301 60BuildRequires: libatomic_ops
548e0d3f 61BuildRequires: libblkid-devel >= 2.17
714b93ed 62BuildRequires: libedit-devel >= 2.11
2a1a6301 63BuildRequires: libfuse-devel
477a1b20 64%{?with_accelio:BuildRequires: libibverbs-devel}
2a1a6301 65BuildRequires: libltdl-devel
477a1b20 66%{?with_accelio:BuildRequires: librdmacm-devel}
f965be58 67BuildRequires: libs3-devel
2a1a6301 68BuildRequires: libstdc++-devel
6fce7056 69%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
714b93ed 70BuildRequires: libtool >= 2:1.5
2a1a6301 71BuildRequires: libuuid-devel
7f577810 72%{?with_lttng:BuildRequires: lttng-ust-devel}
6fce7056 73BuildRequires: nss-devel
e5fc70df 74BuildRequires: perl-base
2a1a6301 75BuildRequires: pkgconfig
714b93ed 76BuildRequires: python >= 1:2.4
9a1a508c 77%{?with_rocksdb:BuildRequires: rocksdb-devel}
bef2a0ad 78BuildRequires: rpmbuild(macros) >= 1.671
f965be58 79BuildRequires: snappy-devel
548e0d3f 80BuildRequires: udev-devel
fa260b6c 81BuildRequires: xfsprogs-devel
7db8c214
JB
82%ifarch %{x8664}
83BuildRequires: yasm
84%endif
430360a9 85%{?with_zfs:BuildRequires: zfs-devel}
2a1a6301
JR
86Requires(post,preun): /sbin/chkconfig
87Requires(preun): rc-scripts
88Requires: %{name}-libs = %{version}-%{release}
7cabda16 89Requires: python-%{name} = %{version}-%{release}
bef2a0ad 90Requires: systemd-units >= 38
60d5543f 91Obsoletes: gcephtool
7db8c214 92Obsoletes: hadoop-cephfs
2a1a6301
JR
93BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
7db8c214 95%define skip_post_check_so libcls_.*.so.* libec_.*.so.*
2a1a6301
JR
96
97%description
98Ceph is a distributed network file system designed to provide
99excellent performance, reliability, and scalability.
100
e5fc70df
JB
101%description -l pl.UTF-8
102Ceph to rozproszony sieciowy system plików zaprojektowany z myślą o
103dobrej wydajności, wiarygodności i skalowalności.
104
2a1a6301
JR
105%package libs
106Summary: Ceph shared libraries
e5fc70df 107Summary(pl.UTF-8): Biblioteki współdzielone Cepha
2a1a6301
JR
108Group: Libraries
109
110%description libs
111Ceph shared libraries.
112
e5fc70df
JB
113%description libs -l pl.UTF-8
114Biblioteki współdzielone Cepha.
2a1a6301
JR
115
116%package devel
e5fc70df
JB
117Summary: Ceph header files
118Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Cepha
96c29907 119License: LGPL v2.1
2a1a6301
JR
120Group: Development/Libraries
121Requires: %{name}-libs = %{version}-%{release}
96c29907 122Requires: boost-devel >= 1.34
6fce7056 123Requires: nss-devel
96c29907
JB
124Requires: leveldb-devel
125Requires: libatomic_ops
126Requires: libuuid-devel
2a1a6301
JR
127
128%description devel
129This package contains the headers needed to develop programs that use
130Ceph.
131
e5fc70df
JB
132%description devel -l pl.UTF-8
133Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
134wykorzystujących Cepha.
135
2a1a6301
JR
136%package static
137Summary: Ceph static libraries
e5fc70df 138Summary(pl.UTF-8): Biblioteki statyczne Cepha
96c29907 139License: LGPL v2.1
2a1a6301
JR
140Group: Development/Libraries
141Requires: %{name}-devel = %{version}-%{release}
142
143%description static
144This package contains static Ceph libraries.
145
e5fc70df
JB
146%description static -l pl.UTF-8
147Ten pakiet zawiera biblioteki statyczne Cepha.
148
149%package -n python-ceph
150Summary: Ceph Python bindings
151Summary(pl.UTF-8): Wiązania Pythona do bibliotek Cepha
152Group: Development/Languages/Python
153Requires: %{name}-libs = %{version}-%{release}
154
155%description -n python-ceph
156Ceph Python bindings.
157
158%description -n python-ceph -l pl.UTF-8
159Wiązania Pythona do bibliotek Cepha.
160
4f42482b
JB
161%package -n java-cephfs
162Summary: CephFS Java bindings
163Summary(pl.UTF-8): Wiązania Javy do biblioteki CephFS
164Group: Libraries/Java
165Requires: %{name}-libs = %{version}-%{release}
166
167%description -n java-cephfs
168CephFS Java bindings.
169
170%description -n java-cephfs -l pl.UTF-8
171Wiązania Javy do biblioteki CephFS.
172
e5fc70df
JB
173%package fuse
174Summary: Ceph FUSE-based client
175Summary(pl.UTF-8): Klient Cepha oparty na FUSE
176Group: Base
177Requires: %{name} = %{version}-%{release}
178
179%description fuse
180FUSE based client for Ceph distributed network file system.
181
182%description fuse -l pl.UTF-8
183Oparty na FUSE klient rozproszonego sieciowego systemu plików Ceph.
184
2a1a6301
JR
185%package radosgw
186Summary: rados REST gateway
e5fc70df
JB
187Summary(pl.UTF-8): Bramka REST-owa rados
188Group: Applications/System
2a1a6301
JR
189#Requires: apache-mod_fcgid
190
191%description radosgw
192radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
193implemented as a FastCGI module using libfcgi, and can be used in
194conjunction with any FastCGI capable web server.
195
e5fc70df
JB
196%description radosgw -l pl.UTF-8
197radosgw to REST-owa bramka HTTP S3 do przechowalni obiektów RADOS.
198Jest zaimplementowana jako moduł FastCGI wykorzystujący libfcgi i może
199być używana w połączeniu z dowolnym serwerem WWW obsługującym FastCGI.
200
245cb856 201%package resource-agents
8029515d
JB
202Summary: OCF Resource Agents for Ceph processes
203Summary(pl.UTF-8): Agenci OCF do monitorowania procesów Cepha
204Group: Applications/System
205Requires: %{name} = %{version}-%{release}
206Requires: resource-agents
207
245cb856 208%description resource-agents
8029515d
JB
209OCF Resource Agents for Ceph processes.
210
245cb856 211%description resource-agents -l pl.UTF-8
8029515d
JB
212Agenci OCF do monitorowania procesów Cepha.
213
2a1a6301
JR
214%prep
215%setup -q
216%patch0 -p1
96a54cb4 217%patch1 -p1
9a1a508c 218%patch2 -p1
b431df60 219%patch3 -p1
eab7d9fa 220%patch4 -p1
2a1a6301
JR
221
222%build
223%{__libtoolize}
d078b205 224%{__aclocal} -I m4
2a1a6301
JR
225%{__autoconf}
226%{__autoheader}
227%{__automake}
c1654e29
JB
228# ac_cv_prog_uudecode_base64=no is a hack to compile Test.class instead of
229# using included one which fails with Sun/Oracle JDK 1.6
2a1a6301 230%configure \
ac843c96 231 %{?with_java:JAVAC=/usr/bin/javac} \
ae4b5127 232 %{?with_zfs:LIBZFS_CFLAGS="-I/usr/include/libzfs -I/usr/include/libspl"} \
c1654e29 233 ac_cv_prog_uudecode_base64=no \
2a1a6301 234 --sbindir=/sbin \
7f577810 235 %{!?with_babeltrace:--without-babeltrace} \
6fce7056
JR
236 --without-cryptopp \
237 --with-nss \
238 %{!?with_tcmalloc:--without-tcmalloc} \
9a1a508c
JB
239 %{?with_kinetic:--with-kinetic} \
240 %{?with_rocksdb:--with-librocksdb} \
430360a9 241 %{?with_zfs:--with-libzfs} \
7f577810 242 %{!?with_lttng:--without-lttng} \
8029515d 243 --with-ocf \
2a1a6301 244 --with-radosgw \
f965be58
JB
245 --with-system-leveldb \
246 --with-system-libs3 \
4f42482b 247 %{?with_java:--enable-cephfs-java --with-jdk-dir=%{_jvmdir}/java} \
477a1b20
JB
248 --disable-silent-rules \
249 %{?with_accelio:--enable-xio}
2a1a6301 250
5e0a173c 251%{__make} -j1
2a1a6301
JR
252
253%install
254rm -rf $RPM_BUILD_ROOT
bef2a0ad
JK
255install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib/ceph/{tmp,mon,osd,mds},log/ceph/stat,run/ceph} \
256 $RPM_BUILD_ROOT%{_sysconfdir}/{ceph,bash_completion.d,logrotate.d,rc.d/init.d,sysconfig} \
257 $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir},/etc/systemd/system/ceph.target.wants}
4f42482b 258
2a1a6301 259%{__make} install \
4f42482b
JB
260 DESTDIR=$RPM_BUILD_ROOT \
261 javadir=%{_javadir}
2a1a6301
JR
262
263install -p src/init-ceph $RPM_BUILD_ROOT/etc/rc.d/init.d/ceph
264install -p src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ceph
265
bef2a0ad 266install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/ceph
b6163d67
JK
267install %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}
268install %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}
269ln -sf /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/ceph.service
270install %{SOURCE15} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/ceph.conf
271
7e46b55b 272# loadable modules
c408d7b3 273%{__rm} $RPM_BUILD_ROOT%{_libdir}/ceph/erasure-code/*.{a,la}
c8a22313 274%{__rm} $RPM_BUILD_ROOT%{_libdir}/rados-classes/*.{a,la}
4f42482b
JB
275%if %{with java}
276%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcephfs_jni.{la,a}
277%endif
278
7e46b55b
JB
279# packaged as %doc
280%{__rm} $RPM_BUILD_ROOT%{_docdir}/ceph/sample.{ceph.conf,fetch_config}
245cb856 281
714b93ed 282%py_postclean
2a1a6301
JR
283
284%clean
285rm -rf $RPM_BUILD_ROOT
286
287%post
288/sbin/chkconfig --add ceph
289%service ceph restart
290
bef2a0ad
JK
291# actual services are to be enabled on cluster deployment
292%systemd_post %{name}.target
293
2a1a6301
JR
294%preun
295if [ "$1" = "0" ] ; then
72daa1da
JR
296 %service ceph stop
297 /sbin/chkconfig --del ceph
2a1a6301 298fi
bef2a0ad
JK
299%systemd_preun %{name}.target
300
301%postun
302%systemd_reload
2a1a6301 303
e5fc70df
JB
304%post libs -p /sbin/ldconfig
305%postun libs -p /sbin/ldconfig
2a1a6301 306
4f42482b
JB
307%post -n java-cephfs -p /sbin/ldconfig
308%postun -n java-cephfs -p /sbin/ldconfig
309
2a1a6301
JR
310%files
311%defattr(644,root,root,755)
9e1f65de
JB
312# COPYING specifies licenses of individual parts
313%doc AUTHORS COPYING README src/sample.ceph.conf src/sample.fetch_config
2a1a6301 314%attr(754,root,root) /etc/rc.d/init.d/ceph
bef2a0ad
JK
315%config(noreplace) /etc/sysconfig/ceph
316%dir /etc/systemd/system/ceph.target.wants
317%{systemdunitdir}/ceph-mds@.service
318%{systemdunitdir}/ceph-mon@.service
319%{systemdunitdir}/ceph-osd@.service
320%{systemdunitdir}/ceph.service
321%{systemdunitdir}/ceph.target
322%{systemdtmpfilesdir}/ceph.conf
2a1a6301
JR
323%dir %{_sysconfdir}/ceph
324%attr(755,root,root) %{_bindir}/ceph
8c5712e2 325%attr(755,root,root) %{_bindir}/ceph-authtool
fa260b6c 326%attr(755,root,root) %{_bindir}/ceph-brag
2a1a6301 327%attr(755,root,root) %{_bindir}/ceph-clsinfo
8c5712e2
JB
328%attr(755,root,root) %{_bindir}/ceph-conf
329%attr(755,root,root) %{_bindir}/ceph-coverage
d91e5335 330%attr(755,root,root) %{_bindir}/ceph-crush-location
8c5712e2 331%attr(755,root,root) %{_bindir}/ceph-debugpack
60d5543f 332%attr(755,root,root) %{_bindir}/ceph-dencoder
2a1a6301 333%attr(755,root,root) %{_bindir}/ceph-mds
8c5712e2 334%attr(755,root,root) %{_bindir}/ceph-mon
7f577810 335%attr(755,root,root) %{_bindir}/ceph-objectstore-tool
2a1a6301 336%attr(755,root,root) %{_bindir}/ceph-osd
5e39e43e 337%attr(755,root,root) %{_bindir}/ceph-post-file
2a1a6301 338%attr(755,root,root) %{_bindir}/ceph-rbdnamer
4f411dc5 339%attr(755,root,root) %{_bindir}/ceph-rest-api
8c5712e2
JB
340%attr(755,root,root) %{_bindir}/ceph-run
341%attr(755,root,root) %{_bindir}/ceph-syn
bef2a0ad 342%attr(755,root,root) %{_bindir}/cephctl
8c5712e2 343%attr(755,root,root) %{_bindir}/cephfs
ae4b5127 344%attr(755,root,root) %{_bindir}/cephfs-journal-tool
b431df60 345%attr(755,root,root) %{_bindir}/cephfs-table-tool
8c5712e2 346%attr(755,root,root) %{_bindir}/crushtool
2a1a6301 347%attr(755,root,root) %{_bindir}/librados-config
8c5712e2
JB
348%attr(755,root,root) %{_bindir}/monmaptool
349%attr(755,root,root) %{_bindir}/osdmaptool
2a1a6301
JR
350%attr(755,root,root) %{_bindir}/rados
351%attr(755,root,root) %{_bindir}/rbd
8c5712e2 352%attr(755,root,root) %{_bindir}/rbd-fuse
9a1a508c 353%attr(755,root,root) %{_bindir}/rbd-replay
7f577810 354%attr(755,root,root) %{_bindir}/rbd-replay-many
9a1a508c 355%attr(755,root,root) %{_bindir}/rbd-replay-prep
8dda6d30
JB
356%attr(755,root,root) /sbin/ceph-create-keys
357%attr(755,root,root) /sbin/ceph-disk
358%attr(755,root,root) /sbin/ceph-disk-activate
359%attr(755,root,root) /sbin/ceph-disk-prepare
360%attr(755,root,root) /sbin/ceph-disk-udev
4f42482b
JB
361%attr(755,root,root) /sbin/mount.ceph
362%attr(755,root,root) /sbin/mount.fuse.ceph
c408d7b3 363%dir %{_libdir}/ceph
548e0d3f 364%attr(755,root,root) %{_libdir}/ceph/ceph-osd-prestart.sh
c408d7b3
JB
365%{_libdir}/ceph/ceph_common.sh
366%dir %{_libdir}/ceph/erasure-code
367%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_example.so*
368%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_fail_to_initialize.so*
369%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_fail_to_register.so*
370%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_hangs.so*
58dc957f 371%ifarch %{x8664}
066d8601 372%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_isa.so*
6fce7056 373%endif
c408d7b3 374%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure.so*
0509a77e 375%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_generic.so*
7f577810
JB
376%ifarch arm
377%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_neon.so*
378%endif
379%ifarch %{ix86} %{x8664} x32
0509a77e 380%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse3.so*
7f577810
JB
381%endif
382%ifarch %{x8664} x32
0509a77e 383%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_jerasure_sse4.so*
7f577810 384%endif
9a1a508c 385%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_lrc.so*
c408d7b3 386%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_entry_point.so*
9a1a508c 387%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_missing_version.so*
b431df60 388%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_shec.so*
0509a77e 389%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_generic.so*
7f577810 390%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_neon.so*
0509a77e
JB
391%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse3.so*
392%attr(755,root,root) %{_libdir}/ceph/erasure-code/libec_test_jerasure_sse4.so*
2a1a6301 393%dir %{_libdir}/rados-classes
5e39e43e 394%attr(755,root,root) %{_libdir}/rados-classes/libcls_hello.so*
7e46b55b 395%attr(755,root,root) %{_libdir}/rados-classes/libcls_kvs.so*
60d5543f 396%attr(755,root,root) %{_libdir}/rados-classes/libcls_lock.so*
4f411dc5 397%attr(755,root,root) %{_libdir}/rados-classes/libcls_log.so*
2a1a6301 398%attr(755,root,root) %{_libdir}/rados-classes/libcls_rbd.so*
7e46b55b 399%attr(755,root,root) %{_libdir}/rados-classes/libcls_refcount.so*
4f411dc5 400%attr(755,root,root) %{_libdir}/rados-classes/libcls_replica_log.so*
2a1a6301 401%attr(755,root,root) %{_libdir}/rados-classes/libcls_rgw.so*
4f411dc5 402%attr(755,root,root) %{_libdir}/rados-classes/libcls_statelog.so*
c8a22313 403%attr(755,root,root) %{_libdir}/rados-classes/libcls_user.so*
4f411dc5 404%attr(755,root,root) %{_libdir}/rados-classes/libcls_version.so*
5e39e43e 405%{_datadir}/ceph
2a1a6301
JR
406%config(noreplace) /etc/logrotate.d/ceph
407%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
408%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
409%config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
410%{_mandir}/man8/ceph.8*
411%{_mandir}/man8/ceph-authtool.8*
412%{_mandir}/man8/ceph-clsinfo.8*
413%{_mandir}/man8/ceph-conf.8*
414%{_mandir}/man8/ceph-debugpack.8*
60d5543f 415%{_mandir}/man8/ceph-dencoder.8*
7f577810
JB
416%{_mandir}/man8/ceph-deploy.8*
417%{_mandir}/man8/ceph-disk.8*
2a1a6301
JR
418%{_mandir}/man8/ceph-mds.8*
419%{_mandir}/man8/ceph-mon.8*
420%{_mandir}/man8/ceph-osd.8*
5e39e43e 421%{_mandir}/man8/ceph-post-file.8*
60d5543f 422%{_mandir}/man8/ceph-rbdnamer.8*
4f411dc5 423%{_mandir}/man8/ceph-rest-api.8*
2a1a6301
JR
424%{_mandir}/man8/ceph-run.8*
425%{_mandir}/man8/ceph-syn.8*
426%{_mandir}/man8/cephfs.8*
427%{_mandir}/man8/crushtool.8*
428%{_mandir}/man8/librados-config.8*
2a1a6301
JR
429%{_mandir}/man8/monmaptool.8*
430%{_mandir}/man8/mount.ceph.8*
431%{_mandir}/man8/osdmaptool.8*
432%{_mandir}/man8/rados.8*
433%{_mandir}/man8/radosgw.8*
434%{_mandir}/man8/radosgw-admin.8*
435%{_mandir}/man8/rbd.8*
8c5712e2 436%{_mandir}/man8/rbd-fuse.8*
9a1a508c 437%{_mandir}/man8/rbd-replay.8*
7f577810 438%{_mandir}/man8/rbd-replay-many.8*
9a1a508c 439%{_mandir}/man8/rbd-replay-prep.8*
60d5543f 440
2a1a6301 441%dir %{_localstatedir}/lib/ceph
b6163d67
JK
442%dir %{_localstatedir}/lib/ceph/mds
443%dir %{_localstatedir}/lib/ceph/mon
444%dir %{_localstatedir}/lib/ceph/osd
2a1a6301
JR
445%dir %{_localstatedir}/lib/ceph/tmp
446%dir %{_localstatedir}/log/ceph
bef2a0ad 447%dir %{_localstatedir}/run/ceph
2a1a6301
JR
448
449%files libs
450%defattr(644,root,root,755)
451%attr(755,root,root) %{_libdir}/libcephfs.so.*.*.*
452%attr(755,root,root) %ghost %{_libdir}/libcephfs.so.1
453%attr(755,root,root) %{_libdir}/librados.so.*.*.*
454%attr(755,root,root) %ghost %{_libdir}/librados.so.2
548e0d3f
JB
455%attr(755,root,root) %{_libdir}/libradosstriper.so.*.*.*
456%attr(755,root,root) %ghost %{_libdir}/libradosstriper.so.1
2a1a6301
JR
457%attr(755,root,root) %{_libdir}/librbd.so.*.*.*
458%attr(755,root,root) %ghost %{_libdir}/librbd.so.1
2a1a6301 459
2a1a6301
JR
460%files devel
461%defattr(644,root,root,755)
2a1a6301
JR
462%attr(755,root,root) %{_libdir}/libcephfs.so
463%attr(755,root,root) %{_libdir}/librados.so
548e0d3f 464%attr(755,root,root) %{_libdir}/libradosstriper.so
2a1a6301
JR
465%attr(755,root,root) %{_libdir}/librbd.so
466%{_libdir}/libcephfs.la
467%{_libdir}/librados.la
548e0d3f 468%{_libdir}/libradosstriper.la
2a1a6301 469%{_libdir}/librbd.la
e5fc70df
JB
470%{_includedir}/cephfs
471%{_includedir}/rados
548e0d3f 472%{_includedir}/radosstriper
e5fc70df 473%{_includedir}/rbd
2a1a6301
JR
474
475%files static
476%defattr(644,root,root,755)
477%{_libdir}/libcephfs.a
478%{_libdir}/librados.a
548e0d3f 479%{_libdir}/libradosstriper.a
2a1a6301
JR
480%{_libdir}/librbd.a
481
e5fc70df
JB
482%files -n python-ceph
483%defattr(644,root,root,755)
67f1bff3 484%{py_sitescriptdir}/ceph_argparse.py[co]
4f411dc5 485%{py_sitescriptdir}/ceph_rest_api.py[co]
e54009d4 486%{py_sitescriptdir}/cephfs.py[co]
714b93ed
JB
487%{py_sitescriptdir}/rados.py[co]
488%{py_sitescriptdir}/rbd.py[co]
e5fc70df 489
4f42482b
JB
490%if %{with java}
491%files -n java-cephfs
492%defattr(644,root,root,755)
493%attr(755,root,root) %{_libdir}/libcephfs_jni.so.*.*.*
494%attr(755,root,root) %ghost %{_libdir}/libcephfs_jni.so.1
495%attr(755,root,root) %{_libdir}/libcephfs_jni.so
496%{_javadir}/libcephfs.jar
497%endif
498
e5fc70df
JB
499%files fuse
500%defattr(644,root,root,755)
e5fc70df
JB
501%attr(755,root,root) %{_bindir}/ceph-fuse
502%{_mandir}/man8/ceph-fuse.8*
503
2a1a6301
JR
504%files radosgw
505%defattr(644,root,root,755)
506%attr(755,root,root) %{_bindir}/radosgw
507%attr(755,root,root) %{_bindir}/radosgw-admin
508%{_sysconfdir}/bash_completion.d/radosgw-admin
509
245cb856 510%files resource-agents
8029515d
JB
511%defattr(644,root,root,755)
512%dir %{_prefix}/lib/ocf/resource.d/ceph
513%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/ceph
514%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/mds
515%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/mon
516%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/osd
517%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
This page took 0.103011 seconds and 4 git commands to generate.