]> git.pld-linux.org Git - packages/ceph.git/blame - ceph.spec
one more boost-system linking fix.
[packages/ceph.git] / ceph.spec
CommitLineData
2a1a6301
JR
1Summary: User space components of the Ceph file system
2Name: ceph
041b9abb 3Version: 0.51
72daa1da 4Release: 1
2a1a6301
JR
5License: LGPLv2
6Group: Base
7Source0: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
041b9abb 8# Source0-md5: e4d07eccd79c9a4a9eeee4066f2a13a3
2a1a6301
JR
9Patch0: %{name}-init-fix.patch
10Patch1: %{name}.logrotate.patch
041b9abb 11Patch2: %{name}-link.patch
2a1a6301
JR
12URL: http://ceph.newdream.net/
13BuildRequires: boost-devel
14BuildRequires: cryptopp-devel
15BuildRequires: curl-devel
16BuildRequires: expat-devel
17BuildRequires: fcgi-devel
18BuildRequires: gdbm-devel
19BuildRequires: google-perftools-devel
20BuildRequires: gtk+2-devel
21BuildRequires: gtkmm-devel
22BuildRequires: keyutils-devel
23BuildRequires: libatomic_ops
24BuildRequires: libedit-devel
25BuildRequires: libfuse-devel
26BuildRequires: libltdl-devel
27BuildRequires: libstdc++-devel
28BuildRequires: libtcmalloc-devel
29BuildRequires: libtool
30BuildRequires: libuuid-devel
31BuildRequires: perl
32BuildRequires: pkgconfig
33BuildRequires: rpmbuild(macros) >= 1.228
34Requires(post,preun): /sbin/chkconfig
35Requires(preun): rc-scripts
36Requires: %{name}-libs = %{version}-%{release}
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%define skip_post_check_so libcls_.*.so.*
40
41%description
42Ceph is a distributed network file system designed to provide
43excellent performance, reliability, and scalability.
44
45%package libs
46Summary: Ceph shared libraries
47Group: Libraries
48
49%description libs
50Ceph shared libraries.
51
52%package -n python-ceph
53Summary: Ceph python bindings
54Group: Development/Languages/Python
55Requires: %{name}-libs = %{version}-%{release}
56
57%description -n python-ceph
58Ceph python bindings.
59
60%package fuse
61Summary: Ceph fuse-based client
62Group: Base
63Requires: %{name} = %{version}-%{release}
64
65%description fuse
66FUSE based client for Ceph distributed network file system
67
68%package devel
69Summary: Ceph headers
70License: LGPLv2
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73
74%description devel
75This package contains the headers needed to develop programs that use
76Ceph.
77
78%package static
79Summary: Ceph static libraries
80License: LGPLv2
81Group: Development/Libraries
82Requires: %{name}-devel = %{version}-%{release}
83
84%description static
85This package contains static Ceph libraries.
86
87%package radosgw
88Summary: rados REST gateway
89Group: Development/Libraries
90#Requires: apache-mod_fcgid
91
92%description radosgw
93radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
94implemented as a FastCGI module using libfcgi, and can be used in
95conjunction with any FastCGI capable web server.
96
97%package obsync
98Summary: synchronize data between cloud object storage providers or a local directory
99License: LGPLv2
100Group: Applications/Networking
101Requires: python
102Requires: python-boto
103
104%description obsync
105obsync is a tool to synchronize objects between cloud object storage
106providers, such as Amazon S3 (or compatible services), a Ceph RADOS
107cluster, or a local directory.
108
109%package gcephtool
110Summary: Ceph graphical monitoring tool
111License: LGPLv2
112Group: Base
113
114%description gcephtool
115gcephtool is a graphical monitor for the clusters running the Ceph
116distributed file system.
117
118%prep
119%setup -q
120%patch0 -p1
121%patch1 -p0
122%patch2 -p1
2a1a6301
JR
123
124%build
125%{__libtoolize}
126%{__aclocal}
127%{__autoconf}
128%{__autoheader}
129%{__automake}
130%configure \
131 --sbindir=/sbin \
132 --without-hadoop \
133 --with-radosgw \
134 --with-gtk2
135
136%{__make} V=1
137
138%install
139rm -rf $RPM_BUILD_ROOT
140install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib/ceph/tmp,log/ceph/stat} \
141 $RPM_BUILD_ROOT%{_sysconfdir}/{ceph,bash_completion.d,logrotate.d,rc.d/init.d}
142%{__make} install \
143 DESTDIR=$RPM_BUILD_ROOT
144
145install -p src/init-ceph $RPM_BUILD_ROOT/etc/rc.d/init.d/ceph
146install -p src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ceph
147
148%{__rm} $RPM_BUILD_ROOT%{_libdir}/rados-classes/*.{a,la}
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/chkconfig --add ceph
155%service ceph restart
156
157%preun
158if [ "$1" = "0" ] ; then
72daa1da
JR
159 %service ceph stop
160 /sbin/chkconfig --del ceph
2a1a6301
JR
161fi
162
163%post libs -p /sbin/ldconfig
164%postun libs -p /sbin/ldconfig
165
166%files
167%defattr(644,root,root,755)
168%doc README src/sample.ceph.conf src/sample.fetch_config
169%attr(754,root,root) /etc/rc.d/init.d/ceph
170%dir %{_sysconfdir}/ceph
171%attr(755,root,root) %{_bindir}/ceph
172%attr(755,root,root) %{_bindir}/cephfs
173%attr(755,root,root) %{_bindir}/ceph-conf
174%attr(755,root,root) %{_bindir}/ceph-clsinfo
175%attr(755,root,root) %{_bindir}/crushtool
176%attr(755,root,root) %{_bindir}/monmaptool
177%attr(755,root,root) %{_bindir}/osdmaptool
178%attr(755,root,root) %{_bindir}/ceph-authtool
179%attr(755,root,root) %{_bindir}/ceph-syn
180%attr(755,root,root) %{_bindir}/ceph-run
181%attr(755,root,root) %{_bindir}/ceph-mon
182%attr(755,root,root) %{_bindir}/ceph-mds
183%attr(755,root,root) %{_bindir}/ceph-osd
184%attr(755,root,root) %{_bindir}/ceph-rbdnamer
185%attr(755,root,root) %{_bindir}/librados-config
186%attr(755,root,root) %{_bindir}/rados
187%attr(755,root,root) %{_bindir}/rbd
188%attr(755,root,root) %{_bindir}/ceph-debugpack
189%attr(755,root,root) %{_bindir}/ceph-coverage
190%dir %{_libdir}/rados-classes
191%attr(755,root,root) %{_libdir}/rados-classes/libcls_rbd.so*
192%attr(755,root,root) %{_libdir}/rados-classes/libcls_rgw.so*
193%attr(755,root,root) /sbin/mkcephfs
194%attr(755,root,root) /sbin/mount.ceph
195%dir %{_libdir}/ceph
196%attr(755,root,root) %{_libdir}/ceph/ceph_common.sh
197%config(noreplace) /etc/logrotate.d/ceph
198%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
199%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
200%config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
201%{_mandir}/man8/ceph.8*
202%{_mandir}/man8/ceph-authtool.8*
203%{_mandir}/man8/ceph-clsinfo.8*
204%{_mandir}/man8/ceph-conf.8*
205%{_mandir}/man8/ceph-debugpack.8*
206%{_mandir}/man8/ceph-mds.8*
207%{_mandir}/man8/ceph-mon.8*
208%{_mandir}/man8/ceph-osd.8*
209%{_mandir}/man8/ceph-run.8*
210%{_mandir}/man8/ceph-syn.8*
211%{_mandir}/man8/cephfs.8*
212%{_mandir}/man8/crushtool.8*
213%{_mandir}/man8/librados-config.8*
214%{_mandir}/man8/mkcephfs.8*
215%{_mandir}/man8/monmaptool.8*
216%{_mandir}/man8/mount.ceph.8*
217%{_mandir}/man8/osdmaptool.8*
218%{_mandir}/man8/rados.8*
219%{_mandir}/man8/radosgw.8*
220%{_mandir}/man8/radosgw-admin.8*
221%{_mandir}/man8/rbd.8*
222%dir %{_localstatedir}/lib/ceph
223%dir %{_localstatedir}/lib/ceph/tmp
224%dir %{_localstatedir}/log/ceph
225
226%files libs
227%defattr(644,root,root,755)
228%attr(755,root,root) %{_libdir}/libcephfs.so.*.*.*
229%attr(755,root,root) %ghost %{_libdir}/libcephfs.so.1
230%attr(755,root,root) %{_libdir}/librados.so.*.*.*
231%attr(755,root,root) %ghost %{_libdir}/librados.so.2
232%attr(755,root,root) %{_libdir}/librbd.so.*.*.*
233%attr(755,root,root) %ghost %{_libdir}/librbd.so.1
234%attr(755,root,root) %{_libdir}/librgw.so.*.*.*
235%attr(755,root,root) %ghost %{_libdir}/librgw.so.1
236
237%files -n python-ceph
238%defattr(644,root,root,755)
239%{py_sitescriptdir}/rados.py*
240%{py_sitescriptdir}/rgw.py*
241%{py_sitescriptdir}/rbd.py*
242
243%files fuse
244%defattr(644,root,root,755)
245%doc COPYING
246%attr(755,root,root) %{_bindir}/ceph-fuse
247%{_mandir}/man8/ceph-fuse.8*
248
249%files devel
250%defattr(644,root,root,755)
251%{_includedir}/cephfs
252%{_includedir}/crush
253%{_includedir}/rados
254%{_includedir}/rbd
255%attr(755,root,root) %{_libdir}/libcephfs.so
256%attr(755,root,root) %{_libdir}/librados.so
257%attr(755,root,root) %{_libdir}/librgw.so
258%attr(755,root,root) %{_libdir}/librbd.so
259%{_libdir}/libcephfs.la
260%{_libdir}/librados.la
261%{_libdir}/librgw.la
262%{_libdir}/librbd.la
263
264%files static
265%defattr(644,root,root,755)
266%{_libdir}/libcephfs.a
267%{_libdir}/librados.a
268%{_libdir}/librgw.a
269%{_libdir}/librbd.a
270
271%files gcephtool
272%defattr(644,root,root,755)
273%attr(755,root,root) %{_bindir}/gceph
274%{_datadir}/ceph_tool
275
276%files radosgw
277%defattr(644,root,root,755)
278%attr(755,root,root) %{_bindir}/radosgw
279%attr(755,root,root) %{_bindir}/radosgw-admin
280%{_sysconfdir}/bash_completion.d/radosgw-admin
281
282%files obsync
283%defattr(644,root,root,755)
284%attr(755,root,root) %{_bindir}/obsync
285%attr(755,root,root) %{_bindir}/boto_tool
This page took 0.06062 seconds and 4 git commands to generate.