]> git.pld-linux.org Git - packages/celestia.git/commitdiff
- make configure look for lua using pkg-config, not static paths
authorhavner <havner@pld-linux.org>
Thu, 29 Jun 2006 21:08:52 +0000 (21:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    celestia-lua50.patch -> 1.3

celestia-lua50.patch

index 713025a44a282a78d90c7dee548a815f0aa68f56..18558dcda0aee9647ef9b0901c4c1049de55b6ee 100644 (file)
@@ -1,12 +1,64 @@
-diff -ruN celestia./configure.in celestia/configure.in
---- celestia./configure.in     2005-01-11 21:40:24.000000000 +0100
-+++ celestia/configure.in      2005-01-11 21:40:46.963692448 +0100
-@@ -359,7 +359,7 @@
- AC_MSG_CHECKING([whether to enable Celestia Extension Language])
- if (test "$enable_lua" != "no"); then
-       CXXFLAGS="$CXXFLAGS -DCELX"
+diff -urN celestia-1.4.1.orig/configure.in celestia-1.4.1.mod/configure.in
+--- celestia-1.4.1.orig/configure.in   2006-02-03 19:09:54.000000000 +0100
++++ celestia-1.4.1.mod/configure.in    2006-06-29 21:41:44.159248250 +0200
+@@ -256,8 +256,9 @@
+ dnl (this is a silly trick to make configure behave)
+ AM_CONDITIONAL(GCONF_SCHEMAS_INSTALL, test "x" = "y")
++PKG_PROG_PKG_CONFIG
++
+ if (test "$ui_gtk" != "no"); then
+-      PKG_PROG_PKG_CONFIG
+       dnl GNOME is an extension to the GTK options
+       if (test "$ui_gnome" = "yes"); then
+@@ -363,43 +364,15 @@
+ AC_ARG_WITH([lua],
+-            AC_HELP_STRING([--with-lua[=DIR]],
++            AC_HELP_STRING([--with-lua],
+                            [Use Lua for Celestia Extension Language support]),
+-            enable_lua="$withval",
++            enable_lua="yes",
+             enable_lua="no")
+                       
+-AC_ARG_WITH([lua-inc],
+-            AC_HELP_STRING([--with-lua-includes[=DIR]],
+-                           [Specify location of Lua headers]),
+-            lua_includes="$withval",
+-            lua_includes="no")
+-                      
+-AC_ARG_WITH([lua-lib],
+-            AC_HELP_STRING([--with-lua-libs[=DIR]],
+-                           [Specify location of Lua libs]),
+-            lua_libs="$withval",
+-            lua_libs="no")
+-
+-AC_MSG_CHECKING([whether to enable Celestia Extension Language])
+-if (test "$enable_lua" != "no"); then
+-      CXXFLAGS="$CXXFLAGS -DCELX"
 -      LDFLAGS="$LDFLAGS -llualib -llua"
-+      LDFLAGS="$LDFLAGS -llualib50 -llua50"
-       
-       if (test "$lua_includes" != "no"); then
-               CXXFLAGS="$CXXFLAGS -I$lua_includes"
+-      
+-      if (test "$lua_includes" != "no"); then
+-              CXXFLAGS="$CXXFLAGS -I$lua_includes"
+-      fi
+-      
+-      if (test "$lua_libs" != "no"); then
+-              LIBS="$LIBS -L$lua_libs"
+-      fi
+-      AC_MSG_RESULT(yes)
+-      
+-      if (test "$enable_lua" != "yes"); then
+-              CXXFLAGS="$CXXFLAGS -I$enable_lua/include"
+-              LIBS="$LIBS  -L$enable_lua/lib"
+-      fi
+-else
+-      AC_MSG_RESULT(no)
++if (test "x$enable_lua" = "xyes"); then
++      PKG_CHECK_MODULES(LUA, lua,
++                        CXXFLAGS="$CXXFLAGS -DCELX $LUA_CFLAGS"
++                        LIBS="$LIBS $LUA_LIBS")
+ fi
+ AM_CONDITIONAL(ENABLE_CELX, test "$enable_lua" != "no")
This page took 0.119293 seconds and 4 git commands to generate.