]> git.pld-linux.org Git - packages/celestia.git/blobdiff - celestia.spec
- up to 1.6.4
[packages/celestia.git] / celestia.spec
index 524d2fd13cfc5e4816b457ee6f9544f1e3e56d66..d38b6a5aaa3dd2668bbf99a2e57ae57370988231 100644 (file)
@@ -1,39 +1,37 @@
-
-%bcond_without kde             # KDE UI as the default one
-%bcond_with    gtk             # use gtk2 UI instead
+#
+# Conditional build:
+%bcond_with    kde             # KDE3 UI as the default one
+%bcond_without gtk             # use GTK+2 UI instead
 %bcond_with    gnome           # use libgnome2 UI instead
 %bcond_with    glut            # use glut UI instead
-
 %bcond_without theora          # without theora support
 
-%if %{with gtk} || %{with gnome} || %{with glut}
-%undefine      with_kde
+%if %{with kde} || %{with gnome} || %{with glut}
+%undefine      with_gtk
 %endif
-
 Summary:       A real-time visual space simulation
 Summary(pl.UTF-8):     Symulacja przestrzeni kosmicznej w czasie rzeczywistym
 Name:          celestia
-Version:       1.5.1
+Version:       1.6.4
 Release:       1
 License:       GPL
 Group:         X11/Applications/Science
-Source0:       http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
-# Source0-md5: df6854a2cf62d2e96612398c13b68fd2
-Patch0:                %{name}-as-needed.patch
-Patch1:                %{name}-gcc43.patch
-Patch2:                %{name}-extras.patch
-Patch3:                %{name}-desktop.patch
-URL:           http://www.shatters.net/celestia/
+Source0:       https://github.com/CelestiaProject/Celestia/archive/refs/tags/%{version}.tar.gz
+# Source0-md5: d4770ffe08cb8761a78bebabcb9067ef
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-null.patch
+URL:           https://celestia.space
 BuildRequires: OpenGL-GLU-devel
 %{?with_glut:BuildRequires:    OpenGL-glut-devel >= 4.0}
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: gettext-tools
 %if %{with gtk} || %{with gnome}
 BuildRequires: cairo-devel
-BuildRequires: gtk+2-devel >= 2.6
+BuildRequires: gtk+2-devel >= 2:2.6
 BuildRequires: gtkglext-devel
 %endif
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 %{?with_kde:BuildRequires:     kdelibs-devel}
 %{?with_gnome:BuildRequires:   libgnomeui-devel}
 BuildRequires: libjpeg-devel
@@ -41,10 +39,9 @@ BuildRequires:       libpng-devel
 BuildRequires: libstdc++-devel
 %{?with_theora:BuildRequires:  libtheora-devel}
 BuildRequires: libtool
-BuildRequires: lua50-devel
+BuildRequires: lua53-devel
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-Requires:      OpenGL
 # celestia < 1.4 original packages
 Obsoletes:     celestia-extrasolar
 Obsoletes:     celestia-generator
@@ -71,8 +68,6 @@ Obsoletes:    celestia-pathfinder
 Obsoletes:     celestia-voyager
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
-
 %description
 Celestia is a free real-time space simulation that lets you experience
 our universe in three dimensions. Unlike most planetarium software,
@@ -86,31 +81,32 @@ through the universe to the object you want to visit.
 
 %description -l pl.UTF-8
 Celestia to wolny symulator przestrzeni komicznej w czasie
-rzeczywistym, który pozwala doświadczać naszego Wszechświata w
-trzech wymiarach. W odróżnieniu od innych programów planetarnych
-Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
-podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
-nawet poza galaktykę. Wszystkie podróże w Celestii są
-niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
-odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
-widoku kilkumetrowych statków kosmicznych. Interfejs typu
-'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
+rzeczywistym, który pozwala doświadczać naszego Wszechświata w trzech
+wymiarach. W odróżnieniu od innych programów planetarnych Celestia nie
+przywiązuje Cię do powierzchni ziemi. Możesz podróżować przez Układ
+Słoneczny do ponad 100,000 gwiazd lub nawet poza galaktykę. Wszystkie
+podróże w Celestii są niezauważalne; funkcja wykładniczego
+przybliżenia pozwala Ci odkrywać Kosmos w różnych skalach - od
+spojrzenia na galaktyki do widoku kilkumetrowych statków kosmicznych.
+Interfejs typu 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
 
 %prep
-%setup -q
-%patch0
+%setup -q -n Celestia-%{version}
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-
-# ugly hack not to require GConf2-devel if we're not building gnome version
-%{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
 
 %build
-cp -f /usr/share/automake/config.sub admin
-%{__make} -f admin/Makefile.common
+%{__gettextize}
+cp -a po/Makefile* po2/
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 
 %configure \
+       CFLAGS="%{rpmcflags} $(pkg-config --cflags libpng)" \
+       LIBS="-ldl" \
        %{?with_kde:--with-kde} \
        %{?with_gtk:--with-gtk} \
        %{?with_gnome:--with-gnome} \
@@ -134,7 +130,7 @@ rm -rf $RPM_BUILD_ROOT
 # desktop/icon
 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
-install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
+cp -p src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
 
 %find_lang %{name} --all-name --with-kde
 
@@ -151,7 +147,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README AUTHORS TODO controls.txt ChangeLog
+%doc NEWS README AUTHORS controls.txt ChangeLog
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/celestia
 %{_pixmapsdir}/*
This page took 0.075639 seconds and 4 git commands to generate.