]> git.pld-linux.org Git - packages/celestia.git/blobdiff - celestia.spec
Version: 1.6.1
[packages/celestia.git] / celestia.spec
index fc51716c97851189bba5f8f9d120f8d8d4f67005..5c3b124b51ddde8e9570e4ee9f866a5f13553c51 100644 (file)
@@ -1,47 +1,54 @@
-
-%bcond_without kde             # KDE UI as the default one
-%bcond_with    gtk             # use gtk2 UI instead
+#
+# Conditional build:
+%bcond_with    kde             # KDE3 UI as the default one
+%bcond_without gtk             # use GTK+2 UI instead
 %bcond_with    gnome           # use libgnome2 UI instead
 %bcond_with    glut            # use glut UI instead
-
-%if %{with gtk} || %{with gnome} || %{with glut}
-%undefine      with_kde
+%bcond_without theora          # without theora support
+#
+%if %{with kde} || %{with gnome} || %{with glut}
+%undefine      with_gtk
 %endif
-
 Summary:       A real-time visual space simulation
 Summary(pl.UTF-8):     Symulacja przestrzeni kosmicznej w czasie rzeczywistym
 Name:          celestia
-Version:       1.5.1
+Version:       1.6.1
 Release:       1
 License:       GPL
 Group:         X11/Applications/Science
 Source0:       http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
-# Source0-md5: df6854a2cf62d2e96612398c13b68fd2
-Patch0:                %{name}-as-needed.patch
-Patch1:                %{name}-gcc43.patch
-Patch2:                %{name}-extras.patch
-Patch3:                %{name}-desktop.patch
+# Source0-md5: 02208982a431b984502fac909bf380f4
+Patch0:                %{name}-includes.patch
+Patch1:                %{name}-as-needed.patch
+Patch2:                gtk-enable-locales-early.patch
+Patch3:                use-stdint_h.patch
+Patch4:                %{name}-desktop.patch
+Patch5:                %{name}-gcc47.patch
+Patch6:                %{name}-null.patch
+#Patch2:               %{name}-extras.patch
+#Patch4:               %{name}-lua51.patch
 URL:           http://www.shatters.net/celestia/
-BuildRequires: OpenGL-devel
+BuildRequires: OpenGL-GLU-devel
 %{?with_glut:BuildRequires:    OpenGL-glut-devel >= 4.0}
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: gettext-tools
 %if %{with gtk} || %{with gnome}
 BuildRequires: cairo-devel
-BuildRequires: gettext-devel
-BuildRequires: gtk+2-devel >= 2.6
+BuildRequires: gtk+2-devel >= 2:2.6
 BuildRequires: gtkglext-devel
 %endif
+BuildRequires: gettext-tools
 %{?with_kde:BuildRequires:     kdelibs-devel}
 %{?with_gnome:BuildRequires:   libgnomeui-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
+%{?with_theora:BuildRequires:  libtheora-devel}
 BuildRequires: libtool
-BuildRequires: lua50-devel
+BuildRequires: lua51-devel
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-Requires:      OpenGL
 # celestia < 1.4 original packages
 Obsoletes:     celestia-extrasolar
 Obsoletes:     celestia-generator
@@ -68,8 +75,6 @@ Obsoletes:    celestia-pathfinder
 Obsoletes:     celestia-voyager
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
-
 %description
 Celestia is a free real-time space simulation that lets you experience
 our universe in three dimensions. Unlike most planetarium software,
@@ -95,26 +100,36 @@ widoku kilkumetrowych statków kosmicznych. Interfejs typu
 
 %prep
 %setup -q
-%patch0
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 # ugly hack not to require GConf2-devel if we're not building gnome version
 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
 
 %build
-cp -f /usr/share/automake/config.sub admin
-%{__make} -f admin/Makefile.common
+%{__gettextize}
+cp -a po/Makefile* po2/
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 
 %configure \
+       CFLAGS="%{rpmcflags} $(pkg-config --cflags libpng)" \
+       LIBS="-ldl" \
        %{?with_kde:--with-kde} \
        %{?with_gtk:--with-gtk} \
        %{?with_gnome:--with-gnome} \
        %{?with_glut:--with-glut} \
        --disable-rpath \
+       %{!?with_theora:--disable-theora} \
        --with-lua \
-       --with-xinerama \
        --with-qt-dir=%{_libdir}
 
 %{__make}
@@ -133,6 +148,8 @@ install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
 
+rm -r $RPM_BUILD_ROOT%{_localedir}/no
+
 %find_lang %{name} --all-name --with-kde
 
 %clean
@@ -148,7 +165,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README AUTHORS TODO controls.txt ChangeLog
+%doc NEWS README AUTHORS controls.txt ChangeLog
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/celestia
 %{_pixmapsdir}/*
This page took 0.061675 seconds and 4 git commands to generate.