]> git.pld-linux.org Git - packages/celestia.git/blobdiff - celestia.spec
Version: 1.6.1
[packages/celestia.git] / celestia.spec
index 416b49e24359f5378a0e27e51fce3d6a95f2559c..5c3b124b51ddde8e9570e4ee9f866a5f13553c51 100644 (file)
@@ -1,47 +1,54 @@
-
-%bcond_without kde             # KDE UI as the default one
-%bcond_with    gtk             # use gtk2 UI instead
+#
+# Conditional build:
+%bcond_with    kde             # KDE3 UI as the default one
+%bcond_without gtk             # use GTK+2 UI instead
 %bcond_with    gnome           # use libgnome2 UI instead
 %bcond_with    glut            # use glut UI instead
-
-%if %{with gtk} || %{with gnome} || %{with glut}
-%undefine      with_kde
+%bcond_without theora          # without theora support
+#
+%if %{with kde} || %{with gnome} || %{with glut}
+%undefine      with_gtk
 %endif
-
 Summary:       A real-time visual space simulation
 Summary(pl.UTF-8):     Symulacja przestrzeni kosmicznej w czasie rzeczywistym
 Name:          celestia
-Version:       1.4.1
-Release:       2
+Version:       1.6.1
+Release:       1
 License:       GPL
 Group:         X11/Applications/Science
 Source0:       http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
-# Source0-md5: be1d36fc97a13b9a276249dbc0efac41
-Patch0:                %{name}-lua50.patch
-Patch1:                %{name}-makefile.patch
-Patch2:                %{name}-gcc4.patch
-Patch3:                %{name}-extras.patch
+# Source0-md5: 02208982a431b984502fac909bf380f4
+Patch0:                %{name}-includes.patch
+Patch1:                %{name}-as-needed.patch
+Patch2:                gtk-enable-locales-early.patch
+Patch3:                use-stdint_h.patch
 Patch4:                %{name}-desktop.patch
+Patch5:                %{name}-gcc47.patch
+Patch6:                %{name}-null.patch
+#Patch2:               %{name}-extras.patch
+#Patch4:               %{name}-lua51.patch
 URL:           http://www.shatters.net/celestia/
-BuildRequires: OpenGL-devel
+BuildRequires: OpenGL-GLU-devel
+%{?with_glut:BuildRequires:    OpenGL-glut-devel >= 4.0}
 BuildRequires: autoconf
 BuildRequires: automake
-%{?with_glut:BuildRequires:    glut-devel >= 3.7}
+BuildRequires: gettext-tools
 %if %{with gtk} || %{with gnome}
 BuildRequires: cairo-devel
-BuildRequires: gtk+2-devel >= 2.6
+BuildRequires: gtk+2-devel >= 2:2.6
 BuildRequires: gtkglext-devel
 %endif
+BuildRequires: gettext-tools
 %{?with_kde:BuildRequires:     kdelibs-devel}
 %{?with_gnome:BuildRequires:   libgnomeui-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
+%{?with_theora:BuildRequires:  libtheora-devel}
 BuildRequires: libtool
-BuildRequires: lua50-devel
+BuildRequires: lua51-devel
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-Requires:      OpenGL
 # celestia < 1.4 original packages
 Obsoletes:     celestia-extrasolar
 Obsoletes:     celestia-generator
@@ -68,8 +75,6 @@ Obsoletes:    celestia-pathfinder
 Obsoletes:     celestia-voyager
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
-
 %description
 Celestia is a free real-time space simulation that lets you experience
 our universe in three dimensions. Unlike most planetarium software,
@@ -83,14 +88,15 @@ through the universe to the object you want to visit.
 
 %description -l pl.UTF-8
 Celestia to wolny symulator przestrzeni komicznej w czasie
-rzeczywistym, który pozwala doświadczać naszego Wszechświata w trzech
-wymiarach. W odróżnieniu od innych programów planetarnych Celestia nie
-przywiązuje Cię do powierzchni ziemi. Możesz podróżować przez Układ
-Słoneczny do ponad 100,000 gwiazd lub nawet poza galaktykę. Wszystkie
-podróże w Celestii są niezauważalne; funkcja wykładniczego
-przybliżenia pozwala Ci odkrywać Kosmos w różnych skalach - od
-spojrzenia na galaktyki do widoku kilkumetrowych statków kosmicznych.
-Interfejs typu 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
+rzeczywistym, który pozwala doświadczać naszego Wszechświata w
+trzech wymiarach. W odróżnieniu od innych programów planetarnych
+Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
+podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
+nawet poza galaktykę. Wszystkie podróże w Celestii są
+niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
+odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
+widoku kilkumetrowych statków kosmicznych. Interfejs typu
+'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
 
 %prep
 %setup -q
@@ -99,22 +105,31 @@ Interfejs typu 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 # ugly hack not to require GConf2-devel if we're not building gnome version
 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
 
 %build
-cp -f /usr/share/automake/config.sub admin
-%{__make} -f admin/Makefile.common
+%{__gettextize}
+cp -a po/Makefile* po2/
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 
 %configure \
+       CFLAGS="%{rpmcflags} $(pkg-config --cflags libpng)" \
+       LIBS="-ldl" \
        %{?with_kde:--with-kde} \
        %{?with_gtk:--with-gtk} \
        %{?with_gnome:--with-gnome} \
        %{?with_glut:--with-glut} \
        --disable-rpath \
+       %{!?with_theora:--disable-theora} \
        --with-lua \
-       --with-xinerama \
        --with-qt-dir=%{_libdir}
 
 %{__make}
@@ -125,6 +140,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        kde_htmldir=%{_kdedocdir} \
+       kde_libs_htmldir=%{_kdedocdir} \
        appsdir=%{_desktopdir}/kde
 
 # desktop/icon
@@ -132,7 +148,9 @@ install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
 
-%find_lang %{name} --with-kde
+rm -r $RPM_BUILD_ROOT%{_localedir}/no
+
+%find_lang %{name} --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -147,7 +165,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README AUTHORS TODO controls.txt ChangeLog
+%doc NEWS README AUTHORS controls.txt ChangeLog
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/celestia
 %{_pixmapsdir}/*
This page took 0.102625 seconds and 4 git commands to generate.