]> git.pld-linux.org Git - packages/celestia.git/blame_incremental - celestia.spec
- converted to UTF-8
[packages/celestia.git] / celestia.spec
... / ...
CommitLineData
1
2%bcond_without kde # KDE UI as the default one
3%bcond_with gtk # use gtk2 UI instead
4%bcond_with gnome # use libgnome2 UI instead
5%bcond_with glut # use glut UI instead
6
7%if %{with gtk} || %{with gnome} || %{with glut}
8%undefine with_kde
9%endif
10
11Summary: A real-time visual space simulation
12Summary(pl.UTF-8): Symulacja przestrzeni kosmicznej w czasie rzeczywistym
13Name: celestia
14Version: 1.4.1
15Release: 2
16License: GPL
17Group: X11/Applications/Science
18Source0: http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
19# Source0-md5: be1d36fc97a13b9a276249dbc0efac41
20Patch0: %{name}-lua50.patch
21Patch1: %{name}-makefile.patch
22Patch2: %{name}-gcc4.patch
23Patch3: %{name}-extras.patch
24Patch4: %{name}-desktop.patch
25URL: http://www.shatters.net/celestia/
26BuildRequires: OpenGL-devel
27BuildRequires: autoconf
28BuildRequires: automake
29%{?with_glut:BuildRequires: glut-devel >= 3.7}
30%if %{with gtk} || %{with gnome}
31BuildRequires: cairo-devel
32BuildRequires: gtk+2-devel >= 2.6
33BuildRequires: gtkglext-devel
34%endif
35%{?with_kde:BuildRequires: kdelibs-devel}
36%{?with_gnome:BuildRequires: libgnomeui-devel}
37BuildRequires: libjpeg-devel
38BuildRequires: libpng-devel
39BuildRequires: libstdc++-devel
40BuildRequires: libtool
41BuildRequires: lua50-devel
42BuildRequires: pkgconfig
43BuildRequires: sed >= 4.0
44Requires: OpenGL
45# celestia < 1.4 original packages
46Obsoletes: celestia-extrasolar
47Obsoletes: celestia-generator
48Obsoletes: celestia-stars
49Obsoletes: celestia-task-default
50# texture replacement addons, virtual provides
51Obsoletes: celestia-textures-earth
52Obsoletes: celestia-textures-earth-clouds
53Obsoletes: celestia-textures-earth-night
54Obsoletes: celestia-textures-galileanmoons
55Obsoletes: celestia-textures-mars
56Obsoletes: celestia-textures-mars-bumpmap
57Obsoletes: celestia-textures-mercury
58Obsoletes: celestia-textures-mercury-bumpmap
59Obsoletes: celestia-textures-moon
60Obsoletes: celestia-textures-moon-bumpmap
61# celestia addons
62Obsoletes: celestia-blackhole
63Obsoletes: celestia-galaxies_extended
64Obsoletes: celestia-galaxy_clusters
65Obsoletes: celestia-globular_clusters
66Obsoletes: celestia-im-starwars
67Obsoletes: celestia-pathfinder
68Obsoletes: celestia-voyager
69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71%define _noautoreqdep libGL.so.1 libGLU.so.1 libGLcore.so.1
72
73%description
74Celestia is a free real-time space simulation that lets you experience
75our universe in three dimensions. Unlike most planetarium software,
76Celestia doesn't confine you to the surface of the Earth. You can
77travel throughout the solar system, to any of over 100,000 stars, or
78even beyond the galaxy. All travel in Celestia is seamless; the
79exponential zoom feature lets you explore space across a huge range of
80scales, from galaxy clusters down to spacecraft only a few meters
81across. A 'point-and-goto' interface makes it simple to navigate
82through the universe to the object you want to visit.
83
84%description -l pl.UTF-8
85Celestia to wolny symulator przestrzeni komicznej w czasie
86rzeczywistym, który pozwala doświadczać naszego Wszechświata w trzech
87wymiarach. W odróżnieniu od innych programów planetarnych Celestia nie
88przywiązuje Cię do powierzchni ziemi. Możesz podróżować przez Układ
89Słoneczny do ponad 100,000 gwiazd lub nawet poza galaktykę. Wszystkie
90podróże w Celestii są niezauważalne; funkcja wykładniczego
91przybliżenia pozwala Ci odkrywać Kosmos w różnych skalach - od
92spojrzenia na galaktyki do widoku kilkumetrowych statków kosmicznych.
93Interfejs typu 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
94
95%prep
96%setup -q
97%patch0 -p1
98%patch1 -p1
99%patch2 -p1
100%patch3 -p1
101%patch4 -p1
102
103# ugly hack not to require GConf2-devel if we're not building gnome version
104%{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
105
106%build
107cp -f /usr/share/automake/config.sub admin
108%{__make} -f admin/Makefile.common
109
110%configure \
111 %{?with_kde:--with-kde} \
112 %{?with_gtk:--with-gtk} \
113 %{?with_gnome:--with-gnome} \
114 %{?with_glut:--with-glut} \
115 --disable-rpath \
116 --with-lua \
117 --with-xinerama \
118 --with-qt-dir=%{_libdir}
119
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT \
127 kde_htmldir=%{_kdedocdir} \
128 appsdir=%{_desktopdir}/kde
129
130# desktop/icon
131install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
132%{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
133install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
134
135%find_lang %{name} --with-kde
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%if %{with gnome}
141%post
142%gconf_schema_install celestia.schemas
143
144%preun
145%gconf_schema_uninstall celestia.schemas
146%endif
147
148%files -f %{name}.lang
149%defattr(644,root,root,755)
150%doc README AUTHORS TODO controls.txt ChangeLog
151%attr(755,root,root) %{_bindir}/*
152%{_datadir}/celestia
153%{_pixmapsdir}/*
154%if %{with kde}
155%{_datadir}/apps/celestia
156%{_datadir}/config/*
157%{_datadir}/mimelnk/application/*
158%{_datadir}/services/*
159%{_iconsdir}/*/*/apps/%{name}.png
160%{_desktopdir}/kde/*.desktop
161%else
162%{_desktopdir}/*.desktop
163%endif
164%{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.056208 seconds and 4 git commands to generate.